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CHAPTER 1

WORDSTAR BASICS

“WordStar Basics” describes the organization and conventions used in this
manual. It also presents an overview of the WordStar menus and commands,
cursor movement, and mouse support.
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The procedures in this manual assume that you've installed WordStar following
the instructions in the Installing and Customizing booklet, and that the default
settings are in effect. If you’ve changed any default settings, you can adapt the
instructions to your settings.

How 10 USE THIS MANUAL

The Reference manual gives detailed explanations of features, functions, and
commands available in WordStar, organized by commands on the pull-down
menus. Each chapter describes the commands on one pull-down menu, in the
order they appear on the menu. For example, Chapter 2 describes each com-
mand on the File menu, which is the first menu on the Opening menu bar.

You can enter each command in several ways. “Menus and Commands” in this
chapter describes in detail how to enter commands. The heading for each com-
mand in this manual includes the corresponding Alt key shortcut followed by
the equivalent classic command.
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If you don’t know what command performs the function you want, or if you
don’t use pull-down menus, you can easily find any feature by using the subject
index and the command index (which contains all the classic commands).

KEYBOARD CONVENTIONS

This manual uses several conventions to describe commands you enter from the
keyboard.
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The arrow symbol (= ) points to the next item you choose on a pull-down
menu or in a dialog box. For example, File=>Copy means to choose the File
menu and then choose Copy from the menu. Following the pull-down com-
mand, the equivalent classic command is shown.

Alt+KEY means to hold down the Alt key and press another key.

Alt+KEY1,KEY2 means to hold down the Alt key while you press KEYT. Then
you can release the Alt key or keep it depressed and press KEYZ2.

AKEY means to hold down the Ctrl (*) key while you press the key assigned to
the command.

AKEY1 KEY2 means to hold down the Ctrl (*) key while you press the first key,
and then press the second key. (It doesn’t matter whether or not you are still
pressing the Ctrl key when you press the second key.)

STARTING WORDSTAR

To start WordStar, at the system prompt, type ws and press Enter. The first
screen that appears shows the version number, serial number, copyright notice,
and the names of your computer and printer. Then the Opening screen
appears, and you can choose a command from one of the menus.
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MENUS AND COMMANDS

WordStar has two complete sets of menus. They are pull-down menus and
classic menus. The commands on both sets of menus perform the same tasks,
using different keystrokes.

HELP LEVELS

The help level setting determines which menus WordStar displays. Pull-down
menus (help level 4) are the default. You can change between pull-down and
classic menus, and change the way classic menus are displayed, by choosing
Help=>Change Help Level, or (except in help level 4) by pressing F1 F1. For a
complete description of the five help levels, see “Change Help Level” in the
“Opening Screen Help Menu” chapter.

PULL-DOWN MENUS AND COMMANDS

At help level 4, the default setting, the menu bar at the top of the Opening and
Edit screens displays the menus available at that screen.

WordStar
menu bar —[File Utilities Additional Help

Filenames: Path: C:\WS 6.1M free ATt
.o \ | CONVERT \ | FAX N\ | INSET \
MACROS \ | OPTIONS \ | 2258DUAL.PS 1.5k | 2250DULB.PS 1.7k
2258DUTB.PS 1.7k | ZDDUAL.PS 2.8k | 2DDUPLB.PS 2.2k | 2DDUPTB.PS 2.2k
3256DUAL.PS 1.5k | 3258DULB.PS 1.7k | 325@8DUTB.PS 1.7k | ARROW.HP .3k
BORDER. P8 .9k | BOX .4k | BOX.PS 1.8k | CAN3R.PS 2.5k
CAN3T. PS 2.7k | CAN4.PS 1.8k | CANIII.PS 1.3k | CHEX.HP .5k
DB@8.DTB 80k | DB@O@.DTD 77k | DB81.DTB 375k | DBB1.DTD 74k
DBBZ2.DTB 84k | DBBZ.DTD 28k | DB@4.DTB 188k | DBB4.DTD 14k
DPSFEED.PS 1.4k | EHANDLER.PS 2.8k | FONTID.CTL 7.3k | HARRIET .3k
HP-ENU.LST 1.8k | HPZ-ENU.LST 1.8k | IBM4B1SF.PS 4.7k | IBM4823F.PS 4.7k
IBMFEED.PS 1.5k | INDEX.DTB 46k | INDEX.DTD 11k | JOAN .3k
JUST .3k | KEYBOARD.MRG .1k | LETTER.PS 2.5k | LIST.DOC .8k
LOGO. PS 5.6k | LWFEED.PS .5k | MACRO.BAK .3k | MACRO.DOC .3k
MAILING.DOC 1.8k | NECFEED.PS .6k | NEUW .3k | OPTION.PS 3.7k
PDFEDIT.HLP 35k | PLAYBILL.BAK .6k | PLAYBILL.DOC .8k | PLAYS.DOC .9k
PLEAD. HP .1k | PLEAD.PS 1.3k | P04845.PS 1.4k | POBRHL4.PS 3.8k

—————————————————
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To display a menu at the Opening screen in help level 4, press the first letter of
the menu name or, if you have a mouse, click the name. You can move
between menus using the Right and Left Arrow keys, AS and AD, or a mouse.
To choose a command on a menu, press the highlighted or underlined charac-
ter (depending on what type of monitor you have) or click the command.

A » symbol to the right of a command name indicates that the command dis-
plays a submenu. To display the submenu, choose the command or press the
Right Arrow key or AD. To return to the menu, press the Left Arrow key or AS.

Three dots (...) to the right of a command name indicate that the command
displays a dialog box.

When you're editing a file, you work at the Editing screen.

WordStar - C:\WUS\SHAKE. DOC

File Edit Uieuw

William Shakespeare

Of all the Elizabethan poets, William Shakespeare is the most
Ifamous. He was born in 1564 in the village of Stratford-on-fAuvon
o an old and prominent family. His father, John Shakespeare,

as a glover and uool dealer with a shop in Stratford.

Shakespeare entered grammar school in 1571 at the age of seven.
[Elizabethan education uas based on learning by rote, and he had
Bn excellent aural memory. His education in Latin left an unmis-
akable impression on his vocabulary. In the upper school, he
studied logic and rhetoric, and excelled in dialectic argument, a
skill he later put to use in his plays. Shakespeare learned

reek mythology and Roman history. UWhen he began to urite, he
shoued a marvelous ability to make a little knouledge go a long
ay.

Shakespeare married uvhile he was still a minor and needed his
parents’ permission. His bride, Anne Hathauay, uas tuenty-six
Insert P1 L1 ue. 508" C1 He. 88"

To display a menu at the Editing screen in help level 4, press Alt and the first let-
ter of the menu name. When the menu appears, you choose a command by
pressing the highlighted or underlined character (depending on what type of
monitor you have) or by clicking the command name.
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MENUS AND COMMANDS

When the help level is set at 1, 2, or 3, the classic Opening Menu appears
when you start WordStar. The pull-down menus don’t appear. The Opening
Menu lists commands for such operations as editing, printing, and deleting files.
To use a command, press the highlighted character.

OPENING MENU
D open a document L change drive/directory
S speed urite (neu file) C protect/unprotect a file
N open a nondocument E rename a file
P print a file 0 copy a file
\ fax Y delete a file
K print from keyboard F turn directory off
I index a document M macros
T table of contents R run a DOS command
X exit UWordStar A additional
F1 help 7?7 display status

When you open a file, the classic Edit Menu appears. It contains basic editing
commands, including the commands to display the other classic menus.

CURSOR SCROLL
“E up “U up G
~X doun ~Z doun’ ~T
S left “R screen up ¥
“D right “C screen Del
“A word left doun “u
“F uword right

EDIT
DELETE
char
word
line
char
undo

MENU

OTHER MENUS
F1 help ~0 onscreen format
~1 tab “K block & save
U turn insert off "M macros
“B align paragraph "P print controls
“N split the line "Q quick functions
L find/replace again

To see the classic menus in help levels 2, 3, or 4, hold down the Ctrl key and
press the command for the menu you want. You can choose any command on
the menu by pressing the appropriate character.

Classic commands work at all help levels, even if they’re not displayed.
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DISPLAYING CLASSIC COMMANDS AT PULL-DOWN MENUS

Some people who use classic commands like to use pull-down menus so that
they can easily find a command that they don’t remember. As a default, classic
commands are shown next to the corresponding pull-down commands on the
pull-down menus.

If you want to turn off the display of classic commands at the pull-down menus,
choose View=>Screen Settings, or use the AOB classic command, and turn off
the setting for Classic Commands on Pull-down Menus. Classic commands
work at all help levels, even if they’re not displayed.

To change the default setting for the display of classic commands on pull-down
menus, use WSCHANGE, the WordStar customization program. See “Changing
WordStar Settings in WSCHANGE” in the Installing and Customizing booklet.

Dot coMMANDS

WordStar commands include a number of dot commands. Sometimes a dot
command is inserted into a document when you make a choice at a menu or
dialog box. You can also type a dot command directly into a document.

A dot command begins with a period, which is followed by the two-letter or
three-letter command and whatever text or setting is required. The period must
be in column 1 of the line, and the dot command must be on a line by itself.
Dot commands are not part of the text, so they take up no real space in the
document.

As a default, dot commands are shown in the document while you're editing.
When you turn off Command Tags display (View=>Command Tags or AOD),
they are not displayed except while you enter them. If you want to always dis-
play dot commands, choose View=>Screen Settings, or use the AOB classic
command, and select Dot Commands: Always On.

WordStar assumes that any line that begins with a period is a dot command line.
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(NSCREEN HELP

Onscreen help is available for every command in WordStar. To get help at
pull-down menus, press F1 or choose Help from the Help Menu.

To get help at classic menus, press F1 at the Opening Menu, and then press the
command you want help with. To get help while editing a document, press F1,
and then press the command you want help with. To get help for an option in
a dialog box, move the cursor to the option and press F1.

S CREENS AND DIALOG BOXES

The following sections describe the elements that appear on the WordStar
screens.

THE EDITING SCREEN

You create and edit your documents at the Editing screen. The Editing screen
can include several screen elements, including menus and other information. If
you want more space on the screen for editing, you can use the WSCHANGE
customization program to remove most of the Editing screen elements (for infor-
mation about WSCHANGE, see the Installing and Customizing booklet). You
can also turn on and off the display of the scroll bar, style bar, status line, and
ruler line by choosing View=>Screen Settings or using the 2OB classic com-
mand.

The following illustration shows the Editing screen for help level 4 (pull-down
menus). The parts of the screen are described below the illustration.
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Style bar Ruler line Title bar
Menu bar

WordStar — C:\WS\SHAKE.DOC
Style Layout Utilities

William Shakespeare

0f all the Elizabethan poets, William Shakespeare is the most
ifamous. He was born in 1564 in the village of Stratford-on-Avon
ito an old and prominent family. His father, John Shakespeare,
was a glover and wool dealer with a shop in Stratford.

Shakespeare entered grammar school in 1571 at the age of seven.
[Elizabethan education was based on learning by rote, and he had
lan excellent aural memory. His education in Latin left an unmis-
itakable impression on his vocabulary. In the upper school, he
tudied logic and rhetoric, and excelled in dialectic argument, a
kill he later put to use in his plays. Shakespeare learned
reek mythology and Roman history. When he began to urite, he
houed a marvelous ability to make a little knouledge go a long
way.

Shakespeare married while he was still a minor and needed his
parents’ permission. His bride, Anne Hathaway, was tuenty-six
Insert P1 L1 UB.58" C1i

He.es"

Status line —T Flag column
Vertical scroll bar

THE TITLE BAR

The title bar shows the name and path of the file you're editing. If you have
installed a mouse, the Close File button is at the left of the title bar. The com-
mand in progress is shown next to the Close File button. The title bar also
shows messages such as Printing and Replace Y/N. If you have a second win-
dow open, the right side of the title bar shows the current window number and,
if you have a mouse, a button to maximize/minimize window size.

THE MENU BAR

The menu bar displays the names of the pull-down menus.

THE STYLE BAR

The style bar shows information about current settings such as the paragraph
style and font names. If you have a mouse, you can click any setting to select it
or turn it on or off. From left to right, the settings are paragraph style, font
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name, bold, italic, underline, Command Tags display, alignment (left, center,
right, or justify), and line spacing. You can move the style bar to the bottom of
the screen using the WSCHANGE customization program. The style bar is not
displayed in nondocument mode.

THE RULER LINE

The ruler line shows current margin and tab settings. The marker on the ruler
line shows the position of the cursor on the page and moves as you move the
cursor. The ruler line is not used in nondocument mode.

The initial ruler line settings in a document are those in the default paragraph
style. The default settings are left margin at O, right margin at 6.5 inches, and
tab stops every .5 inch.

When you change the margin or tab settings in a document, the ruler line
changes to show the new settings.

The ruler line can contain the following characters:

CHARACTER MEANING
F Left margin
4 Right margin
q First line indent (paragraph margin)
> Tab stops
o Decimal tabs

- Space between margins and tabs
| Temporary indent (*OG)
You can change margin and tab settings using paragraph styles or by choosing

Layout=>Ruler Line (or using the ~OL classic command). For more information,
see “Ruler Line” in the “Editing Screen Layout Menu” chapter.
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THE STATUS LINE

The status line shows the cursor location, messages, and warnings as shown in
the following illustration. The status line is located at the bottom of the screen.
You can move it to the top of the screen using the WordStar customization
program WSCHANGE (DBA2B).

Line Column Size current
State indicators Insert on/off number number window button

Column-Replace 12345678398¢<B><K> Insert P111 L1i1 UB.58" C1 He.@0" =*

t t t
Markers set Page Vertical Horizontal
number  position position

You can use a mouse with several status line options. You can click Insert to
switch between Insert and Overtype. You can click the page number (for docu-
ments) or line number (for nondocuments) to display the Go to Page (or Line)
dialog box, and you can click the beginning and end block markers and marker
numbers to go to those locations.

THE VERTICAL SCROLL BAR
The vertical scroll bar lets you use a mouse to move around in a document. For
more information, see “Moving the Cursor and Scrolling with a Mouse” in this
chapter.
THE FLAG COLUMN
The flag column shows a flag character for each line to remind you of what is
on the line. The flags and their meanings are listed below.
FLAG MEANING

< The line ends with a hard carriage return.

A blank space means that the line ends with a soft carriage
return produced by word wrap within a paragraph.

P This is a page break; a new page begins below this line.
F This line ends with a form feed produced by the APL
command.

This is a column break.
A The file ends on or above this line.

+ Text on this line extends beyond the right edge of the sceen.
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FLAG MEANING

The dot command on this line changes the onscreen format
and the printout.

The dot command on this line changes only the printout.

? The dot command on this line is not recognized by
WordStar.

1 The dot command on this line changes the onscreen format
and the printout; it works best if it's placed at the beginning
of a page.

- The line ends with a carriage return without a line feed,; it
will be overprinted by the next line.

J The line ends with a line feed without a carriage return
(produced by AP)); the next line may not begin at the left
margin when printed.

W This is the second window separator in nondocument mode.

DISPLAYING COMMAND TAGS

When you choose a WordStar command, WordStar often puts a command tag
into your text. For example, AB appears at the beginning and end of bold text,
and if you change the font, for example, to the Courier 10 font, the tag
<Courier 10.0> is inserted.

Command tags and dot commands take up space on the screen and may make
text appear out of alignment. You can choose View=>Command Tags, or use
the AOD classic command, to remove these tags from the screen while you
edit, and to display them again. (If you have a mouse, you can also click the

[*] button on the style bar.) The commands remain in effect even when the
tags aren’t displayed.

If you edit with Command Tags off, you may want to turn them on periodically
to see what commands are active in the file. For example, it’s a good idea to
have Command Tags on before you delete, copy, or remove text, so that you
can see what commands are included in the text.

For more information, see “Command Tags” in the “Editing Screen View Menu”
chapter.

1-11
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DiALOG BOXES

Filename: [CBNISNSE[H0M0e L B
Page Numbers: Pages:
¢ All o 0dd
o Selected Pages: o Even
¢ Both .
Option button
Copies: ———— Check box
Teithiox [X]1 Use Form Feeds
Printer: DG [ 1 Pause Betueen Pages
[ 1 Print Unformatted Text
Redirect To: [ [X1 Interpret Merge Uariables
Printers:
List —» | ASC256 | ASCII | DRAFT | ws4
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If WordStar needs more information to carry out a command, a dialog box
appears. Each dialog box contains one or more areas where you fill in informa-
tion or select settings.

The illustration below shows the Print dialog box.

List box Command button
M—

The list of printers below the dialog box is displayed because the cursor is in
the list box; whenever you move the cursor to a list box, the corresponding list
appears below the dialog box. The list shows the available choices, for
example, for filenames or fonts.

To move around in a dialog box, press the Tab key to move forward and
Shift+Tab to move backward. To select an option directly, press Alt and the
key for the highlighted or underlined character. You can also use a mouse to
move around and select options. To change settings in a dialog box, use these
procedures.

= |n a list box, type a name, or press the Down Arrow key to move to the list
and then use the Arrow keys to select a name from the list. You can use the
AR (Repeat) command to repeat the information you entered most recently.
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= To select an option button, move to the button for the setting you want. A
diamond shape indicates a selection. If you change your mind, you can
press Alt and the highlighted or underlined character or use the Up or Down
Arrow keys to move to another option button.

= To turn a check box setting on or off, move to the option and press the
Spacebar. An X in the brackets indicates that the setting is on; empty
brackets show an off setting. Once you select the option, you can also press
the Plus (+) key to turn the option on and the Minus (-) key to turn it off.

= When you select an option with a text box, type the appropriate information,
for example, the number of copies to print. (Some text boxes may not be
long enough for the information you need to type; in this case, when you get
to the end of the box, the information you typed scrolls to the left and you
can keep typing.)

To save the settings and close the dialog box, press F10 or choose OK. (F10
enters the WordStar command ~K; you can use ~K and F10 interchangeably.)
To cancel your choices, press Esc or tab to the Cancel button and press Enter
or, if you have a mouse, click Cancel.

TIP If you prefer to use the Enter key instead of the Tab key to move between
options, you can change this setting while editing by choosing Edit—Editing
Settings—.! Closes Dialog. When you use Enter to move between options, it
doesn’t close dialog boxes; use F10, K, or OK. You can also change this
setting using the WINSTALL Change basic editing defaults option.

MOVING THE CURSOR AND SCROLLING

To move the cursor, you can use the direction keys located on the numeric
keypad to the right of the regular keyboard or you can use WordStar com-
mands. (For information about using a mouse to move around in a document,
see “Using a Mouse.”) The direction keys include the Arrow keys, the PgUp
and PgDn keys, the Home key, and the End key.
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The WordStar commands that move the cursor are called the cursor diamond
because of the locations of the keys on the keyboard.

wlelx
ATl
]

Up one line AEor T

Down one line AXord

Left one character AS or «—

Right one character ADor—

Left one word AA or Ne—
Right one word AF or A—

To column 1 in first onscreen line AQE or Home
Beginning of file AQR or AHome
Right end of last onscreen line AQX or End
End of file AQC or AEnd
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Scrolling allows you to move another portion of the text onto the screen, either
vertically or horizontally.

Up one line AW or APgUp
Down one line AZ or APgDn
To previous screen AR or PgUp
To next screen AC or PgDn

For a complete list of cursor movement and scrolling commands, see Quick
Reference.

Usine A MOUSE

The mouse pointer, which is normally a rectangle, appears onscreen when a
mouse is installed on your computer. The pointer does not appear in any
companion program except Inset®. You can switch between the mouse and
keyboard at any time.

If you would rather not use a mouse in WordStar, you can turn off mouse sup-
port in the WordStar customization program WSCHANGE (DCHA).

MoUSE CONVENTIONS IN WORDSTAR

Click means to point to an item and press the left mouse button.

Double-click means to point to an item and press the left mouse button twice in
quick succession.
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Drag means to hold down the left mouse button while you move the mouse,

and then release the button.

Ctrl+Click means to hold down the Ctrl key and press the left mouse button.
Shift+Click means to hold down the Shift key and press the left mouse button.

Ctrl+Shift+Click means to hold down the Ctrl key and press the Shift key and

the left mouse button.

MoVING THE CURSOR AND SCROLLING WITH A MOUSE

The vertical scroll bar, located along the right side of the screen, is for moving
forward and backward in a document. The vertical scroll bar contains a slider

box that indicates the relative position of the cursor in the file.

Previous line

Click T

Next line

Click 1

Previous screen

Click above the slider box

Next Screen

Click below the slider box

Beginning of a document

Drag the slider box to the top

End of a document

Drag the slider box to the bottom

Approximate position in a document

Drag the slider box to the relative
position in the file
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You can use these mouse shortcuts.

FUNCTION KEYS

Change drive/directory at a filenames list

Double-click the directory

Open document

Double-click the document name

Close a document

Double-click the Close File button in
the title bar

Go to page

Click the page number in the status line

Go to marker

Click the marker in the status line

Switch windows

Click in the window

Select setting on style bar

Click the button

When you're using Preview, you can also click on a button in the menu bar to
do the same thing as pressing the corresponding key. You can also use the right
mouse button as a shortcut to View=>Adjust Window, and then drag or click

the mouse to choose a window to view.

Funcrtion KEys

You can use the function keys, which are labeled F1, F2, F3, and so on, to
execute the most frequently used WordStar commands with a single keystroke.
The function keys are set to issue WordStar commands with the WordStar
macro function. For complete information, see Appendix D, “Function Keys

and Other Macros.”
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C OMMAND LINE OPTIONS

When you start WordStar, you can bypass the copyright screen and the
Opening screen to begin editing a document immediately. To do this, type ws
followed by the name of the file you want to edit, for example, ws first.doc.

WordStar opens the file in document mode. To specify nondocument mode,
use the /n option, for example, ws first.doc /n.

The chart below describes the options you can use.

OPTION
/n
/d

/s
/p

/m macroname

/x

/o nnn
/hn

DESCRIPTION
Opens the named file as a nondocument

Opens the named file as a document (use this option if
you've changed the default file mode to nondocument)

Opens a new file with no filename
Prints the named file

Executes the named macro; if a filename is also specified,
opens the file before executing the macro

Exits WordStar upon returning to the Opening screen (use /x
with another option, for example, type filename.doc /p /x
to print the file and then exit WordStar)

Goes to decimal location nnn in the named file

Sets the help level to n (0, 1, 2, 3, or 4)

THE wscHANGE ¢ USTOMIZATION PROGRAM

1-18

The WSCHANGE customization program allows you to set up WordStar to run
the way you want. You can specify initial settings for many features, such as
margins and justification. You can also customize how WordStar works on
your computer. For example, you can change the colors for the screen display.



THE WSCHANGE CUSTOMIZATION PROGRAM

WSCHANGE works through a series of menus, where you make a choice by
typing a letter. When this manual refers to a setting you can change with
WSCHANGE, the letters you press to get to that setting are shown in paren-
theses. For example WSCHANGE (CCD) means that to get to that setting, you
start WSCHANGE and then press C, press C, and press D.

For complete information on WSCHANGE, see the Installing and Customizing
booklet.
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CHAPTER 2

()PENING SCREEN
FILE MENU

The Opening Screen File menu includes commands to open, copy, delete,
rename, and print files, and other commands to manage files.
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NEW

Pull-down: ALT + F, W
Classic: S

Opens a new file without assigning a name fo it.

When you open a new file, it's empty. You can type or insert other files. When
you save the file, WordStar prompts you for a filename.

The file you open when you use the New command is a document file. If you
like, you can use WSCHANGE (DCBA) to make nondocument the default file
format.

OPEN DOCUMENT Pull-down: ALT + F, D

Classic: D

Opens a document file.
Follow these steps to open a document file.
1 Choose File=>Open Document, or use the D classic command.

2 In the Open Document dialog box, specify the name of the file to open.
You can open either an existing file or a new one. If necessary, specify the
path with the filename.

A filename can have up to eight characters and an optional extension of up
to three characters. Type a period between the filename and the extension.
Don’t use spaces between the characters. Filenames can include letters,
numbers, and these symbols:

$&#!% T (){})-_~@

Note: Files with the extensions .COM, .EXE, .OVR, .SYS, .DCT, .CRT, .WSF,
.PDF, .DCC, .INF, .PRD, .WSM, and .$?? (where ? can be any character) do
not appear in the WordStar filename lists, so don’t use them to name your

text files. You can change this list of filename extensions using
WSCHANGE (CEC).
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3 Press F10 or choose OK.

TIP To go directly to a specific file when you start WordStar, type the
filename on the command line. For example, type ws \ws\status.dan to go
directly to the STATUS.DAN file.

For more information on documents and nondocuments (ASClI! files), see
“Open Nondocument.”

OPEN NONDOCUMENT Pull-down: ALT + F, N
Classic: N

Opens a nondocument file.
Follow these steps to open a nondocument file.
17 Choose File=>Open Nondocument, or use the N classic command.

2 In the Open Nondocument dialog box, specify the name of the file to open.
You can open either an existing file or a new one. If necessary, specify the
path with the filename.

3 Press F10 or choose OK.

A nondocument file is in ASCII format, which is a standard text format. When
you edit a nondocument, most of the WordStar text formatting capabilities,
such as aligning text, word wrap, and justification, are not applicable.

TIP To go directly to a specific nondocument file when you start WordStar,
type the filename and the /n option on the command line. For example, type
ws \ws\knox.txt /n to go directly to the KNOX.TXT file in the WS directory.

If you open a nondocument file in document mode by mistake, exit the file
without saving it (File=>Close, or ~KQ). If you save the file, WordStar adds for-
matting codes to it. If you open a document file in nondocument mode and
save it, WordStar strips codes necessary for formatting.

When you print a nondocument, select Print Unformatted Text in the Print
dialog box. (Otherwise, any lines that begin with periods will be considered
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dot commands.) You can print a nondocument with any printer definition file
(PDF), but if your PDF contains formatting codes for documents, you may get
unexpected printing results. If you have problems printing a nondocument,
choose DRAFT for the printer.

DOCUMENTS AND NONDOCUMENTS

The differences between documents and nondocuments are described below.

Menus and Commands Documents have complete menus. For nondocu-
ments, classic menus include only the commands available in nondocument
mode; pull-down menus are the same as those in document mode, but com-
mands that apply only to documents do not work. Two commands work dif-
ferently: in a nondocument, the A0l command sets tab width rather than
displaying the Ruler Line dialog box, and the A6 command turns auto-indent on
and off rather than changing hard carriage returns to soft returns.

Note: When auto-indent is on, WordStar indents lines as they are typed. Type
spaces or tab to the column to which you want to indent. Each time you press

Enter, the new line starts at that column. You can change the amount of inden-
tation by adding or deleting spaces or tabs on the line where you want the new
indentation to begin.

Formatting The following functions are not available for nondocuments:
centering, automatic hyphenation, justification, line spacing, margins, ruler
line, soft hyphens, and word wrap.

Tab Stops Document tab stops are initially set every .5 inch, but you can reset
them anywhere on the ruler line. Tabs in nondocuments usually use a special
tab character and are customarily set every 8 spaces; you can use the A0l
classic command to reset them only to a binary multiple, such as 1,2, 4, or 16
spaces. You can also use WSCHANGE (DCBD) to set nondocument mode to
use other tab stops.

Cursor Indicator In documents, the status line shows the page, line, and

column where the cursor is located. In nondocuments, it shows only line and
column.

Dot Commands WordStar checks dot commands in documents and changes
the screen display and printed documents accordingly. Dot commands in a
nondocument do not take effect, and the commands themselves are printed.
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Embedded Information If you open a document file as a nondocument, you
will see printing-related information embedded in codes throughout the
document.

Go to Page The Go to Page command on the Edit menu (*QI) finds a page
number in documents; it finds a line number in nondocuments.

Aligning Text In nondocument mode, using the Reformat commands on the
Utilities menu (B or AQU) strips high order bits and symmetrical sequences.
Tab sequences are replaced with blanks; soft carriage returns are replaced with
hard carriage returns. Other sequences are deleted.

CONVERTING DOCUMENTS TO NONDOCUMENTS

Before editing a document in nondocument mode, you should convert the file
to nondocument (ASCII) format. Depending on the type of nondocument you
want, you can use any of three methods:

= QOpen the file in nondocument mode, and then choose
Utilities=>Reformat=>Rest of Document, or press AQU. This method
doesn’t preserve any formatting, such as page offset or page breaks.

= Print the file to disk using the ASCII or ASC256 special printer selection. Use
ASC256 if you want extended characters to remain in the file. This method
preserves formatting; spaces are at the beginning of each line if there was a
page offset, and blank lines are at the ends of pages for page breaks.

Use this procedure: Choose File=>Print and specify the file to convert. In
the Print dialog box, select ASCIl or ASC256 in the Printer list box. In the
Redirect To text box, type the name you want to give the ASClI! file. If you
don’t type a filename, the file is named ASCII.WS or ASC256 .WS. Press F10
or choose OK to start printing to disk.

For more information on printing to disk, see “Printing to Disk” in “Print” in
this chapter.

= Mark the entire file as a block, and then choose Edit=>Copy=>To Another File,
or press AKW. In the dialog box, select the Copy in ASCII Format check box.
This method does not preserve any formatting, and does not insert carriage
returns at the end of each line; each paragraph appears as one long line.
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CONVERTING NONDOCUMENTS TO DOCUMENTS

If you want to edit a nondocument (ASCII) file in document mode, open the file
as a document. Before you start editing, you should change the hard carriage
returns to soft returns. Press 76 at each line, except at the last line of each para-
graph and the blank lines between paragraphs. (Use the 6 at the top of the
keyboard and not the 6 in the numeric keypad.) This changes hard carriage
returns to soft returns. Then reformat the entire file (Utilities=>Reformat=>Rest
of Document, or ~QU).

Note: If the text in the nondocument doesn’t start in the far left column on the
screen, before you use 76, you can delete the spaces at the beginning of each
line by putting the cursor in column 1 and pressing AT. Or you can mark the

entire area to the left of the text as a column block and delete the block.

PRINT

Pull-down: ALT + F , P
Classic: P

Prints a file.
Follow these steps to print a file:
17 Choose File=Print, or use the P classic command.

2 In the Print dialog box, change any of the print options you want. The print
options and their defaults are described below.

“

Filename: [SBNTREIEE0MIe L OK B
Page Numbers: Pages: il Cancel §
¢ All o 0dd
o Selected Pages: o Even
¢ Both
Copies:

[X]1 Use Form Feeds
Printer: DRGNS [ 1 Pause Betueen Pages
[ 1 Print Unformatted Text

Redirect To: [N [X1 Interpret Merge Uariables
T T e S T T S T |




PRINT

Filename Select the file to print. The default is the last file you edited.

Page Numbers Select All (the default) to print every page in the file. To
specify the pages to print, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, to print pages 1 through 3 and pages 5 and 7, type 1-3 5 7. (If
you've reassigned page numbers, when you use Selected Pages, printing
starts at the first occurrence of the first number specified, and ends at the
first occurrence of the last number specified.)

Copies You can print more than one copy of the document. The default
is one copy. To change it, type the number of copies you want. (If you
always want the file printed a certain number of times, you can use
Utilities=>Merge Print Commands=>Print File n Times, or the .rp dot
command. See “Merge Print Commands” in “Editing Screen Utilities
Menu.”)

Printer WordStar displays the name of the printer assigned to the file. To
change it, type another printer name or select a name from the list of your
installed printers.

Redirect To The output normally goes to whatever port you specified for
the printer you are using. If you want to redirect the output to another port,
type the name of the port. If you want to redirect output to a disk file, type
the filename. For more information, see “Printing to Disk” in this section.

Pages To print only odd or only even pages, select Odd or Even. The
default is Both.

Use Form Feeds If you want WordStar to send a form feed command when
moving to the next page of a printout, select this check box. Form feeds are
required for a laser printer or other sheet feeder. The default depends on the
type of printer you are using. You can use PRCHANGE to specify a different
default for each of your printers. Whenever you print on paper shorter than

11 inches, clear this box.

Pause Between Pages If you need to have the printer pause between pages
so that you can feed individual sheets of paper to it, select this check box.
You can use PRCHANGE to specify a different default for each of your
printers. The default is no pause. If you select this option, WordStar pauses
before the second page and each subsequent page.
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Print Unformatted Text If you select this option, WordStar prints all the dot
commands and does not execute them. Always use this option for printing
nondocuments. The check box is clear as a default.

Interpret Merge Variables Merge print variables and commands are
interpreted as a default. If you clear this check box, variable names are
printed in the text rather than the variables, and merge print commands are
ignored. For more information on merge print commands and variables, see
“Merge Print Commands” in “Editing Screen Utilities Menu.”

Note: You can change the default settings for many of the print options
using WSCHANGE or PRCHANGE.

3 Press F10 or choose OK to print the file.

WordStar normally prints in the background so that you can continue with what
you were doing before you started printing. The word Printing appears in the
status line. If printing stops during background printing, Print Wait replaces
Printing. You can use WSCHANGE (BDCA) to turn background printing off.
This makes printing faster.

If your file contains any Ask for Variable, Pause Print, or Clear Screen com-
mands, and you are using background printing, the Print Wait message appears
in the status line. You must press P to go to the Printing screen (described
below), and then enter the required response. If your file contains any Display
Message commands, you don't see the messages unless you go to the Printing
screen.

TIP The default speed for printing is full speed. However, some printers
can't receive the printing input at this speed. If you're printing while editing,
you may notice a time lag between pressing keys and the resulting onscreen

operation. To eliminate this lag, use PRCHANGE to change the printing speed
to a slower setting.

The Printing screen shows messages and commands related to printing. The
Printing screen is hidden during background printing. You must display the
Printing screen before you can see a printing-related message or enter a printing-
related command during printing. To display this screen, choose File=>Print or
use the classic command P at the Opening screen or AKP while editing.




PRINT

P Pause F Print at Full Speed

C Continue after Pausing Esc Cancel Printing
B Print from Background

Messages appear below the Printing screen commands. The commands are
described below.

COMMAND DESCRIPTION
P Pauses printing temporarily
C Continues printing after a pause
B Starts background printing and exits the Printing screen
F Starts full-speed printing if you used PRCHANGE to choose

a slower printer speed

Esc Cancels printing completely and exits the Printing screen

During printing, the Printing screen status line shows the page number that is
currently being printed. It also shows the copy number that is currently being
printed. This is useful if you are printing more than one copy of a document.

PRINTING TO DISK

Sometimes you may want to “print” a document to a file on disk rather than
printing it on paper. For example, you can review merge-printed form letters
on the screen before you print them on letterhead paper. You can print to disk
either by typing a filename to redirect the output to or by using one of the spe-
cial printer description files (PDFs). Both methods are described below.

SENDING PRINTER-FORMATTED OUTPUT TO A FILE

To tell WordStar to run a file through a specific PDF and send the output to a
new file rather than sending it to the printer, specify the new filename in the
Redirect To box in the Print dialog box.

You can print to disk if your computer is not connected to the printer, and
produce a disk copy of the document formatted with all the proper codes for
the printer. You can then take the file on a floppy disk to a computer con-
nected to the printer and print the file using the DOS COPY command. For
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example, if the printer is connected to port LPT1, type copy output.doc Ipt1 /b
at the system prompt. For more information on the DOS COPY command, see
your DOS manual.

SPECIAL PDFS FOR PRINTING TO DISK

WordStar allows you to select any of five “printers” that make disk files rather
than sending text to a regular printer. They are named PRVIEW, ASCII,
ASC256, XTRACT, and WS4. You can select one in the Printer box in the Print
dialog box.

Note: The ASCII, ASC256, and WS4 PDFs are already created for you. If you
want to use the PRVIEW or XTRACT PDF, use PRCHANGE to install it.

PRVIEW Produces a file that looks as much like an actual printout as possible,
with headers and footers and with data inserted if you are merge printing. It
begins with the .pl dot command so that the page breaks appear in the proper
spots when you look at the file in document mode. Each line ends with a hard
carriage return.

ASCIl and ASC256 Produce a file that is an ASCII version of the document,
with all print controls and dot commands removed. Each line ends with a hard
carriage return. With ASCII, extended characters (ASCII 128-255) are not
printed or are replaced with ASCII characters; ASC256 prints extended charac-
ters. (You can also use Edit=Copy to Another file, or AKW, to write text to an
ASClI file.)

XTRACT Produces a file similar to the PRVIEW file, but without headers,
footers, and page breaks, and with soft carriage returns. This format allows you
to perform some simple manipulations on text and data files. For example, if
you had a data file named FORM1.DTA with several fields (such as name, title,
company, address, city, state, and zip), you could use XTRACT to create a data
file containing only the information in the name field. Create a file called
FORMI1.LTR containing these commands:

.op

.df forml.dta

.rv name,title, company,address,city,state, zip
&name&
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Note that this file ends with a carriage return after &name& so that each name
prints on a separate line.

When you merge print this file and use the XTRACT PDF, the output file con-
tains only the names from the data file.

WS4  Creates a file that is compatible with WordStar Release 4.

When you use any of these PDFs, specify a name for the output file by typing
the new filename at the Redirect To box in the Print dialog box. If you don’t
specify a new filename when printing with ASCII, ASC256, PRVIEW, or
EXTRACT, the output file is given the same name as the PDF but with a

WS extension, for example, ASCII.WS. With WS4, the new file has the same
filename as the original file with the .\WS4 extension.

PRINT FROM KEYBOARD Pull-down: ALT + F, K
Classic: K

Allows you to use your printer as a typewriter.

This command is useful for addressing envelopes and filling out forms. Follow
these steps:

7 Choose File=Print from Keyboard, or use the K classic command.

2 Inthe Print from Keyboard dialog box, select the template filename, printer,
and, if necessary, the port. These options are described below.

Print from Keyboard

Template Filename: [NINIONG:I0TIHE LB OK B

Printer: [LGIEN I § Cancel &

Redirect Output To: NN

2-11
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Template Filename A sample template file (KEYBOARD.MRQG) is included
with WordStar. You can use that file or create a new one. More
information is given below this list.

Printer Select the printer you’re using. Do not specify a printer, such as
the ASCII printer, that is used to create disk files.

Redirect Output To You can direct the printed output to a different port
just as you can from other printing dialog boxes.

3 Press F10 or choose OK.

4 Type the text you want, and press Enter after each line. As soon as you
press Enter, that line of text is sent directly to the printer. (You must press
Enter before text will print, even if your printer is in unbuffered mode.)
When you print from keyboard, text doesn’t wrap automatically and it can’t
be reformatted.

You can type dot commands while printing from the keyboard. When you
type Enter at the end of the line, the line is not printed, and the dot
command takes effect. Do not use the .co command (for columns) because
printing is unpredictable. WordStar interprets any line that begins with a
period as a dot command.

5 When you finish typing the text, press Esc to quit.

When printing begins depends on the type of printer you have. On page
printers, the entire page must be filled before printing begins. If you want to
print before the page is full, try a manual form feed or type a .pa (page break)
command or use a APL (form feed) command. On daisy wheel printers, the
internal buffer must be full.

Template Files Template files for printing from the keyboard contain dot
commands that define the page margins. A template file can also include dot
commands for selecting a font, changing line height and line spacing, and turn-
ing off page numbers. A template file also includes .av dot commands that ask
for variables at print time.
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A template file might look like this:

Lk, T

.rp 65000 (lets you repeat the instructions that
follow up to 65,000 times)

.mt 0 top margin of zero)

.mb 0 bottom margin of zero)

.op omits page numbers)

(
(
(
.av text (asks for variable “text”)
(
(
(

.1h 8 line height of 6 lines per inch)
.1s 2 double spacing)
&texté& text variable)
FAX Pull-down: ALT + F, F

Classic: \
Creates files that you can send with a fax board.

This command creates fax files in .PCX format. These files can be transmitted
directly through a fax board using the software that came with the fax board.
The resulting faxes look like the printed file, including all the fonts and other
formatting.

Note: Most fax boards can transmit .PCX files. However, if your board does
not support .PCX format, you must convert the .PCX file to a format supported
by the board. Most fax board software includes a conversion utility that can
do this.

One .PCX file is created for each page in a document. All the .PCX files you
create are placed in the WS\FAX directory, which WordStar creates the first
time you create a fax file. You can specify another fax file directory using
WSCHANGE (CD4l).

Follow these steps to create fax files:

7 Choose File=>Fax, or use the \ classic command.

2 In the Fax dialog box, specify the name of the file to fax. If necessary,
specify the path with the filename.

2-13



OPENING SCREEN FILE MENU

2-14

3

4

Fax File Location: C:\WS\FAX . Cancel

If you want to change the displayed name for the first fax file to create,
specify the name you want. The default is the first five letters of the original
filename, followed by three digits that represent the page number, starting
with 001. Fax files for subsequent pages are numbered sequentially. The
filename extension is always .PCX.

If the filename you specify is the name of an existing file, WordStar asks if
you want to overwrite the file. If you choose Overwrite (or press Y),
WordStar deletes the old file and replaces it with the new file. If you choose
Cancel (or press N), WordStar does not create the fax files. You can start
again and use a different filename.

TIP To avoid confusion, always choose a unique filename when you
create fax files, and delete fax files promptly when you no longer need them.

Change any of the options you want. These options are described below.

File to Fax: [sHNINNNITTHORII0 L

Name of Fax File: FINY [LH. PCX Resolution: § view §
o Lou

High

Special 388 dpi

9-pin Dot Matrix

24-pin Dot Matrix

Fax Page Numbers:
¢ All

o Selected Pages: [N

0O 00 ¢

Fax Page Numbers Select All (the default) to create fax files for every page.
To specify pages, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, for pages 1 through 3 and pages 5 and 7, type 1-3 5 7.

IMPORTANT When you use Selected Pages, you must specify the
physical page numbers, even if you've reassigned page numbers. For
example, if you have a three-page document with no page number on the
first page, and the second and third pages numbered 1 and 2, you must
specify 2-3 (or 2 3) to create fax files for the last two pages. If you're not
sure about the physical page numbers, you can choose the View button
(described below) to start Preview. Preview displays the physical page
numbers at the top of the screen or, if more than one page is displayed,
above each page.
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Resolution Select the resolution your fax board uses. High resolution, the
default, is 200x200 dots per inch (dpi), and low resolution is 200x100 dpi.
The Special 300 dpi option is provided for fax drivers that use this
resolution. The 9-Pin Dot Matrix and 24-Pin Dot Matrix settings are not
used for creating fax files. They create files that can be printed on a dot
matrix printer using a utility (not provided with WordStar) for printing .PCX
files.

If the setting does not match the setting in your fax software, the file may not
look right when it is faxed. High resolution produces much better-looking
output. (Be sure to send the fax using the same resolution you create it with.)

View You can choose the View button to preview the file in order to
decide which pages to create fax files for. While you are previewing the
file, you can use all the usual Preview commands, including the Options
command to create fax files. If you create fax files in Preview, you return to
editing when you exit Preview; otherwise, you return to the Fax dialog box.
For more information about Preview, see “Preview” in “Editing Screen View
Menu.”

5 When you finish, press F10 or choose OK. WordStar creates the fax file or
files, displaying the progress.

You can press Esc to cancel fax file creation after the current page, or
press Esc twice to cancel it immediately.

After you create a fax file, you can use the SHOWPCX utility to identify the file,
to make sure you’ve processed the correct pages, and to check the quality of
the fonts. Start at the system prompt, type showpcx fax\filename (you don’t
need to type the .PCX extension), and press Enter. The fax file appears on the
screen in half-size format, so that you can see more of the page. Press the

plus (+) key on the numeric keypad to view it in maximum resolution. You can
use the scrolling commands and PgUp and PgDn to move around on the page.
When you finish viewing the file, press Esc to exit SHOWPCX. (Depending on
your monitor and the resolution you specified for the fax file, the image may
not have the proper proportions.)
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When you are working with fax files, keep these things in mind:

The fax file is a graphic representation of the printed page and is created
using the same process as Preview. All the features and limitations of
Preview apply to creation of fax files. For example: The same fonts are
available, and a 72-point font is used for fonts that are larger than 72 points.
Colors other than white are changed to black. System variables (such as date
and time) and merge print variables are not replaced with the corresponding
data.

For the best appearance of fonts in fax files, it’s best to use the FAX.PDF
printer driver for the document. This printer driver supplies fonts
comparable to Hewlett-Packard Laseret Il fonts, including Courier, Line
Printer, and scalable Times and Univers fonts. FAX.PDF is installed when
you install WordStar. You can add your own fonts to this PDF using
PRCHANGE.

The best way to determine how the fax will look is by using Preview at
4x zoom. Usually (depending on your monitor resolution), this option
corresponds most closely with the fax file resolution.

Creating fax files requires up to 27K of memory in addition to what WordStar
usually needs. You may need to free up memory for optimum performance
with fax files. See Installing and Customizing for guidelines on memory
usage. If your fax driver software remains in memory, you may need to
remove it before starting WordStar, and send your faxes after exiting
WordStar.

If the appearance of fonts (especially large fonts) is blocky, WordStar may
need more memory while creating screen fonts. If less than 512K is
available when you start WordStar, you can remove memory-resident
programs or use WSCHANGE settings to make more memory available, and
then run the DELCRT utility to delete the blocky fonts. Then start WordStar
and create the fax files again. You can also improve these fonts by creating
.WSF files for large fonts using smaller symbol sets. For more information on
WSF files, see the Installing and Customizing booklet.

Fax files are large, and take up a lot of disk space. You may want to delete
them regularly. Also, .CRT files are created when you create fax files. You
can delete .CRT files that you no longer need using the DELCRT utility. For
more information, see “Preview Files” in “Preview” in “Editing Screen View
Menu.”
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COPY

Pull-down: ALT + F - 0
Classic: O

Copies a file.

Copying makes an exact duplicate of the file being copied; the original is saved,
not erased. Follow these steps to copy a file:

1

2

Choose File=Copy, or use the O classic command.

In the Copy dialog box, specify the name of the file to copy. If the file is not
on the current drive and directory, specify the path with the filename.

Specify the name of the file to copy to. You can put the copy on another
drive or directory by specifying the path with the filename.

You can use the same filename if you copy from one drive or directory to
another, but you cannot have two files with the same name in the same
directory. If the filename you specify for the new copy is the name of an
existing file, WordStar asks if you want to overwrite the file. If you choose
Overwrite (or press Y), WordStar deletes the old file and replaces it with the
new file. If you choose Cancel (or press N), WordStar does not copy the
file. You can start again and use a different filename.

Press F10 or choose OK to copy the file.

DELETE

Pull-down: ALT + F, T
Classic: 'Y

Deletes a file.

Follow these steps to delete a file:

1

2

Choose File=Delete, or use the Y classic command.

In the Delete dialog box, specify the name of the file to delete. If the file is
not on the current drive and directory, specify the path with the filename.
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3 Press Y or Enter to confirm you want to delete the file.

4 Press F10 or choose OK to delete the file.

RENAME Pull-down: ALT + F, E
Classic: E

Renames a file.
Follow these steps to rename a file:
7 Choose File=Rename, or use the E classic command.

2 In the Rename dialog box, specify the name of the file to rename. If the file
is not on the current drive and directory, specify the path with the filename.

3 Type a new name for the file.

If the filename you specify is the name of an existing file, WordStar tells you
that the file already exists. Type a different name.

4 Press F10 or choose OK to rename the file.

TIP You can move a file when you rename it by specifying the path with the
filename. The new location must be on the same disk drive.

PROTECT/UNPROTECT Pull-down: ALT + F, C
Classic: C

Protects a file so that it can’t be changed, or removes protection from a
protected file.

Use this command to protect master versions of form documents and final

drafts of documents so they can’t be changed accidentally. You may want to
protect files if you share disks with other people. You can remove the
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protection whenever you want. Follow these steps to protect a file or remove
the protection from a file.

1 Choose File=Protect/Unprotect, or press C, the classic command.

2 In the Protect/Unprotect dialog box, specify the name of the file to protect or
unprotect. If the file is not on the current drive and directory, specify the
path with the filename.

WordStar shows whether the file is currently protected and asks if you want
to change the setting.

3 Press F10 or choose OK to protect or unprotect the file.

When you edit a protected file, Protect is displayed in the status line. You can
move through the file, but you can’t use commands that would change it, and
you can’t add or delete anything. To leave a protected file, choose File=>Close
or use the AKQ classic command.

WordStar automatically protects backup files (.BAK) from changes as a safety
measure. Files are also protected by DOS if you have too many files in the root
directory of a disk (for most disks, 110-112 files). You must remove some files
from the full directory to unprotect the files in the directory.

You can also protect files (or make them read-only) using the operating system
or other software, such as local area network (LAN) software. WordStar can’t
unprotect files protected by other software.

CHANGE DRIVE/DIRECTORY Pull-down: ALT + F, V
Classic: L

Changes the logged drive and directory.
The logged drive or directory is the one you're currently working in. WordStar
looks for and stores files on the logged drive and directory unless you tell it

otherwise.

1 Choose File=Change Drive/Directory, or use the L classic command.
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2 In the Change Drive/Directory dialog box, specify the name of the drive and
directory to change to.

3 Press F10 or choose OK.

CAUTION When you change disks in a floppy disk drive, log on to the
drive again. If you don’t, the operating system may refuse to write to the disk,
or it may damage data on the new disk. (Never remove a floppy disk while
you're editing a file on it and then log on to the drive again.)

CHAN GE FILENAME DISPIAY Pull-down: ALT + F, H
Classic: F

Changes which filenames are displayed in the filenames list.

When you choose File =>Change Filename Display, or use the F classic command,
the Change File Listings dialog box appears. Type the filenames you want to
see at the Opening screen. Use the * and ? wild-card characters. For example,
begin with CHAP, have four more characters, and have no filename extension.
Note: You can omit all filenames with a certain extension from the filename

list using WSCHANGE (CEC). For more information, see “Open Document” in
this chapter.

RUN DOS COMMAND Pull-down: ALT + F, R
Classic: R

Allows you to run a DOS command without leaving WordStar.

When you use this command, WordStar temporarily moves into the back-
ground, and you can type the DOS command you want. For example, you can
start Lotus 1-2-3 and look up information on a spreadsheet, or you can use the

DOS CHKDSK command to check how much free disk space you have.

7 Choose File=Run DOS Command, or use the R classic command.
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2 In the Run DOS Command dialog box, type the DOS command to run.

3 Press F10 or choose OK.

TIP If you want to run more than one DOS command without returning to
WordStar, type command and press Enter to run the DOS command processor.
You can then run as many commands as you want. When you finish using DOS
commands, type exit and press Enter. Then press any key to return to WordStar.

The amount of memory you can use to run DOS commands depends on how
much memory WordStar is using, whether you are using any memory-resident
programs, how much EMS memory is available to WordStar, and how much
disk space is available.

CAUTION Never load a memory-resident program (such as DOS PRINT
or Sidekick) using this command. If you plan to use such a program from
within WordStar, be sure you load it before you start WordStar.

S TATUS

Pull-down: ALT + F, U

Displays the Status screen.

“

Classic: ?

Current Filename: C(noned Continue
Inset: Not Loaded
Default printer: DRAFT
Release: WordStar for DOS North American Uersion 7.8 Reu. A
Serial Number: 12345678
Language: United States (881)
— Memory Usage
WordStar: 218k Messages: 2k Hyphenation: Bk
Text and Data: 86k Printing: Bk Thesaurus: Bk
Spelling: 8k
Conuentional Memory In Use: 298k Available: 278k
Expanded Memory C(EMS) In Use: 256k Available: 4336k
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The Status screen gives information on last file edited, Inset status, default
printer, WordStar version and serial number, language, and memory usage.

E XIT WORDSTAR Pull-down: ALT + F, X
Classic: X

Exits WordStar.
If you’re printing in the background when you use the Exit command, the Print-

ing screen appears. You must wait until printing finishes, or press Esc to cancel
printing, before you exit WordStar.



CHAPTER 3

OPENING SCREEN
UTILITIES MENU

The Opening Screen Ultilities menu includes commands for creating an index or
a table of contents and for using the WordStar macro system.

Utilities]
T

TOC...
Macros >

~
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Z
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9
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m
Z
&
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=
m
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=
™
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c

Jl%V])lle Pull-down: ALT + U, I
Classic: 1

Creates an index.
You can create an index from entries you’ve already made in a document, or
you can tell WordStar to index every word except those listed in an exclusion

list. (Exclusion lists are described later in this section.)

For information on marking index entries in your documents, see “Index/TOC
Entry” in “Editing Screen Insert Menu.”
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Follow these steps to create an index:
7 Choose Utilities=>Index, or use the | classic command.

2 In the Index dialog box, specify the name of the file to index. Specify the
directory path if necessary.

3 Select any options you want to change. The options are described below.

Page Numbers Select All (the default) to index the entire file. To specify
the pages to index, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, to index pages 1 through 3 and pages 5 and 7, type 1-3 5 7. (If
you've reassigned page numbers, when you use Selected Pages, indexing
starts at the first occurrence of the first number specified, and ends at the
first occurrence of the last number specified.)

Index Every Word If you don't select this check box (the default), WordStar
indexes only the entries you’ve marked and typed. If you select this option,
WordStar indexes all those entries, and all the words in the document minus
any words that appear in exclusion lists.

)
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Pages To index only odd or only even pages, select Odd or Even. The
default is Both.

4 Press F10 or choose OK to create the index.

WordStar creates an index file that has the same filename as the document with
the .IDX extension. All entries in the file are in alphabetical order with the page
numbers listed, and duplicate entries are combined. You can edit the index file
to make any formatting changes or corrections.

EXCLUSION LISTS

An exclusion list is a nondocument file that contains an alphabetical list of
words to exclude from an index. WordStar uses two exclusion lists.

The general exclusion list is named WSINDEX.XCL and is supplied with
WordStar. It contains a list of the most common words in English (articles,
pronouns, prepositions, conjunctions, and so on) that are rarely indexed.
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The document-specific exclusion list has the same name as the document for
which you are making the index, but with the .XCL extension. To create this
list, create a nondocument file with the appropriate name, and type the specific
words from your document that you want to exclude from the index. Be sure to
type each word on a separate line.

TIP You can quickly create a document-specific exclusion list. First, use the
Index command to index every word in your document. Next, open the index
file as a nondocument and delete the words you do want in the index. Then
change the extension of the file to .XCL. This file is now an exclusion list.

TOC

Pull-down: ALT + U, T
Classic: T

Creates a table of contents.

The table of contents is created from entries you’ve previously inserted in your
document. For information on entering table of contents entries, see
“Index/TOC Entry” in “Editing Screen Insert Menu.”

Follow these steps to create a table of contents:
1 Choose Utilities=>TOC, or use the T classic command.

2 In the Table of Contents dialog box, specify the name of the file to create the
table of contents for. Specify the directory path if necessary.

3 Select any options you want to change. The options are described below.

Page Numbers Select All (the default) to include table of contents entries
from the entire file. To specify pages, select Selected Pages and type the
page numbers, separated with spaces. You can specify a range by using a
hyphen. For example, to create a table of contents for pages 1 through 3
and pages 5 and 7, type 1-3 5 7. (If you've reassigned page numbers,
when you use Selected Pages, the table of contents starts at the first
occurrence of the first number specified, and ends at the first occurrence of
the last number specified.)
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Pages To create a table of contents from entries on only odd or only even
pages, choose Odd or Even. The default is Both.

4 Press F10 or choose OK to create the table of contents.

WordStar places all the table of contents entries, with page numbers, in a new
file that has the same filename as the document with the .TOC extension. You
can edit the table of contents file to make any formatting changes or corrections.

If you specified table of contents entries for separate tables of contents using
.tc1, .tc2, and so on, WordStar creates a separate table of contents file for each
with the extensions .TO1, .TO2, and so on.

MACROS Pull-down: ALT + U, M
Classic: M

Records, creates, edits, or runs a macro that enters a longer series of text and
commands.

The WordStar macro capabilities allow you to use a few keystrokes to enter a
series of keystrokes and commands. For example, you can create a macro so
that each time you press Alt+W, the word WordStar is inserted in your text. Or
a macro can change the order of two words (mark the first word as a block,
move the cursor to the end of the next word, and move the block).

When you choose Macros, the following menu appears.

Play. .. MP
Record. .. MR

Edit/Create... MD
Single Step... MS

Copy... MO
Delete... MY
Rename. . . ME

You can create a macro in either of two ways:

= Use Record, or the MR classic command, to record keystrokes. This is the
easier way to create a macro. WordStar records commands and keystrokes
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as you enter them. When you are finished, WordStar compiles them into a
macro file that contains all the appropriate macro commands.

= Use Edit/Create, or the MD classic command, to enter macro commands into
a file that you edit like a nondocument. To use this command, you need to
know the WordStar macro language. This language allows you to create
macros that are too complex to record with the Record command. For
example, you can repeat a certain action as many times as needed each time
you run the macro. The example in “The Macro Language” in “Editing
Screen Ultilities Menu” enters a bullet character and waits for you to type
text, then repeats that sequence after the end of each paragraph; the macro
stops and returns you to editing when you finish your bulleted list.

If you need to write a macro that is too complex to record, you can first record
a simple macro that contains commands and keystrokes that can be recorded,
then use Edit/Create to add the macro language for the rest of the macro. You
can also copy a macro and edit it to create a similar one, and you can copy
blocks of macro commands from one macro file to another.

After you create a macro, you can use Single Step, or the MS classic command
to play it back step by step to identify any problems.

To execute a macro, you can either use a hot key, or use Play or the MP classic
command. You can stop the macro by pressing Esc or ABreak. (When a macro
is paused for input, you must use ~Break.) You can change the Esc keystroke or
add another key to stop a macro in WSCHANGE (DCDC and DCDD).

You can also copy, rename, and delete macros using commands on the Macros
menu.

TIP You can set up a macro to run a series of commands that you frequently
use when you start WordStar. Then you can run the macro immediately when
you start WordStar by typing ws /mmacroname. for example, you can set up a
macro named LETTER to change to the C:\CUSTOMER directory, open a new
file, and read in a file of boilerplate text and formatting. Then, any time you
want to start WordStar and start a new letter, type ws /mletter. If you want to
start WordStar, open a file, and then run a macro, type the filename before the
/m option.
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W ORKING WITH MACROS

MACRO HOT KEYS

You can execute a macro by pressing a single key or key combination called a
hot key. You can assign a hot key to a macro when you create it. Eighty-two
hot keys are available:

The function keys F2 through F9, and F11 and F12. (F1 is reserved for Help
and F10 for closing dialog boxes.)

The function keys F1 through F12 combined with the Shift key.
The function keys F1 through F12 combined with the Ctrl key.
The function keys F1 through F12 combined with the Alt key.

The Alt key combined with the letters A-Z and the digits 0-9.

Keep these points in mind about macro hot keys:

The Alt key combined with the letters F, E, V, I, S, L, U, and H access the
WordStar pull-down menus. If you use any of these keystrokes as hot keys,
you can'’t use them for those menus. (You can still display the menus using a
mouse or using the Right and Left Arrow keys in the menu bar.)

You don't have to assign a hot key to each macro. If a macro is not assigned
a hot key, you can run the macro using the Play command (or the MP classic
command).

If you want to assign a hot key to a macro that doesn’t have one, or change
the hot key assigned to a macro, use Macros=>Rename, or ME. Don’t use
Macros=>Record (MR); it will erase the macro and create a new one.

WordStar comes with predefined macros for most of the function key hot
keys and for several other hot keys. These macros are listed in Appendix D,
“Function Keys and Other Macros.” You can define new macros for these
keys if you want, using Record (MR) or Edit/Create (MD).
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MACRO FILES AND DIRECTORIES

Each macro is stored as a file, with the name you gave it while recording or edit-
ing and the .WSM extension.

CAUTION When you record, create, or edit a macro and save it,
WordStar compiles the macro, adding executable code. Macro files appear to
be nondocuments (ASCII files) when you edit them, but they contain other
information. You must edit them with Macros=>Create/Edit (or MD) to get
usable macros.

On most systems, all the macro files are stored in one directory. The default

macro directory name is WS\MACROS; you can change it with WSCHANGE
(CD2G).

Pull-down: ALT + U, M, P
Classic: MP

Executes a macro.

You can execute a macro either using a hot key or using this command. For an
explanation on using hot keys, see “Macro Hot Keys” in this section.

Follow these steps to play a macro:
1 Choose Utilities=Macros=>Play, or use the MP classic command.

2 In the Play Macro dialog box, specify the macro to play. You can choose
the macro either by name or hot key. When you press the Down Arrow key
and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.

3 Press F10 or choose OK.

WordStar executes all the commands and enters all the text specified in the
macro. Generally, menus and dialog boxes are not displayed unless you need
to enter input.

You can stop the macro by pressing Esc or ~Break. (When a macro is paused
for input, you must use ~Break.)
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REcorD

Pull-down: ALT + U, M, R
Classic: MR

Records a series of keystrokes and stores them as a macro that you can
execute.

You can create a macro by choosing Record and then pressing all the
keystrokes that you want in the macro. Follow these steps:

7

2

Choose Utilities=>Macros=>Record, or use the MR classic command.

In the Record Macro dialog box, type the name you want to give the macro.
If the macro name is already in use, confirm that you want to redefine the
macro, or specify another name.

Specify the hot key that will execute the macro. You can press the Down
Arrow key and scroll through the list to see which hot keys are available. If
the hot key you specify is already in use, confirm that you want to reassign
the hot key or specify another hot key. If you don’t want to assign a hot key
to the macro, you can skip this step.

Type a description of the macro to remind you of what it does and to help
you find it in the list. The description can be up to 48 characters long. If
you don’t want to give a description for the macro, you can skip this step.

Press F10 or choose OK.

Enter all the keystrokes you want in the macro. Enter them in the same way
you want to play them back when you run the macro.

You may need the macro to pause when you run it so that you can enter
information such as a filename. At any place you want the macro to pause,
press Alt+hyphen. Then type any number of keystrokes as an example of
the input. Press Alt+hyphen again to end the pause, and continue entering
the macro keystrokes. When you execute the macro, it pauses at that point
for input and continues after you press Alt+hyphen. (You can change the
Alt+hyphen keystroke to another keystroke in WSCHANGE (DCDB).)

Note: Mouse actions and clicks are not recorded in macros and do not
work while you are recording a macro; you must use the keyboard.
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7 When you finish entering the keystrokes, press Alt+= (hold down the Alt key

and press =). (You can change the Alt+= keystroke to another keystroke

using WSCHANGE (DCDA).)

WordStar records and compiles the macro. If you want to make adjustments to
the macro, you can either record it again or edit it using Macros=>Edit/Create,
or the MD classic command.

EDIT/CREATE Pull-down: ALT + U, M, E

Classic: MD

Creates and modifies a macro that contains keystrokes and commands that
you enter.

Each macro consists of a series of WordStar commands and functions. You edit
a macro using the same commands you use for editing a nondocument file. Fol-
low these steps:

-4

Choose Utilities=>Macros=>Edit/Create, or use the MD classic command.
In the Edit/Create Macro dialog box, specify the macro name.

When you press the Down Arrow key and scroll through the list of macros,
the description for the highlighted macro appears in the dialog box.

If you're creating a new macro, specify the hot key that will execute the
macro. You can press the Down Arrow key and scroll through the list to see
which hot keys are available. If the hot key you specify is already in use,
confirm that you want to reassign the hot key or specify another hot key. If
you don’t want to assign a hot key to the macro, you can skip this step.

Type a description of the macro to remind you of what it does and to help
you find it in the list. The description can be up to 48 characters long. If
you don’t want to give a description for the macro, you can skip this step.

Press F10 or choose OK. WordStar opens a full-screen editing window for
the macro.
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7

Type the text of the macro or make any editing changes. For information
about what you can enter, see “The Macro Language” in “Macros” in
“Editing Screen Utilities Menu.” When you edit a macro, you can use the
commands used for editing nondocuments.

TIP You may want to periodically use File=>Save (*KS) to save your
changes while editing.

When you finish, save the macro using File=>Save and Close (*KD).

WordStar compiles the macro. If it finds any syntax errors or other errors, they
are entered into the macro file. You must edit the macro again to correct the
errors.

Errors in a macro file are noted by a message describing the error, followed by
the line of the macro that contains the error, with a caret (*) below the line
pointing to the location of the error.

TIP The Alt+D hot key is preassigned to a macro that goes to the next error
message in a macro file. This is helpful when you edit macros to fix errors.

If you want to copy a block of text from one macro into another, be sure to start
from the Opening screen. Choose Macros=>Edit/Create (or MD), and then
choose File=>Open/Switch (or ~OK). Then copy the block between the win-
dows in the same way you would while editing a document.

SINGLE STEP Pull-down: ALT + U, M, S

Classic: MS

Plays back a macro one step at a time to locate errors.

After you create or edit a macro, you can play it back step by step to identify
any problems. This command is helpful when a macro doesn’t work exactly as
you expect it to. Follow these steps:

1

2

Choose Utilities=>Macros=>Single Step, or use the MS classic command.

In the Single Step dialog box, specify the macro to play. You can specify
the macro either by name or by hot key. When you press the Down Arrow
key and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.
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Press F10 or choose OK.
WordStar executes the first command or keystroke in the macro, and pauses.

Press the Spacebar to continue to the next command, function, or keystroke.
Continue in this manner until the macro finishes. You can stop running the
macro by pressing Esc or ABreak. (When a macro is paused for input, you
must use ABreak.)

Pull-down: ALT + U, M, C
Classic: MO

Copies a macro.

If you want to create a macro similar to another one, you can copy the first
macro and edit the copy. You can also make copies of macros so that several
people can use them on their computers. Follow these steps:

1

2

Choose Utilities=>Macros=>Copy, or use the MO classic command.
In the Copy Macro dialog box, specify the macro to copy.

You can specify the macro either by name or by hot key. When you press
the Down Arrow key and scroll through the list of macros, the description
for the highlighted macro appears in the dialog box.

Specify the macro name for the new copy. Type the path with the name if
necessary. If the name is already in use, confirm that you want to overwrite
the current macro.

4 Press F10 or choose OK to copy the macro.

The copied macro has the same description as the original, but is not assigned a
hot key. You can assign a hot key and description when you edit the macro, or
you can use Rename Macro (or the ME classic command).

3-11
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DELETE Pull-down: ALT + U, M, D
Classic: MY

Deletes a macro.

Follow these steps to delete a macro:

1 Choose Utilities=>Macros=>Delete, or use the MY classic command.

2 In the Delete Macro dialog box, specify the macro to delete. You can
specify the macro either by name or by hot key. When you press the Down
Arrow key and scroll through the list of macros, the description for the

highlighted macro appears in the dialog box.

3 Press F10 or choose OK to delete the macro, and confirm the deletion.

RENAME Pull-down: ALT + U, M, N
Classic: ME

Renames a macro.

You can use this command to rename a macro, assign a new hot key, or add or
edit a description. Follow these steps:

T Choose Utilities=>Macros=>Rename, or use the ME classic command.

2 In the Rename Macro dialog box, specify the macro to rename. You can
specify the macro either by name or by hot key. When you press the Down
Arrow key and scroll through the list of macros, the description for the
highlighted macro appears in the dialog box.

3 Specify the new macro name, hot key, and/or description. If the name or
hot key is already in use, confirm that you want to overwrite the current
assignment.

4  Press F10 or choose OK to rename the macro.




CHAPTER 4

(O PENING SCREEN
ADDITIONAL MENU

The Opening Screen Additional menu includes commands for starting the
MailList”, TelMerge®, and Star Exchange® companion programs.

Additional
MailList AM
TelMerge AT

Star Exchange AS

MAILLIST Pull-down: ALT + A, M
Classic: AM

Starts the MailList program.

MailList lets you easily create, update, and sort mailing lists and inventories by
providing you with ready-made forms on which to enter your data. You can
then merge print letters, envelopes, reports, labels, and lists using this data. For
information, see “MailList” in the Companion Programs manual.
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OPENING SCREEN ADDITIONAL MENU

TELMERGE Pull-down: ALT + A, T

Classic: AT
Starts the TelMerge telecommunications program.
TelMerge lets you easily link to telecommunications services such as MCI Mail

and electronic bulletin boards. It also lets you send files over your phone lines.
For information, see “TelMerge” in the Companion Programs manual.

S TAR EXCHANGE Pull-down: ALT + A, S

Classic: AS
Starts the Star Exchange file conversion program.

Star Exchange converts documents created with one word processor to docu-
ments that are compatible with another word processor. After you convert a
file to WordStar format using Star Exchange, you can edit the file with
WordStar. For information, see “Star Exchange” in the Companion Programs
manual.



CHAPTER 5

(O PENING SCREEN
HELP MENU

Use the commands on the Opening Screen Help menu to get onscreen help for
WordStar commands and options, and to change the way WordStar displays
menus and prompts.

Change Help Level...

H ELP Pull-down: ALT + H, H
Classic: F1

Displays help for the current command.

You can get onscreen help for every WordStar command and for each option in
a dialog box.

If you are using pull-down menus, when you choose Help from the Help menu,
you get an overview of WordStar help. To get help for a specific command,
highlight it on the menu and press F1. To get help in a dialog box, press F1.
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OPENING SCREEN HELP MENU

If you are using classic menus, press F1 at the Opening Menu or at the editing
screen, and then press the command you want help with. To get help in a
dialog box, press F1.

CHAN GE HELP LEVEL Pull-down: ALT + H, C
Classic: F1 F1

Changes which menus and prompts are displayed.

Once you're an experienced WordStar user, you might want to display classic
menus instead of pull-down menus, or turn off the display of menus and confir-

. mation prompts altogether. You can do either of these by changing the help
level.

The classic menus take up one third of most screens, so turning them off by
changing from help level 3 to help level 2 allows you to see considerably more
of a document while you edit. Even when menus are not displayed, you can
still use the commands.
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Follow these steps to change the help level:

7 If you are using pull-down menus, choose Help=>Change Help Level. If
you are using classic menus, press F1 F1.

2 Choose the help level you want.

HELP LEVEL DESCRIPTION

4 Pull-down menu names are displayed on the menu bar at
the top of the screen. To see a menu, hold down the Alt
key and press the first letter of the menu name. All prompts
are displayed. This is the default setting.

3 All classic menus and prompts are displayed.

2 The classic Edit Menu is not displayed, but prompts are
displayed. This gives a full-screen display of the document.
Other classic menus are displayed if you pause after
pressing the menu letter (AK, 2O, AP, Q).




CHANGE HELP LEVEL

HELP LEVEL DESCRIPTION

1 No menus are displayed during editing unless you ask for
help. Dialog boxes asking you to confirm a response are
not used either.

0 Menus are not displayed unless you ask for help.
Confirmation dialog boxes are not displayed. You can
move, copy, and delete hidden blocks.

3 Press F10 or choose OK.

At help levels 2 and below, you can display the classic Edit Menu by pressing
F1.

You can change the default help level at the WINSTALL Set Basic Editing
Defaults menu or using WSCHANGE (DBAA).




CHAPTER 6

EDITING SCREEN
FILE MENU

The File menu includes commands to open, close, save, and print files, prepare
files for fax transmission, and other commands to manage files.

m
O
=
Z
Q
¥}
@)
=
™
™
P4
-
=
m
=
m
Z
e

Open/Suitch. .. ~0K |
Close

Save “KS
Save fis... “KT
Save and Close “KD
Print... “KS™KP
Fax... “K\
Change Printer... “P?
Copy. .. “KO
Delete. .. ~KJ
Rename. . . “KE
Change Drive/Directory... "KL
Run DOS Command. .. “KF
Status ~07
Exit WordStar “KQX
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EDITING SCREEN FILE MENU

OPEN/SWITCH Pull-down: ALT F, W

Classic: "OK

Opens a window so that you can look at two documents at once, or at two
parts of the same document. If two windows are already open, moves the
cursor to the other window.

Follow these steps to open a new window or to move the cursor to the other
window:

17 Choose File=>Open/Switch, or use the AOK classic command.

2 In the Open dialog box, specify the name of the file to open. You can open
either an existing file or a new one.

A filename can have up to eight characters and an optional extension of up
to three characters. Type a period between the filename and the extension.
Don’t use spaces between the characters. Filenames can include letters,
numbers, and these symbols:

$&#1% " (){}-_~@

Note: Files with the extensions .COM, .EXE, .OVR, .SYS, .DCT, .CRT, .WSF,
.PDF, .DCC, .INF, .PRD, .WSM, and .$2? (where ? can be any character) do not
appear in the WordStar filenames lists, so don’t use them to name your text
files. You can change this list of filename extensions using WSCHANGE (CEC).

3 Press F10 or choose OK. The screen splits in half. The cursor is located in

the new file on the bottom half of the screen.

You can edit in either window. To move the cursor to the other window, use
this command or choose View=>Open/Switch Window, or use the AOK classic
command.

The title bar shows a [1] when the cursor is in the top window and a [2] when
the cursor is in the bottom window. It also shows the name of the file where
the cursor is currently located. You can use a mouse to switch to the other win-
dow by clicking this number.

The file in the second window is always opened as a document if the file in the
first window is a document, or as a nondocument if the file in the first window
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is a nondocument. If you want to be able to open a document and a nondocu-
ment at the same time, use WSCHANGE (DCGQ) to turn on the prompt that
asks you whether to open a document or a nondocument when you open a
second window.

TIP If you want to see how the document you're editing looked before you
made your most recent editing changes, you can open a second window on the
same document. The second window shows the version that you saved last, in
protected mode, because you can’t make changes to both copies.

Keep these points in mind when working with two windows:

= To change the sizes of the windows, choose View=Change Window Size,
or use the AOM classic command. You can also press A~ (hyphen) to
enlarge the current window one line at a time. For more information, see
“Change Window Size” in “Editing Screen View Menu.”

= You can mark blocks in both windows at once. To copy a block between
windows, choose Edit=>Copy=>Block from Other Window, or press KA.
To move a block between windows, choose Edit=>Move=>Block from Other
Window, or press AKG. For more information, see “Copy” and “Move” in
“Editing Screen Edit Menu.”

= You cannot edit notes or macros when you have a document in the second
window.

CLOSE

Pull-down: ALT + F, C

Closes the file you are editing.

If you have made any changes to the file since you last saved it, WordStar asks
if you want to save the changes, abandon them, or cancel the operation. The
default is to save the changes.

You can also use the AKQ classic command to close the file and abandon
changes. If you press AKQ, and you have made changes to the file since you
last saved it, WordStar tells you that you’ve made changes and asks whether
you want to abandon it anyway. The default is Yes, to abandon. If you choose
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No, WordStar returns you to editing; if you choose Save, WordStar saves the
changes and closes the file.

SAVE

Pull-down: ALT + F, S
Classic: "KS

Saves the file you’re editing, then resumes editing in the same place.

It's a good idea to use this command periodically when you're working in a file. It
guarantees you won't lose your work if you have a power failure or other problem.

When you edit an existing file, the original file stays on disk while you work on
a copy in the computer’s memory. Each time you save the file, the copy in
memory (with all your changes) goes back on the disk and replaces the original
file. The original is saved as the backup file, with the .BAK extension.

SAVE AS Pull-down: ALT + F > A

Classic: "KT
Saves the file you are editing and allows you to rename the file.
Follow these steps to save and name a file.
7 Choose File=>Save As, or use the AKT classic command.

2 In the Save As dialog box, specify the name for the file. Include a directory
path if necessary.

3 Press F10 or choose OK to save the file.
If you keep the same filename, the previous version of the file is saved as the
backup file. If you give the file a different name than it originally had, the

original file is unchanged.

T1P Ifthe current disk is full and you want to save the file to another disk,
just specify the new drive as part of the filename.



SAVE AND CLOSE

SAVE AND CLOSE Pull-down: ALT + F, L

Classic: KD
Saves the file and returns you to the Opening screen.
This command saves the file with the same name it had when you opened it.

When you edit an existing file, the original file stays on disk while you work on
a copy in the computer’s memory. Each time you save the file, the copy in
memory (with all your changes) goes back on the disk and replaces the original
file. The original is saved as the backup file, with the .BAK extension.

TIP Ifyou try to save a file and WordStar tells you there is insufficient disk
space to save it, you can choose File=>Save As (or use “KT) to save it to a
different disk, or you can choose File=Run DOS Command (or use "KF) to
delete files from the disk so that you can save the file.

PRINT

Pull-down: ALT + F, P
Classic: "KS"KP

Saves the current file and then prints it.
This command saves the current file and then prints it (or prints another file that
you specify). The file is not closed; you can continue editing it, although your

changes aren’t printed. Follow these steps:

7 Choose File=>Print, or use the classic commands ~KS (to save the file) and
then ~AKP (to print it).

2 In the Print dialog box, change any of the print options you want. The print

options and their defaults are described below.
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Filenane: [IIXTEHIY

Page Numbers: Pages: ¢ Cancel
* All o 0dd
o Selected Pages: o Even
¢ Both
Copies:

[X] Use Form Feeds
Printer: [ 1 Pause Betueen Pages
[ 1 Print Unformatted Text
Redirect To: Interpret Merge Uariables

e ————————

Filename Specify the file to print. The default is the file you are currently
editing.

™
x
P&

Page Numbers Select All (the default) to print every page in the file. To
specify the pages to print, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, to print pages 1 through 3 and pages 5 and 7, type 1-3 5 7. (If
you've reassigned page numbers, when you use Selected Pages, printing
starts at the first occurrence of the first number specified, and ends at the
first occurrence of the last number specified.)

Copies You can print more than one copy of the document. The default
is one copy. To change it, type the number of copies you want. (If you
always want the file printed a certain number of times, you can use
Utilities=>Merge Print Commands=>Print File n Times, or the .rp dot
command. See “Merge Print Commands” in “Editing Screen Ultilities
Menu.”)

Printer WordStar displays the name of the printer assigned to the file. To
change it, type another printer name or select a name from the list of your
installed printers.

Redirect To The output normally goes to whatever port you specified for
the printer you are using. If you want to redirect the output to another port,
type the name of the port. If you want to redirect output to a disk file, type
the filename. For more information, see “Printing to Disk” in “Print” in
“Opening Screen File Menu.”
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Pages To print only odd or only even pages, choose Odd or Even. The
default is Both.

Use Form Feeds If you want WordStar to send a form feed to the printer
when moving to the next page of a printout, select this check box. Form
feeds are required for a laser printer or other sheet feeder. The default
depends on the type of printer you are using. You can use PRCHANGE to
specify a different default for each of your printers. Clear this box whenever
you print on paper shorter than 11 inches.

Pause Between Pages If you need to have the printer pause between pages
so you can feed individual sheets of paper to it, select this check box. You
can use PRCHANGE to specify a different default for each of your printers.
The default is no pause. If you select this option, WordStar pauses before
the second page and each subsequent page.

Print Unformatted Text If you select this option, WordStar prints all the dot
commands and does not execute them. Always use this option for printing
nondocuments. The check box is clear as a default.

Interpret Merge Variables Merge print variables and commands are
interpreted as a default. If you clear this check box, variable names are
printed in the text rather than the variables, and merge print commands are
ignored. For more information on merge print commands and variables, see
“Merge Print Commands” in “Editing Screen Utilities Menu.”

Note: You can change the default settings for many of the print options
using WSCHANGE or PRCHANGE.

Press F10 or choose OK to print the file.

WordStar normally prints in the background so that you can continue with what
you were doing before you started printing. The word Printing appears in the
status line. If printing stops during background printing, Print Wait replaces
Printing. You can use WSCHANGE (BDCA) to turn background printing off.
This makes printing faster.

If your file contains any Ask for Variable, Pause Print, or Clear Screen com-
mands, and you are using background printing, the Print Wait message appears
in the status line. You must press P to go to the Printing screen (described
below), and then enter the required response. [f your file contains any Display
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Message commands, you don't see the messages unless you go to the Printing
screen.

TIP The default speed for printing is full speed. However, some printers
can't receive the printing input fast enough. If you're printing while editing,
you may notice a time lag between pressing keys and the resulting onscreen
operation. To eliminate this lag, use PRCHANGE to change the printing speed
to a slower setting.

The Printing Screen shows messages and commands related to printing. The
Printing screen is hidden during background printing. You must display the
Printing screen before you can see a printing-related message or enter a printing-
related command during printing. To display this screen, choose File=>Print or
use the classic command P at the Opening screen or AKP while editing.

Printing

P Pause F Print at Full Speed

C Continue after Pausing Esc Cancel Printing
B Print from Background

Messages appear below the Printing screen commands. The commands are
described below.

COMMAND DESCRIPTION
P Pauses printing temporarily
C Continues printing after a pause
B Starts background printing and exits the Printing screen
F Starts full-speed printing if you used PRCHANGE to choose

a slower printer speed
Esc Cancels printing completely and exits the Printing screen
During printing, the Printing screen status line shows the page number that is

currently being printed. It also shows the copy number that is currently being
printed. This is useful if you are printing more than one copy of a document.
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FAX

Pull-down: ALT + F, F
Classic: K\

Creates files that you can send with a fax board.

This command creates fax files in .PCX format. These files can be transmitted
directly through a fax board using the software that came with the fax board.
The resulting faxes look like the output to the printer, including all the fonts and
other formatting.

Note: Most fax boards can transmit .PCX files. However, if your board does
not support .PCX format, you must convert the .PCX file to a format supported
by the board. Most fax board software includes a conversion utility that can
do this.

One .PCX file is created for each page in a document. All the .PCX files you
create are placed in the WS\FAX directory, which WordStar creates the first
time you create a fax file. You can specify another fax file directory using
WSCHANGE (CD4l).

Follow these steps to create fax files:
17 Choose File=>Fax, or use the AK\ classic command.

2 In the Fax dialog box, specify the name of the file to fax. If necessary,
specify the path with the filename.

3 If you want to change the displayed name for the first fax file to create,
specify the name you want. The default is the first five letters of the original
filename, followed by three digits that represent the page number, starting
with 001. Fax files for subsequent pages are numbered sequentially. The
filename extension is always .PCX.

If the filename you specify is the name of an existing file, WordStar asks if
you want to overwrite the file. If you choose Overwrite (or press Y),
WordStar deletes the old file and replaces it with the new file. If you choose
Cancel (or press N), WordStar does not create the fax files. You can start
again and use a different filename.

TIP To avoid confusion, always choose a unique filename when you
create fax files, and delete fax files promptly when you no longer need them.
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6-10

4 Change any of the options you want. These options are described below.

File to Fax: [BENIETTIEMI0e L

Fax File Location: C:\WS\FAX Cancel
Name of Fax File: [IGIHY (. PCX Resolution: B view §
o Lou

Fax Page Numbers: ¢ High
¢ All o Special 380 dpi
o

o Selected Pages: [ 9-pin Dot Matrix

o 24-pin Dot Matrix

Fax Page Numbers Select All (the default) to create fax files for every page.
To specify pages, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, for pages 1 through 3 and pages 5 and 7, type 1-3 5 7.

IMPORTANT  When you use Selected Pages, you must specify the
physical page numbers, even if you've reassigned page numbers. For
example, if you have a three-page document with no page number on the
first page, and the second and third pages are numbered 1 and 2, you must
specify 2-3 (or 2 3) to create fax files for the last two pages. If you're not
sure about the physical page numbers, you can choose View=>Preview (or
AOP). Preview displays the physical page numbers at the top of the screen
or, if more than one page is displayed, above each page.

Resolution Select the resolution your fax board uses. High resolution,
the default, is 200x200 dots per inch (dpi), and low resolution is 200x100
dpi. The Special 300 dpi option is provided for fax drivers that use this
resolution. The 9-Pin Dot Matrix and 24-Pin Dot Matrix settings are not
used for creating fax files. They create files that can be printed on a dot
matrix printer using a utility (not provided with WordStar) for printing
PCX files.

If the setting does not match the setting in your fax software, the file may not
look right when it is faxed. High resolution produces much better-looking
output. (Be sure to send the fax using the same resolution you create it with.)

View You can choose the View button to preview the file in order to
decide which pages to create fax files for. While you are previewing the
file, you can use all the usual Preview commands, including the Options
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command to create fax files. If you create fax files in Preview, you return to
editing when you exit Preview; otherwise, you return to the Fax dialog box.
For more information about Preview, see “Preview” in “Editing Screen View
Menu.”

5 When you finish, press F10 or choose OK. WordStar creates the fax file or
files, displaying the progress.

You can press Esc to cancel fax file creation after the current page, or press
Esc twice to cancel it immediately.

After you create a fax file, you can use the SHOWPCX utility to identify the file,
to make sure you've processed the correct pages, and to check the quality of
the fonts. Start at the system prompt, type showpcx fax\filename (you don't
need to type the .PCX extension) and press Enter. The fax file appears on the
screen in half-size format, so that you can see more of the page. Press the Plus
(+) key on the numeric keypad to view it in maximum resolution. You can use
the scrolling commands and PgUp and PgDn to move around on the page.
When you finish viewing the file, press Esc to exit SHOWPCX. (Depending on
your monitor and the resolution you specified for the fax file, the image may
not have the proper proportions.)

When you are working with fax files, keep these things in mind:

= The fax file is a graphic representation of the printed page and is created
using the same process as Preview. All the features and limitations of
Preview apply to creation of fax files. For example: The same fonts are
available, and a 72-point font is used for fonts that are larger than 72 points.
Colors other than white are changed to black. System variables (such as
date and time) and merge print variables are not replaced with the
corresponding data.

= For the best appearance of fonts in fax files, it's best to use the FAX.PDF
printer driver for the document. This printer driver supplies fonts
comparable to Hewlett-Packard LaserJet Il fonts, including Courier, Line
Printer, and scalable Times and Univers fonts. FAX.PDF is installed when
you install WordStar. You can add your own fonts to this PDF using
PRCHANGE.

= The best way to determine how the fax will look is by using Preview at
4x zoom. Usually (depending on your monitor resolution), this option
corresponds most closely with the fax file resolution.
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Creating fax files requires up to 27K of memory in addition to what WordStar
usually needs. You may need to free up memory for optimum performance
with fax files. For guidelines on memory usage, see Installing and
Customizing. If your fax driver software remains in memory, you may need
to remove it before starting WordStar, and send your faxes after exiting
WordStar.

If the appearance of fonts (especially large fonts) is blocky, WordStar may
need more memory while creating screen fonts. If less than 512K is
available when you start WordStar, you can remove memory-resident
programs or use WSCHANGE settings to make more memory available, and
then run the DELCRT utility to delete the blocky fonts. Then start WordStar
and create the fax files again. You can also improve these fonts by creating
\WSF files for large fonts using smaller symbol sets. For more information on
\WSF files, see the Installing and Customizing booklet.

Fax files are large, and take up a lot of disk space. You may want to delete
them regularly. Also, .CRT files are created when you create fax files. You
can delete .CRT files that you no longer need using the DELCRT utility. For
more information, see “Preview Files” in “Preview” in “Editing Screen View
Menu.”

CHAN GE PRINTER Pull-down: ALT + F, H
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Classic: “P?

Changes the printer assigned to the file you are editing.

When you choose this command, WordStar displays a list of the available
printer description files (PDFs), and you can choose the one you want. Follow
these steps:

1

2

Choose File=>Change Printer, or use the ~AP? classic command.

In the Change Printer dialog box, specify the name of the printer to use. The
list below the dialog box shows the available printers.

Press F10 or choose OK.
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After you change the printer, you can use Style=>Font (or AP=) to see the fonts
available for that printer. See “Font” in “Editing Screen Style Menu.”

After you change the printer and any fonts you need to change, be sure to refor-
mat your document (Utilities=>Reformat=>Rest of Document or the AQU classic
command).

COPY

Pull-down: ALT + F ) o0
Classic: "KO

Copies a file.

Copying makes an exact duplicate of the file being copied; the original is saved,
not erased. Follow these steps to copy a file:

1

2

Choose File=>Copy, or use the AKO classic command.

In the Copy dialog box, specify the name of the file to copy. If the file is not
on the current drive and directory, specify the path with the filename.

Specify the name of the file to copy to. You can put the copy on another
drive or directory by specifying the path with the filename.

You can use the same filename if you copy from one drive or directory to
another, but you cannot have two files with the same name in the same
directory. If the filename you give for the new copy is the name of an
existing file, WordStar asks if you want to overwrite the file. If you choose
Overwrite (or press Y), WordStar deletes the old file and replaces it with the
new file. If you choose Cancel (or press N), WordStar does not copy the
file. You can start again and use a different filename.

4 Press F10 or choose OK to copy the file.

6-13
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D ELETE

Pull-down: ALT + F = T
Classic: “KJ

Deletes a file.

Follow these steps to delete a file:

1 Choose File=>Delete, or use the ~AKJ classic command.
2 In the Delete dialog box, specify the name of the file to delete. If the file is
not on the current drive and directory, specify the path with the filename.
3 Press Y or Enter to confirm you want to delete the file.
4 Press F10 or choose OK to delete the file.
RENAME Pull-down: ALT + F, E

Classic: "KE

Renames a file.

Follow these steps to rename a file:

1

2

4

Choose File=>Rename, or use the ~KE classic command.

In the Rename dialog box, specify the name of the file to rename. I[f the file
is not on the current drive and directory, specify the path with the filename.

Type a new name for the file.

If the filename you type is the name of an existing file, WordStar tells you
that that file already exists. Type a different name.

Press F10 or choose OK to rename the file.

TIP You can move a file when you rename it by specifying the path with the
filename. The new location must be on the same disk drive.

6-14
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CHAN GE DRIVE/DIRECTORY Pull-down: ALT + F,V
Classic: "KL

Changes the logged drive and directory.

The logged drive or directory is the one you're currently working in. WordStar
looks for and stores files on the logged drive and directory unless you tell it

otherwise.

1 Choose File=>Change Drive/Directory, or use the ~AKL classic command.

2 In the Change Drive/Directory dialog box, specify the name of the drive and
directory to change to.

3 Press F10 or choose OK.

CAUTION When you change disks in a floppy disk drive, log on to the
drive again. If you don’t, the operating system may refuse to write to the disk,
or it may damage data on the new disk. (Never remove a floppy disk while
you’re editing a file on it and then log on to the drive again.)

RUN DOS COMMAND Pull-down: ALT + F, R
Classic: “"KF

Allows you to run a DOS command without leaving WordStar.

When you use this command, WordStar temporarily moves into the back-
ground, and you can type the DOS command you want. For example, you can
start Lotus 1-2-3 and look up information on a spreadsheet, or you can use the
DOS CHKDSK command to check how much free disk space you have.

7 Choose File=>Run DOS Command, or use the AKF classic command.

2 Inthe Run DOS Command dialog box, type the DOS command to run.

3 Press F10 or choose OK.
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TIP If you want to run more than one DOS command without returning to
WordStar, type command and press Enter to run the DOS command processor.
You can then run as many commands as you want. When you finish using
DOS commands, type exit and press Enter. Then press any key to return to
WordStar.

The amount of memory you can use to run DOS commands depends on how
much memory WordStar is using, whether you are using any memory-resident
programs, how much EMS memory is available to WordStar, and how much
disk space is available.

CAUTION Never load a memory-resident program (such as DOS PRINT,
Inset or Sidekick) using this command. If you plan to use such a program from
within WordStar, be sure you load it before you start WordStar.

S TATUS Pull-down: ALT + F ’ U
Classic: "O?

Displays the Status screen.

d_

Current Filename: C:\WS\SHAKE.DOC

Continue

Byte count: 128
Markers set: (noned
Inset: Not Loaded
Current printer: HP3

Release: WordStar for DOS North American Uersion 7.8 Reu. A
Serial Number: 12345678
Language: United States (881>

— Memory Usag
WordStar: 210k Messages: 2k Hyphenation: Bk
Text and Data: 188k Printing: Bk Thesaurus: Bk
Spelling: Bk
Conuentional Memory In Use: 298k flvailable: 278k
Expanded Memory C(EMS) In Use: 256k Available: 4336k
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The Status screen gives information on the current filename, byte count from
the beginning of the file to the cursor position, markers set, Inset status, printer,
WordStar version and serial number, language, and memory usage.

EXIT WORDSTAR Pull-down: ALT + F, X
Classic: "KQX

Closes the file without saving changes, then immediately exits WordStar.

If you’ve made changes to the file since the last time you saved it, WordStar
prompts you to verify that you want to abandon your changes.

If you're printing in the background when you use the Exit command, the Print-
ing screen appears after you exit the file. You must wait until printing finishes,
or press Esc to cancel printing, before you exit WordStar.



CHAPTER /.

EDITING SCREEN
EDIT MENU

The Edit menu includes commands for marking and working with blocks of
text, finding and replacing text, going to various locations in the file, editing
notes, and other editing operations.

i T R R e e 0
Mark Block Beginning "“KB
Mark Block End “KK
Move >
Copy >
Delete >

Mark Previous Block "KU

Find... “QF
Find and Replace... "0A
Next Find L
Go to Character... “QG
Go to Page... ~QI
Go to Marker >
Go to Other »
Set Marker >
Edit Note “OND
Note Options >
Editing Settings >
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UNDO

Pull-down: ALT + E, U
Classic: U

Cancels or stops a command.
You can use Undo to cancel many WordStar operations. For example, you can

= Restore the text that you most recently deleted

® Cancel a response to a prompt before the response is final
= Stop a find or a find-and-replace operation

= Stop a spelling check

= Stop printing

RESTORING TEXT

When you choose Edit=>Undo or use the AU classic command, the last group
of characters you erased is restored to the screen (unerased) at the current cur-
sor location.

Undo does not unerase single characters erased with the Backspace key, the
Del key, ~G, or AH (except for note tags, index tags, graphics tags, and user
print tags). However, you can use WSCHANGE (DBEB) to specify that they can
be unerased.

TIP Unerasing is an easy way to move a phrase. Erase the text, move the
cursor to the new location, and choose Edit=>Undo.

WordStar stores your last erasure in a special memory buffer. Only the last
erasure is stored. Each time you erase something, WordStar empties the buffer
of the previous erasure and puts the current erasure in its place.

Using Undo copies the contents of the buffer into the text. It does not empty
the buffer. You can unerase the same text repeatedly. This is useful for
duplicating words and phrases.



MARK BLOCK BEGINNING

Normally, WordStar unerases a maximum of 500 bytes, but you can change
that value with WSCHANGE (CCJ). Keep in mind that the buffer is in working
memory. Therefore, the larger the buffer, the less memory is available for edit-
ing your files and other WordStar operations.

MARK BLOCK BEGINNING Pull-down: ALT + E, B
Classic: "KB

Marks the beginning of a block of text.

A block is a portion of text that you mark so that you can perform a task on it,
for example, move, copy, or delete it.

When you choose Edit=>Mark Block Beginning or use the ~KB classic com-
mand, the <B> marker appears. Once you mark both ends of the block, the
markers disappear, and the block is highlighted.

TIP |t's a good idea to have Command Tags display on before you mark a
block, so that you can see what commands you're including in the block. For
example, if you mark bold text, be sure to include both the beginning and end
bold command tags.

MARKING A BLOCK WITH A MOUSE

To mark a block using a mouse, position the mouse pointer where you want the
block to begin. Drag the mouse to where you want the block to end and
release the button.

If you drag the mouse down, the text above it is highlighted to the end of each
line unless column mode is on (for information on column mode, see “Editing
Settings” in this chapter).

You can also use the following keyboard/mouse button combinations to mark a
block:

Ctrl+Click If no block is marked, marks a block from the cursor to the mouse
pointer. If a block is already marked, sets a new block beginning marker.
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Shift+Click If no block is marked, marks a block from the cursor to the mouse
pointer. If a block is already marked, sets a new block ending marker.

Ctrl+Shift+Click Unmarks the block in the current window and moves the cur-

sor to the mouse pointer position.

WORKING WITH BLOCKS

Keep these points in mind when you work with blocks:

* The block beginning marker, <B>, must precede the block end marker, <K>,
in the text. In column block mode, the end marker must also be to the right

of the beginning marker.

= To mark a new block, move the cursor to the new block beginning and end
locations and mark them. The <B> and <K> markers move to the new

locations.

= A block is marked only while you are editing. After you exit the file, the

block is no longer marked.

®  You can mark one block at a time in each window.

® You can unmark the block in the current window by pressing AKU.

For more information about working with blocks, see the following sections:

TOPIC

Moving a block

Copying a block

Copying a block to another file
Deleting a block

Column blocks

Hiding a block

Inserting a block from another file

SECTION

“Move” in this chapter

“Copy” in this chapter

“Copy” in this chapter

“Delete” in this chapter
“Editing Settings” in this chapter

“Block Highlighting” in “Editing Screen
View Menu”

“File” in “Editing Screen Insert Menu”
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TOPIC SECTION

Block math “Block Math” in “Editing Screen
Utilities Menu”

Sorting a block alphabetically “Sort Block” in “Editing Screen
Utilities Menu”

Converting the case of the text “Convert Case” in “Editing Screen

in the block Style Menu”

Counting words in a block “Word/Character Count” in “Editing

Screen Utilities Menu”

MARK BLOCK END Pull-down: ALT + E, E

Classic: "KK
Marks the end of a block of text.

When you choose Mark Block End, the <K> marker appears. Once you mark
both ends of the block, the marker disappears, and the block is highlighted.

To include the carriage return in the last line of the block, mark the block end
at the beginning of the next line.

For more information on working with blocks, see “Mark Block Beginning”
above.

Move

Pull-down: ALT + E, V

Moves a block of text to the current cursor position.

The following table describes the commands on this menu and the correspond-
ing classic commands.
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PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

Block AKV Moves the marked block to the current
cursor position.

Block from ~KG Moves the block marked in the other

Other Window window to the current cursor position.

The block is inserted; it does not overtype text. The text at the original location
disappears.

For information on moving a block in column mode, see “Editing Settings” in
this chapter.

COPY

Pull-down: ALT + E, C

Copies a block of text.

Block “KC
Block from Other Windou “KA
From Windous Clipboard "KL
To Windows Clipboard “K1
To Another File... “Ku

The following table describes the commands on this menu and the correspond-
ing classic commands.

PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

Block AKC Copies the marked block of text to the
current cursor position.

Block from AKA Copies the block of text marked in the

Other Window other window to the current cursor
position.

From Windows AK] Copies the block of text from the

Clipboard Microsoft Windows Clipboard to the

current cursor position.
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PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

To Windows ~K] Copies the block of text to the Microsoft
Clipboard Windows Clipboard.

To Another File AKW Copies the marked block of text to

another file. In the dialog box, specify
the name of the file to which to copy the
block. Include a path if necessary. If
you select Copy in ASCII Format,
WordStar strips out the formatting
(command tags and dot commands) and
converts tabs to spaces. If you specify a
file that already exists, you can either
Overwrite (delete the old file and create
a new one consisting of the block) or
Append (add the block to the end of the
existing file). If you type a filename that
does not already exist, a new file is
created and the block is copied to it.

The block you copy is inserted; it does not overtype text. The text at the
original location remains where it is and is still marked as a block.

To copy a block to or from the Windows Clipboard, you must be running
WordStar under the Windows program in 386 enhanced mode. When you
copy a block from the Clipboard, the text is inserted into your WordStar file in
ASCII format. You cannot copy a block from the Clipboard if it contains
graphics or text that is not in ASCIl format. When you copy a block to the Clip-
board, all WordStar formatting commands are removed, so that only the text is
copied, in ASCII format. The block replaces the previous contents of the Clip-
board. If the block includes a note tag, only the reference number is copied; to
copy a note to the Clipboard, display the note text, mark it as a block, and then
copy it.

Note: The Windows clipboard is limited to 64K of data; if you try to copy a
larger block, only the first 64K can be copied. Also, WordStar needs up to 64K
of memory (depending on the size of the block) to copy a block to the Clip-
board; if enough memory is not available, only part of the block is copied.

For information on copying a block when you're using column mode, see “Edit-
ing Settings” in this chapter.
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D ELETE

Deletes text.

Pull-down: ALT + E, D

Block
Word
Line

Line Left of Cursor "QDel
Line Right of Cursor "QY
To Character... “QT

The following table describes the commands on this menu and the correspond-

ing classic commands.

PULL-DOWN
COMMAND

Block

Word

Line

Line Left of
Cursor

Line Right
of Cursor

To Character

CLASSIC

COMMAND DESCRIPTION

NICY

AT

A

AQDel

/\QY

/\QT

Deletes the currently marked block.
The text around it is automatically
reformatted.

Deletes from the cursor position to the
end of the word.

Deletes the entire current line (the one
containing the cursor).

Deletes the text on the same line as and
to the left of the cursor.

Deletes the text on the same line as and
to the right of the cursor.

Deletes all the text up to a specified
character. Specify the character at the
Delete to Character dialog box. You
can type a period to delete to the end of
the sentence, or press Enter to delete to
the end of the paragraph. (If display of
dot commands is off, dot commands are
not deleted.)

You can also use several other keys to delete text.
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COMMAND DESCRIPTION

AG or Del Deletes the character, space, or command tag at
the cursor.

AH or Backspace Deletes the character, space, or command tag to the

left of the cursor.

TIP Use Edit=>Undo ("U) to restore the last text deleted (except single
characters). See “Undo” in this chapter.

MARK PREVIOUS BLOCK Pull-down: ALT + E, K
Classic: "KU

Marks the block that was marked before you marked the current block or
moved a block marker.

When you choose Edit=>Mark Previous Block, or use the ~KU classic com-
mand, WordStar marks the block that was previously marked. If no block was
marked before the current one, the command has no effect.

This command allows you to work with two blocks of text. You can, for
example, mark one block and copy it, then mark another and move it, then
re-mark the first block to copy it again.

FIND Pull-down: ALT + E, F
Classic: AQF

Locates text that you specify.
Follow these steps to find text in the current document.
1 Choose Edit=>Find, or use the AQF classic command.

2 In the Find dialog box, type the text to find. Guidelines for typing text are
given after these steps.
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| BT HlCity- Boys-and- Girls: Club

options: [N = Cancel

Search:

¢ For Next Occurrence [ 1 Whole Words
o Entire File/Global [ 1 Ignore Case (WD
[ 1 Backuard
Occurrence: Z [ 1 Use 7 Wildcard Character

3 Select any options you want to use, or type the option letters in the Options
box, which shows all the selected options. Press AY if you want to clear all
the options. The options are described below. As a default, the search is for
the next occurrence and no other options are used. You can set default
options with WSCHANGE (DBGA).

Search For Next Occurrence (C) Finds the next occurrence (or the
previous one, if Search Backward is also used) after the current cursor
location.

Search Entire File/Global (G) Moves to the beginning of the file (or the
end, if Search Backward is also used) before beginning the search.

Occurrence (n) When you select this option, you also type a number, n.
Then the search goes to the nth occurrence of the search text. For example,
to find the fifth occurrence of a word in the document, type 5.

Whole Words (W) Finds whole words only. For example, if you type
“can” and don't select this option, WordStar finds “can,” “canned,”
“American,” and “scandal.”

Ignore Case (U) Ignores the case (uppercase or lowercase) of the
characters. This option finds text whether or not any letters are capitalized.

Backward (B) Searches backward from the cursor toward the beginning of
the file.

Use 2 Wildcard Character (2) Treats a question mark (?) in the search text
as a wildcard character. For example, if you type “d?g” and select this




FIND

option, WordStar finds “dig,” “dog,” and “dug.” If you use a ? in the search
text and don’t select this option, WordStar searches for the ? character.

When you finish selecting options, press F10 or choose OK to start the find
operation. The cursor moves to the next instance of the text you typed.

If you want to go to the next instance of the text you typed, choose
Edit=>Next Find, or use the AL classic command.

To interrupt a Find operation, press Esc.

TYPING THE TEXT TO FIND

When you type the text to find, keep these things in mind:

WordStar can find any sequence of characters, including spaces and control
characters (control characters are the command tags that begin with a caret,
such as AB for bold). The text to find can be up to 65 characters long.

When you type the text to find, you must be precise. WordStar searches for
exactly what you type. If you type an extra space after a word, WordStar
finds it only if you used an extra space in the text.

You can use the question mark (?) as a wildcard character. For example, to
find all occurrences of Suzy, Susy, and Suzi, type Su??.

To specify a control character that is included in the text to find, press AP
and the character. For example, to specify a bold command (APB), hold
down the Ctrl key and press PB (be sure to hold down the Ctrl key for both
keystrokes).

To specify a hard carriage return, hold down the Ctrl key and press N. To
find a soft hyphen at the end of a line, hold down the Ctrl key and press P—.
To find a soft hyphen in the middle of a line, hold down the Ctrl key and
press P6.

Note: You can find some elements using Go To commands. See the informa-
tion on the Go To commands in this chapter.
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FIND AND REPIACE Pull-down: ALT + E, R
Classic: AQA

Locates text and replaces it with text you specify.
Follow these steps to find and replace text in the current document.
1 Choose Edit=>Find and Replace, or use the A"QA classic command.

2 In the Find and Replace dialog box, type the text to find. Guidelines for
typing text are given after these steps.

Find and Replace

|30 HlCheryl Mattheus

Replace: Cancel
Options: NN
[X1 Align
Search: [ 1 Don’t Ask
¢ For Next Occurrence [ 1 Whole Words
o Entire File/Global [ 1 Ignore Case (WD
o Rest of File [ 1 Maintain Case
[ 1 Backuard
Replace [Jji] Occurrences [ 1 Use ? Wildcard Character

—

3 Type the replacement text.

4 Select any options you want to use, or type the option letters in the Options
box, which shows all the selected options. Press AY if you want to clear all
the options. The options are described below. As a default, the search is for
the next occurrence and no other options are used. You can set default
options with WSCHANGE (DBGA).

Search For Next Occurrence (C) Finds the next occurrence (or the
previous one, if Search Backward is also used) after the current cursor

location.

Search Entire File/Global (G) Searches globally through the entire file
starting from the beginning (or the end if Search Backward is also used).
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Search Rest of File (R) Searches through the rest of the document for all
occurrences of the text.

Replace n Occurrences (n) When you select this option, you also type a
number, n. Then WordStar finds and replaces n occurrences of the text.
For example, to replace five occurrences of a word, type 5.

Align (A) Aligns the paragraph after replacement. After reaching the end of
the paragraph, the cursor returns to the spot where the replacement was
made. If you don’t use this option, you may need to reformat your
paragraphs after replacing text.

Don’t Ask (N) Replaces text without asking whether or not you want to
make the replacement. As a default, the replace operation is displayed so
that you can keep track of it.

Whole Words (W) Finds whole words only. For example, if you type
“can” and don’t select this option, WordStar finds “can,” “canned,”
“American,” and “scandal.”

Ignore Case (U) Ignores the case (uppercase or lowercase) of the
characters. This option finds text whether or not any letters are capitalized.

Maintain Case (M) Enters the replacement text using the same case as the
text you're replacing.

Backward (B) Searches backward from the cursor toward the beginning of
the file.

Use ? Wildcard Character (?) Treats a question mark (?) in the search text
as a wildcard character. For example, if you type “d?g” and select this
option, WordStar finds “dig,” “dog,” and “dug.” If you use a ? in the search
text and don't select this option, WordStar searches for the ? character.

TIP When you select Entire File or Rest of File with the Don’t Ask option,
you can turn off the display of replacements to speed up the operation. Just
press the Spacebar after the operation starts.

5 When you finish selecting options, press F10 or choose OK to start the Find
and Replace operation. The cursor moves to the next instance of the text
you typed and WordStar asks whether you want to replace this instance

(unless you selected the Don’t Ask option).
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6

7

Choose Yes to replace the text or No to skip this instance.

If you selected the Entire File option, WordStar goes to the next instance of
the text to find, and you repeat step 6.

If you didn’t select the Entire File option, and you want to go to the next
instance of the text you typed, choose Edit=>Next Find, or use the AL classic
command.

To interrupt a Find and Replace operation, press Esc.

TyYPING THE TEXT TO FIND

When you type the text to find or the replacement text, keep these things in
mind:

WordStar can find and replace with any sequence of characters, including
spaces and control characters (control characters are the command tags that
begin with a caret, such as ~B for bold). The text to find and the
replacement text can each be up to 65 characters long.

When you type the text to find, you must be precise. WordStar searches for
exactly what you type. If you type an extra space after a word, WordStar
finds it only if you used an extra space in the text.

You can use the question mark (?) as a wildcard character in the text to find.
For example, to find all occurrences of Suzy, Susy, and Suzi, type Su??.

To specify a control character that is included in the text to find or the
replacement text, press AP and the character. For example, to specify a bold
command (*PB), hold down the Ctrl key and press PB.

To specify a hard carriage return, hold down the Ctrl key and press N. To
find a soft hyphen at the end of a line, hold down the Ctrl key and press P-.
To find a soft hyphen in the middle of a line, hold down the Ctrl key and
press P6.

Note: You can find some elements using Go To commands. See the informa-
tion on the Go To commands in this chapter.
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NEXT FIND Pull-down: ALT + E, X
Classic: "L

Locates the next instance of text you specified with Find or Find and Replace.

If you used Find, WordStar moves the cursor to the next occurrence of the
specified text and returns you to the editing screen.

If you used Find and Replace, WordStar moves the cursor to the next occur-
rence of the specified text, asks whether you want to replace it, replaces it if
you answer Yes, and then returns you to the editing screen.

GO TO CHARACTER Pull-down: ALT + E, G
Classic: AQG

Moves the cursor to the next occurrence of a particular character.
To go to a character, follow these steps:
1 Choose Edit=>Go to Character, or use the *QG classic command.

2 In the Go to Character dialog box, type the character to go to. You can type
any character, or you can press Enter to go to the end of the paragraph.

If dot command display is off, WordStar ignores characters in a dot command.

GO TO PAGE Pull-down: ALT + E, P
Classic: AQI

Moves the cursor to the first character on the page (or line, in a
nondocument) you specify.

Follow these steps to go to a page:

1 Choose Edit=Go to Page, or use the ~QI classic command.
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2 In the Go to Page dialog box, type the page number to go to. You can also
type the Plus ( + ) sign for the next page or the Minus (- ) sign for the
previous page. To go forward or back a certain number of pages, type +n or
-n, where n is the number of pages to move. For example, +6 moves the
cursor forward six pages.

3 Press F10 or choose OK.

GO TO MARKER Pull-down: ALT + E ’ M
Classic: AQ 0-9

Moves the cursor to the marker you specify.
To move the cursor to a marker, choose Go to Marker, and then choose a num-
ber for the marker (0-9) from the menu that appears. Alternately, you can use

the classic command AQ followed by the marker number.

For information on setting markers, see “Set Marker” in this chapter.

GO TO OTHER Pull-down: ALT + E, (0]

Moves the cursor to a particular location.

Font Tag e
Style Tag K
Note. .. “ONG
Previous Position “QP
Last Find/Replace “QuU
Beginning of Block “QB
End of Block “QK
Document Beginning “QR
Document End ~QC
Scroll Continuously Up  "QU
Scroll Continuously Doun "QZ

The following table describes the commands on this menu and the correspond-
ing classic commands.
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PULL-DOWN
COMMAND

Font Tag
Style Tag

Note

Previous Position

Last Find/Replace

Beginning of Block
End of Block
Document Beginning

Document End

CLASSIC

GO TO OTHER

COMMAND DESCRIPTION

AQ=
Q<

AONG

AQP

AQV

AQB

AQK

AQR

~rQC

Moves the cursor to the next font tag.

Moves the cursor to the next paragraph
style tag.

Moves the cursor to the next note.
Select the type of note (the default is
Any Note). Specify Note Tag Only to
move to the note tag. If this check box
is clear, WordStar opens a window on
the note, and you can specify text to
locate within the note and options for
the text. (If no text is specified,
WordStar goes to the beginning of the
note.) See “Find and Replace” in this
chapter for information on the options.

Moves the cursor to where it was
located before the previous operation.

Moves the cursor to the previous Find or
Find and Replace location or to the last
block location.

Moves the cursor to the beginning of the
currently marked block.

Moves the cursor to the end of the
currently marked block.

Moves the cursor to the beginning of the
document.

Moves the cursor to the end of the
document.
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PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

Scroll Continuously Up AQW Scrolls continuously up, one line at a
time. When you choose this command,
the screen starts scrolling up toward the
beginning of the document (the text
moves down). You can stop the
scrolling by pressing any key.

Scroll Continuously rQZ Scrolls continuously down, one line at a

Down time. When you choose this command,
the screen starts scrolling down toward
the end of the document (the text moves
up). You can stop the scrolling by
pressing any key.

S ET MARKER Pull-down: ALT + E, S

Classic: "K 0-9
Puts a temporary marker in the file to mark a certain location.

You can use place markers to help find your place in a file. Once you set a
marker, you can then quickly move the cursor to that location. You can put up
to 10 markers in a file.

To set a marker, choose Edit=>Set Marker, and then choose a number for the
marker (0-9) from the menu that appears. Alternately, you can use the classic
command ~K followed by the marker number.

To move a marker, move the cursor to the new location and choose
Edit=>Set Marker (or AK) with the same marker number. To delete a marker,
move the cursor to the marker and use Set Marker with the same marker
number.

To move the cursor from anywhere in the file to a marker, use Go to Marker or
the classic command ~Q followed by the marker number. See “Go to Marker”
in this chapter.



EDIT NOTE

Markers are in effect only while you edit the file. They are not saved when
you exit.

If you sort text that contains markers, the markers stay in their original location
and do not move with the text.

EDIT NOTE Pull-down: ALT + E, N
Classic: "OND

Allows you to edit an existing footnote, endnote, annotation, unprinted
comment, or index entry.

Follow these steps to edit a note:

1 Place the cursor on the note you want to edit.

2 Choose Edit=>Edit Note, or use the AOND classic command.
If the note is a footnote, endnote, annotation, or unprinted comment,
WordStar opens a window on the note so that you can edit it. Or, if the
note is an index entry, the Edit Index Entry dialog box appears.

3 If the note is a footnote, endnote, annotation, or unprinted comment, edit
the note as you would a document. When you finish editing, choose

File=>Save, or press ~KD, to save your changes.

Or, if the note is an index entry, edit the entry, and then press F10 or choose
OK to save your changes.

This command is used for editing existing notes only. For information on insert-
ing notes, see “Note” and “Index Entry” in “Editing Screen Insert Menu.”
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N OTE OPTIONS Pull-down: ALT + E, T

STARTING NUMBER FOR NOTE

Sets options for notes.

Starting Number for Note...

Convert Note... “ONU
Convert at Print... .cv
Endnote Location .pe

Pull-down: ALT + ET,S

Changes the starting number for footnotes and endnotes.

Footnotes and endnotes are usually numbered, starting with 1. You can change
the starting number, or change to a letter sequence. You can also choose to
restart footnote numbering on each page or to number footnotes consecutively
throughout the document.

It's usually best to use this command at the beginning of the file; otherwise,
only the subsequent notes will be numbered in the new sequence. Follow
these steps:

1

Choose Edit=>Note Options=>Starting Number for Note or use the AONN
classic command.

In the Starting Number for Note dialog box, choose Footnote Starting Value
or Endnote Starting Value.

Type the new starting number or letter. For example, you could type A to
use an alphabetical sequence, 4 to use a numeric sequence starting with the
number 4 rather than the number 1, or F to use an alphabetical sequence
starting with F.

As a default, footnote numbers start with the starting value on each

page. To number footnotes sequentially throughout the document, select
Continuous Through Document. To return to the default, select

Restart on Each Page.

Press F10 or choose OK.
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WordStar inserts the .f# (footnote numbering) or .e# (endnote numbering) dot
command, followed by the new starting number or letter, for example, .e# a.
The .f# command can also have a d for numbering throughout the document or
a p to restart numbering on each page, for example, .f#d 1. You can get the
same result by typing the .f# or .e# command. To return to default numbering,
delete the dot command line.

CONVERT NOTE Pull-down: ALT + E, T, C
Classic: ONV

Converts a footnote, endnote, annotation, or comment to another type of note.
7 Place the cursor on the note you want to convert.

2 Choose Edit=>Note Options=>Convert Note. Alternately, you can use the
AONV classic command.

3 In the Convert Note dialog box, select the type of note to convert to.

4 Press F10 or choose OK.

CONVERT AT PRINT Pull-down: ALT + E, T, P
Classic: CV

Converts all footnotes, endnotes, and comments from one type of note to
another for printing only.

This command allows you to print all notes of one type as another type of note.
For example, if you have both footnotes and endnotes in one document, you
can print all the notes as footnotes, and they will be numbered consecutively.
You can also print comments as either endnotes or footnotes.

17 Choose Edit=>Note Options=>Convert at Print.

2 Inthe Convert at Print Time dialog box, select the appropriate conversion
or conversions.

3 Press F10 or choose OK.
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The .cv dot command is inserted, followed by the appropriate conversion. The
possible dot command lines are .cv f>e (print footnotes as endnotes), .cv e>f
(print endnotes as footnotes), .cv ¢>f (print comments as footnotes), and

.cv c>e (print comments as endnotes). You can get the same result by typing
the appropriate .cv command. To delete the conversion, delete the dot com-
mand line.

The notes will be converted when you print. Each note will appear the same as
the printed type of note in the text, but will revert to its original type if you
remove the .cv dot command. To convert a note permanently, use the Convert
Note command on this menu.

ENDNOTE LocATION Pull-down: ALT + E, T, E

Classic: .PE
Changes the location in the file where endnotes are printed.
Endnotes are usually printed at the end of a file, but you can print them at
another location using this command. For example, if you have three chapters
of a book in one file, you can print the endnotes for each chapter at the end of
that chapter rather than printing all of them at the end of the third chapter.
1 Place the cursor at the first location where you want to print endnotes.
2 Choose Edit=>Note Options=>Endnote Location.
All the endnotes that are inserted earlier in the file will be printed at this
location. Subsequent endnotes will be printed at the next location where
you use this command. Endnotes that come after the last location where

you use this command will be printed at the end of the document.

The .pe dot command is inserted. You can get the same result by typing the .pe
command. To delete the endnote location, delete the dot command line.

For information about endnotes, see “Note” in “Editing Screen Insert Menu.”
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E DITING SETTINGS Pull-down: ALT + E, I

Changes settings for column block mode, column replace mode, auto align,
and for using the Enter key in dialog boxes.

Column Block Mode “KN

Column Replace Mode "KI
.Auto Align ~0A
.4 Closes Dialog "0«

These settings are either on or off. When a setting is on, a dot is displayed next
to it on the menu. To change a setting, choose the command or use the cor-
responding classic command.

COLUMN BLOCK MODE Pull-down: ALT + E, I, C
Classic: "KN

Turns column block mode on and off.

In column block mode, block operations are performed with column blocks, as
opposed to regular blocks. With column block mode on, the beginning and
end block markers define the top-left and bottom-right corners of the block.

column mode off column mode on

AKBtext text ~“"KBtext text
text text text text text text
text text text text text text
text textAKK text textAKK

You can use column block mode, for example, to switch two columns of infor-
mation in a table. When column mode block is on, the word Column appears
in the status line.

TIP If your text contains command tags, turn on Command Tags display
before marking the block to make sure you include the command tags in the
block. Then turn off Command Tags display to make sure you included all the
columns you want in the block.
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Keep these points in mind when you work with column blocks:

= A dot command is not considered part of a column block. If you move or
delete a column block, a dot command within the block remains at its
original location.

= When column block mode is on, moving, copying, inserting, or deleting a
block affects the surrounding text. It's a good idea to save your work just
before doing any of these operations, so you can go back to the previous
version quickly. Also see “Column Replace Mode” below.

= When you sort a column block (Utilities=>Sort Block, or AKZ), WordStar uses
the highlighted portion of each line to determine how to sort the entire line.

= When you insert a file (Insert=File, or AKR) when column block mode is on,
WordStar expects the inserted file to be a column; it inserts the file one line
at a time and expects all lines to be the same length. If a line in the block is
not the same length as the previous lines, WordStar pauses and warns you.

For more information on working with column blocks, see “Column Replace
Mode” below. For information on blocks, see “Mark Block Beginning” and
“Mark Block End” in this chapter.

COLUMN REPLACE MODE Pull-down: ALT + E, I, R

Classic: “KI

Turns column replace mode on and off.

Column replace mode determines how moving, copying, inserting, and deleting
column blocks affect the surrounding text. Column replace mode is effective
only when column block mode is on. When column replace mode is on,
Column-Repl appears in the status line.

When column replace mode is on, if a block is moved or deleted, spaces
replace the block, leaving a “hole” at its original location. A moved, copied, or
inserted block replaces any text at the cursor. You can use Edit=Undo, or AU,
to restore that text.

CAUTION Ifthe text that is replaced is too long to fit in the undo buffer,

no warning is given, and you will be unable to restore all the text. See “Undo”
in this chapter for more information.
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When column replace mode is off, if a block is moved or deleted, surrounding
text fills in the space that was originally occupied by the block. A moved,
copied, or inserted block pushes to the right any text at its new location.

AUTO ALIGN Pull-down: ALT +E, I, A
Classic: “"OA

Turns auto align off or on.

When you edit a document, you often change the length of lines. WordStar
then aligns the paragraph you’re editing to fit the lines within the margins. This
is called auto align. When you start WordStar, auto align is normally on.
When auto align is off, text in a paragraph is not realigned when you edit that
paragraph.

Use this command to turn auto align on and off while you’re editing.

Auto align works only in paragraphs that you edit. You must use
Utilities=>Reformat, or AB or AQU, to reformat other paragraphs or the rest
of the document. You would use Reformat, for example, if you changed

margin or tab settings. See “Reformat” in “Editing Screen Utilities Menu.”

If you turn off Word Wrap (Layout=>Alignment and Spacing, or .aw), Auto Align
is also off until you turn Word Wrap on again.

You can change the default setting for auto align using WSCHANGE (DBCE).

Pull-down: ALT + E, I, D
Classic: O

) CLOSES DIALOG

Changes the function of the Enter key in dialog boxes.

Normally, when you press the Enter key in a dialog box, WordStar closes the
dialog box. Use this command to make the Enter key move the cursor to the
next option. At the last option, the Enter key still closes the box.

This command changes the Enter key function for the current editing session.
You can change the default setting using WSCHANGE (DBH2D).




CHAPTER 8

EDITING SCREEN
VIEW MENU

The View menu includes commands for previewing your printed document
onscreen, turning on and off the display of command tags and other screen
elements, and opening, switching, and sizing windows.

Previeu “0P
Command Tags “0D

Block Highlighting “KH

Open/Suitch Windouw “OK
Change Windou Size... "OM

Screen Settings... “0B
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P REVIEW Pull-down: ALT +V, P
Classic: "OP

Displays the document onscreen exactly as it will appear printed.
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When you start Preview, you see the current page onscreen, with columns,
headers, footers, footnotes, fonts, line spacing, and so on. At the top of the
screen is the Preview menu bar. The commands on the Preview menus let you
move around in your document and change your view of the document. You
can view another page, choose a different view of a page or pages, scan a range
of pages, and display a grid for checking page alignment. You can also prepare
faxes for transmission.

The Preview commands are described below.




Go 1o

ViEw

Pull-down

PREVIEW

. ALT+V, P, G
Classic: "OPG

Previews another page.

GO To

| Specified Page ...
{ First Page -
| Last Page
Next Page
| Previous Page

To display the first, last, next, or previous page, choose the appropriate option.
To preview a specific page, choose Specified Page, type the page number and
press Enter. Preview goes to the specified physical page and ignores any page
number commands you may have set. If Preview is displaying more than one
page, the page you specify will be the first page at the top of the screen.

Pull-down: ALT +V, P,V
Classic: "OPV

Previews the document from any of several perspectives.

Uiew

f! “ntire Page
Facing Pages

Multiple Pages

} Thumbnail Display

1 2x Zoon :

4 4x Zoom

1 Adjust Window ...

Entire Page Displays the entire current page, the same view as when you first
choose Preview.

Facing Pages Zooms out and displays two pages next to each other, the way
pages look in a book or newsletter.
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Multiple Pages Zooms out and displays four to ten pages, depending on your
monitor and the page size. It is good for looking at the overall layout of a short
document, or a section of a longer one.

Thumbnail Display Zooms out and displays ten or more pages, depending on
your monitor and the page size. It's good for looking at the overall layout of a
document. Press APgDn or ~PgUp to see the next set or the previous set of
pages. Press AHome or AEnd to see the first or last page of a document. To
zoom in on a specific page, use the direction keys to move the highlighting to
the page number, and then choose the magnification.

TIP You can quickly change the magnification by using the Plus (+) or
Minus (<) keys on the numeric keypad. For example, if you’re viewing the
thumbnail display, press + to see the multiple pages display. If you’re viewing
the entire page display, press — to see facing pages.

2x Zoom Zooms in and makes the page appear twice as large. You can then
use the direction keys to move the display window to a different part of the
page. For example, press the Down Arrow key or AX to move down a few
lines, or press PgDn or AC to move down a full screen. Use APgDn to move to
the next page.

4x Zoom Zooms in and makes the page appear four times as large. You can
use the same commands as you can with 2x Zoom.

Adjust Window Lets you move to a different part of the page. When you
choose this command, WordStar displays a small picture of the page with a box
outlining the current window display. Use the direction keys to move the box
to the area of the page you want to see. (To move the box more quickly, use
the Shift key with the direction keys.) When the box is where you want it,

press Enter to return to the page. The area you selected appears on the screen.

TIP To adjust the window display without choosing View and Adjust
Window, press Insert to display the box, and use the direction keys to move it.
When you stop moving the box, WordStar returns you to the page.
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OPTIONS Pull-down: ALT +V, P, O
Classic: "OPO

Scans the document, displays a grid to check the alignment of text, and
prepares faxes for transmission.

These options are described below.

Automatic Scan Shows successive portions of the document until you
press Esc.

TIP To locate a portion of your document quickly, scan the document in
thumbnail display, then press Esc when you see the page you want. Move the
highlighting to that page number and choose a View command to preview, or
press Alt+1 or choose Return to Editing and then Current page to exit Preview
and edit that page.

Scan Range Scans a specified range of pages. After you choose Scan range,
you specify the page numbers where you want the scan to start and stop.

Fax Files for Entire Document Creates a .PCX file for each page of the docu-
ment. You can send these files through a fax board using the software that
came with the board. The resulting page printed by the fax machine at its
destination looks exactly like the previewed page. If you did not start Preview
from the Fax dialog box, WordStar prompts you for a five-letter name for the
first fax file. The default name is FnnnPmmm.PCX, where nnn is a document
number and mmm is the page number, assigned sequentially. The default
resolution is used (high resolution unless you’ve changed the value for FAX_RES
in the FONTID.CTL file).

When you choose this command, an entire view of each page is displayed in
Preview as its .PCX file is created, and the .PCX filename is displayed at the top
of the screen. When all the .PCX files are created, Preview displays the entire
page view of the last page for which a .PCX file was created. The .PCX files are
created in the WS\FAX directory. (The fax directory is a subdirectory of the
directory that contains the FONTID.CTL file. If it doesn’t already exist when
you create fax files, WordStar creates it.)

You can also create fax files using the Fax=>File command. For more informa-
tion on creating fax files, see “Fax” in “Opening Screen File Menu.”




EDITING SCREEN VIEW MENU

Exir

Fax Files for Range Creates fax files for a specified range of pages. After you
choose this command, you specify the page numbers where you want the range
to begin and end. For more information on creating fax files, see the informa-
tion above on the previous command, Fax Files for Entire Document. If you
want to create fax files for several ranges, just use this command as many times
as necessary.

IMPORTANT  When you specify the range of pages, you must specify the
physical page numbers, even if you've reassigned page numbers. For example,
if you have a three-page document with no page number on the first page, and
the second and third pages numbered 1 and 2, you must specify 2-3 to print the
last two pages. If you're not sure about the physical page numbers, you can
check them using Preview. Preview displays the physical page numbers at the
top of the screen or, if more than one page is displayed, above each page.

Grid Display On/Off Displays a grid across the page. Grid display is useful
for making sure your text is properly aligned.

Pull-down: ALT + V, P , E
Classic: "OPE

Exits Preview and returns you to the editing screen.

You can choose to return to the page you're currently viewing or to the original
page you were editing when you chose Preview.

To return to the page you're currently viewing, choose Current Page or

press Alt+1. If you're in a view that displays more than one page, you return
to the page whose number is highlighted. To return to the page you were edit-
ing before you chose Preview, choose Original Page or press Alt+2.

PREVIEW FILES

Preview creates CRT directories containing screen font files (.CRT) and graphics
files (.Gn$, where n is a number) in your WordStar directory. WordStar may
create a number of CRT directories, depending on your monitor(s) and on the
page size and orientation.



PREVIEW

The .CRT files are created when you preview a document with fonts that you
haven’t previewed before. Each time you see the message Building preview font,
WordStar is creating a .CRT file.

The .Gn$ files are created when you use the zoom commands in Preview with
graphics (.PIX) files.

Each time you preview a document that contains a new Inset graphic, a

\WSG file is created. This file contains specific graphics information that is
needed for Preview. The .WSG files are stored in the directory that contains
your .PIX files. To save disk space, you can delete the .WSG files when you're
finished with them (use the DOS DEL command).

To save disk space, you may want to delete the .CRT and .Gn$ files and the
CRT directories periodically, especially if they contain files for fonts and
graphics that you are no longer using. You can delete these files and directories
individually by using the DOS DEL and RD commands, or you can delete them
all at once by using the DELCRT.EXE program, which is in your WordStar direc-
tory. At the DOS prompt in the WordStar directory, type delcrt and press Enter.
DELCRT.EXE deletes all of the .CRT files, .Gn$ files, and CRT directories from
your WordStar directory. (Note that DELCRT deletes only those .CRT files with
eight digits in the filename (nnnnnnnn.CRT).

PREVIEW ADVISORIES
Keep these points in mind when you use Preview:
= Preview works only on monitors with graphics capability.

= Preview can’t run with two windows open, unless you are have at least 80K
(5 pages) of EMS memory available.

= |f the appearance of fonts (especially large fonts) is blocky, WordStar may
need more memory while creating fonts. If less than 512K is available when
you start WordStar, you can remove memory-resident programs or use
WSCHANGE settings to make more memory available, and then run the
DELCRT program to delete the blocky fonts. Then start WordStar and use
Preview again. You can also improve these fonts by creating .WSF files for
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large fonts using smaller symbol sets. For more information on .WSF files,
see the Installing and Customizing booklet.

= |f an Inset graphic is too compressed (for example, if a very large graphic is
reduced to a small size for printing), it won’t be displayed correctly in
Preview.

= Preview does not support text mode .PIX files. If you want to preview a page
with a text mode pix file, you must first convert the .PIX file to graphics
mode, which may affect the appearance of the printed page. For more
information, see “Converting a text screen to graphics” in the “Inset” section
of the Companion Programs manual.

= |[f you often start WordStar from ProFinder™, you may want to redefine the
+ and - ProFinder hot keys. Otherwise, you won’t be able to use the + and
— keys as zoom keys in Preview. For more information, see “Setting the
Configuration Options” in the “ProFinder” section of the Companion
Programs manual.

COMMAND TAGS Pull-down: ALT +V, C

Classic: “OD
Turns display of WordStar command tags on and off.

WordStar command tags, such as B for bold and <COURIER 10> for a font
change, are normally displayed onscreen. However, they take up space and
may make text appear out of alignment. Choose View=>Command Tags, or use
the AOD classic command, to remove these tags from the screen while you
edit, or to display them again. The commands remain in effect even when the
tags aren’t displayed.

It's a good idea to turn Command Tags display on before you mark a block to
see what commands you’re including in the block. For example, if bold text

begins at the beginning of the block, be sure to include the tag that begins bold
in the block.

View=>Command Tags can also turn on and off the display of dot commands,
soft space characters, and the flag column at the right of the screen. You can
specify whether or not to include each of these elements in Command Tags by
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choosing View=>Screen Settings, or "OB. If display of dot commands is off
and you type a dot in column 1, the new dot command disappears after you
press Enter. For more information, see “Screen Settings” in this chapter.

You can turn Command Tags display on and off with a mouse by clicking the
[*] button in the style bar.

You can use WSCHANGE (DBAB) to turn the default setting for Command Tags
on or off and to change which elements are turned on and off when you choose
Command Tags.

B LOCK HIGHLIGHTING Pull-down: ALT +V, B
Classic: "KH

Turns block highlighting (and display of block markers) on and off.

You can use this command to hide the block markers and highlighting, and to
turn them on again. If you hide a block or a marker, and then mark a new
block beginning or end, block highlighting is turned on again.

At all help levels except 0, you can hide the marked block as a safety measure.
At these levels, WordStar won’t move, copy, erase, or write blocks when the

markers are hidden.

You can delete block markers, rather than hiding them, by pressing AK<.

OPEN/SWITCH WINDOW Pull-down: ALT +V, O
Classic: "OK

Opens a window so that you can look at two documents at once, or at two
parts of the same document. If two windows are already open, moves the
cursor to the other window.

Follow these steps to open a window or move the cursor to the other window:

7 Choose View=>Open/Switch Window, or use the AOK classic command.
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2 In the Open dialog box, specify the name of the file to open. You can open
either an existing file or a new one.

A filename can have up to eight characters and an optional extension of up
to three characters. Type a period between the filename and the extension.
Don’t use spaces between the characters. Filenames can include letters,
numbers, and these symbols:

$&#!1% " (){})-_~@

Note: Files with the extensions .COM, .EXE, .OVR, .SYS, .DCT, .CRT, .WSF,
.PDF, .DCC, .INF, .PRD, .WSM, and .$?? (where ? can be any character) do
not appear in the WordStar filenames lists, so don’t use them to name your

text files. You can change this list of filename extensions using
WSCHANGE (CEC).

3  Press F10 or choose OK.

The screen splits in half. The cursor is located in the new file on the bottom
half of the screen.

You can edit in either window. To move the cursor to the other window, use
this command or choose File=>Open/Switch, or use the AOK classic command.

The title bar shows a [1] when the cursor is in the top window and a [2] when
the cursor is in the bottom window. It also shows the name of the file where
the cursor is currently located. You can use a mouse to switch to the other win-
dow by clicking this number.

The file in the second window is always opened as a document if the file in the
first window is a document, or as a nondocument if the file in the first window
is a nondocument. If you want to be able to open a document and a non-
document at the same time, use WSCHANGE (DCGGQG) to turn on the prompt
that asks you whether to open a document or a nondocument when you open a
second window.

TIP If you want to see how the document you’re editing looked before you
made your most recent editing changes, you can open a second window on the
same document. The second window shows the version that you saved last, in
protected mode because you can’t make changes to both copies.
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Keep these points in mind when working with two windows:

To change the sizes of the windows, choose View=>Change Window Size,
or use the AOM classic command. You can also press A~ (hyphen) to
enlarge the current window one line at a time. For more information, see
“Change Window Size” in this chapter.

You can mark blocks in both windows at once. To copy a block between
windows, choose Edit=>Copy=>Block from Other Window, or press KA.
To move a block between windows, choose Edit=>Move=>Block from Other
Window, or press AKG. For more information, see “Copy” and “Move” in
“Editing Screen Edit Menu.”

You cannot edit notes or macros when you have a document in the second
window.

CHAN GE WINDOW SIZE Pull-down: ALT + V, W

Classic: "OM

Changes the number of lines displayed in a window.

When you open a second window, each window takes up half the screen.
Follow these steps to change the window size:

1

2

3

Choose View=>Change Window Size, or use the AOM classic command.

In the Change Window Size dialog box, choose Full Screen or Half Screen
or specify the number of lines you want for the current window.

If you choose Full Screen, each window takes up the full screen, and the
screen flips from one file to the other when you move the cursor between

windows.

Press F10 or choose OK.

You can specify a default window size in WSCHANGE (DCGH).

Note: You can press A— (hyphen) to enlarge the current window one line at
a time.

8-11
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SCREEN SETTINGS Pull-down: ALT +V, S

Classic: "OB

Determines which screen elements are displayed during editing.

You can use this command to turn on and off the display of several screen
elements and to decide which elements to turn on and off using
View=>Command Tags (or AOD). Follow these steps:

1

2

Choose View=>Screen Settings, or use the 2OB classic command.

In the Screen Settings dialog box, change any options you want. The
options are described below.

Screen Settings

Dot Commands: Display On Screen:
o Aluays On
¢ Display with Command Tags [X1 Scroll Bar

Flag Column: [X]1 Style Bar
o Aluways On

¢ Display with Command Tags [X]1 Status Line

Soft Space Dots: [X]1 Ruler Line

o Always On

¢ Aluays Off [X] Classic Commands on
o Display with Command Tags Pull-down Menus

Dot Commands Dot commands can be always displayed or turned on and
off with Command Tags (the default). If display of dot commands is off and
you type a dot in column one, the new dot command disappears after you
press Enter. You can change the default in WSCHANGE (DBAE).

Flag Column The flag column at the right of the screen can be always
displayed or turned on and off with Command Tags (the default). You can
change the default in WSCHANGE (DBAC).

Soft Space Dots The spaces that WordStar inserts when it justifies text to
make the line end at the right margin are called soft spaces. WordStar can
display soft spaces as small dots. These dots can be always displayed, never
displayed (the default), or turned on and off with Command Tags. You can
change the default in WSCHANGE (DBAD).
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Scroll Bar This option turns on and off the display of the vertical scroll bar
at the right of the screen. The scroll bar is especially useful for mouse users.
The default is scroll bar display on. You can change the default in
WSCHANGE (DBA)).

Style Bar This option turns on and off the display of the style bar. The style
bar displays information about current settings, and allows easy access to
these settings using a mouse. The default is style bar display on. You can
change the default in WSCHANGE (DBAG).

Status Line This option turns on and off the display of the status line. The
status line displays information about the current editing status. The default
is status line display on. You can change the default or move the status line
to the top of the screen using WSCHANGE (DBAI or DBA2B).

Ruler Line This option turns on and off the display of the ruler line at the
top of the screen. The ruler line shows the margins and tab stops that
currently apply to your text. The default is ruler line display on. You can
change the default in WSCHANGE (DBAH). You can still make changes to
the ruler when it’s not displayed. For more information on ruler lines, see
“Ruler Line” in “Editing Screen Layout Menu.”

Classic Commands on Pull-down Menus This option turns on and off the
display of classic commands on the pull-down menus. If you use the classic
commands, this display is useful as a reminder and to determine the related
pull-down commands. The default is classic commands on. You can
change the default in WSCHANGE (DBAK).

3 Press F10 or choose OK.

For more information on these screen elements, see “Screens and Dialog
Boxes” in “WordStar Basics” in this manual.




CHAPTER 9

EDITING SCREEN
INSERT MENU

The Insert menu includes commands for inserting elements such as page
breaks, other files, graphics, footnotes, and so on, into your documents.
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EDITING SCREEN INSERT MENU

P AGE BREAK Pull-down: ALT + I, P

Classic: JPA
Inserts a page break.

Use Page Break when you want to force a new page to start before the next
automatic page break.

Place the cursor on the first line you want to appear on the new page, and
choose Insert=>Page Break.

The .pa dot command is inserted. You can get the same result by typing the .pa
command. To delete the page break, delete the .pa command line.

This command inserts a hard page break, which stays in the same location rela-
tive to the surrounding text when you edit the document. The page break that
WordStar automatically inserts when you fill a page is a soft one. Text moves
across a soft page break as needed when you add or delete lines.

For information on page length, see “Length of Page” in “Page Layout” in
“Editing Screen Layout Menu.” For information on keeping lines on the same
page, see “Special Effects” in “Editing Screen Layout Menu.” For information
on handling blank lines at the end of a page, see “Suppress Blank Lines at Top
of Page” in “Page Layout” in “Editing Screen Layout Menu.”

COLUMN BREAK Pull-down: ALT + I, C

Classic: .CB

Starts a new column.

WordStar automatically ends a column at the bottom of a page. Use Column
Break when you want to force a new column to start before the next automatic
column break.

Place the cursor on the first line you want to appear in the new column, and
choose Insert=>Column Break.
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The .cb dot command is inserted. You can get the same result by typing the .cb
command. To delete the column break, delete the .cb command line.

This command inserts a hard column break, which stays in the same location
relative to the surrounding text when you edit the document. The automatic
column break is a soft one. Text moves across a soft column break as needed
when you add or delete lines.

For more information on columns, see “Columns” in “Editing Screen Layout
Menu.”

TODAY’S DATE VALUE Pull-down: ALT + I, T
Classic: "M@

Inserts the current date at the cursor position.

When you choose Insert=>Today’s Date Value, or use the "M@ classic com-
mand, the date is inserted, for example, June 4, 1992. You can change the date
format with WSCHANGE (DCDG). For example, you can format the date like
this: 4 June 1992.

‘[;’:ITJIZI{ VALUFE Pull-down: ALT + 1; A

Inserts a value into the text.

Current Time “M?
Last Math Result M=

Last Math Expression “Mit
Last Math as Dollar "M$

Current Filename M
Current Drive “M:
Current Directory “M.
Current Path “MN
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When you choose Insert=>Other Value, WordStar displays a menu of the values
you can insert. Choose the one you want. The table below describes all of the
values and gives the classic command that inserts each one.

CLASSIC
VALUE COMMAND DESCRIPTION
Current Time AM! Inserts the current time, for example,

9:30 p.m. You can change the time
format with WSCHANGE (DCDH).

Last Math Result M= Inserts the last math result you obtained
using Utilities=>Calculator (*\QM) or
Utilities=>Block Math (AKM).

Last Math Expression ~ AM# Inserts the last math expression you
entered using Utilities=>Calculator
("QM).

Last Math as Dollar AM$ Inserts the last math result you obtained

using Utilities=>Calculator (*QM) or
Utilities=>Block Math (AKM), in dollar
format. For example, if the result was
23.1, itis inserted as $23.10; if it was
28, it is inserted as $28.00.

Current Filename AM* Inserts the name of the current file.

Current Drive AM: Inserts the currently logged drive letter.

Current Directory AM. Inserts the currently logged directory
name.

Current Path AM\ Inserts the full path and filename of the
current file.




VARIABLE

VARIABLE Pull-down: ALT + 1,V

Inserts a predefined variable into the text.

Date &6
Time &'&

Page &it&
Line & &
Filename &*&
Drive &:&
Directory &.&
Path &\&

A variable is information that is inserted into a document when you print it; you
put the variable name in the text, and WordStar replaces it with the appropriate
value at print time. The commands on this menu insert variable names for
several predefined variables.

When you choose Insert=>Variable, WordStar displays a menu of the variables
you can insert. Choose the one you want. The table below describes all of the
variables. You can type the variable names in the text instead of issuing the
command if you like.

VARIABLE NAME DESCRIPTION

Date &@& Inserts the current date, for example,
September 28, 1992. You can change
the date format with WSCHANGE
(DCEC).

Time &l& Inserts the current time, for example,
9:30 a.m. You can change the time
format with WSCHANGE (DCED).

Page &#& Inserts the current page number. (Note
that the ampersands are not required in
headers and footers.)

Line &_& Inserts the current line number.
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VARIABLE NAME DESCRIPTION

Filename &*& Inserts the name of the current file.

Drive &:& Inserts the currently logged drive letter.

Directory &.& Inserts the currently logged directory
name.

Path &\& Inserts the full path and filename of the
current file.

When you print a file that contains a variable, you must be sure the Interpret
Merge Variables option is selected in the Print dialog box so that WordStar
replaces the variable name with the value. Otherwise, the variable name is
printed.

For more information about variables, see “Merge Printing Commands” in
“Editing Screen Ultilities Menu.”

EXTENDED CHARACTER Pull-down: ALT + I, E

Classic: “"PO

Inserts an extended character.

Some printers can print special characters such as graphics characters, Greek
letters, and accented letters. These characters are called an extended character
set. They vary from printer to printer, and from font to font on many printers.

Before printing an extended character, check your printer documentation to
find the corresponding ASCII code (a number between 0 and 255). Then follow
these steps:

1 Choose Insert=>Extended Character, or use the AP0 (zero) classic command.

WordStar displays the Extended Character dialog box. It includes a chart
that shows the IBM extended character set.

2 Type the code you want. (Use the code from the chart only if your printer

uses the IBM extended character set.) The character is inserted.
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In your text, WordStar displays the characters from the IBM extended character
set. If your printer or font uses a different character set, the characters displayed
in the text will not match those that are printed.

TIP You can use a shortcut to enter an extended character. Just hold down
the Alt key and press the number (ASCII code) on your numeric keypad. When
you release the Alt key, the character appears on the screen.

You can use extended characters for international characters such as accented
letters and for box and line drawing, as described below. For more information
about extended characters, see Appendix B, “ASCII Conversion Charts.”

INTERNATIONAL CHARACTERS

Some languages include characters with accents or other diacritical marks that
distinguish them from other alphabetical characters, such as i and a, other char-
acters such as ; or £, and words with accent marks, such as écran. WordStar
provides several methods for entering these characters:

= |f the character is available on your printer, you can use Insert=>Extended
Character, use the AP0 classic command, or press Alt plus the number for the
character as described above.

= You can use Layout=>Special Effects=Overprint Character, or the APH
classic command, to overprint a character with an accent mark or other
available character. However, if you are using a proportional font, the
accent mark may be off center. In that case, you can try one of the other
methods.

= Many international keyboards produce extended characters when keys are
pressed normally, and some keyboards have a “dead key” that produces
extended characters when used with certain other keys. For information, see
your computer or keyboard documentation.

= When the international character table is turned on in WSCHANGE (DCGM;
the default setting is off), you can enter international characters into your
document by pressing the two keys that compose the character. For
example, if you type a quotation mark (“) and then the letter o, an o with an
umlaut (6) appears on the screen. (The first character you type does not
appear; the international character appears only after you type the second
character.) This method emulates the “dead key” described above.
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The 6 character appears onscreen only if it is supported by your computer’s
onscreen character set (code page). If the character is not supported, the
characters you typed appear next to each other (“0) on the screen. If your
printer supports the 6 character, WordStar prints it as 6; otherwise, WordStar
prints it as 6.

The keys and characters you can use are:

KEY EXAMPLE LETTERS
' a a,e EioufalsoAl O,U,y,Y with
code page 850)
' a a, e i,ouflsoAEIO,U,Yy,Y with
code page 850)
A a a,ei,0,u(also A, E, I, O, Uwith code
page 850)
“ o a,ei,0,ufalsoAE1I O,U,ywith
code page 850)
~ ] n, N (also a, A, o, O with code page 850)
, c c C

If you turn the international character table on, and you need to type two
characters that normally form an international character, type the first charac-
ter twice to override the international character function. For example, to
type the word open in quotation marks, type “ “open”.

You can change the WordStar default settings for the international character
table and the code page in WSCHANGE (DCGM and DCGL). (For informa-
tion about code pages, see Appendix B, “ASCIl Conversion Charts,” and your
DOS manual.)

Bo0X AND LINE DRAWING

The IBM extended character set includes characters for drawing lines and
boxes. If your printer (or the font you are using) uses this character set, you can
draw lines and boxes in WordStar. (If your printer cannot draw these charac-
ters, WordStar may instruct it to use the available characters that are most
similar to them.)
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You can insert a line or box character using Insert=>Extended Character

(or APO), or the Alt key plus the character, or you can use the function keys that
are preset to enter ten of these characters. You can also use the BOX file sup-
plied with WordStar to draw boxes. The function keys and the BOX file are
described below.

When used with the Alt key, ten of the function keys insert line and box draw-
ing characters. The function key settings are shown below. (You can change
these settings using the Macros commands; see “Macros” in “Editing Screen
Utilities Menu.”)

F1o | 2 -
3 F4 4
Fs L F6
7 T F8 L
FO | F10

When you install WordStar, the BOX file is placed in your WS directory. It con-
sists of a box drawn with the function key characters. This box is 23 columns
wide and 7 lines deep. You can use it to enclose a title or text up to 21

columns wide and 5 lines long. You can insert this box into a file using
Insert=>File (or AKR). If you create other boxes or line drawings frequently, you
can keep each one in a separate file, and insert the files when you want them.

Keep these points in mind when working with boxes:

= You must use a nonproportional (fixed width) font for a box. Otherwise, the
right side of the box will be uneven when it’s printed.

= When you edit text inside a box, turn Insert off. With Insert on, characters
and spaces you type push the right side of the box to the right on the line
you're editing. Use column blocks to move text inside a box. Also be
careful when using the Backspace and Del keys. If you accidentally erase a
character that’s part of the box, you can replace it with the appropriate
function key character. You should also turn off auto-alignment before a box
in your text to be sure the box is not accidentally realigned. Then turn it on
again after the box. Use Word Wrap in Layout=>Alignment and Spacing or
.aw off and .aw on.
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= [f you use a laser printer and you want to use a proportional font or edit text
within a box, you can use the .xI0 command to overprint two pages. For
more information, see the laser printer information in “Customizing” in the
Installing and Customizing booklet.

= To quickly add height to an existing box, place the cursor on one row of the
box and delete the line (Edit=>Delete=>Line or AY). Then use Edit=>Undo
(AU) to restore the row. Continue to use Undo until the box is the height
you want. To change the width of a box, use column blocks to add or delete
characters.

CUSTOM PRINTER CODE Pull-down: ALT + I, U

Inserts a custom printer code.

Custom printer codes are special printing instructions that let you take
advantage of a printer’s special features. You can use a custom printer code,
for example, to print a special character, such as a paragraph symbol. You can
also use a custom printer code to insert a file that contains the series of printer
codes you want. For example, you can insert a file in your printer’s program-
ming language to print a border or a logo.

WordStar comes with preset custom printer codes for many printers. If they are
available for your printer, they are listed on the Printer Information screen when
you install your printer. If the printer code you want is not set up for your
printer, you can use the Change Printer Codes command on this menu. See
“Change Printer Codes” in this chapter.

When you choose Insert=>Custom Printer Code, WordStar displays a menu of
the seven available codes. Choose the one you want. Alternately, you can use
the corresponding classic command.

The first six codes, 1-6, enter the preset codes. They correspond to the classic
commands APF, APG, APQ, APW, APE, and APR.

Other (or the AP! classic command) allows you to enter a one-time custom
printer code. When you choose this command, the Custom Printer Code dialog
box appears. The options in this box are described below.
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Printer Code Enter either the ASCII code or the name of the file containing the
printer code. To enter the name of the file, type %F"filename". Be sure to type
an uppercase F and to include the quotation marks. (If you use an ASCII,
ASC256, PRVIEW, or EXTRACT PDF, you can't insert files into a custom printer
code.)

Screen Display Enter a descriptive name. This name will be displayed on the
screen where you insert the code when Command Tags display is off. (When
Command Tags display is on, the ASCII code or filename is shown.)

Width of Character(s) If the code will print a character or characters, type the
width of the character(s) in inches. If the code is nonprinting, use the default
setting, 0".

F ILE

Pull-down: ALT + I, F
Classic: "KR

Inserts a copy of a file into the file you're editing.

This command is useful for inserting standard paragraphs, combining docu-
ments, and inserting files from several other programs.

INSERTING A WORDSTAR FILE

Follow these steps to insert a WordStar file:
1 Choose Insert=>File, or use the AKR classic command.

2 In the Insert File dialog box, specify the file you want to insert. Include the
path if necessary.

Note: With a dBASE file, you can insert only field names by typing the
filename followed by /f; for example, address.dbf/f.

If the file is a spreadsheet, another dialog box appears. See the instructions
below for inserting a spreadsheet.

3 Press F10 or choose OK to insert the file.
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If column mode is on, the file is inserted as a column. Text to the right of the
column moves to the right.

INSERTING A SPREADSHEET OR DATABASE

2

You can insert a WordStar file, a dBASE Il, dBASE 111, dBASE lll+, or dBASE IV
database file, a Lotus 1-2-3 (versions previous to 3.0), Symphony, or Quattro
spreadsheet, or a file in any of these formats created by another program.

For Lotus 1-2-3 version 3.0 and later and for other file formats, either save the
file to a supported format or use Star Exchange to convert the file to WordStar
format before inserting it.

Follow these steps to insert a spreadsheet or database:

1 Choose Insert=>File, or use the AKR classic command.

In the Insert File dialog box, specify the file you want to insert. Include the
path if necessary.

Note: With a dBASE file, you can insert only field names by typing the
filename followed by /f; for example, address.dbf/f.

If the file is a spreadsheet, specify the range to insert. The default displayed
shows the full range of the worksheet, and if you assigned range names to
the worksheet, these names are also displayed. To insert the entire
worksheet, press F10 or choose OK. To insert part of the worksheet, specify
the range of cells or a range name and press F10 or choose OK. You can
use * to mean the end of the worksheet; for example, if Z41 is the last cell,
D1..* is the same as D1..Z41.

If the file is a Symphony file that contains more than one spreadsheet
window, choose the window to insert. If you restricted a window in
Symphony, only the restricted area is inserted. If you choose a window that
is smaller than the range you chose, or vice versa, the smaller of the two is
inserted.

3 Press F10 or choose OK to insert the file.
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TIP If you use proportional fonts, you may prefer to use Star Exchange to
convert a database or spreadsheet before you insert it. Star Exchange inserts
tabs between columns; Insert=>File inserts spaces. If you don’t use Star
Exchange, change to a nonproportional font before you insert the database or
spreadsheet so that the columns are aligned properly. Also, if the lines in the
file you insert are longer than the line length in the document, you can set a
large right margin (Layout=>Ruler Line, or .rm) or turn off Word Wrap
(Layout=>Alignment and Spacing, or .aw off) above the inserted file to prevent

realigning. You can return to your previous settings at the end of the inserted
file.

FILE AT PRINT TIME Pull-down: ALT + I, L
Classic: JFI

Inserts another file when you print the current file.

You can chain files so that they print one after the other, or nest them, inserting
one inside the other. The files are connected only for printing; their contents
remain separate. Follow these steps to chain or nest files:

1 Choose Insert=> File at Print Time.

2 In the Insert File at Print Time dialog box, specify the file you want to insert.
Include the path if necessary.

3 Press F10 or choose OK.

WordStar inserts the .fi dot command with the filename. You can get the same
result by typing .fi and the filename on a new line.

To print the files, specify the first file in the series. WordStar inserts each file in
turn while printing.

Keep the following points in mind when you insert files at print time:
= |f your files contain paragraph styles, be sure to select a paragraph style at

the beginning of each file you insert so that the file is printed with the correct
formatting.

9-13
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= |f you want a file to begin on a new page, insert a page break just above the
location where you insert the file.

® |f you insert a file at the end of another file, leave a blank line (ending with a
carriage return) under the .fi command.

»  WordStar automatically numbers all pages in order as they are printed. If
you want an inserted file to use different page numbers, assign page numbers
in the appropriate locations (Layout=>Page Numbering).

If you have text files on floppy disks, and you insert a file that is on a different
floppy disk, you can add the c option at the end of the .fi command to have
WordStar stop and prompt you to change disks. The command would read
fi filename c.

CHAINING FILES

To chain files, insert the next file at the end of each file.

If you want, you can create a command file that contains just the .fi commands.
For example, if you have a book with five chapters, each in its own file, you
can create a command file named BOOK.ALL, as shown below:

.fi c:\write\chapterl
.fi c:\write\chapter2
.fi c:\write\chapter3
.fi c:\write\chapter4
.fi c:\write\chapter5

To print the book, just print the command file, BOOK.ALL. WordStar prints
each chapter in turn.

TIP WordStar can display messages that tell you which file is currently being
printed. See “Display Message” in “Merge Print Commands” in “Editing Screen
Utilities Menu.”

NESTING FILES

To nest files, insert the file at the location where you want it in the current file.
Once the nested file is printed, WordStar resumes printing the original file
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where it left off. You can nest one file inside another, and those two files inside
a third, and so on, up to eight levels.

The nesting level is very important when you merge print documents with data
files. The printing repeats only the file containing the .df (define data file) com-
mand and files nested within it.

GRAPHIC Pull-down: ALT + I, G

Classic: "P*
Inserts a graphic.

You can insert into your documents graphics created using a number of
programs. You can use files in any of the formats listed in the following table:

TYPE EXTENSION TYPE EXTENSION
Amiga ILBM AFF KoFax Group 4 KFX
ASCII Text IXT Lotus .PIC
AT&T Group 4 ATT MacPaint .MAC
AutoCAD DXF .DXF Mac PICT .PCT
CALS Raster .CAL MS-Windows WMF
CompuServe .GIF Metafile .CGM
DeluxePaint .LBM Micrografx .DRW
Dr. Halo CUT Microsoft Paint .MSP
GEM Image IMG PC Paintbrush .PCX
GEM Metafile .GEM TIFF TIF
HP Laser]et LPCL TARGA .TGA
HP Plotter .PGL Tektronix Plot 10 .P10
Inset AGF WordPerfect WPG
Inset PIX

9-15
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You can also insert files in several fax formats. See “Inserting Fax Files” in this
section.

WordStar uses Inset® .PIX file format for previewing and printing graphics, and
shows the graphic in the document with a command tag called a pix tag.
When you insert a graphic file in another format, WordStar converts it to a .PIX
file and inserts a pix tag that specifies the .PIX file.

If you change your original graphic, the graphic in your document is not
updated; you must delete the old pix tag and insert the graphic again.

Follow these steps to insert a graphic:

T

Place the cursor where you want the upper-left corner of the graphic. (See
“Placement of Graphics” in this section for more information.)

Choose Insert=>Graphic, or use the AP* classic command.

WordStar prompts you for the name of the file to insert. Note that the
filenames list shows all the files in your default graphics directory (the one
where you installed Inset). You can use WSCHANGE (CD3D) to change
your default directory for graphics files to insert and to include in the list
only files with a specific filename extension.

Specify the file to insert.
Press Enter or F10 or choose OK.
If the file is a .PIX file, WordStar inserts a pix tag, and you return to editing.

If the file is in another format, the Convert Graphic dialog box appears. You
can accept the defaults, or you can change several options:

Converted Filename The default name for the converted filename is the
original filename with the .PIX extension. You can specify a different
filename if you like.

Conversion Options The default, Use Settings in File, converts the graphic
file using the dimensions, colors, and so on, in the file. If you select Use
Settings on Options Screen, the file is converted using the settings on the
Convert Graphic Options dialog box, described below.
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Options If you choose the Options button, WordStar displays the Convert
Graphic Options dialog box. You can change output options such as
dimensions, color, resolution, and so on. Change any options you want.
The options are described below these steps.

5 Press F10 or choose OK. The file is converted, and WordStar inserts a pix
tag.

Convert Graphic

The graphic you have chosen is not in WordStar format.
WordStar will convert the graphic to .PIX format.

Original Filename: C:\WS\INSET\HERON.PCX

Converted Filename: [PSHBNTRNUGNNITGIULINIES

Conversion Options: | Options |
¢ Use Settings in File
o Use Settings on Options Screen

The options on the Convert Graphic Options dialog box are described below:

Height The height of the image. The default, .00", uses the height from the
original file. You can specify the height in inches (in or “), centimeters (cm), or
points (pt).

Width The width of the image. The default, .00", uses the width from the
original file. You can specify the width in inches (in or ), centimeters (cm), or
points (pt).

Aspect The aspect ratio is the width divided by the height, as a decimal value
(for example, 1.5). Specifying any two of these values determines the third. If
you change any of these values, the converted image may appear shorter and
wider or taller and thinner.

Rotation Rotation is available for vector graphics only. It is specified in
degrees counterclockwise from the original rotation; for example, 45 turns the
image 45 degrees counterclockwise.

Reverse B/W If you select this check box, the printed image will have the
colors inverted if it is a black and white image. If it is a gray or color image, the
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foreground and background colors will be swapped if they are explicitly iden-
tified; otherwise, the highest color number on the palette will be swapped with
color zero.

Smoothness Edge smoothing for the “jaggy” appearance of some raster images.

Ignore Background If an image has a varied, non-solid background, selecting
this option changes it to white during conversion. For example, when you con-
vert a .GIF file, select this option if there are holes in the background.

Resolution Horizontal and vertical resolution in dots per inch (dpi). The
default, 300 dpi, is used for most laser printers. Leave the settings as O to use
300 dpi.

Screen Frequency This option provides a way to adjust the number of gray
levels in an image, using the formula Gray levels=(Resolution/Screen
Frequency) .

Contrast Contrast from lightest to darkest colors on a relative scale of
-100 to +100.

Brightness Intensity of all colors on a relative scale of ~100 to +100.

Colors The default is 16 colors. If you have a printer that does gray scaling,
such as a laser printer, use the default. If your printer doesn’t have gray scaling,
use 2.

Process Type Snap, the default, matches colors in the image to the nearest
available color when converting. It produces a fast, high-contrast conversion.
Halftone and Dither are useful when converting color to black and white.
Halftone uses the standard diagonal pattern, which is better for high-resolution
printing; Dither uses a more random pattern, which may be better for low-
resolution dot matrix printers or low-resolution monitors. Diffuse is useful
when the number of colors is being reduced, for example, when you are con-
verting a VGA image that will be displayed on a CGA monitor. Diffuse can
also produce better results than Halftone or Dither when creating black and
white files; however, it takes longer.

Color Processing Allow Color is the default. If you want to change colors to
grays or black, select Force Gray to use a gray level palette or Force B/W to
print all colors as black and the background as white. Select Allow Color or
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Force Gray if you have a color printer or one that is capable of gray scaling.
Force B/W produces black and white images without any shades of gray.

If you change Convert Graphic options, the new settings are the ones WordStar
displays the next time you use the Convert Graphic Options dialog box. These
settings are saved in the TOPIX.SET file.

INSERTING FAX FILES

If you have fax files created by any of several fax devices, you can insert them
into your document in the same way as other graphics files. The following
table shows the formats you can insert. Since many of the formats do not have
unique filename extensions, you need to identify the file type to WordStar using
a different, unique extension. The table shows both the original extension and
the WordStar extension.

ORIGINAL WORDSTAR
TYPE EXTENSION EXTENSION
AdTech Perfectfax .FO1 .ADT
Brooktrout Fax-Mail 96 .301 .BRK
Calculus EZ-Fax .001 .EZF
Canon Navigator Fax .FAX .CAN
Cogpnition Sciences SciFax .SCl .SCl
Complete (PC) FAX .001 .CPF
Complete FAX/Portable .001 .CFP
Everex EverFax24/96 Mode C .FAX .EFX
Everex EverFax 24/96 Mode B .FAX .EF3
Fremont FreCom FAX96 .FAX .F96
Fujitsu dexNET .001 .DXN
Gammalink Fax TIF .GAM
Generic Fax .FAX .CG3
Hayes JT Fax .001 JTF
Imavox TurboFax IMG .TBF
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ORIGINAL WORDSTAR
TYPE EXTENSION EXTENSION
Intel .DCX .DCX
JetFax .FFF JET
OAZ Communications .OAZ .OAZ
NetFax Manager
Relisys TEFAX .FAX .TEF
Ricoh Fax Card/DX-1 Adapter .001 .RIC
American Data Tech .001 .SMF
SMARTFAX
SpectraFAX .DCX .DCX
Touchbase Systems .001 .WPF
WorldPort 2496
TriGem SoftFax .FO1 .TRI
Xerox MicroFax FAX .MIF

If the fax file you are inserting is in a format that has two different extensions in
the table, follow these steps to tell WordStar which format corresponds with the
filename extension:

1 Open the TOPIX.SET file as a nondocument. This file is in your graphics
directory (\WSNINSET unless you specified a different directory name during
installation).

2 Add a new line at the bottom of the file. The line should consist of the
original filename extension, an equal sign, and the WordStar extension.

For example, if you are using Hayes JT Fax format, the line is: 001=JTF. This
line causes WordStar to assume that all imported graphics with the .001
extension are in Hayes )T Fax format.

3 Save the TOPIX.SET file.

You can add as many lines as you want for different fax formats, as long as the
original extensions are different.
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THE INSET GRAPHICS PROGRAM

WordStar prints graphics using Inset, a graphics program that is included with
WordStar as a companion program. You must install Inset before you can print
graphics.

You can use Inset to “capture” an image onscreen and store it in a .PIX file, and
to create and edit graphics. See the “Inset” section of the Companion Programs
manual for complete information about how to use Inset.

See also “Inset” in “Editing Screen Utilities Menu.”

PILACEMENT OF GRAPHICS

You must manually make space in your file for graphics that you insert. If a
graphic is not on the same line as any text, leave enough blank lines for the
graphic.

If you want text and graphics on the same line, reset the margins if necessary so
that the text doesn’t overwrite the graphic. Use these guidelines:

= To place the graphic to the left of text, set a paragraph margin where the left
side of the graphic will be. Then set the left margin where the text will start,
and set a tab at the same location as the left margin. Insert the graphic, press
Tab, and type the text.

= To place the graphic to the right of text, wait until the text is final so you
won’t need to reformat it later, then insert the graphic. You can use right
margin settings or hard carriage returns to format the text around the graphic.

= When placing text next to a graphic, use absolute leading rather than
automatic leading. See “Leading (Line Height)” in “Alignment and Spacing”
in “Editing Screen Layout Menu.”

To see how the text will look with the inserted graphic, use View=>Preview, or
the classic command AOP.
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PRINTING FILES THAT CONTAIN GRAPHICS

WordStar automatically loads Inset into memory as needed at print time. While
you're printing a file that contains graphics, you can’t check spelling or open a
second window; that memory is reserved for Inset.

N OTE Pull-down: ALT + I ) N

Inserts a comment, footnote, endnote, or annotation.

Comment. . . 20ONC
Footnote...  "“ONF
Endnote. .. “ONE

Annotation... “ONA

COMMENT Pull-down: ALT + I, N, C
Classic: "ONC

Inserts a nonprinting comment that you can see on the screen.

1 Choose Insert=>Note=>Comment, or use the AONC classic command.

2 Type the comment in the new window at the bottom of the screen. The
comment can be as long as you like. You can edit it the same way you edit

a document.

3 When you finish typing the comment, choose File=>Save and Close, or use
the AKD classic command.

When Command Tags display is on, the first few words of the comment appear
as a command tag. When display is off, the command tag is not displayed.

To view or edit a comment, be sure display is on, move the cursor to the com-
mand tag, and choose Edit=>Edit Note, or use the AOND classic command.



NOTE

If you want to insert a one-line unprinted comment, you can use the .ig or
the .. dot command. Just type the dot command at the beginning of the line,
and type the text on the same line. For example, you could type .ig This is an
unprinted comment. You might also use one of these dot commands if you
want to display the entire comment rather than a note tag that shows the first
few words of the comment.

TIP Use the .. dot command if you want to see a comment when Command
Tags display is turned off. The .. dot command is displayed even when you've
set dot commands to turn on and off with Command Tags.

For more information, see “Edit Note” and “Note Options” in “Editing Screen
Edit Menu.”

FoornNoTtE Pull-down: ALT + I, N, F

Classic: "ONF
Inserts a footnote.
1 Choose Insert=>Note=>Footnote, or use the AONF classic command.
2 Type the footnote in the new window at the bottom of the screen. The
footnote can be as long as you like. You can edit it the same way you edit a

document.

3 When you finish typing the footnote, choose File=>Save and Close, or use
the AKD classic command.

When Command Tags display is on, the first few words of the footnote appear
as a command tag. When display is off, the command tag is not displayed, but
the reference number is displayed.

To view or edit a footnote, be sure display is on, move the cursor to the com-
mand tag, and choose Edit=>Edit Note, or use the AOND classic command.

When you print the document, the reference to the footnote is superscripted.
Footnotes are printed at the bottom of the page.
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Footnotes are numbered automatically. You can change the first number or
change numbers to letter references using Edit=>Note Options=>Starting
Number for Note, or the .f# dot command.

You can change a number of footnote options using WSCHANGE (DAD).

For more information about notes, see “Edit Note” and “Note Options” in
“Editing Screen Edit Menu.”

ENDNOTE Pull-down: ALT + I, N, E
Classic: "ONE

Inserts an endnote.
1 Choose Insert=>Note=>Endnote, or use the AONE classic command.

2 Type the endnote in the new window at the bottom of the screen. The
endnote can be as long as you like. You can edit it the same way you edit a
document.

3 When you finish typing the endnote, choose File=>Save and Close, or use
the AKD classic command.

When Command Tags display is on, the first few words of the endnote appear
as a command tag. When display is off, the command tag is not displayed, but
the reference number is displayed.

To view or edit an endnote, be sure display is on, move the cursor to the com-
mand tag, and choose Edit->Edit Note, or use the AOND classic command.

When you print the document, the reference to the note is superscripted.
Endnotes are printed at the end of the document unless you specify a different
location using Edit=>Note Options=>Endnote Location, or the .pe dot command.

Endnotes are numbered automatically. You can change the first number or
change to letter references using Edit=>Note Options=>Starting Number
for Note , or the .e# dot command.

For more information, see “Edit Note” and “Note Options” in “Editing Screen
Edit Menu.”
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ANNOTATION Pull-down: ALT + I, N, A

Classic: "ONA

Inserts an annotation.

An annotation is similar to a footnote; the difference is that you specify the refer-
ence symbol that appears in text, rather than having a numbered sequence.

1 Choose Insert=>Note=>Annotation, or use the A\ONA classic command.

2 In the Annotation Mark dialog box, type the reference you want the
annotation to have; for example, * or ##. This reference is printed in the
same way as a footnote number.

3 Press Enter or F10 or choose OK.

4 Type the annotation in the new window at the bottom of the screen. The
annotation can be as long as you like. You can edit it the same way you
edit a document.

5 When you finish typing the annotation, choose File=>Save and Close, or use
the AKD classic command.

When Command Tags display is on, the first few words of the annotation
appear as a command tag. When display is off, the command tag is not dis-
played, but the annotation mark is displayed.

To view or edit an annotation, be sure display is on, move the cursor to the
command tag, and choose Edit=>Edit Note, or use the A\OND classic command.

When you print the document, the reference to the annotation is superscripted.
Annotations are printed at the bottom of the page.

You can change a number of note options using WSCHANGE (DAD). The foot-
note options also apply to annotations.

For more information, see “Edit Note” and “Note Options” in “Editing Screen
Edit Menu.”
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I NDEX/TOC ENTRY Pull-down: ALT + I, I

Displays the Index/TOC Entry menu.

Use this command to insert or mark an entry for an index or table of contents.
After you insert or mark all your entries, use Index or TOC at the Opening
Utilities menu to create the index or table of contents.

TOC Entry... .tc
Index Entry... ~ONI

Mark Text for Index “PK
Dot Leader to Tab "P.

Toc ENTRY Pull-down: ALT + I, I, T
Classic: TC

Specifies a line of text to appear in the Table of Contents.

Before you create a table of contents, you use this command at the beginning of
each heading line in your document. At each location, you insert the line of
text you want to appear in the table of contents. Then you use TOC at the
Opening Utilities menu to create a table of contents composed of all the entries
you inserted. For more information, see “TOC” in “Opening Screen Ultilities
Menu.”

Follow these steps to insert a table of contents entry:

7 Place the cursor at the beginning of the heading line that you are entering in
the table of contents.

2 Choose Insert=Index/TOC Entry=>TOC Entry.

3 Inthe Table of Contents Entry dialog box, type the entire line of text that you
want to appear in the table of contents, including punctuation and
indentation. You can block copy the actual heading line if you want. Use
these guidelines to type the entry:
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®= To indent an entry, type extra blank spaces before the text.

= Type the # symbol where you want the page number to be printed. If
you want the # symbol to appear in the entry, precede it with a backslash
(\).

4 When you finish typing the entry, press F10 or choose OK.

WordStar inserts the .tc dot command followed by the text for the table of con-
tents entry. You can get the same result by typing the dot command and the
entry on a new line. If you want to edit the table of contents entry, edit it in the
dot command line.

You can insert periods up to the next tab stop by putting the cursor in the
appropriate position in the dot command and using Dot Leader to Tab (see
“Dot Leader to Tab” in this section).

One space after the .tc and before the text produces no indentation. Insert addi-
tional spaces as needed for the different levels of indentation.

For example, if you insert this entry on page 1:

.tc DEFINITION . . . . . . . . « . . . . #
and this one on page 3:

.tc Looking It Up . . . . . . . . . . #
the entries below will appear in the table of contents:

DEFINITION . . . v v o« « o « « « « . #
Looking It Up . . . . . . . . . . #

You can have several different tables of contents in one document. For
example, you can have a regular table of contents, another for figures, and a
third for tables. To assign an entry to a different table of contents, edit the .tc
command line and enter a digit from 1 to 9 directly after the .tc (without any
spaces). For example, if you use the number 1 for the Figures table of contents,
you might have the following entry:

.tcl Figure 1 . . . . . . . . . . . #
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To create the table of contents, save and close the document. At the Opening
screen, choose Utilities=>TOC, or use the classic command T. WordStar then
puts all the table of contents entries, with page numbers, into a file with the
.TOC extension. You can edit and print the .TOC file.

1

2

INDEX ENTRY Pull-down: ALT + I, I, I

Classic: “"ONI

Allows you to type an entry to appear in the Index.

Before you create an index, you mark the index entries in your text. Use this
command when the word or phrase you want in the index does not appear in
the text as you want it to appear in the index. (If the word or phrase appears in
the text as you want it to appear in the index, you can instead mark it with the
Mark Text for Index command on this menu.)

Place the cursor at the location you want to reference in the index.

Choose Insert=>Index/TOC Entry=>Index Entry, or use the AONI classic
command.

In the Index Entry dialog box, type the word or phrase that you want to
appear in the index. Keep in mind the following points:

Capitalize the entry the way you want it to appear in the index.

If you want to add a subreference, type a comma and the subreference,
for example, type Phrase to index, subreference. When you create the
index, the subreference appears under the main reference, indented two
spaces.

A phrase to index can contain up to 150 characters, including the
subreference. (An extended character counts as 3 characters.) Extra
characters are ignored.

To make the page number for an entry bold, type a plus (+) before the
text in the entry, for example, type +Files, naming.

For a cross-reference, type a hyphen (=) before the word or phrase, for
example, type —~Naming files, see Files. When WordStar creates the
index, it won’t add a page number for this entry.
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® If you want to include a comma, plus sign, or hyphen as part of the text
instead of using them for subreferences, boldface, or cross-references,
insert a backslash (\) before the character; for example, type \~to
include a hyphen. If you want a backslash to be part of an entry, type a
second backslash (\\).

4 When you finish typing the index entry, press F10 or choose OK.

When Command Tags display is on, the first few words of the index entry
appear as a command tag. When display is off, the command tag is not dis-
played.

To view or editan index entry, be sure display is on, move the cursor to the
command tag, and choose Edit=>Edit Note, or press A\OND. For more informa-
tion, see “Edit Note” in “Editing Screen Edit Menu.”

You can also use the .ix dot command to enter an index entry. Type .ix and the
entry on a new line. Type the entry as described above.

To create the index, save and close the document. At the Opening screen,
choose Utilities=>Index, or use the classic command I. WordStar then puts all
the index entries, with page numbers, into a file with the .IDX extension. You
can edit and print the .IDX file. For more information, see “Index” in “Opening
Screen Utilities Menu.”

For more information, see “Mark Text for Index” below and “Index” in
“Opening Screen Utilities Menu.”

MARK TEXT FOR INDEX Pull-down: ALT + 1,1, M

Classic: "PK
Marks the beginning and end of a word or phrase to appear in the Index.

Before you create an index, you mark the index entries in your text. Use this
command to include a word or phrase in the index, when you want the index
entry to appear exactly as it does in the text. (If the word or phrase does not
appear in the text as you want it to appear in the index, use the Index Entry
command on this menu.)

Place the cursor on the first character that will be in the index entry. Choose
Insert=>Mark Text for Index, or use the APK classic command. With Command
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Tags display on, the ~K tag appears. To mark the end of the index entry, place
the cursor after the last character to be included and choose Mark Text for
Index again.

To delete an index entry, place the cursor on the AK and press Del or AG. Be
sure to remove both the beginning and ending command tags.

For more information, see “Index Entry” above and “Index” in “Opening Screen
Utilities Menu” in “Opening Menu.”

Dot LEADER TO TAB Pull-down: ALT + I, I, D
Classic: "P.

Inserts periods up to the next tab.

This command is used primarily for entering table of contents entries. When
you choose Insert=>Dot Leader to Tab or use the ~P. classic command,
WordStar inserts a tab and a line of periods that goes to the next tab stop. You
can then type # so that the page number is printed after the periods. The cursor
moves over the tab and all of the periods as if they are all one character, and
you can delete them all at once using Del or Backspace.

For more information, see “TOC Entry” in this chapter.

P AR. OUTLINE NUMBER Pull-down: ALT + I, O
Classic: "OZ

Inserts a paragraph outline number.

Paragraph outline numbers allow you to number headings or sections of your
document. Follow these steps to insert a paragraph outline number.

7 Choose Insert=>Par. Outline Number, or use the AOZ classic command.

2 In the Paragraph Outline Number dialog box, specify the number to insert in
one of these ways:
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= Press Enter to accept the displayed number.

= Press the Right Arrow key or N to change to the next level. For example,
the next number displayed after 1 is 2. If you press the Right Arrow key,
the 2 changes to 1.1. When the number you want is displayed, press
Enter.

= Press the Left Arrow key or P to change to the previous level. For
example, the next number displayed after 1.1 is 1.2. If you press the Left
Arrow key, the 1.2 changes to 2. When the number you want is
displayed, press Enter.

Paragraph numbers are highlighted in the text. WordStar automatically renum-
bers subsequent paragraphs when you enter a new number or delete a number.

To change a paragraph number, delete the existing one and insert a new one at
the same location. To delete a paragraph number, place the cursor on it and
press the Del key. The entire number is deleted.

The first paragraph outline number you assign in a document is normally 1. To
change the starting number or the format for paragraph numbers, follow these
steps:

1

2

Choose Insert=>Par. Outline Number, or use the AOZ classic command.

In the Paragraph Outline Number dialog box, choose the Options button.
The options in the Paragraph Outline Options dialog box are described
below.

Starting Number To specify a different starting number, select this option
and type the new number. For example, if you type 3.3, the next paragraph
number you insert is 3.3.

Paragraph Outline Numbering Style Normally, paragraph numbers
contain only numerals, up to eight levels deep. Select this option to change
the numbering system to include upper- and lowercase letters and roman
numerals or to have a different number of levels. Type 9 wherever you
want numerals starting with O to appear. Type 1 for numerals starting

with 1. Type Z where you want uppercase letters, z where you want
lowercase letters, and 1 and i for upper- and lowercase roman numerals.
For example, Z.1.z would use a numbering system that started with A, then
A.1, then A.1.a.
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Use Compound Numbers When this option is selected (the default),
paragraph numbers include the full number, for example, I.A.1.a. Clear this
check box for outline style numbering, which uses only the last character of
the current level, for example, a.

You can include other characters in the command to print those characters
as part of the paragraph number. For example, if you type {Z.9.Z}, the
paragraph numbers are enclosed in braces.

TIP You can use your printer’s extended characters to add the paragraph
symbol (1) or the section symbol (§). If your printer uses the IBM extended
character set, the paragraph symbol is Alt-20 and the section symbol is
Alt-21. For more information, see “Extended Character” in this chapter.

3 Press F10 or choose OK.

WordStar inserts the .p# dot command in your text, followed by the starting
number if you changed it, then the style information, then c if you turned com-
pound numbering on or o (outline numbering) if you turned it off. The settings
are separated with commas, and commas indicate options without changed set-
tings. You can get the same result by typing the dot command.

For example, the dot command .p#3.3 changes the starting number to 3.3,

.p#, Z.1.z changes to letter, number, letter format, .p#, {Z.9.Z} encloses the
paragraph numbers in braces, and .p# 3.3, Z.9.z. changes both the starting num-
ber and the style. The command .p#,, 0 switches from compound to outline
numbering, and .p# 3,1.A.1,c changes all three settings.

You can use WSCHANGE (DBI) to change the paragraph numbering options.

CHAN GE PRINTER CODES Pull-down: ALT + 1, H

Allows you to specify the code to be entered when you insert a custom printer
code.

Custom printer codes are special printing instructions that let you take
advantage of a printer’s special features. You can use a custom printer code,
for example, to print a special character, such as a paragraph symbol. You
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might use one custom printer code to turn on a printer feature and another one
to turn it off.

Custom printer codes are already set up in the WordStar PDF files for some
printers. If your printer has them, they are listed on the Printer Information
screen when you install your printer.

IMPORTANT If you want to set up a printer code so that it is available for
all your documents, you can use PRCHANGE to define it in the PDF as
described in the following section, “Adding Custom Printer Codes to Your
PDF.” Use Change Printer Codes when you want to change the code for the
current document only.

Use Change Printer Codes to define a custom printer code in the current docu-
ment, overriding any setting for the code in the PDF. Use the following steps.

1 Choose Insert=>Change Printer Codes.

2 In the Change Custom Printer Codes dialog box, select the code you want to
change. The four available codes correspond to the classic commands APQ,
APW, APE, and ~APR. (You can change APF and APG only with
PRCHANGE.)

3 Type the code for the feature you want to use on your printer. Refer to your
printer manual to find out what code to use. For example, if your printer
manual shows a BASIC program, you need to translate to ASCII or
hexadecimal (hex) code. Use the “ASCII Conversion Charts” in Appendix B
to translate your printer code to ASCII or hex.

4 Press F10 or choose OK.

WordStar enters the printer code definition into the document using the .xq,
xw, .xe, and .xr commands. You can get the same result by typing the dot
command followed by the code in your text. At the point in the document
where you want to send the code, type the corresponding “"PQ, "PW, ~PE, or
APR command.

When you use custom printer codes, keep these points in mind:
= Codes for different makes and models of printers are usually different.

Custom printer codes that work on one printer may not work properly on
another.
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= Don’t use a custom printer code for a standard print feature that is normally
supported by WordStar, such as underlining or superscript. If you don’t get
the feature with the usual WordStar command, you can try using a different
PDF, or you can use PDFEDIT to enter the correct code for the command.
See the Installing and Customizing booklet for more information.

= Be sure to choose No sheet feeder for your PDF (either during installation or
using PRCHANGE) before trying to access your sheet feeder with your own
custom printer codes. Otherwise, the WordStar sheet feeder commands may
conflict with your custom printer codes.

= The WordStar character tables are mapped according to the character/
symbol set associated with the font currently in use. If you change the

character/symbol set with a custom printer code, WordStar will not know
about the change, and the results will be unpredictable.

ADDING CUSTOM PRINTER CODES TO YOUR PDF

If you want to have custom printer codes available in all your documents that
use a particular PDF, you can add them to your PDF in PRCHANGE (using
ASCII codes). Follow these steps:

1  Start at the DOS prompt. Exit WordStar if necessary.

2 From the DOS prompt, type winstall and press Enter to start WINSTALL.
3 Choose Modify or install a printer (PRCHANGE).

4 Atthe Installed Printer Menu, choose the PDF in which you want to change
or add custom printer codes.

5 At the PDF Modification Menu, choose Change custom printer code.

6  Any existing custom printer codes are listed on the Custom Printer Code
Menu. Choose one to change or press + to add a new one.

The Define a custom printer code screen appears. Notice that the WordStar
command for the code is shown at the right of the screen. (The commands
are added in the order APF, APG, APQ, APW, APE, and ~PR.)
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7  Enter a descriptive name for the printer code.

8 Enter the ASCII code for the feature you want (up to 72 characters). For
example, Esc A O (zero) would be entered as A[AN@. Refer to your printer
manual to find out what code to use.

9 The width option is for proportional spacing of printable characters. If the
ASCII code you entered is a printable character, enter a character of similar
width for the width option for a wide character, A for a medium character,
or | for a narrow character. If the code you entered is not a printable
character, skip the width option, leaving 0 (zero) on the screen.

10  Save your changes and exit.

For more information, see “Modifying a PDF” in the Installing and Customizing
booklet.




CHAPTER 10

EDITING SCREEN
STYLE MENU

The Style menu includes commands for inserting styles such as bold and
underline into your files, specifying fonts, working with paragraph styles, and
converting text to upper- or lowercase.

m
)
~
P4
o)
W
(@)
=
m
m
Z
¥
~
~
P~
m
<
m
Z
=
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Underline “PS
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Select Paragraph Style... "OFS
Return to Previous Style "OFP
Define Paragraph Style... "OFD

Manage Paragraph Styles >
Convert Case >
Settings...
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B OLD

Pull-down: ALT + S, B
Classic: “"PB

Marks the beginning or end of text you want printed in bold.
Follow these steps to mark bold text:
1 Place the cursor where you want bold text to start.

2 Choose Style=>Bold, or use the APB classic command. The text is
highlighted and, with Command Tags display on, the AB tag appears.

3 Place the cursor where you want the bold text to end, and choose
Style=Bold or press APB again.

You can also mark bold text with a mouse by clicking the B button on the style
bar. The B button is highlighted when bold is in effect.

To delete bold, place the cursor on the B and press Del or AG. Be sure to
remove both the beginning and ending markers.

If you’re using custom fonts, be sure to add the bold font to your PDF. For
more information, see the Installing and Customizing booklet.

If bold isn’t available on your printer, use double strike. (See “Double Strike” in
“Other” in this chapter.)

Note: With many proportional fonts, bold characters are larger than regular
characters, so you may not get as many characters on a line.

I TALIC
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Pull-down: ALT + S o I
Classic: "PY

Marks the beginning or end of text you want printed in italic.
Follow these steps to mark italic text:

7 Place the cursor where you want italic text to start.
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2 Choose Style=Italic, or use the APY classic command.
The text is highlighted and, with Command Tags display on, the AY tag appears.

3 Place the cursor where you want the italic text to end, and choose
Style=>Italic or press APY again.

You can also mark italic text with a mouse by clicking the | button on the style
bar. The I button is highlighted when italic is in effect.

To delete italic, place the cursor on the AY and press Del or AG. Be sure to
remove both the beginning and ending markers.

If you’re using custom fonts, be sure to add the italic font to your PDF. For
more information, see the Installing and Customizing booklet.

U NDERLINE Pull-down: ALT + S, U
Classic: "PS

Marks the beginning or end of text you want underlined.
Follow these steps to mark underlined text:

1 Place the cursor where you want underlining to start.

2 Choose Style=>Underline, or use the ~PS classic command.

The text is highlighted and, with Command Tags display on, the AS tag
appears.

3 Place the cursor where you want the underlining to end, and choose
Style=>Underline or press ~PS again.

You can also mark underlined text with a mouse by clicking the U button on
the style bar. The U button is highlighted when underlining is in effect.

10-3
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To delete underlining, place the cursor on the AS and press Del or AG. Be sure
to remove both the beginning and ending markers.

Usually, spaces between underlined words are underlined when you print
the document. To change this setting, choose Style=>Settings and select
Continuous Underline in the Settings dialog box, or use the .ul dot command.
For more information, see “Settings” in this chapter.

TIP  You can get double underlining by redefining the strikeout character and
using the Strikeout command. (See “Strikeout” in “Other” in this chapter.)

F ONT
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Pull-down: ALT + S, F
Classic: "P=

Changes the font in which text is printed.

A font is a particular size and style of typeface. Here are some examples of
different fonts:

Courier 10 point
Helvetica 10 point italic

Bodoni 12 point bold

Use these steps to change the font:

7 Place the cursor where you want the new font to start.
2 Choose Style=Font, or use the AP= classic command.
3 In the Font dialog box, select the font you want.

4 If the font you select is a scalable font, type the point size (for a proportional
font) or pitch (for a nonproportional font).

5 Press F10 or choose OK.

If Command Tags display is on, a font tag appears in the text, for example,
<COURIER 10>. Text following the tag is printed in the new font until you
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change to a different font. To remove a font tag, place the cursor on it and
press Del or AG.

The style bar shows the current font. You can change the font using a mouse
by clicking the font name.

After you change a font in an existing document, use Utilities=>Reformat=>Rest
of Document or the AQU classic command to reformat the rest of the document.

When you choose Font, you can select from the fonts available for the printer
PDF assigned to the document. You can customize the list of available fonts
when you install or modify your printer. See “Customizing WordStar” in the
Installing and Customizing booklet. Keep in mind that even if you add the font
to a printer PDF, the font must also be present in your printer for you to be able
to print with it.

You can also change fonts using paragraph styles. See “Define Paragraph Style”
in this chapter.

If you print a document with a printer other than the one assigned to it,
WordStar tries to match the fonts. If that is not possible, WordStar chooses the
closest available fonts, maintaining the line breaks and adjusting the justifica-
tion if necessary. It’s best to change the printer assigned to your document,
then change the fonts, and reformat before printing.

WORKING WITH FONTS
The following sections give information about the different kinds of fonts.

For detailed information about installing and modifying fonts, see “Customizing
WordStar” in the Installing and Customizing booklet.

INTERNAL, CARTRIDGE, AND SOFT FONTS

The fonts available to you depend on your printer. Internal fonts are those that
are already installed on the printer when you purchase it. For some printers,
you can also get cartridge fonts, which plug into the printer, or soft fonts, which
come on a disk for you to copy to the printer. When you install your printer for
WordStar, you choose the fonts you want to use from a list of those typically
available for the printer.
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You can use the WINSTALL option Add or delete fonts (PRCHANGE) to add
fonts after the initial printer installation. If you want to add fonts for a laser
printer, and the fonts aren’t shown on the PRCHANGE list for that printer, you
can use the WINSTALL option Add fonts to custom database (LSRFONTS) to
create a custom database, and then use PRCHANGE to add fonts from the
custom database to the PDF. See “Adding Fonts to a PDF” in “Customizing
WordStar” in the Installing and Customizing booklet.

FIXED-SIZE AND SCALABLE FONTS

On most nonlaser printers and many laser printers, fonts are available in
specific sizes only. Some printers also have scalable fonts, which contain the
information for the font style, but not the size. WordStar lets you choose the
size you want for these fonts and has the printer scale the typeface to that size.
You can choose any size from .25 points to 999.75 points (in .25-point incre-
ments) for a proportional scalable font, or from .1 to 40 characters per inch for
a nonproportional scalable font.

PROPORTIONAL AND NONPROPORTIONAL FONTS

In nonproportional (fixed pitch) fonts, each character takes up the same amount
of space on the page. Nonproportional fonts are measured in pitch (characters
per horizontal inch). For example, a COURIER 10 font is a nonproportional
font with 10 characters per inch (pica); a COURIER 12 font has 12 characters
per inch (elite). On dot matrix printers, expanded print is usually 5 characters
per inch and compressed print is 17 characters per inch.

When you select a font with a different pitch, WordStar determines how many
characters of the new pitch will fit on a line and displays the correct line breaks
onscreen.

In proportional fonts, different letters take up different amounts of space; for
example, an “m” takes up more space than an “i.” Proportional fonts are
usually measured in points, which specify the height of the letters. For
example, standard text characters are 10 points, but footnotes might be in

a smaller size, such as 8 points.

On the screen, a line of proportionally spaced text may appear to extend
beyond the margins. This is because proportionally spaced letters often take up
less space than nonproportionally spaced letters, and you can fit more charac-
ters on a line. To see where the characters will be printed, look at the marker
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in the ruler line. As you move the cursor across a line of text, the marker shows
where the text at the cursor will be printed. If you have a graphics monitor, you
can also choose View=>Preview, or use the AOP classic command, to see how
the text will look on the printed page.

OTHER Pull-down: ALT + S, 0

Lets you use strikeout, subscript, superscript, double strike, and colors

or shadings.
Strikeout “PX
Subscript PU
Superscript “PT
Double Strike “PD
Color/Shading... "P-
STRIKEOUT Pull-down: ALT + S, O, S

Classic: "PX
Marks the beginning or end of text you want to strike out.

Text you mark for strikeout is overprinted with hyphens. It is useful, for
example, in documents to indicate where you want to delete text.

Follow these steps to strike out text:
1 Place the cursor where you want strikeout to start.
2 Choose Style=>Other=>Strikeout, or use the APX classic command.

The text is highlighted and, with Command Tags display on, the symbol
AX appears.

3 Place the cursor where you want strikeout to end, and choose
Style=>Other=>Strikeout or press APX again.
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To delete strikeout, place the cursor on the AX and press Del or AG. Be sure to
remove both the beginning and ending markers.

To change the character used to strike out text, choose Style=>Settings and
select the Character for Strikeout option in the Settings dialog box, or use the
xx dot command, followed by the new character. For example, type .xx/ to
use the slash. See “Character for Strikeout” in “Settings” in this chapter.

TIP To get a double underline, change the strikeout character to an
underscore character (.xx_). Then mark the text for both underline and
strikeout.

SUBSCRIPT Pull-down: ALT + S, O, B
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Classic: "PV
Marks the beginning or end of text you want printed as a subscript.

Subscript text is printed slightly below the rest of the text on the line, for
example, H,O.

Follow these steps to subscript text:
1 Place the cursor where you want the subscript to start.
2 Choose Style=>Other=>Subscript, or use the APV classic command.

The text is highlighted and, with Command Tags display on, the AV
tag appears.

3 Place the cursor where you want the subscript to end, and choose
Style=>Other=>Subscript or press APV again.

To delete subscript, place the cursor on the AV and press Del or AG. Be sure to
remove both the beginning and ending markers.

On some printers you can specify how far below or above the text subscripts
and superscripts are printed. This amount is normally 3/48 inch. To change it,
start on a new line above the subscripts in the text. Type .sr (sub/superscript
roll) followed by the number of 48ths of an inch of roll you want, and press
Enter. For example, to change to 4/48-inch roll, type .sr 4. To permanently
change the sub/superscript roll, use WSCHANGE (BCK).
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The .sr 0 command usually gives the best results on dot matrix printers. This
command allows WordStar to access the printer’s built-in subscript/superscript
settings. Some dot matrix printers have a special half-high font available specifi-
cally for subscript and superscript. If you don’t use .sr 0, WordStar prints full
size subscript/superscript moved up or down as described above. However, if
you use .sr 0, in some instances WordStar may not recognize the smaller font
and may not justify the text properly. If this happens, delete the .sr 0 and try
choosing another font for subscript and superscript.

With scalable fonts, WordStar automatically uses a smaller font size for sub-
scripts. The size is the x-height (height of the lowercase x) of the original
height. For example, if the text is 12-point Times Roman, the subscript text is
8.1-point Times Roman.

On some printers, you can change the font assigned to subscript and superscript
by choosing a font from the list of available fonts in your PDF. See the informa-
tion on the PRCHANGE Add or Delete Fonts option in “Customizing” in the
Installing and Customizing booklet.

SUPERSCRIPT Pull-down: ALT + S, O, P

Classic: "PT

Marks the beginning or end of text you want printed as a superscript.

Superscript text is printed slightly above the rest of the text on the line, for
example, MailList™.

Follow these steps to superscript text:
1 Place the cursor where you want the superscript to start.
2 Choose Style=>Other=>Superscript, or use the APT classic command.

The text is highlighted and, with Command Tags display on, the AT tag
appears.

3 Place the cursor where you want the superscript to end, and choose
Style=>Other=>Superscript or press APT again.

To delete superscript, place the cursor on the AT and press Del or ~G. Be sure
to remove both the beginning and ending markers.
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On some printers, you can specify how far below or above the text subscripts
and superscripts are printed. This amount is normally 3/48 inch. To change it,
start on a new line above the superscripts in the text. Type .sr (sub/superscript
roll) followed by the number of 48ths of an inch of roll you want, and press
Enter. For example, to change to 4/48-inch roll, type .sr 4. To permanently
change the sub/superscript roll, use WSCHANGE (BCK).

The .sr 0 command usually gives the best results on dot matrix printers. This
command allows WordStar to access the printer’s built-in subscript/superscript
settings. Some dot matrix printers have a special half-high font available specifi-
cally for subscript and superscript. If you don’t use .sr 0, WordStar prints full
size subscript/superscript moved up or down as described above. However, if
you use .sr 0, in some instances WordStar may not recognize the smaller font
and may not justify the text properly. If this happens, delete the .sr 0 and try
choosing another font for subscript and superscript.

With scalable fonts, WordStar automatically uses a smaller font size for super-
scripts. The size is the x-height (height of the lowercase x) of the original
height. For example, if the text is 12-point Times Roman, the superscript text is
8.1-point Times Roman.

On some printers, you can change the font assigned to subscript and superscript
by choosing a font from the list of available fonts in your PDF. See the infor-
mation on the PRCHANGE Add or Delete Fonts option in the Installing and
Customizing booklet.

DOUBLE STRIKE Pull-down: ALT + S, O, D
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Classic: "PD
Marks the beginning or end of text you want printed with double strike.
When you choose Double Strike, the printer strikes each character twice to
produce a light bold for emphasizing words or phrases. On page printers, the
printer prints each character twice, with the two characters slightly offset.
Double strike is useful when bold is not available for your printer or type style.
Follow these steps to double strike text:

1 Place the cursor where you want double strike to start.

2 Choose Style=>Other=>Double Strike, or use the APD classic command.
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The text is highlighted and, with Command Tags display on, the AD
tag appears.

3 Place the cursor where you want double strike to end, and choose
Style=>Other=>Double Strike or press APD again.

To delete double strike, place the cursor on the AD and press Del or AG. Be
sure to remove both the beginning and ending markers.

COLOR/SHADING Pull-down: ALT + S, O, C
Classic: “"P—

Prints text in a different color or shade of gray.

Use this command only if you have a color printer or one, such as the
Hewlett-Packard Laser]et Ill, that supports shades of gray or other patterns

and font enhancements such as outline, shadow, and reverse (white on black).
Follow these steps to change the color or shade:

1 Place the cursor where you want the new color or shade to start.

2 Choose Style=Other=Color/Shading, or use the AP- classic command.

3 The Color dialog box shows the color currently in effect and a list of 16
colors, shades of gray, or patterns available on your printer. Select the color
or shade you want.

4 Press F10 or choose OK.
If Command Tags display is on, a command tag stating the color or shade (for
example, <Red>) appears on your screen. Text following the command tag

prints in the new color until you change the color again.

To remove the color, place the cursor on the command tag and press Del or ~G.
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SELECT PARAGRAPH STYLE Pull-down: ALT + S, S
Classic: "OFS

Assigns a paragraph style to subsequent text.

Paragraph styles contain layout settings for text. You can use them to change
several layout settings at once, and to store groups of settings that you use often,
so that you can apply them easily. For example, Heading style turns bold and
underline on, and Body Text style turns them off. WordStar comes with several
predefined paragraph styles, and you can edit them and create additional ones.
When you create a new document, the default style, Body Text, is in effect until
you select a different style. You can change the default style at the WINSTALL
Set Basic Editing Defaults menu or by using WSCHANGE (DAFB).

Follow these steps to select a paragraph style:

1 Choose Style=>Select Paragraph Style, or use the AOFS classic command.
Or, you can use the Alt+0 (zero) macro as a shortcut.

2 In the Select Paragraph Style dialog box, select the style you want.

3 Press F10 or choose OK.

WordStar inserts a paragraph style tag in the text, and subsequent text is
formatted in that style until you select another style. If necessary, choose

Utilities=>Reformat=>Rest of Document or use the QU classic command.

The style bar shows the current paragraph style. You can change the paragraph
style using a mouse by clicking the style name.

For more information on paragraph styles, see “Define Paragraph Styles” and
“Manage Paragraph Styles” in this chapter.

PREDEFINED PARAGRAPH STYLES

WordStar comes with nine predefined paragraph styles that you can select. The
following table describes them.
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Body Text

Hanging Indent 1

Hanging Indent 2

Hanging Indent 3

Heading

Manuscript

Paragraph Indent

RETURN TO PREVIOUS STYLE

DESCRIPTION

Sets all the paragraph style options for the text you use
most often.

Starts the first line of a paragraph at the left margin,
and indents subsequent lines to the first tab stop. This
style is useful for outlines and bulleted or numbered
lists.

Starts the first line of a paragraph at the first tab stop,
and indents subsequent lines to the second tab stop.
If you use Hanging Indent 1 for the first level of an
outline, you can use Hanging Indent 2 for the next
level.

Starts the first line of a paragraph at the second tab
stop, and indents subsequent lines to the third tab stop.

Turns on bold and underline.

Indents the first line of a paragraph, and double-spaces
text.

Indents the first line of a paragraph.

Quotation Indents both left and right margins one inch.
Title Uses a larger font (if available), centers the text, and
turns on bold.
RETURN TO PREVIOUS STYLE Pull-down: ALT + S, R

Classic: "OFP

Returns to the paragraph style that was in effect before the current one.

When you choose this command, WordStar inserts a tag for the previous para-
graph style, and subsequent paragraphs use that style. This command is useful
when you want to switch back and forth between two styles.
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D EFINE PARAGRAPH STYLE Pull-down: ALT + S, D
Classic: "OFD

Allows you to create a new paragraph style or edit an existing one.
Paragraph styles contain layout settings for text. You can use paragraph styles
to change several layout settings at once, and to store groups of settings that
you use often, so that you can apply them easily. For example, the Heading
style turns bold and underline on, and the Body Text style turns them off.
WordStar comes with several predefined paragraph styles, and you can edit
them and create additional ones.

Follow these steps to define a paragraph style:

1 Choose Style=>Define Paragraph Style, or use the AOFD classic command.

2 In the Define Paragraph Style dialog box, change any options you want.
The options are described below these steps.

3 Press F10 or choose OK to save the paragraph style.

Define Paragraph Style

Style: [RIEAT Left Margin: [E
ist Line Indent:
Font: l Right Margin: MR i Cancel
Leading: (Line Height) Line Spacing:
JCV M. 50" 1.0808" 1.50"- 2.80"- 2.50"-3.80"-3.50" - 4.00"-4.50" 5. 80" 5|
On Off Inherit Alignment: ¢ Flush Left
Bold o * o o Centered
Italic o * [\] o Flush Right
Underline o * [ o Justified
Strikeout o * o o Inherited
Doublestrike o * ]
Superscript o * o Color/Shading: |GG
o ¢ o
* o o

Subscript
Word Urap [-1 Update Style Library
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Note: For settings that are measured in inches, you can specify a different unit
of measurement by typing the symbol after the number: r for ruler units
(columns), p or pt for points (1/72 inch), or ¢ or cm for centimeters. For
example, you can set the line height to 13 points by typing 13p.

Style The name of the current paragraph style is displayed here. You can
select a different style from the list, or type a name for a new style. You can
press the Spacebar and move to the next option to start with the current settings
in the document. Then, return to the Style option to name the new style.

Font To change the font, select a font from the list. If you choose a scalable
font, be sure to specify the point size or pitch. If you don’t want the font in a
document to change when you apply the style (the style “inherits” the font from
the preceding text), clear this option.

Leading (Line Height) To change the leading (line height), type the height you
want. You can type the value in inches; for example, type 1/6 for 1/6 inch to
set the 6 lines per inch standard line height. You can also specify another unit
of measurement; for example, type 12p to set the leading to 12 points.

Tabs You can set up to 32 tab stops. Separate them with spaces, and type the
tab locations in inches. For example, to set tabs at 1 inch and 2.5 inches, type
1 2.5. You can specify another unit of measurement; for example, to set tabs in
columns 5 and 10, type 5r 10r. For a decimal tab, type # before the number.
To clear all tabs, press AY. If you don’t want to change the tabs in a document
when you apply the style, clear this option.

Left Margin Set a left margin if you want text with this style to have a par-
ticular left margin. Specify the margin in inches or use another unit of measure-
ment. You can use the Left Margin setting together with the First Line Indent
option to set a “hanging” indent, which is useful for numbered or bulleted lists.
For example, if you set the left margin to .3" and the first line indent to 0", the
first line of each paragraph will “hang out” to the left of the rest of the para-
graph.

1st Line Indent Set a first line indent if you want the first line of each para-
graph to have a different indentation than the rest of the paragraph. You can
use this setting to indent the first line of each paragraph, or for a hanging indent
as described in the previous paragraph. Specify the margin in inches or use
another unit of measurement. For example, to set a .2 inch indent, type .2.
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Right Margin Set a right margin if you want text with this style to have a
particular right margin. Specify the margin in inches or use another unit of
measurement. For example, to set a 5.25 inch indent, type 5.25.

Line Spacing The default is 1 for single-spaced text. Type 2, for example, if
you want double-spaced text. If you don’t want to change the spacing in a
document when you apply the style, clear this option.

On/Ofi/Inherit Options You can select On, Off, or Inherit for any of these
options. For example, for a heading style, you might want to set Bold and Italic
both to On. If you select Inherit, text with this style has whatever setting is cur-
rent in the file before the style tag. When the cursor is at one of these options,
you can press the Plus ( +) sign for on, the Minus ( ) sign for off, or O (zero) for
inherit.

Alignment You can select Flush Left (the default) for ragged right text,
Centered to center each line, Flush Right to align text at the right margin but not
at the left, or Justified for right-justified text. If you don’t want to change the
alignment in a document when you apply the style, select Inherited.

Color/Shading To change the color or shade, select a color or shade from the
list. If you don’t want the color or shade in a document to change when you
apply the style, delete the entry and leave this option blank.

Update Style Library Select this check box if you want to save the style to the
style library as well as in the document.

Note: Inherited style settings and settings that change the line height do not
apply to headers, footers, or footnotes.

For more information on the paragraph style options, see the following sections:

TOPIC SEE

Choosing a style “Select Paragraph Style” in this chapter
Reverting to the “Manage Paragraph Styles” in this chapter
previous style

The style library “Manage Paragraph Styles” in this chapter
Margins and tabs “Ruler Line” and “Page Layout” in this chapter

Fonts “Font” in this chapter
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TOPIC SEE

Boldface “Bold” in this chapter

Italic “Italic” in this chapter

Underline “Underline” in this chapter

Double strike, strikeout, “Other” in this chapter

subscript, and superscript

Justification, centering, “Alignment and Spacing” in “Editing Screen
line height, line spacing, Layout Menu”

and word wrap

WORKING WITH PARAGRAPH STYLES

When you begin a document, the default style, Body Text, is in effect until you
choose another style. You can change the default style at the WINSTALL Set
Basic Editing Defaults menu or using WSCHANGE (DAFB).

To change to a new style, choose Select Paragraph Style (or AOFS), described in
this chapter. To remove a style, move the cursor to the style tag, and press Del
or AG.

You can change individual settings within text that uses a style. For example,
you can make text bold or change the font.

DOCUMENT STYLES AND THE STYLE LIBRARY

The nine predefined paragraph styles are stored in the style library. Styles in the
style library are available for any document. When you use a style from the
library, WordStar makes a copy of that style and stores it with the document.
The copy in the document is called a document style.

When you create or edit a style, it is saved as a document style, which means
that it is available for use in the current document. When you save the style,
you can also save it to the style library by selecting the Update Style Library
check box. You can also save a document style to the library by choosing
Style=>Manage Paragraph Styles=>Copy Style to Library, or using the AOFO
classic command. You can also rename styles and delete library styles. See
“Manage Paragraph Styles” in this chapter.
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You can keep generic styles in the library and customize them for each docu-
ment. You can also add customized document styles to the library to make
them available for other documents.

If a document style and a library style have the same name but different set-
tings, when you look at the style, the document settings are displayed, and the
name in the styles list has an asterisk after it. If you want to use the library style
in the document, rename the library style.

To keep your file from getting too large, WordStar deletes unused document
styles when you save the file. If you’ve customized a document style but
haven’t used it in the document, you can keep it by saving it to the library. To
delete a document style, just delete all occurrences of the style tag in the docu-
ment.

Note: If you copy text that contains paragraph style tags from one document (or
note) into another document, and a document style used in the text doesn’t
exist in the new document, the style tags change to show only question marks.
You can then specify a style that exists in the new document.

CHANGING DEFAULT EDITING SETTINGS
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Your default paragraph style determines the default editing settings, for
example, margins and line height. Unless you change the default paragraph
style in WSCHANGE (DAFB), it is Body Text.

To change default settings using paragraph styles, choose Style=>Define Para-
graph Style or use the AOFD classic command. Choose the default paragraph
style, enter your changes in the Define Paragraph Style dialog box, and close
the dialog box. Then choose Style=>Manage Paragraph Styles=>Copy Style to
Library (or use AOFO) to copy that style to the library. Whenever you create a
new document, the new settings are in effect.

WSCHANGE also includes options to change the default editing settings. How-
ever, when your default paragraph style is in the paragraph style library (Body
Text is in the style library as a default), settings changed in WSCHANGE do not
take effect. If you want WSCHANGE changes to take effect, you can change
the default paragraph style to a style that does not exist or is not in the style
library, or you can delete the library version of your default style and not create
another one.



MANAGE PARAGRAPH STYLES

MANAGE PARAGRAPH STYLES Pull-down: ALT + S, M
Classic: "OF

Copies, deletes, and renames paragraph styles.

Delete Library Style... "OFY
Rename Library Style... "OFR
Rename Document Style... "OFE

These commands allow you to copy a document style to the style library, delete
a library style, and rename a library or document style.

COPY STYLE TO LIBRARY Pull-down: ALT + S, M, C
Classic: "OFQO

Copies a document paragraph style to the style library.
Use this command when you create a paragraph style that you want to have
available for other documents, or when you modify a paragraph style and want

to save the changes to the library. Follow these steps:

1 Choose Style=>Manage Paragraph Styles=>Copy Style to Library, or use the
AOFO classic command.

2 In the Copy Style to Library dialog box, select the style to copy.
3 If you want to give the library style a different name, specify the name.
4 Press F10 or choose OK to copy the paragraph style.

For more information, see “Document Styles and the Style Library” in “Define
Paragraph Style” in this chapter.
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DELETE STYLE FROM LIBRARY Pull-down: ALT + S, M, D

Classic: "OFY

Deletes a paragraph style from the style library.
Follow these steps to delete a library style:

1 Choose Style=>Manage Paragraph Styles=>Delete Style from Library, or use
the AOFY classic command.

2 In the Delete Library Style dialog box, select the style to delete.
3 Press F10 or choose OK to delete the style.

For more information, see “Document Styles and the Style Library” in “Define
Paragraph Style” in this chapter.

Note: To delete a document style, simply delete all occurrences of the style tag
for that style from the document.

RENAME LIBRARY STYLE Pull-down: ALT + S, M, R
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Classic: "OFR

Renames a paragraph style in the style library.
Follow these steps to rename a library style:

7 Choose Style=>Manage Paragraph Styles=>Rename Library Style, or use the
AOFR classic command.

2 In the Rename Library Style dialog box, select the style to rename.
3 Specify the new name for the style.
4 Press F10 or choose OK to rename the style.

For more information, see “Document Styles and the Style Library” in “Define
Paragraph Style” in this chapter.



CONVERT CASE

RENAME DOCUMENT STYLE Pull-down: ALT + S, M, E
Classic: "OFE

Renames a document paragraph style.
Follow these steps to rename a document style:

1 Choose Style=>Manage Paragraph Styles=>Rename Document Style, or use
the AOFE classic command.

2 In the Rename Document Style dialog box, select the style to rename.
3 Specify the new name for the style.
4 Press F10 or choose OK to rename the style.

For more information, see “Document Styles and the Style Library” in “Define
Paragraph Style” in this chapter.

CONVERT CASE Pull-down: ALT + S, C

Converts all the letters in a block to lowercase or uppercase, or all the letters
to lowercase except for the first letter of every sentence.

Choose one of the following commands from the Convert Case menu.

PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

Uppercase AK Converts the marked block to all
uppercase letters.

Lowercase AK Converts the marked block to all
lowercase letters.

Sentence case AK. Capitalizes the first letter following a

period, question mark, or exclamation
point and a space, and converts all other
letters to lowercase, except for the letter
“I” when it appears by itself.
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Note: 1f you use the classic commands, do not hold down the Ctrl key when
you press the second character of the command (", ", or .).

For information on blocks, see “Mark Block Beginning” and “Mark Block End”
in “Editing Screen Edit Menu.”

S ETTINGS Pull-down: ALT + S, E

Changes settings for continuous underline and strikeout character.

CONTINUOUS UNDERLINE

Turns on and off underlining of spaces between underlined words.

Underlined text is marked using the Style=>Underline or the ~PS classic com-
mand. Usually, spaces between underlined words are underlined when you
print. This command allows you to turn this underlining on and off. Follow
these steps:

7 Place the cursor where you want continuous underlining to end.

2 Choose Style=>Settings.

3 In the Settings dialog box, clear the Continuous Underline check box to
turn off continuous underlining.

4 Press F10 or choose OK.

WordStar inserts the .ul off dot command into the text. You can get the same
result by typing the dot command.

When continuous underline is on, spaces are underlined when you print, but
they do not appear underlined onscreen, even in Preview.

To start underlining spaces, place the cursor where you want the underlining to
start, choose Style=>Settings, and select the Continuous Underline check box.
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WordStar inserts the .ul on dot command into the text. You can get the same
result by typing the dot command.

To change the default setting for continuous underline, use WSCHANGE (BCE).

CHARACTER FOR STRIKEOUT
Changes the character used to strike out text.

The character used to strike out text (using Style=>Other=>Strikeout, or APX) is
normally a hyphen (). Follow these steps to change the strikeout character:

1  Place the cursor where you want the new character to take effect (generally
at the beginning of the document).

2 Choose Style=>Settings.

3 In the Settings dialog box, select Character for Strikeout.

4 Type the character to use for strikeout.

5 Press F10 or choose OK.

WordStar inserts the .xx dot command followed by the new character. For
example, .xx/ changes the character to the slash. You can get the same result

by typing the dot command.

Whenever you subsequently use strikeout in the document
(Style=>Other=>Strikeout, or APX), the new character overprints the text.

To permanently change the character used for strikeout, use WSCHANGE (BCI).

10-23




CHAPTER 11

EDITING SCREEN
IAYOUT MENU

The Layout menu includes commands for setting up the layout of your docu-
ment. It includes page size, margins, tabs, columns, headers, footers, page and
line numbering, alignment, spacing, and other layout elements.
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CENTER LINE Pull-down: ALT + L, C
Classic: "OC

Centers the current line of text.

When you choose this command, WordStar centers all of the characters on the
line within the current margins. Spaces before and after the text are ignored.

If you later change the margins and reformat the text, centering is adjusted for
the new margins.

To delete the centering, place the cursor at the left margin of the line and
press Del or AG.

For more information on centering text, see “Define Paragraph Style” in “Editing
Screen Style Menu” and “Alignment and Spacing” in this chapter.
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RI GHT ALIGN LINE Pull-down: ALT + L, 1
Classic: O]

Aligns the current line of text at the right margin.

Use this command to align one line of text flush right (aligned at the right
margin) instead of at the left margin. When text is right-aligned, the left
margin is ragged.

You can position a longer section of text flush right using Layout=>Alignment
and Spacing (*OS) or paragraph styles. See “Alignment and Spacing” in this
chapter and “Define Paragraph Style” in “Editing Screen Style Menu.”

RULER LINE Pull-down: ALT + L, R
Classic: “OL

Changes settings for left, right, and paragraph margins, and for tabs.
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RULER LINE

The ruler line at the top of the screen shows the settings for left, right, and para-
graph margins, tabs, decimal tabs, and temporary indents. For a complete
description of the ruler line, see “WordStar Basics.”

To change the ruler line settings, follow these steps:

1

2

3

Place the cursor in the text where you want the changes to begin.
Choose Layout=>Ruler Line, or press the AOL classic command.

In the Ruler Line dialog box, type the settings you want. You can set
margins and tabs to .01 inch accuracy; for example, the right margin setting
can be 5.25". You can specify a unit of measurement other than inches by
typing the symbol after the number: r for ruler units (columns), p or pt for
points (1/72 inch), or ¢ or cm for centimeters.

Ruler Line

Left Margin: BEFCEN ist Line Indent: [N

Right Margin: ICRELN ¢ Cancel

e S XTSH 50 1.00'"-1.50"-2.80'-2.508"-3.808"-3.50""-4.80""- 4.5

The options in this dialog box are described below.

Left and Right Margins The left and right margins are the text boundaries.
You can set the left margin to any value between 0 and 25.4 inches, and the
right margin between 1 and 36 inches. You must leave at least .2 inch
between the left and right margins.

First Line Indent Set a first line indent if you want the first line of each
paragraph to have a different indentation than the rest of the paragraph.
You can use this setting to indent the first line of each paragraph or for a
hanging indent that is good for bulleted or numbered lists. For example, to
set a .2 inch indent, type .2, or to set a 3-column indent, type 3r.

Tab Stops You can set as many tab stops as you want. Tab stops allow you
to align columns of text by the first character you type after tabbing. Type
the tab locations, separating them with spaces. For example, to set tabs at

1 inch and 2.5 inches, type 1 2.5.

11-3




EDITING SCREEN LAYOUT MENU

You can also set decimal tabs, which allow you to align the decimal points
in a column of numbers. The decimal points (or the space at the end of the
number) line up at the decimal tab location. Type # before the tab location
to set a decimal tab, for example, type #3 to set a decimal tab at 3 inches.
The example below shows a column aligned using a decimal tab.

1234.56
$432,697
.99
1.414679
3,429,733.0

4  After you change the options you want, press F10 or choose OK.

WordStar inserts a dot command in your text for each setting you’ve changed.
These commands are .Im for Left Margin, .rm for Right Margin, .pm for First
Line Indent, and .tb for tab stops, each followed by the appropriate setting num-
ber or numbers in inches. You can get the same result by typing the dot com-
mand in the text. When you type the dot command, you can use the same
units of measurement you use in the dialog box (you must type i, in, or “ if you
use inches). When you type the dot command, you can also use the Plus (+)
sign or Minus ( —) sign to move a margin a specified distance from the current
margin. For example, .Im +.5" sets the left margin .5" to the right of the current
margin. With this setting, if you change the original left margin, all indented
text maintains the same relationship to the margin.

To change a setting, just delete the old setting in the dot command and type the
new one. To delete a setting, delete the dot command line.

TIP You can specify all the ruler line settings with paragraph styles.

See also “Define Paragraph Style” in this chapter and “The Ruler Line” in “The
Edit Screen” in “WordStar Basics.”

You can also insert a ruler line into your document with the .rr dot command
using any of these three methods:

® Type .rr followed by the new ruler line, using the characters shown below.
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CHARACTER MEANING

L left margin

R right margin

P paragraph margin (first line indent)
CHARACTER MEANING

! tab stops

# decimal tabs

- columns (.1") between margins and tabs

To set the left margin at 0, type a hyphen immediately after the command;
don’t type the L. To set the left margin at .1 inch or .2 inch, use an over-
printed line (see “Special Effects” in this chapter) after the dot command, and
type the L in the left margin location.

= Press AOO to insert a .rr dot command with the current ruler line settings.
You can then edit the settings. (The left margin must be .3" or greater.)

= Use the .rr dot command to use a predefined ruler line. Three ruler lines are
predefined; .rr0 uses the default margins and tabs, .rr1 indents the left and
right margins .5" from the standard margins, and .rr2 gives a .5" hanging
indent. You can define ruler lines 0-9 using WSCHANGE (DAE).

COLUIWN S Pull-down: ALT + L, O
Classic: "OU

Sets up multiple columns or returns to single-column text.

one column —|

«—two columns
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This command sets up newspaper-style columns. The text starts in the first column,
and when that column is filled, the text wraps to the next column. When you fill
the last column on the page, the text wraps to the next page. When you add or
delete text and reformat the document, WordStar adjusts the text in the columns.

7

2

Choose Layout=>Columns, or use the AOU classic command.

In the Column Layout dialog box, type the settings you want. You can set
margins and column widths to .01 inch accuracy; for example, the right
page margin setting can be 7.25". You can specify a unit of measurement
other than inches by typing the symbol after the number: r for ruler units
(columns), p or pt for points (1/72 inch), or ¢ or cm for centimeters.

Column Layout

Number of Columns:

Space Betueen Columns: [JRIFEH ¢ Cancel

Right Page Margin:
Column Midth:

The options in this dialog box are described below.
Number of Columns Enter the number of columns you want, from 1 to 8.

Space Between Columns Enter the width for the “gutter” between the
columns.

Right Page Margin Enter the rightmost edge where text will be printed on
the line (not the width of a column).

Column Width WordStar calculates the width of each column from your
entries for the number of columns, space between columns, and right
margin and displays it here.

3 After you change the options you want, press F10 or choose OK.

WordStar inserts dot commands in your text for your settings. These commands
are .co for Number of Columns and .rm for Column Width (right margin for the
column), each followed by the appropriate setting number or numbers. The

Space Between Columns setting is included in the .co command. For example,
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.co4, .2" gives you four columns of text with .2" between columns. You can get
the same result by typing the dot commands in the text. When you type the dot
command, you can use the same units of measurement you use in the dialog
box (you must type i, in, or # if you use inches).

To change a setting, just delete the old setting in the dot command and type the
new one. To delete a setting, delete the dot command line.

Note: If the left margin setting is greater than 0, WordStar adds the left margin
to the space between columns. For example, if the left margin is set to 1 inch
and the space between columns is set to .2 inch, the space between columns
will be 1.2 inches. To indent the leftmost column only, change the page offset
instead of the left margin (see “Margins” in “Page” in this chapter).

One column symbol (a triple horizontal bar) appears at the beginning of each
line in the first column, two column symbols in the second column, and so on.
The columns are not shown next to each other on the screen. You can see how
they look using View=>Preview or the AOP classic command.

The column break (end of each column) appears onscreen as a double line
with a Cin the flag column. If you want to end a column before the bottom of
the page, use Insert=>Column Break (or .cb). If you want to keep several lines
together in a column, use Layout=>Special Effects=>Keep Lines Together in
Column (or .cc). For more information, see “Column Break” in “Editing Screen
Insert Menu” and “Keep Lines Together in Column” in “Special Effects” in this
chapter.

To turn off columns and resume regular page layout, choose Columns and set
the number of columns to 1. Be sure to adjust the right margin as necessary.
WordStar inserts a page break and the appropriate dot command. To change
existing columns to regular page layout, remove the .co dot command line and
any related commands, and reformat the text.

Any footnotes in columns become endnotes.

If you change the top or bottom margin when you set columns, the .mt or .mb
command must be above the .co command for it to take effect on the same

page.
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P AGE Pull-down: ALT + L, P
Classic: “"OY

Changes settings for margins, orientation, page length, paper bin, and suppress-
ing blank lines at the top of the page.

Use this command to determine how your text is printed on the page. Follow
these steps:

1 Choose Layout—>Page, or use the 2OY classic command.

2 In the Page Layout dialog box, enter the settings you want. The options are
described below these steps.

Page Layout

Margins
0dd Offset: Top: Header: [ENEEH
Even Offset: Bottom: Footer:

Orientation: Page Length: [EBGIEH [ 1 Supress Blank Lines
¢ Portrait at Top of Page

o Landscape Paper Bin: [

Note: You can change the defaults for most of these settings in
WSCHANGE (DAA).

3 After you change the options you want, press F10 or choose OK.

MARGINS

The margin settings in the Page Layout dialog box specify the limits of the text
area on the printed page. The following illustration shows how these margins
and the left and right margins affect the page layout. (You can set the left and
right margins using either paragraph styles or Layout=>Ruler Line.)
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For each option you want to change, type the new setting. You can set the mar-
gins to .01 inch accuracy; for example, the top margin setting can be 1.25".

You can specify a unit of measurement other than inches by typing the symbol
after the number: r for ruler units (columns for horizontal settings or lines for
vertical settings), p or pt for points (1/72 inch), or ¢ or cm for centimeters.

When you close the Page Layout dialog box, WordStar inserts a dot command in
your text for each setting you’ve changed. These commands are .poo and .poe
for Odd and Even Page Offset, .mt and .mb for Top and Bottom Margins, and
.hm and .fm for Header and Footer Margins, each followed by the corresponding
setting in inches. You can get the same result by typing the dot command in the
text. When you type the dot command, you can use the same units of measure-
ment you use in the dialog box (you must type i, in, or " if you use inches).

To change a setting, just delete the old setting in the dot command and type the
new one. To delete a setting, delete the dot command line.

Each type of margin is described in more detail below.

PAGE OFFSET

The page offset is the amount of space between the left edge of the paper and
column 1 of the text. The default page offset is .8 inch. If you want to print
closer to the left edge of the paper, you can make the page offset smaller.

For some documents, you may want to set different page offsets for odd and even
pages. For example, if you plan to put the pages in a binder, you can use a bigger
page offset on odd pages to leave room for the binder holes. For example, you
could set the odd page offset to 1 inch and the even page offset to .5 inch.

rl——T small page offset r—lj_ large page offset

( ™~
—_ {"‘\o —
s

T s =
N _

even page odd page
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The page offset and left margin settings together determine the distance
between the edge of the page and the text. In other words, if the page offset is
.8 inch, and you set the left margin to .2 inch, the text is printed 1 inch from the
edge of the page.

ToP AND BOTTOM MARGINS

The top and bottom margins define the space between the text and the top
and bottom of the paper. On an 8.5 x 11-inch page, if the top margin is

.33 inches and the bottom margin is 1.33 inches, the space left for text is 9.33
inches.

Headers and footers are printed above and below the top and bottom margins,
so you need to leave enough room for them in the margins. See “Header and
Footer Margins” below.

To work correctly, the top and bottom margin commands must be placed at the
top of the page, before any blank lines or text.

HEADER AND FOOTER MARGINS

The header margin is the space between the last header line and the first line of
text. The header and the header margin must fit into the top margin. If they are
larger, the text may not be printed correctly.

The footer margin is the space between the last line of text (on a full page) and
the first footer line. The footer plus the footer margin must fit in the bottom
margin so that the text is printed correctly.

See also “Headers/Footers” in this chapter.

ORIENTATION

On printers that have this capability, you can choose portrait (the default) or
landscape orientation. In landscape orientation, text is printed lengthwise on
the page, as shown in the following illustration.
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portrait landscape

When you use landscape text, be sure to change the right margin (in the Ruler
Line dialog box, or the .rm dot command) and page length (in this dialog box,
or the .pl dot command) accordingly. For 8.5 x 11-inch paper, set the right mar-
gin to 9.6 inches and the page length to 8.5 inches. Remember to return to the
original settings when you return to portrait mode.

If you specify centered page numbers in landscape text and they are not printed
correctly, be sure the dot command .pc 0 is at the beginning of the document.

When you change the orientation, WordStar inserts the dot command .pr or=I
for landscape or .pr or=p for portrait. You can get the same result by typing the

dot command, exactly as shown here.

You can’t combine landscape and portrait modes on the same page.

PAGE LENGTH

11-12

Page length is the total length of the paper. WordStar is set up for 8.5 x 11-inch
paper. If you use paper of a different size, change the page length setting. For
example, type 14 to set the page length to 14 inches for legal-size paper. You
can set the page length to .01 inch accuracy. You can specify a unit of mea-
surement other than inches by typing the symbol after the number: r for ruler
units (lines), p or pt for points (1/72 inch), or ¢ or cm for centimeters.

If you change this setting, when you close the Page Layout dialog box,
WordStar inserts the .pl dot command in your text, followed by the page length
you specified. You can get the same result by typing the dot command in the
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text. When you type the dot command, you can use the same units of measure-
ment you use in the dialog box (you must type i, in, or # if you use inches).

If you change the page length setting, be sure to do so at the top of the page,
before any blank lines or text.

PAPER BIN

If the sheet feeder for your printer has more than one paper bin, you can choose
this option to specify the bin to use. For example, if you keep letterhead paper
in bin 1 and plain paper in bin 2, you can choose bin 1 at the top of page 1 and
bin 2 at the top of page 2. You must change this setting at the top of the page,
before any blank lines or text. Select Paper Bin and select the bin from the list.

When you change the bin, WordStar inserts the .bn dot command followed by
the number of the bin. You can get the same result by typing the dot command.

Note: Be sure you installed your sheet feeder when you installed your printer.
If your sheet feeder isn’t on the menu, use PDFEDIT to enter the sheet feeder
codes into your PDF (see “Using PDFEDIT” in the Installing and Customizing
booklet).

SUPPRESS BLANK LINES AT TOP OF PAGE

When blank lines fall at the top of the page, they can create uneven top mar-
gins throughout the printed document. Select this check box to suppress blank
lines when they fall at the top of a page. For all subsequent text, blank lines
that fall on the top of a page are shown above the page break, and are sup-
pressed when the document is printed. If you have Command Tags display set
to display soft spaces, the suppressed line is displayed as a line full of soft
spaces. To stop suppressing blank lines, clear this option.

When you select or clear this option, the dot command .sb on or .sb off is
inserted in the text. You can get the same result by typing the dot command.

WordStar always suppresses soft blank lines at the top of a page when they are
created by a line spacing greater than one (for example, double spacing).

The default for suppressing blank lines is off. You can change it to on using
WSCHANGE (DAAK).
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H EADERS/FOOTERS Pull-down: ALT + L, H

Inserts a header or footer into the document.

When you choose Headers/Footers, the following menu appears.

HEADER
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Footer... .fo

Pull-down: ALT + L, H, H
Classic: HE

Inserts a header into the document.

A header is text that is printed at the top of every page. You can use it to print
information such as document title, author, date, and page numbers. Follow
these steps to insert a header:

1

Put the cursor at the top of the first page you want the header printed on
(before any blank lines or text).

Choose Layout=>Headers/Footers=>Header.

In the Header dialog box, select the number of lines you want in the header.
A header can have from one to five lines.

Select whether you want this header for all pages, odd pages only, or even
pages only. (To insert different headers for odd and even pages, use Header
twice, once for each.)

Press F10 or choose OK. WordStar inserts one or more header dot
commands into the file.

Type the text you want after the dot command for each line of the header.
For guidelines on entering the text, see “Entering Header and Footer Text”
below.

The header dot commands are .h1 (or .he) for the first line, and .h2, .h3, .h4,
and .h5 for the other lines. If you specify odd or even pages, the letter o or e
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follows the number in the dot command, without any spaces. You can get the
same result by typing the dot command in the text.

For example, with the following header dot commands, “Chapter 1” will be
printed at the top of every odd page and “The Gray Cat” will be printed at the
top of every even page, as shown in the illustration. Note that the odd header
is right-aligned on the page; for information on right-aligning a header, see
“Entering Header and Footer Text” below.

.hlo Chapter 1
.hle The Gray Cat

f A
The Gray Cat Chapter 1
— T Ny —/————
eT e
T D
2 3
\ J

To delete a header, delete the header dot command line or lines. To stop using
a header for subsequent pages, insert the same dot command that began it,
without any text.

For information on the header margin, which affects the placement of a header
on the page, see “Margins” in “Page Layout” in this chapter.

ENTERING HEADER AND FOOTER TEXT

Follow these guidelines when typing text for a header or footer:

= Be sure to leave a space between the dot command and the text. If you

leave more than one space, the header or footer will be indented by that
number of spaces.

= To include the page number in a header or footer, use the # character. For

example, .f1 Page # is printed as Page 1 on the first page. To print the #
character itself rather than the page number, precede it with a backslash.
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For example, .h1 Draft \#2 is printed as Draft #2. To include a backslash,
use two backslashes.

You can use print styles such as bold and underlining in headers and footers.
The marked text is not highlighted on the screen, but it is printed correctly.
Styles in headers or footers do not affect text in the rest of the document, nor
do styles in the rest of the document affect headers or footers.

Each header or footer is printed in the default font unless you specify a
different font in the dot command line.

To right align a header or footer, you can either use a paragraph style or use
this method: Start on a new line (if you inserted the dot command from the
Header or Footer dialog box, make a note of the dot command, and delete
the dot command line). Choose Layout=>Right Align Line, or press ~Q].
Type the text of the header or footer and press Enter. Then move the cursor
up to the line that contains the text and type the appropriate dot command,
for example, .h10 (don’t press Enter).

To have some text in one header or footer line flush left and some flush right,
type the text you want flush left after the dot command and press Enter. Then
choose Layout=>Right Align Line, or press A0}, and type the text you want
flush right. The flush right text is now a line below the dot command line.
Move the cursor to the beginning of the current line (press AQS or use the
cursor movement keys), and press Backspace to remove the hard return.
Now all the text is on the same line as the dot command and aligned at the
margins.

To put a blank line between two header or footer lines, specify a header or
footer for that line and put two blank spaces (press the Spacebar twice) after
the dot command.

To align proportional text in inches in a header or footer, start on a new line.
(If you inserted the dot command from the Header or Footer dialog box,
delete the dot command line, but remember the dot command.) Type the
text so that you can line it up correctly. Then type the dot command at the
beginning of the line.

The number of lines in a header plus the header margin (set in Layout=>Page
or using the ;hm dot command) must be less than or equal to the top margin
(set in Layout=>Page or using the .mt dot command) for the page to be
printed correctly.
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® You can use View=>Preview or the AOP classic command to see how
headers and footers will look when printed.

= |f your headers and footers aren’t printed correctly and displayed correctly in
Preview, you may need to increase the size of the header/footer buffer in
WSCHANGE (CC2C). Try doubling the default size. Proportional fonts,
extended characters, or a lot of text in headers or footers, may cause you to
run out of buffer space.

FooTER Pull-down: ALT + L, H, F
Classic: JF 0

Inserts a footer into the document.

A footer is text that is printed at the bottom of every page. You can use it to
print information such as document title, author, date, and page numbers.

As a default footer, WordStar prints the page number, centered. Follow these
steps to insert a footer:

1 Put the cursor anywhere on the first page where you want the footer printed.
2 Choose Layout=>Headers/Footers=>Footer.

3 In the Footer dialog box, select the number of lines you want in the footer.
A footer can have from one to five lines.

4 Select whether you want this footer for all pages, odd pages only, or even
pages only. (To insert different footers for odd and even pages, use Footer
twice, once for each.)

5 Press F10 or choose OK. WordStar inserts one or more footer dot
commands into the file.

6 Type the text you want after the dot command for each line of the footer.
For guidelines on entering the text, see “Entering Header and Footer Text” in
“Header” above.

The footer dot commands are .f1 (or .fo) for the first line, and .2, .f3, .f4, and
{5 for the other lines. If you specify odd or even pages, the letter o or e follows
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the number in the dot command, without any spaces, for example, .foe text.
You can get the same result by typing the dot command in the text.

To delete a footer, delete the footer dot command line or lines. To turn off a
footer for subsequent pages, insert the same dot command that began it,

without any text.

For information on the footer margin, which affects the placement of a footer on
the page, see “Margins” in “Page Layout” in this chapter.

See also “Page Numbering” in this chapter.

PAGE NUMBERING Pull-down: ALT + L, N
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Sets whether page numbers are printed at the bottom of the page, their
position on the line, and the number used.

As a default WordStar prints the page number, centered, on the bottom of each
page unless you insert a different footer. Follow these steps to change page
numbering:

1 Putthe cursor at the top of the first page where you want the page number
printed (before any blank lines or text).

2 Choose Layout=>Page Numbering.

3 In the Page Numbering dialog box, change any options you want. The

options are described below.

Page Numbering

[X1 Print Page Numbers

Set Page Number:

Position on Line: ¢ Centered

o [ Fron Left Margin
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Print Page Numbers Clear this option if you don’t want page numbers to
be printed. Select it if you want to resume printing page numbers.

Set Page Number This option sets the number that is printed on the current
page. WordStar restarts consecutive numbering at the specified number. If
you previously suppressed printing of page numbers, specifying a number
turns it back on. This option is useful, for example, if a document is
contained in several files and you want page numbers to continue
consecutively from one file to the next, or if you want to restart page
numbers at 1 after a table of contents.

Position on Line Select Centered (the default) or type the position in inches
for the page number. For example, type 1.5 to print page numbers at 1.5"
from the left margin. You can specify a unit of measurement other than
inches by typing the symbol after the number: r for ruler units (columns),

c or cm for centimeters, or p or pt for points (1/72 inch).

4 Press F10 or choose OK.

When you close the Page Numbering dialog box, WordStar inserts a dot com-
mand in your text for each setting you’ve changed. The command for Set Page
Number is .pn, followed by the page number. The command for Position on
Line is .pc, followed by the corresponding setting (in inches unless you specify
otherwise, or O for centered). Print Page Numbers inserts .op to omit page num-
bers or .pg to resume printing page numbers. You can get the same result by
typing the dot commands in the text. When you type the .pc dot command,
you must type i, in, or “ if your setting is in inches.

To change a setting, just delete the old setting in the dot command and type the
new one. To delete a setting, delete the dot command line.

Note: Page numbers are printed in the default font. To use another font, insert
a footer. See “Headers/Footers” in this chapter.

11-19



EDITING SCREEN LAYOUT MENU

LINE NUMBERING
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Pull-down: ALT + L, L
Classic: .L#

Starts line numbering and sets line numbering options.

You can print line numbers in the left margin of your document, as on legal
pleading paper. Line numbers do not appear onscreen; they appear only on the
printed page and when you use View=>Preview (or AOP). With line numbers,
vertical lines are printed at the left and right of the text.

Follow these steps to start line numbering:

1

Put the cursor at the top of the first page where you want the line numbering
(before any blank lines or text).

2 Choose Layout=>Line Numbering.

3

In the Line Numbering dialog box, change any options you want. The
options are described below.

Line Numbering

[ 1 Use Line Numbering Spacing:
¢ Single
o Double . Cancel

Numbering Style:
¢ Numbers Restart on Each Page
o Continuous Numbering Throughout Document

Print Line Numbers [J}/18" to the Left of the Left Margin

Use Line Numbering Select this box to turn on line numbering, or clear it
to turn it off.

Spacing You can select single spacing (the default) or double spacing.

Numbering Style You can either have numbers restart at 1 on each page
(the default), or have continuous numbering throughout the document.

Print Line Numbers As a default, line numbers are printed 3 columns to
the left of the vertical line at the left of the text. You can type a different
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4 Press F10 or choose OK.

When you close the Line Numbering dialog box, WordStar inserts the .1# dot
command in your text, followed by your settings in the format .l# style spacing
distance. The style is p for restart on each page or d for continuous numbering,
and there is no space between the p or d and the spacing number. For
example, I# d2 4 turns on line numbers that print continuously throughout the
document, double-spaced, four columns to the left of column 1. You can get
the same result by typing the dot command in your text. When you type the
distance, type it in columns.

TIP Turning on line numbering may change the line height. You may need
to specify the line height in the document using the Alignment and Spacing
command or the .Ih dot command. See “Alignment and Spacing” in this
chapter.

If the vertical lines are not printed correctly, or if you want to change the char-
acters used to print them, you can change the characters in WSCHANGE (DB)).
You can also change several other line numbering settings using WSCHANGE
(DBJ), including the default distance between the numbers and the text and the
line numbering font.

With page printers, you may need to increase the page offset or print the line
numbers closer to the text because of the “dead space” at the margins of the
paper where the printer doesn’t print.

To print a document with both line numbers and footnotes or endnotes, you
must use the same line height for the document and the notes.

ALIGNMENT AND SPACING Pull-down: ALT + L, A
Classic: "OS

Sets alignment, kerning, word wrap, hyphenation, line spacing, and line height.
Follow these steps to change alignment and spacing settings:

1 Choose Layout=>Alignment and Spacing, or use the 2OS classic command.
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2 In the Alignment and Spacing dialog box, change any of the options you
want. The options are described below these steps.

Alignment and Spacing

AlignMent:
¢ Flush Left [X] Kerning
o Centered [X] Word Wrap i Cancel
o Flush Right [X] Hyphenation

o Justified
Line Spacing: Leading: CLine Height)

3 Press F10 or choose OK.

You can change several defaults for alignment and spacing using WSCHANGE
(DBC).

ALIGNMENT

Flush left text (the default) is lined up at the left margin, with a ragged right
margin. In centered text, each line is centered within the margins. (To center
single lines, you can use Center Line. See “Center Line” in this chapter.) Flush
right text is aligned at the right margin, with a ragged left margin. Justified text
is aligned at both the left and right margins; WordStar adds spaces as needed so
that all the lines extend to the right margin.

When you change the alignment setting, WordStar inserts a dot command in
your file. The commands are .0j off for flush left text, .ojr for flush right text,
.0j on for justified text, and .ojc for centered. You can get the same result by
typing the dot command.

You can also change the alignment by clicking the appropriate button on the

Style bar: L, C, R, or ) for Flush Left, Centered, Flush Right, or Justified. The but-
ton for the alignment setting that is in effect is highlighted.

LINE spPAcING

You can print your text single-spaced (the default), double-spaced, triple-
spaced, and so on. Type 1 for single spacing (no blank lines between lines of
text), 2 for double spacing (one blank line between lines of text), and so on.
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When you change the line spacing setting, WordStar inserts the .Is dot com-
mand, followed by the spacing number, into the text. For example, the .Is 2
command starts double spacing. You can get the same result by typing the dot
command.

If you change the line spacing for existing text, use Utilities=>Reformat or AB or
AQU to reformat the text to reflect the new spacing.

Changing the line height (leading) can give the same effect as changing the line
spacing, and is often preferable. For example, both .Ih 16 (line height 16/48 inch)
and .Is 2 (double spacing, using the default line height of 1/6, or 8/48, inch) give
you a double-spaced printout. But with the line height command, you don't see
the extra blank lines on the page, so you can see more of the text while you edit.
Also, when you use line spacing, the blank lines become part of the file, so the file
takes up more disk space. With either method, WordStar adjusts the page breaks
accordingly and shows the correct page breaks onscreen.

If you change both line height and line spacing, the blank lines added for line
spacing are at the specified line height; for example, if you enter both .Is 2 and
.Ih 16, the text is quadruple-spaced (but appears double-spaced on the screen).

For more information, see “Leading” below.

KERNING

When kerning is selected (the default), WordStar adjusts the space between cer-
tain pairs of printed characters. (You can add or edit kerning information using
PDFEDIT.) The example below shows how kerning eliminates gaps and gives
an even look to pairs of letters.

KerningOn: TATaTc Td Te To T, LT LV LW LY Ly WA Wa W.
Kerning Off: TATaTc Td Te To T, LT LV LW LY Ly WA Wa W.

When you change the kerning setting, WordStar inserts the .kr on or .kr off dot
command into the text. You can get the same result by typing the dot command.

Note: Kerning is available only for certain laser printers with scalable fonts.
Kerning is not supported for some extended characters, including some letters
with accent marks or umlauts. Kerning works only with characters that are not
remapped in the Composed Characters Table or the Character Translation Table
in PDFEDIT.
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WORD WRAP

When word wrap is on (the default), WordStar automatically moves the cursor
to a new line when you type past the right margin. You press Enter only to
mark the end of a paragraph. Use this option to turn off word wrap perma-
nently for a section of a file. It also disables justification and automatic
reformatting of the text. You might, for example, turn word wrap off at the
beginning of a columnar table to be sure it isn’t reformatted in later editing ses-
sions, and turn it back on at the end of the table. You can also turn word wrap
off and on temporarily while editing. See “Editing Settings” in “Editing Screen
Edit Menu.”

When you change the word wrap setting, WordStar inserts the .aw on or
.aw off dot command into the text. You can get the same result by typing the
dot command.

HYPHENATION
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When hyphenation is on (the default), WordStar hyphenates words at the ends
of lines when aligning and reformatting text. These hyphens are called soft
hyphens because they’re printed only when a word breaks at the end of a line.
Soft hyphens that are not at the end of a line disappear when Command Tags
display is off. If hyphenation is turned off, and subsequent alignment moves a
soft hyphen away from the end of the line, it’s displayed as an equal sign (=) but
not printed.

When you change the hyphenation setting, WordStar inserts the .hy on or
-hy off dot command into the text. You can get the same result by typing the
dot command.

If you turn hyphenation off for text that already includes hyphenated words,
those words are still hyphenated. If you don’t want them hyphenated, delete
the hyphens.

You can change the way WordStar hyphenates words and the default setting for
hyphenation using WSCHANGE (DBCD and DBCC).

Note: Hyphens you type into the text are hard hyphens, because they are always
printed as you typed them. You can enter a soft hyphen to hyphenate a word only
if it falls at the end of a line using Layout=>Special Effects=>Optional Hyphen,
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or the AOE classic command. For more information on soft hyphens, see
“Optional Hyphen” in “Special Effects” in this chapter.

LEaDING (LINE HEIGHT)

The leading, or line height, is the distance between lines of print. It is measured
from the bottom of one line of text to the bottom of the following line.

WordStar has both absolute leading and automatic leading. With absolute lead-
ing, you set a specific line height value, and lines are equally spaced at that
height until you change the setting. With automatic leading, WordStar chooses
the line height for your font, and changes the line height automatically when-
ever you change fonts or font size. Both types of leading are discussed below.

To change the line height, type the height you want. Type a or auto for auto-
matic line height, or the absolute value you want. You can type the value in
inches; for example, type 1/6 for 1/6 inch, for the 6 lines per inch standard line
height (the default). You can specify another unit of measurement by typing the
symbol after the number: p or pt for points (1/72 inch) or ¢ or cm for cen-
timeters. For example, you can set the line height to 12 points by typing 12p.

When you change the line height setting, WordStar inserts the .lh dot com-
mand, followed by the value in inches, into the text. For example, .lh 13p sets
the line height to 13 points, and .lh a sets it to automatic. You can get the same
result by typing the dot command. When you type the dot command, you can
use the same units of measurement you use in the dialog box (you must type i,
in, or " if you use inches). You can also type the dot command in 48ths of an
inch. For example, .lh 8 is 8/48 inch, or the standard 6 lines per inch, and .lh
16 is 16/48 inch, or 3 lines per inch (double-spaced).

With automatic leading, WordStar determines the line height by the built-in lead-
ing for each font. If the font size varies on a single line of text, WordStar bases the
line height on the largest font in the line. If you use large fonts, you can change to
a smaller font just before blank lines to prevent spaces between paragraphs from
being too large. With printers other than page printers, all single-high fonts are set
to 12 points (6 lines per inch), double-high fonts are set to 24 points (3 lines per
inch), and triple-high fonts are set to 36 points (2 lines per inch).

If a printer can’t move in the specified increments, WordStar uses the closest
line height available on the printer.
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Changing the line height affects the number of lines that can be printed on a
page. The display changes to show where the new page breaks fall, but the line
height on the screen does not change. To see how the line height will look
when printed, use View=>Preview, or ~OP.

You can also set the line height using paragraph styles, and you can change the
default line height by changing the line height in the Body Text paragraph style.
For more information, see “Define Paragraph Style” in this chapter.

For more information, see “Line Spacing” above.

S PECIAL EFFECTS Pull-down: ALT + L, E

Overprints lines or characters, inserts an optional hyphen, centers text ver-
tically on the page, and keeps text together on lines or pages or in columns.

When you choose Special Effects, the following menu appears.

Overprint Character “PH
Ouerprint Line P

Optional Hyphen “OE
UVertically Center Text on Page "0U
Keep Words Together on Line “PO
Keep Lines Together on Page... .cp
Keep Lines Together in Column... .cc

OVERPRINT CHARACTER Pull-down: ALT + L, E, C
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Classic: "PH
Prints a character over the previous one.

This command allows you to create special characters by printing two charac-
ters in the same space. Use these steps:

1 Place the cursor in the space after the character to be printed over.

2 Choose Layout=Special Effects=>Overprint Character, or use the APH
classic command. The AH tag appears in the text.
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3 Type the character to be printed over the previous one. You can then
continue typing.

To overprint more than two characters, use this command again before each
additional character.

TIP If you frequently overprint with the same characters, you can use
WSCHANGE (DBBF) to have WordStar automatically overprint the second

character on the previous character whenever you type it. This can be useful,
for example, with an accent mark.

OVERPRINT LINE Pull-down: ALT + L, E, L
Classic: P

Prints a line of text over the previous one.

When you use this command, two complete lines of text are printed on top of
each other. Follow these steps:

1 Type the first line of text. Don't let the line wrap to the line below, and
don’t press Enter.

2 Choose Layout=>Special Effects=>Overprint Line, or use the AP classic
command. A hyphen appears in the flag column.

3 Type the second line, and end it by pressing Enter.

To overprint more than two lines, use this command again before each addi-

tional line.
OPTIONAL HYPHEN Pull-down: ALT + L, E, H
Classic: "OE
Inserts a soft hyphen.

Use this command to hyphenate a word when automatic hyphenation is off or
to change the location of a hyphen. If the word extends past the right margin,
WordStar hyphenates it at the location you specified. (If hyphenation inserted a
soft hyphen elsewhere in the word, delete it.)
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The hyphens inserted with this command are called soft hyphens because
they’re printed only when a word breaks at the end of a line. Soft hyphens that
are not at the end of a line disappear when Command Tags display is off. If
hyphenation is turned off, and subsequent alignment moves a soft hyphen away
from the end of the line, it’s displayed as an equal sign (=) but not printed.

When you use this command in the middle of a word, a soft hyphen is also
inserted at the beginning of the word. If you want to prevent a word from being
hyphenated, just use this command at the beginning of the word. If the word
contains any other soft hyphens, delete them.

You can turn automatic hyphenation on and off using the Hyphenation option
in the Alignment and Spacing dialog box, or the .hy on/off dot command. See
“Alignment and Spacing” in this chapter.

VERTICALLY CENTER TEXT ON PAGE Pull-down: ALT + L, E, V

Classic: "OV
Centers text vertically on the page.

When you use this command, the text from the cursor to the next page break

is centered vertically in the remaining space on the page. Any blank lines
following the text are ignored. Carriage returns are added above the text to cen-
ter it. A page break is inserted at the end of the text, if one isn’t already there.

When you center a page that is not the only page of a document, be sure to
insert a page break before the page you are centering (if another page is before
it) and after the page (if another page is after it).

KEEP WORDS TOGETHER ON LINE Pull-down: ALT + L, E, K
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Classic: "PO

Keeps two words together on the same line.

To keep two words together on the same line, use this command instead of
pressing the Spacebar between the words. This command inserts a binding
space, which is shown on the screen as m when Command Tags display is on.
A phrase that uses binding spaces instead of regular spaces is treated as one
word when WordStar aligns and reformats text.
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KEEP LINES TOGETHER ON PAGE Pull-down: ALT + L, E, P
Classic: CP

Keeps a certain number of lines from being split by a page break.
Follow these steps to keep lines together on the same page:

7 Place the cursor on the first line you want to keep together.

2 Choose Layout=>Special Effects=>Keep Lines Together on Page.

3 In the Keep Lines Together on Page dialog box, type the number of lines you
want to keep together.

4 Press Enter or F10 or choose OK.

WordStar inserts the .cp dot command in your file, followed by the number of
lines to keep together. You can get the same result by typing the dot command.

For example, the .cp 5 command keeps the subsequent 5 lines together. If
there isn’t enough room for all five lines to be printed on the page, all five lines

move to the next page.

You must insert this command at the beginning of a paragraph, because the dot
command must come after a hard carriage return.

Don't change the line height between a .cp command and the end of the text
you want to keep together.

I(EEP LINES TOGETHER IN COLUMN Pull-down: ALT + L, E, O
Classic: .CC

Keeps a certain number of lines from being split by a column break.
Follow these steps to keep lines together in the same column.
1 Place the cursor on the first line you want to keep together.

2 Choose Layout=>Special Effects=>Keep Lines Together in Column.

11-29



EDITING SCREEN LAYOUT MENU

3 In the Keep Lines Together in Column dialog box, type the number of lines
you want to keep together.

4 Press Enter or F10 or choose OK.

WordStar inserts the .cc dot command in your file, followed by the number of
lines to keep together. You can get the same result by typing the dot command.
For example, the .cc 5 command keeps the subsequent 5 lines together. If there
isn’t enough room for all five lines to be printed in the column, all five lines
move to the next column.

You must insert this command at the beginning of a paragraph, because the dot
command must come after a hard carriage return.

Don’t change the line height between a .cc command and the end of the text to
keep together.
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CHAPTER 12

EDITING SCREEN
UTILITIES MENU

The Utilities menu includes commands for checking spelling, using the
Thesaurus, starting the Inset graphics program, using the WordStar math func-
tions, sorting blocks, counting characters, reformatting text, and repeating a
command. It also includes the WordStar macro system and merge printing
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commands.
Utilities
Spelling Check Global “QR"QL I
Spelling Check Other >
Thesaurus. . . ~QJ
Language Change. .. .1a
Inset “P&
Calculator ~QM
Block Math “KM
Sort Block >
Word Count “K?
Macros >
Merge Print Commands >
Reformat >
Repeat Next Keystroke ~QQ

12-1




EDITING SCREEN UTILITIES MENU

SPELLING CHECK GLOBAL Pull-down: ALT + U, S
Classic: “"QR"QL

Checks the spelling of all the words in the document.

You can use Spelling Check Global to check the spelling in your documents
and to check for double words, such as the the. Words in notes and dot com-
mands aren’t checked. Follow these steps:

7 Choose Utilities=>Spelling Check Global.

WordStar goes to the beginning of the document and then checks each
word against its dictionary. If the word is not in the main dictionary,
WordStar checks the personal dictionary. (For more information, see “The
Spelling Dictionaries” in this chapter.)

If WordStar finds a word that is not in the dictionaries, or a double word, it
displays the word and suggestions for how to correct it in the Spelling Check
dialog box.
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Spelling Check

Word: boock

Suggestions: 1 book 2 box 3 block 4 back 5 bake & beak 7 beck

Global Replacement is off Display More Suggestions
Ignore/Check Next Word Enter Correction
Add to Personal Dictionary Bypass This Time Only

Esc Cancel

Suggestions come from the main dictionary and your personal dictionary.
The suggestions match the original word as closely as possible. For
example, if the original word is capitalized and plural, the suggestions are
capitalized and plural.

If there are more suggestions than fit on the screen, the Display More
Suggestions option appears. Choose it to see the additional suggestions.
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If you want to use one of the suggestions, press the number of that
suggestion. The corrected word replaces the misspelled word in your file,
and the text around it is reformatted if necessary.

The Global Replacement option turns global replacement on and off. The
default is off. Turn it on if you want to use the correction (which you either
choose from the list or type using Enter Correction) throughout the file.

If you don’t want to use any of the suggestions, choose one of the options.
The options are described below.

Ignore/Check Next Word Ignores the word and goes to the next word.
The word is ignored throughout the file.

Add to Personal Dictionary Adds the word to your personal dictionary.
Once you add the word to the personal dictionary, WordStar doesn’t stop at
it again.

Enter Correction Lets you type a replacement word. Type the word in the
Spelling Correction dialog box, and press F10 or choose OK. WordStar
enters the word you typed in the text, and checks its spelling.

Bypass This Time Only Bypasses this occurrence of the word but stops at
subsequent occurrences.

Esc Cancel Stops the spelling check before the end of the document.

After you choose one of the options, WordStar checks for the next word that
is not in its dictionaries. Continue entering an option for each word that
WordStar displays. When you are finished, WordStar shows the number of
words checked. Press F10 or choose Continue to return to editing.

If you run a spelling check, and then open a second window, use Preview, or
run a DOS command, WordStar forgets any words to be ignored or corrected
throughout the document. You need to instruct WordStar again to ignore or
correct those words.
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SPELLING CHECK OTHER Pull-down: ALT + U, O

Checks the spelling of your text.

You can use Spelling Check Other to check the spelling in your documents and
to check for double words, such as the the.

Rest of Document “QL

Word “QN
Type Word... “Qo
Rest of Notes “ONL

REST OF DOCUMENT Pull-down: ALT + U, O, R
Classic: AQL

Checks spelling of all the words in the rest of the document.

When you choose Rest of Document, the spelling check begins at the current
cursor position and goes to the end of the file. To check the whole document,
move the cursor to the beginning of the document before starting the spelling
check. Words in notes and dot commands aren’t checked. Follow these steps:

7 Choose Utilities=>Spelling Check Other=>Rest of Document, or use the
AQL classic command.

WordStar checks each word against its dictionary. If the word is not in the
main dictionary, WordStar checks the personal dictionary. (For more
information, see “The Spelling Dictionaries” in this section.)

If WordStar finds a word that is not in the dictionaries, or a double word, it
displays the word and suggestions for how to correct it in the Spelling Check
dialog box.

Spelling Check
Word: boock

Suggestions: 1 book 2 box 3 block 4 back 5 bake 6 beak 7 beck

Global Replacement is off Display More Suggestions
Ignore/Check Next Uord Enter Correction
Add to Personal Dictionary Bypass This Time Only

Esc Cancel

1 ST U o e A i e S N |
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Suggestions come from the main dictionary and your personal dictionary.
The suggestions match the original word as closely as possible. For
example, if the original word is capitalized and plural, the suggestions are
capitalized and plural.

If there are more suggestions than fit on the screen, the Display More
Suggestions option appears. Choose it to see the additional suggestions.

If you want to use one of the suggestions, press the number of that
suggestion. The corrected word replaces the misspelled word in your file,
and the text around it is reformatted if necessary.

The Global Replacement option turns global replacement on and off. The
default is off. Turn it on if you want to use the correction (which you either
choose from the list or type using Enter Correction) throughout the file.

If you don’t want to use any of the suggestions, choose one of the options.
The options are described below.

Ignore/Check Next Word Ignores the word and goes to the next word.
The word is ignored throughout the file.

Add to Personal Dictionary Adds the word to your personal dictionary.
Once you add the word to the personal dictionary, WordStar doesn’t stop at
it again.

Enter Correction Lets you type a replacement word. Type the word in the
Spelling Correction dialog box, and press F10 or choose OK. WordStar
enters the word you typed in the text, and checks its spelling.

Bypass This Time Only Bypasses this occurrence of the word but stops at
subsequent occurrences.

Esc Cancel Stops the spelling check before the end of the document.

After you choose one of the options, WordStar checks for the next word that
is not in its dictionaries. Continue entering an option for each word that
WordStar displays. When you are finished, WordStar shows the number of
words checked. Press F10 or choose Continue to return to editing.
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If you run a spelling check, and then open a second window, use Preview, or
run a DOS command, WordStar forgets any words to be ignored or corrected
throughout the document. You need to instruct WordStar again to ignore or
correct those words.

Pull-down: ALT + U, o, W
Classic: AQN

Checks spelling of the word at the cursor.

You can use this command to check a single word or a short series of words,
or to add words to your exceptions dictionary (described in “The Spelling
Dictionaries” in this section).

1  Place the cursor on the word to check.

2 Choose Utilities=>Spelling Check Other=>Word, or use the AQN classic
command.

WordStar checks the word against its dictionary. If the word is not in the
main dictionary, WordStar checks the personal dictionary. (For more
information, see “The Spelling Dictionaries” in this section.)

If the word is not in the dictionaries, it displays the word and suggestions for
how to correct it in the Spelling Check dialog box.

Spelling Check

Hord: picture is spelled correctly

Suggestions: 1 pictures 2 pictured 3 picture

Ignore/Check Next Word Enter Correction
Add to Personal Dictionary Bypass This Time Only
Add to Exceptions Dictionary Esc Cancel

Suggestions come from the main dictionary and your personal dictionary.
The suggestions match the original word as closely as possible. For
example, if the original word is capitalized and plural, the suggestions are
capitalized and plural.
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If there are more suggestions than fit on the screen, the Display More
Suggestions option appears. Choose it to see the additional suggestions.

3 If you want to use one of the suggestions, press the number of that
suggestion. The corrected word replaces the misspelled word in your file,
and the text around it is reformatted if necessary.

If you don’t want to use any of the suggestions, choose one of the options.
The options are described below.

Ignore/Check Next Word Ignores the word and goes to the next word.
The word is ignored in any subsequent spelling checks in this editing
session.

Add to Personal Dictionary Adds the word to your personal dictionary.
Once you add the word to the personal dictionary, WordStar doesn't flag it
as misspelled again.

Add to Exceptions Dictionary Adds the word to the exceptions dictionary,
so that it will be flagged during spelling checks even though it is a valid
word. This option appears only for correctly spelled words. The exceptions
dictionary is described in “The Spelling Dictionaries” in this section.

Enter Correction Lets you type a replacement word. Type the word in the
Spelling Correction dialog box, and press F10 or choose OK. WordStar
enters the word you typed in the text.

Bypass This Time Only Bypasses this occurrence of the word but stops at
occurrences in subsequent spelling checks in this editing session. WordStar
moves to the next word in the text and checks it.

Esc Cancel Stops the spelling check.

WordStar can also show you the definitions of correctly spelled words. Defini-
tions are not shown as a default, because they use up memory, which makes
the spell checker slower. You can turn definitions on in WSCHANGE (CCC).
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TyPE WORD Pull-down: ALT + U, O, T

12-8

Classic: “QO
Checks spelling of any word you type.
You can use this command to check the spelling of a word that is not in your
document, or to add words to your exceptions dictionary (described in “The

Spelling Dictionaries” in this section).

1 Choose Utilities=>Spelling Check Other=>Type Word, or use the AQO
classic command.

2 In the dialog box, type the word to check.

WordStar checks the word against its dictionary. If the word is not in the
main dictionary, WordStar checks the personal dictionary. (For more
information, see “The Spelling Dictionaries” in this section.)

If the word is not in the dictionaries, WordStar displays suggestions for how
to correct it in the Spelling Check dialog box.

Word: picture is spelled correctly

Suggestions: 1 pictures 2 pictured 3 picture

Ignore/Check Next UWord Enter Word into Text
Add to Personal Dictionary Bypass This Time Only
Add to Exceptions Dictionary Esc Cancel

Suggestions come from the main dictionary and your personal dictionary.
The suggestions match the original word as closely as possible. For
example, if the original word is capitalized and plural, the suggestions are
capitalized and plural.

If there are more suggestions than fit on the screen, the Display More
Suggestions option appears. Choose it to see the additional suggestions.

3 If you want to insert one of the suggestions in your text, press the number of

that suggestion. The word is inserted in your file, and the text around it is
reformatted if necessary. If you don’t want to use any of the suggestions,
choose one of the options. The options are described below.
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Ignore/Check New Word Ignores the word and lets you type another word
to check. The word is ignored in any subsequent spelling checks in this
editing session.

Add to Personal Dictionary Adds the word to your personal dictionary.
Once you add the word to the personal dictionary, WordStar doesn’t stop at
it again.

Add to Exceptions Dictionary Adds the word to the exceptions dictionary,
so that it will be flagged during spelling checks even though it is a valid
word. This option appears only for correctly spelled words. The exceptions
dictionary is described in “The Spelling Dictionaries” in this section.

Enter Word into Text Inserts the word in your text at the current cursor
location.

Esc Cancel Stops the spelling check.
WordStar can also show you the definitions of correctly spelled words. Defini-

tions are not shown as a default, because they use up memory, which makes
the spell checker slower. You can turn definitions on in WSCHANGE (CCC).

REST OF NOTES Pull-down: ALT + U, O, N
Classic: "ONL

Checks spelling in all the notes (footnotes, endnotes, annotations, and
comments) from the cursor position to the end of the document.

Because notes often contain proper names, WordStar ignores them during a
normal spelling check. Use this command to check just the text in notes, start-
ing at the cursor position. If you want to use a special personal dictionary for
the notes, see “The Personal Dictionary” in this section.

1 Choose Utilities=>Spelling Check Other=>Rest of Notes, or use the
AONL classic command.

WordStar checks each word against its dictionary. If the word is not in
the main dictionary, WordStar checks the personal dictionary. (For more
information, see “The Spelling Dictionaries” in this section.)
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If WordStar finds a word that is not in the dictionaries, or a double word, it
displays the word and suggestions for how to correct it in the Spelling Check
dialog box.

Spelling Check

Uord: boock

Suggestions: 1 book 2box 3 block 4 back 5 bake 6 beak 7 beck

Global Replacement is off Display More Suggestions
Ignore/Check Next UWord Enter Correction
Add to Personal Dictionary Bypass This Time Only

Esc Cancel

Suggestions come from the main dictionary and your personal dictionary.
The suggestions match the original word as closely as possible. For
example, if the original word is capitalized and plural, the suggestions are
capitalized and plural.

If there are more suggestions than fit on the screen, the Display More
Suggestions option appears. Choose it to see the additional suggestions.

2 If you want to use one of the suggestions, press the number of that
suggestion. The corrected word replaces the misspelled word in the note,
and the text around it is reformatted if necessary.

The Global Replacement option turns global replacement on and off. The
default is off. Turn it on if you want to use the correction (which you either
choose from the list or type using Enter Correction) throughout the file.

If you don’t want to use any of the suggestions, choose one of the options.
The options are described below.

Ignore/Check Next Word Ignores the word and goes to the next word.
The word is ignored throughout the notes.

Add to Personal Dictionary Adds the word to your personal dictionary.
Once you add the word to the personal dictionary, WordStar doesn’t stop at
it again.

Enter Correction Lets you type a replacement word. Type the word in the
Spelling Correction dialog box, and press F10 or choose OK. WordStar
enters the word you typed in the text.
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Bypass This Time Only Bypasses this occurrence of the word but stops at
subsequent occurrences.

Esc Cancel Stops the spelling check.

3 After you choose one of the options, WordStar checks for the next word that
is not in its dictionaries. Continue entering an option for each word that
WordStar displays. When you are finished, WordStar shows the number of
words checked. Press F10 or choose Continue to return to editing.

If you run a spelling check, and then open a second window, use Preview, or
run a DOS command, WordStar forgets any words to be ignored or corrected
throughout the document. You need to instruct WordStar again to ignore or
correct those words.

THE SPELLING DICTIONARIES

WordStar uses spelling dictionaries to determine which words to flag as
misspelled and to give suggestions for spelling corrections. Besides the main
dictionary, you can also use several special dictionaries, which are described
below.

THE PERSONAL DICTIONARY

The personal dictionary contains words you use that are not in the main
dictionary, for example, proper names and technical terms.

Any time you run a spelling check, you can add a word to the personal diction-
ary by selecting Add to Personal Dictionary. You can also edit the personal
dictionary as a nondocument, and add, change, or delete words, or block insert
words from another file (for example, names from a data file). Make sure each
word is on a separate line. Be sure to save the dictionary file when you finish
editing.

If you want to add many words to the personal dictionary, you may want to
create a number of smaller dictionaries, organized according to the kinds of
documents you work with, rather than one large one. A large personal diction-
ary can slow down the spelling checker.
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If you have more than one personal dictionary, use WSCHANGE (DCAEF) to
tell WordStar to prompt you for the name of the personal dictionary when you
run a spelling check. When you’re prompted for a personal dictionary name,
you can choose an existing personal dictionary or type a new name to create a
new personal dictionary. Any words you add during a spelling check are
added to the personal dictionary you specify.

THE EXCEPTIONS DICTIONARY

The exceptions dictionary contains words that you want flagged, even though
they may be valid words. For example, you may want the word “fro” to be
flagged because you occasionally type “fro” instead of “for.” If you add “fro” to
your exceptions dictionary, WordStar always flags that word so you can deter-
mine if it is correct.

You can add a word to the exceptions dictionary when you use Word (*QN) or
Type Word (*QO). Select Add to Exceptions Dictionary (which appears only if
the word is spelled correctly).

You can add, change, or delete words from your exceptions dictionary by using
WordStar to edit the dictionary as a nondocument file. Make sure each word is
on a separate line. Be sure to save the file when you finish editing.

OTHER DICTIONARIES

International dictionaries and medical and legal dictionaries for use with
WordStar are available separately.

With the dictionary for each language, you can hyphenate and check spelling
in that language. WordStar checks spelling and hyphenation for the current
language only. The default language is American English. You can change the
current language within a document by using Utilities=>Language Change or
the .la dot command with the appropriate code, and you can change the
default language in WSCHANGE (DCGK). For more information, see
“Language Change” in this chapter.

Medical and legal dictionaries are available in some languages. They contain
the WordStar standard dictionary as well as specialized terms. Instructions
for installing and using the special dictionaries are included in the dictionary
package.




THESAURUS

THESA URUS Pull-down: ALT + U, T

Classic: AQJ

Displays synonyms for words in your text or words you type.

To display synonyms for a word in the document, place the cursor on that
word. (If you want to type in a word, the cursor location doesn’t matter.) Then
follow these steps:

Choose Utilities=>Thesaurus, or use the AQJ classic command.

The Thesaurus dialog box displays synonyms for the word at the cursor.
Synonyms are grouped according to definition and part of speech. The most
commonly used synonyms are listed first. If all the synonyms don’t fit on
the screen, scroll or move the cursor past the bottom line to display the next
synonyms.

»

4

3

Word: prominent

Adv  [FFENN, magnificent, elevated, exalted, excellent, great, heavenly,

To insert a word in your text, highlight it and select OK.

L Cross—reference P Return to Previous Word

high, lofty, sublime, superb:

substantial, important, consequential, considerable, critical,
crucial, material, meaningful, momentous, significant, vital,

uweighty:

conspicuous, arresting, astonishing, astounding, eye-catching,

Type New Word K Define Highlighted Word

If you want to replace the original word in the text with one of the
synonyms, move the cursor to the synonym you want and press Enter. The
text around the word is reformatted if necessary.

If you don’t want to use any of the synonyms to replace the original word,

choose the option you want, or press Esc or choose Cancel to exit the
thesaurus. The options are described below.
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I Type New Word When you choose this option, type a word to check for
synonyms, then press F10 or choose OK.

L Cross-reference Displays a list of synonyms for the synonym at the
cursor. You can then move the cursor to the synonym you want and insert
it in the document, or you can choose Return to Previous Word or press P to
return to the previous screen.

K Define Highlighted Word Displays the definition for the currently
highlighted word. You can move the highlighting to the original word in
quotes at the upper-left of the menu. You can press | to type another word,
N to see the next definition of the word, or P to see the previous definition.
Press Esc or choose Cancel to return to the synonym screen.

P Return to Previous Word Returns to the synonyms for the previous word
you checked for synonyms in this session of using the thesaurus. This
option works only if you have already requested synonyms for another word
in this session.

Usually, the word you want is among the synonyms displayed by the thesaurus.
If WordStar cannot find the word you request, it looks up synonyms for the root
word. [f it can’t find the word or the root word, it displays a list of the closest
words alphabetically, with the cursor on the word closest to the one you
requested. You can press Enter to look up synonyms for that word, or you can
move the cursor to another word and press Enter.

International thesauruses come with the dictionaries in language packs that are
available for use with WordStar. With these thesauruses, you can check
synonyms for words in various languages. The default language is American
English. You can change the current language within a document using
Utilities=>Language Change, or the .Ia dot command with the appropriate code,
and you can change the default language in WSCHANGE (DCGK). For more
information, see “Language Change” in this chapter.
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LANGUAGE CHANGE Pull-down: ALT + U, L

Classic: LA
Changes the language used for spelling checks, hyphenation, and the thesaurus.
WordStar checks spelling and hyphenation and looks up synonyms for the cur-
rent language only. The default language is American English. You can change

the default language in WSCHANGE (DCGK).

If you have purchased language packs for other languages, follow these steps to
change the language in a document:

1 Choose Utilities=>Language Change.

2 Inthe Language Change dialog box, type the code for the language you
want. The codes are listed in the documentation that comes with the
language packs and in the IBM DOS manual.

3 Press F10 or choose OK.

WordStar inserts the .la dot command, followed by the language code, into the
document. You can get the same result by typing the dot command.

Once you specify a language, you can check spelling, hyphenate, and use the
thesaurus as you normally would.

INSET

Pull-down: ALT + U, I
Classic: "P&

Starts the Inset graphics program.

The Inset program allows you to capture graphics from other programs and to
create and edit graphics. You can then insert the graphics into your WordStar

documents.

You must install the Inset program through WordStar (using WSSETUP or the
WINSTALL Add or remove a feature option) and set up Inset (using the Inset
Setup program) before you can use the Inset command.
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When you choose Utilities=>Inset or use the AP& classic command, WordStar
loads Inset into memory if it is not already loaded, and starts Inset. The Inset
Main Menu appears, and you can use any of the Inset commands.

Note: Each time WordStar loads Inset, it must clear memory. The Ignore and
Global Replace lists, which are generated when you check spelling, are erased
from memory.

For complete information about Inset, see the “Inset” section of the Companion
Programs manual. For information about inserting a graphic into a document,
see “Graphic” in “Editing Screen Insert Menu.”

CALC ULATOR Pull-down: ALT + U 9 C
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Classic: AQM
Evaluates a mathematical expression that you type.

The onscreen calculator provides addition, subtraction, division, multiplication,
and exponential operations. It also provides natural and common logarithms,
square root, integer, and trigonometric functions. Follow these steps to use the
onscreen calculator:

1 Choose Utilities=>Calculator, or use the AQM classic command.

“

Enter Mathematical Expression to be Calculated:

Result of Last Calculation:

4]
Ualid Symbols:
+ Add 7% Percent int Integer sin Sine
— Subtract sqr Square Root log Base 18 Log cos Cosine
% Multiply ~ Exponentiate In Base e Log tan Tangent

7/ Divide exp e"x atn Arc Tan
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2 In the Calculator dialog box, type the expression you want to evaluate and
press Enter or choose OK. (Do not type an equal sign at the end of the
expression.) You can use /R to reenter the previous expression so that you
can edit and recalculate it. More information about notation is given after
these steps.

WordStar displays the answer as Result of Last Calculation.

3 If you want to evaluate another expression, type it in the dialog box. When
you finish using the calculator, press Enter or Esc or choose OK or Cancel.

After you return to editing, you can insert the result of the last expression (or the
expression itself) into your text at the cursor position by choosing Insert=>Other
Value, and then Last Math Result, Last Math Expression, or Last Math as Dollar.
The corresponding classic commands are M= (result), AM# (expression), and
AMS$ (result as dollar amount). For more information, see “Variable” in “Editing
Screen Insert Menu.”

When entering an expression, keep these points in mind:

= Expressions are normally evaluated from left to right, except that
exponentiation takes precedence over multiplication and division, which
take precedence over addition and subtraction. You can change the order in
which WordStar performs operations by using parentheses () to enclose
operations that are to be done first. Be sure to use beginning and end
parentheses for each of these operations. For example:

500*.001*(((.001+1)A180)/(((.001+1)A180)-1))

WordStar always performs the operation within the innermost set of paren-
theses first. WordStar uses its normal order of precedence when performing
the operations within parentheses. You can nest up to 32 pairs of paren-
theses; however, the equation can become too complicated for WordStar
before that level is reached. If an equation is too complicated, an error mes-
sage appears.

" You can use scientific notation to enter a long number. For example,
1.23e25 represents the number 12300000000000000000000000. Answers
have a maximum precision of 12 digits. If an answer is longer, WordStar
gives the closest answer it can, using scientific notation. The largest number
WordStar can work with is 1e63. The smallest number is 1e-63, which is
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written out as a decimal point followed by 62 zeros and a 1. (WordStar uses
14-digit BCD floating-point math internally.)

= The trigonometric functions sine, cosine, tangent, and arc tangent work with
angles in degrees. For example, to find the sine of 45 degrees, type sin(45).
Do not type a space before the opening parenthesis.

For information about performing calculations on merge printed variables, see
“Set Variable to Math Result” in “Merge Print Commands” in this chapter.

BLOCK MATH Pull-down: ALT + U, B
Classic: "KM

Performs calculator functions in the currently marked block.

With block math, you can perform mathematical functions that are indicated in
a marked block. Follow these steps:

1 Mark the beginning and end of the block (Edit=>Mark Block Beginning and
Edit=>Mark Block End, or AKB and ~AKK). Be sure the block contains all the
numbers you want included in the calculation and no extra numbers or
operators. If you're adding a column of numbers, you may want to use
Column Block Mode (Edit=>Editing Settings=>Column Block Mode, or AKN).
Rules for entering numbers and operators are given after these steps.

2 Choose Utilities=Block Math, or use the "KM classic command.
The result of the calculation is displayed in the Block Math dialog box.
3 Press F10 or choose Continue to return to editing.
After you return to editing, you can insert the block math result into your text
at the cursor position by choosing Insert=>Other Value=>Last Math Result or
Last Math as Dollar. The corresponding classic commands are AM= (result) and

AMS$ (result as dollar amount). For more information, see “Variable” in “Editing
Screen Insert Menu.”
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WordStar uses the following rules to determine whether the digits it encounters
in a marked block are part of a number:

= A number is any set of digits (the characters 0-9).

= A negative number is indicated with a minus sign () or parentheses (). Any
number within parentheses is considered negative.

= A period is considered a decimal point when the character immediately after
it is a digit.

= The letter e surrounded by digits is considered a scientific notation; for
example, 2e25 means 2 * 10>,

= The maximum number of digits in a number is 30.

= A percent sign (%) indicates a percentage.

Parentheses and square brackets show precedence in mathematical operations.
Answers have a maximum precision of 12 digits. If the answer is longer,
WordStar gives the closest answer it can, using scientific notation. Numbers

in dot command lines are ignored.

See also “Calculator” in this chapter.

S ORT BLOCK Pull-down: ALT + U, K
Classic: "KZ

Sorts text in the marked block in alphabetic and numeric order.
Follow these steps to sort text:

1 Mark the block you want to sort (Edit=>Mark Block Beginning and
Edit=>Mark Block End, or AKB and ~KK). Be sure that the leftmost marked
characters on each line are the ones you want to use for the sort. If
necessary, change to Column Block Mode (Edit=>Editing Settings=>Column
Block Mode, or AKN). For example, if you want to sort an address list by
zip code, turn column mode on and mark the zip code column as a block.
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(The entire lines are moved when they’re sorted, not just the portion of the
line in the block.)

2 Choose Utilities=>Sort Block, or use the AKZ classic command.

3 Choose Ascending (or press A) or Descending (or press D) for the sort order.

WordStar sorts the lines in the marked block and puts them in the new order.

Lines are sorted based on the following sort order: first spaces, then symbols,
then numbers, and then letters.

When you sort numbers aligned with a decimal tab, be sure the smaller num-
bers have leading zeros. For example, if the largest number is 100, numbers 1
and 10 should be 001 and 010.

TIP If your line spacing setting is greater than 1, change it to 1 before you
sort to avoid sorting all the blank lines.

For information on sorting MailList data files, see “MailList” in the Companion
Programs manual.

WORD/ CHARACTER COUNT Pull-down: ALT + U, W
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Classic: "K?
Counts the words and bytes in the marked block or in the entire document.

Use this command to get a count of words and bytes in the currently marked
block or, if no block is marked, in the entire file.

The Status screen also shows a count in bytes from the beginning of the file to
the current cursor position. Choose File=Status or use the 2O? classic com-
mand to display the Status screen.
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MACROS Pull-down: ALT + UM
Classic: "M

Records, creates, edits, or runs a macro that enters a longer series of text and
commands.

The WordStar macro capabilities allow you to use a few keystrokes to enter a
series of keystrokes and commands. For example, you can create a macro so
that each time you type Alt+W, the word “WordStar” is inserted in your text.
Or a macro can change the order of two words (mark the first word as a block,
move the cursor to the end of the next word, and move the block).

When you choose Macros, the following menu appears.

Record. .. MR
Edit/Create... "MD
Single Step... “MS

Copy... “MO
Delete... “MY
Rename. . . “ME

You can create a macro in either of two ways:

s Use Record, or the AMR classic command, to record keystrokes. This is the
easier way to create a macro. WordStar records commands and keystrokes
as you enter them. When you are finished, WordStar compiles them into a
macro file that contains all the appropriate macro commands.

= Use Edit/Create, or the AMD classic command, to enter macro commands
into a file that you edit like a nondocument. To use this command, you
need to know the WordStar macro language. This language allows you to
create macros that are too complex to record with the Record command.
For example, you can have a macro repeat a certain action as many times as
needed each time you run the macro. The example in “The Macro
Language” in this section enters a bullet character and waits for you to type
text, then repeats that sequence after the end of each paragraph; the macro
stops and returns you to editing when you finish your bulleted list.
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If you need to write a macro that is too complex to record, you can first record
a simpler macro that contains commands and keystrokes that can be recorded,
then use Edit/Create to add the macro language for the rest of the macro. You
can also copy a macro and edit it to create a similar one, and you can copy
blocks of macro commands from one macro file to another.

After you create a macro, you can use Single Step, or the AMS classic com-
mand, to play it back step by step to identify any problems.

To execute a macro, you can either use a hot key, or use Play, or the

AMP classic command. You can stop the macro by pressing Esc or ABreak.
(When a macro is paused for input, you must use *Break.) You can change
the Esc keystroke or add another key to stop a macro in WSCHANGE (DCDC
and DCDD).

You can also copy, rename, and delete macros using commands on the
Macros menu.

TIP You can set up a macro to run a series of commands that you frequently
use when you start WordStar. Then you can run the macro immediately when
you start WordStar by typing ws /mmacroname. For example, you can set up a
macro named LETTER to change to the C:\CUSTOMER directory, open a new
file, and read in a file of boilerplate text and formatting. Then, any time you
want to start WordStar and start a new letter, type ws /mletter. If you want to
start WordStar, open a file, and then run a macro, type the filename before the
/m option.

WORKING WITH MACROS
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MACRO HOT KEYS

You can execute a macro by pressing a single key or key combination called a
hot key. You can assign a hot key to a macro when you create it. Eighty-two
hot keys are available:

= The function keys F2 through F9, and F11 and F12. (F1 and F10 are reserved
for help and closing dialog boxes.)

® The function keys F1 through F12 combined with the Shift key.

® The function keys F1 through F12 combined with the Ctrl key.
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= The function keys F1 through F12 combined with the Alt key.
= The Alt key combined with the letters A-Z and the digits 0-9.
Keep these points in mind about macro hot keys:

= The Alt key combined with the letters F, E, V, I, S, L, U, and H access the
WordStar pull-down menus. If you use any of these keystrokes as hot keys,
you can’t use them for those menus. (You can still display the menus using a
mouse or using the Right and Left Arrow keys in the menu bar.)

= You don’t have to assign a hot key to each macro. If a macro is not assigned
a hot key, you can run the macro using Macros=>Play (or the AMP classic
command).

= |f you want to assign a hot key to a macro that doesn’t have one, or change
the hot key assigned to a macro, use Macros=>Rename, or AME. Don’t use
Macros=>Record (*"MR); it will erase the macro and create a new one.

= WordStar comes with predefined macros for the function key hot keys and
several other hot keys. These macros are listed in Appendix D, “Function
Keys and Other Macros.” You can define new macros for these keys if you
want, using Record (*MR) or Edit/Create ("MD).

MACRO FILES AND DIRECTORIES

Each macro is stored as a file, with the name you gave it while recording or
editing and the .WSM extension.

CAUTION When you record, create, or edit a macro and save it,
WordStar compiles the macro, adding executable code. Macro files appear to
be nondocuments (ASCII files) when you edit them, but they contain other
information. You must edit them with Macros=>Create/Edit (or "MD) to get
usable macros.

On most systems, all the macro files are stored in one directory. The default

macro directory name is WS\MACROS; you can change it with WSCHANGE
(CD2Q).
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Piay

Pull-down: ALT + U, M, P
Classic: "MP

Executes a macro.

You can execute a macro either using a hot key or using this command. For an
explanation on using hot keys, see “Macro Hot Keys” in this section.

Follow these steps to play a macro:
1 Choose Utilities=>Macros=>Play, or use the AMP classic command.

2 |n the Play Macro dialog box, specify the macro to play. You can choose
the macro either by name or hot key. When you press the Down Arrow key
and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.

3 Press F10 or choose OK.

WordStar executes all the commands and enters all the text specified in the
macro. Generally, menus and dialog boxes are not displayed unless you need
to enter input.

You can stop the macro by pressing Esc or ABreak. (When a macro is paused
for input, you must use ~Break.)

REcorD Pull-down: ALT + U, M, R
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Classic: "MR

Records a series of keystrokes and stores them as a macro that you can
execute.

You can create a macro by choosing Record and then pressing all the
keystrokes that you want in the macro. Follow these steps:

1 Choose Utilities=>Macros=>Record, or use the AMR classic command.
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2 In the Record Macro dialog box, type the name you want to give the macro.
If the macro name is already in use, confirm that you want to redefine the
macro or give it another name.

3 Specify the hot key that will execute the macro. You can press the Down
Arrow key and scroll through the list to see which hot keys are available. If
the hot key you specify is already in use, confirm that you want to reassign
the hot key or specify another hot key. If you don’t want to assign a hot key
to the macro, you can skip this step.

4 Type a description of the macro to remind you what it does and help you
find it in the list. The description can be up to 48 characters long. If you
don’t want to give a description for the macro, you can skip this step.

5 Press F10 or choose OK.

6 Enter all the keystrokes you want in the macro. Enter them in the same way
you want them played back when you run the macro.

You may need the macro to pause when you run it so that you can enter
information such as a filename. At any place you want the macro to pause,
press Alt+Hyphen. Then type any number of keystrokes as an example of
the input. Press Alt+Hyphen again to end the pause, and continue entering
the macro keystrokes. When you execute the macro, it pauses at that point
for input and continues after you press Alt+Hyphen. (You can change the
Alt+Hyphen keystroke to another keystroke using WSCHANGE (DCDB).)

Note: Mouse actions and clicks are not recorded in macros and do not
work while you are recording a macro; you must use the keyboard.

7 When you finish entering the keystrokes, press Alt+= (hold down the Alt key
and press =). (You can change the Alt+= keystroke to another keystroke
using WSCHANGE (DCDA).)

WordStar records and compiles the macro. If you want to make adjustments to

the macro, you can either record it again or edit it using Macros=>Edit/Create,
or the AMD classic command.
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EDIT/CREATE Pull-down: ALT + U, M, E
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Classic: "MD

Creates and modifies a macro that contains keystrokes and commands that
you enter.

Each macro consists of a series of WordStar commands and functions. You edit
a macro using the same commands you use for editing a nondocument file.
Follow these steps:

Note: You cannot edit a macro if you already have two editing windows open.

1

2

Choose Utilities=>Macros=>Edit/Create, or use the AMD classic command.
In the Edit/Create Macro dialog box, specify the macro name.

When you press the Down Arrow key and scroll through the list of macros,
the description for the highlighted macro appears in the dialog box.

If you're creating a new macro, specify the hot key that will execute the
macro. You can press the Down Arrow key and scroll through the list to see
which hot keys are available. If the hot key you specify is already in use,
confirm that you want to reassign the hot key or specify another hot key. If
you don’t want to assign a hot key to the macro, you can skip this step.

Type a description of the macro to remind you of what it does and to help
you find it in the list. The description can be up to 48 characters long. If
you don’t want to give a description for the macro, you can skip this step.

Press F10 or choose OK. WordStar opens a full-screen editing window for
the macro.

Type the text of the macro or make any editing changes. For information
about what you can enter, see “The Macro Language” in this section. When
you edit a macro, you can use the commands used for editing
nondocuments.

TIP  You may want to periodically use File=>Save ("KS) to save your
changes while editing.
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7 When you finish, save the macro using File=>Save and Close (*KD).

WordStar compiles the macro. If it finds any syntax errors or other errors, they
are entered into the macro file. You must edit the macro again to correct the
errors.

Errors in a macro file are noted by a message describing the error, followed by
the line of the macro that contains the error, with a caret () below the line
pointing to the location of the error.

TIP The Alt+D hot key is preassigned to a macro that goes to the next error
message in a macro file. This is helpful when you edit macros to fix errors.

If you want to copy a block of text from one macro into another, start from the
Opening screen rather than the Editing screen. Choose Macros=>Edit/Create
(or AMD), and then choose File=Open/Switch (or 2OK). Then copy the block
between the windows in the same way you would while editing a document.

SINGLE STEP Pull-down: ALT + U, M, S
Classic: "MS

Plays back a macro one step at a time to locate errors.

After you create or edit a macro, you can play it back step by step to identify

any problems. This command is helpful when a macro doesn’t work exactly as

you expect it to. Follow these steps:

1 Choose Utilities=Macros=>Single Step, or use the AMS classic command.

2 In the Single Step dialog box, specify the macro to play. You can specify the
macro either by name or by hot key. When you press the Down Arrow key
and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.

3 Press F10 or choose OK.

WordStar executes the first command or keystroke in the macro, and pauses.
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4 Press the Spacebar to continue to the next command, function, or keystroke.
Continue in this manner until the macro finishes. You can stop running the
macro by pressing Esc or ABreak. (When a macro is paused for input, you
must use ~Break.)

Pull-down: ALT + U, M , C
Classic: "MO
Copies a macro.

If you want to create a macro similar to another one, you can copy the first
macro and edit the copy. You can also make copies of macros so that several
people can use them on their computers. Follow these steps:

1

2

4

Choose Utilities=»Macros=>Copy, or use the AMO classic command.

In the Copy Macro dialog box, specify the macro to copy.

You can specify the macro either by name or by hot key. When you press
the Down Arrow key and scroll through the list of macros, the description
for the highlighted macro appears in the dialog box.

Specify the macro name for the new copy. Type the path with the name if
necessary. If the name is already in use, confirm that you want to overwrite

the current macro.

Press F10 or choose OK to copy the macro.

The copied macro has the same description as the original, but is not assigned a
hot key. You can assign a hot key and description when you edit the macro, or
you can use Rename Macro (or the AME classic command).
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DELETE Pull-down: ALT + U, M, D
Classic: "MY

Deletes a macro.

Follow these steps to delete a macro:

1 Choose Utilities=>Macros=>Delete, or use the AMY classic command.

2 In the Delete Macro dialog box, specify the macro to delete. You can
specify the macro either by name or by hot key. When you press the
Down Arrow key and scroll through the list of macros, the description for

the highlighted macro appears in the dialog box.

3 Press F10 or choose OK to delete the macro, and confirm the deletion.

RENAME Pull-down: ALT + U, M, N
Classicc: "ME

Renames a macro.

You can use this command to rename a macro, assign a new hot key, or add or
edit a description. Follow these steps:

1 Choose Utilities=>Macros=>Rename, or use the AME classic command.

2 In the Rename Macro dialog box, specify the macro to rename. You can
specify the macro either by name or by hot key. When you press the
Down Arrow key and scroll through the list of macros, the description for
the highlighted macro appears in the dialog box.

3 Specify the new macro name, hot key, and/or description. If the name or
hot key is already in use, confirm that you want to overwrite the current
assignment.

4 Press F10 or choose OK to rename the macro.
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WordStar macros are written and recorded in a BASIC-like language.

Each macro consists of one or more subroutines. A subroutine is a series of
statements. The MAIN subroutine is required, and you can use as many other
subroutines as you like.

Each statement is a command or function and, if required, its arguments. A
statement can have a modifying clause. Each statement can have a label to
identify it.

Commands generally control the flow of execution, by specifying which
statement to execute next. Some commands are Call, GoTo, Return, Stop,
and PlayMacro.

Functions perform specific tasks. Some functions are Key, SetHelpLevel, Insert,
and PauseForlnput. The Key function is the most important function because it
supplies keystrokes to WordStar as if they were typed at the keyboard.

The macro language is described in detail in the following sections. To see
more examples, you can look at the macro files that came with WordStar.
Unless you’ve changed directory names, they are in the \WS\MACROS direc-
tory. These macros are for the function keys and several other hot keys, and
are listed in Appendix D.

MACRO STRUCTURE

A very simple macro is shown below.

Sub MAIN
Key ("Good morning! {Enter}")
End Sub

This macro types Good morning! into a document and starts a new line. The
macro has three lines. The first line says that the subroutine MAIN begins here,
and the last line ends the subroutine.
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The second line in the macro is a statement that consists of a single Key( ) func-
tion and its argument, the keystroke string Good morning!{Enter}. Arguments
for functions are always enclosed in parentheses. Keystroke strings are always
enclosed in quotation marks. {Enter} signifies the Enter key.

The following example shows a macro for writing a bulleted list. A complete
explanation follows the macro. After the explanation of the example, all the
macro functions, commands, and other elements are described in detail.

REM This macro is for creating bulleted lists.
Sub MAIN
AutoRestore(ON) : Insert(ON) : CmdTags (OFF)

SetHelpLevel (4) : HideDots (ON)

Key ("{Ctrl+O}FSHanging indent 1{Enter}")
Call Timesl2
ListLoop: Key (" +{Tab}")
PauseForInput ("{Enter}", ‘Enter the text.’)
IfException
NCM: Goto ListDone '‘User entered nothing
End IfException
Key ("{Enter}")
GoTo ListLoop
ListDone: Key ("{Ctrl+Q}{Del}")
Key ("{Ctrl+O}FP")
Stop
End Sub

Sub Timesl2

Key ("{Ctrl+P}=Times 12{Enter}")
Return

End Sub

This macro is composed of two subroutines, MAIN and Times12. MAIN has
the instructions for entering the bulleted list, and Times12 changes fonts.

The macro has two comments to remind the user what the macro is doing.

They are the REM line at the beginning of the macro and the comment “User
entered nothing,” which describes the situation in which that line takes effect.
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At the beginning of the MAIN subroutine are statements that use the
AutoRestore, Insert, CmdTags, SetHelpLevel, and HideDots functions to set
those five editor states.

The first Key function selects the Hanging Indent 1 paragraph style. Notice
that it contains all the keystrokes to choose this style, using the AOFS classic
command.

Next, the Call command runs the Times12 subroutine, which uses a Key state-
ment to change to the Times 12 font. After the font change, the Return com-
mand returns to MAIN. Instead of having this subroutine, you could put the
Key statement directly in the MAIN subroutine. However, you might want to
use this subroutine often in a macro, and it is convenient to be able to call it at
several places.

ListLoop is a label. A label marks a location so that you can go to it from else-
where in the subroutine to run the subsequent instructions. In this case, the
label allows a macro to return to the same location a number of times, creating
a “loop.” The Key statement types two spaces and then the bullet character and
atab. The PauseForinput function causes the macro to wait while the user
enters the text that goes next to the bullet, displaying the message Enter the text.
After entering the text, the user presses Enter, the input termination character.

If the user enters text and presses Enter, the IfException is ignored, and the next
Key statement presses Enter to go to the next line. Then the GoTo command
moves back to the ListLoop label to repeat the procedure for entering another
bullet and text.

The three lines beginning with IfException are an IfException clause. An
IfException clause tells the macro what to do if it does not receive the expected
user input. The IfException signifies the beginning of the clause and the
EndlfException signifies the end. NCM (No Cursor Movement) is the type of
exception. The NCM line tells the macro that if the user doesn’t enter anything
before pressing Enter (after the bullet character is entered), the macro should go
to the label InputDone. This clause provides the way to end the bulleted list
after the user enters the text for the last bullet.

All the indentation in the macro is optional; it is used to make the macro easy
to read. After the ListLoop label, the Key statement could be on the same line
or the next line, and all the following lines could begin at the left margin.
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At the ListDone label, there are two Key statements. The first deletes everything
on the line to the left of the cursor using the AQDel classic command. This
removes the last bullet that was inserted, for which there was no text. The last
statement reverts to the paragraph style that was in effect above the bulleted
list, using the AOFP classic command. At this point, the macro is finished,

and the user returns to editing.

Note that this macro uses classic commands. You can instead use the
pull-down menu Alt key combinations for the same commands.

Also note that you can put several statements on a single line by separating
statements with a colon (:). You can put spaces or tabs before and after the
colon, but they are not required. For example, the first two lines under

Sub MAIN in the example above contain five statements.

SUBROUTINES

The format of a subroutine is

Sub name
statements
End Sub

A subroutine name must begin with a letter and can contain up to 31 charac-
ters. The characters must be letters, digits, and the underline character, ( _).

Each macro must include the MAIN subroutine, and it is always executed first.
You can use additional subroutines to execute the same groups of statements in
several locations within a macro; you can enter a subroutine once and call it
each time it’s needed.

Each statement in a macro must be within a subroutine. Subroutines are
separate; a subroutine can call other subroutines, but one subroutine cannot be
within another in the text of a macro. Only the MAIN subroutine is executed
automatically; you must call any other subroutine to execute it.

Use the Call command to call the subroutine at each location you want to use
it. See “Commands” in this section.
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THE KEY( ) FUNCTION

The Key() function is the most important component of a macro. It specifies
the keystrokes that the macro enters. It is in the following format:

Key ("keystroke string")

The keystroke string must be enclosed in quotation marks. The string can
include text and special keys such as direction keys and WordStar commands.
A simple Key command with text only is

Key ("Sincerely yours,")
This command types the phrase Sincerely yours,.

Special keys are generally enclosed in braces, for example, {Enter} and {PgDn}.
A complete list of special keys is in Appendix C, “Macro Keystrokes.” Braces
are also used with key combinations, for example, {Alt+F1} and {Ctrl+P}. The
following Key command opens a document named KNOX.DOC:

Key ("{Alt+F}Dknox.doc{Enter}")
The following rules apply to special keys and key combinations:

= Upper- and lowercase letters are treated the same; for example, ALT is the
same as Alt.

= The caret symbol () can be used for the Ctrl key. Braces are not required
when this symbol is used. For example, AC (not enclosed in braces) is
equivalent to {Ctrl+C}.

® You can also enter control characters in a macro by pressing AP and then
the control character. For example, if you press APAC (hold down the
control key, press P and then C, then release the control key), AC appears
in the macro.

= For key combinations, you can use the Plus (+) sign, a space, or a hyphen
(-). For example, {Alt+F7}, {Alt F7}, and {Alt-F7} are equivalent.
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® An extended ASCII character can be entered by holding down the Alt key
and pressing the appropriate number keys on the numeric keypad. For
example, pressing Alt+156 puts the £ symbol in the macro.

= To enter an actual ", {, }, or #, double the character; type " ", {{, } }, or AA,

For any dialog box option with a check box, you can enter the commands to
move to that option, then enter a plus sign (+) for on, a minus sign (- ) for off,
or O for inherit (in paragraph styles). For example, the following Key( ) function
goes to the Alignment and Spacing dialog box using the 2OS classic command
and turns hyphenation on:

Key ( "A0Sh+" )

For more information about entering keystrokes, see Appendix C, “Macro
Keystrokes.”

OTHER FUNCTIONS

You can use several other functions besides the Key( ) function in WordStar
macros.

The following two functions allow the macro to pause for user input.

PauseForInput(“input termination key ”, 'message text’) Pauses macro execu-
tion so the user can enter text. The input termination key is the keystroke that
causes macro execution to resume. It must be enclosed in quotation marks.
The termination key is optional if you don’t include a message; if you don’t
specify a keystroke, Alt+Hyphen is used.

The message text is the message you want displayed while paused for input. It
must be enclosed in apostrophes. It is optional; if you don’t specify a message,
Paused. Press {ALT+-} to continue appears. To enter an apostrophe in the
message text, double the character; type ’ ’. If you include a message, the

input termination key is required in the PauseForlnput statement. If you use a
termination key other than the default, be sure to include a message that gives
the name of the key; otherwise, the person running the macro won’t know what
to do.

When you record a macro, Alt+Hyphen is used as the input termination key,
unless you change the default key using WSCHANGE (DCDB).
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PauseForKey() Pauses macro execution so the user can enter a single
keystroke (for example, Y or N). As soon as the user presses a key, macro
execution resumes.

The remaining functions set editing conditions for playing back the macro.
These editing conditions can affect how the commands in the macro work.
When you create a macro, it's best to use these functions unless you're sure the
editing conditions won’t affect macro execution. For example, if a macro is
written assuming that insert is on, and it is run in overtype mode, text could be
lost. If a macro is run at a different help level than it is written for, different
menus and dialog boxes may appear, and some of the commands in the macro
may not work correctly.

SetHelpLevel(1/2/3/4) Sets the help level in use for macro execution.
Insert(ON/OFF) Sets Insert mode to on or off for macro execution.

CmdTags(ON/OFF) Sets Command Tags display (or AOD) on or off for
macro execution.

HideDots(ON/OFF) Sets display of dot commands on or off for macro
execution.

ColMode(ON/OFF) Sets column block mode on or off for macro execution.

ColReplace(ON/OFF) Sets column replace mode on or off for macro
execution.

AutoRestore(ON/OFF) After the macro finishes running, restores the editor
conditions that were in effect when the macro started. This function is turned
on whenever a macro is recorded.

SingleStep(ON/OFF) Allows you to Single Step through a selected portion
of a macro.

When you record a macro, WordStar automatically inserts all these functions,
with the current settings, into the macro file. For example, recording a simple
macro to type Good morning! produces this macro file:
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Sub MAIN

SetHelpLevel (4)

Insert (ON)

CmdTags (OFF)

HideDots (ON)

ColMode (OFF)

ColReplace (OFF)

AutoRestore(ON)

Key ("Good morning! {Enter}")
End Sub

COMMANDS

You can use the following commands to control the flow of the macro
execution.

Call subroutine Executes the named subroutine in the current macro. When
the subroutine is completed, macro execution returns to the statement after the
Call statement, unless the subroutine includes the Stop command.

PlayMacro ‘macro’ Executes another macro. The macro name must be
enclosed in apostrophes. Include a path with the macro name if necessary.
Do not include the .WSM extension. To enter an apostrophe in the macro
name or path, double the character; type ’ ’. When the macro is completed,
execution returns to the statement after the PlayMacro statement in the original
macro, unless the other macro includes the Stop command.

ChainMacro ‘macro’ Executes another macro. The macro name must be
enclosed in apostrophes. Include a path with the macro name if necessary.
Do not include the .WSM extension. To enter an apostrophe in the macro
name or path, double the character; type ’ . When the macro is completed,
execution does not return to the original macro unless the ChainMacro com-
mand was invoked from a subroutine other than Main. In this case, execution
returns to the subroutine that called the subroutine containing the ChainMacro
command.

Stop Terminates the macro.
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Return Stops the current subroutine and returns to either the calling sub-
routine or the calling macro. If there is no calling subroutine or macro, the
macro is terminated.

GoTo label Goes to the named label, executes it, and continues from that
location. The label must be within the same subroutine as the GoTo command.

A label is a name that identifies a statement or location in a macro. You can
use a label to go to a specific location in the macro, and to repeat a set of
instructions in a loop. A label name must begin with a letter and can
contain up to 31 characters, which must be letters, digits, and the underline
character ( _). It must end with a colon ( :).

THE IFEXCEPTION CLAUSE

When you run the macro and it enters the keystrokes in the Key function, addi-
tional user input may be required before the macro can go on to the next func-
tion. For example, if you run a macro with the command to insert the file
JOE.DOC, Key(“{Alt+1}Fjoe.doc{Enter}”), and the JOE.DOC file doesn’t exist, a
message is displayed that requires user input. This is called an exception condi-
tion, and is handled using the IfException clause.

You can follow any Key command with an IfException clause. The IfException
clause handles these three types of exception conditions:

= User acknowledgement required (ACK) This condition occurs when
WordStar issues a message in response to a command issued by the macro,
and the user needs to press a key to acknowledge it. For example, after a
spelling check WordStar displays the number of words checked, and you
must press F10 or choose OK to continue.

= User clarification required (QRY) This condition occurs when WordStar
displays a dialog box in response to a command issued by the macro, and
the user needs to enter information or choose one of several options. For
example, if the macro inserts a file and gives a filename that doesn’t exist,
you need to type the correct filename or close the dialog box. When you
record a macro, ACK conditions are included when appropriate.
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® No cursor movement (NCM) If the macro repeats a cursor movement
command such as PgUp or PgDn indefinitely, this condition occurs when
the cursor reaches the beginning or end of the file or line. This condition
also occurs when no user input is received before the input termination key
is pressed after a PauseForlnput statement.

The IfException clause has the following format:

IfException
[ACK:
statements]
[QRY:
statements]
[NCM:
statements])
[DEF:
statements]

End IfException

The ACK, QRY, and NCM subclauses handle the three conditions described
above, and the DEF statement gives the default exception processing for

ACK and QRY conditions. At least one of these subclauses must be defined in
each IfException clause. The IfException, End IfException, and each subclause
must begin on a new line. You can use spaces or tabs to indent the subclauses
if you want.

If one of the three exception conditions occurs when the macro is run, the
IfException clause becomes active. If the subclause for the type of exception is
defined, WordStar executes the statements in that subclause. Otherwise, if the
exception is an ACK or QRY type and the DEF clause is defined, WordStar
executes the statements in the DEF subclause.

If no IfException clause is present in an ACK or QRY condition, or if an
appropriate subclause is not defined, the macro displays a message and waits
for user input for the dialog box or message on the screen. When appropriate
input is entered, the macro resumes. If no IfException clause is present in an
NCM condition, the condition is ignored and the macro proceeds.

When you record a macro, ACK and QRY (but not NCM) IfException clauses
are automatically inserted when exception conditions are encountered.
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The following example shows the use of ACK:

Sub Main
Key ("{Ctrl+Q}A")
Key ("wonderful{Tab}"})
Key ("excellent{Tab}")
Key ("MG")
Key ("{F10}")
IfException
ACK: Key ("{Esc}")
End IfException
End Sub

This macro uses the ~QA classic command. In the Find and Replace dialog
box, it instructs WordStar to replace “wonderful” with “excellent” using the

G (Entire File/Global) and M (Maintain Case) options. Then it issues the

F10 keystroke to close the dialog box and start the Find and Replace operation.
During this operation, the macro pauses at each instance of “wonderful” for the
user to press Y or N for the replacement. When the operation is complete, the
All replacements complete message triggers the ACK IfException, which sup-
plies the Esc keystroke to clear the message from the screen and resume editing.

The following example shows the use of QRY:

Sub Main

Key (" {Ctrl+P}=")

Key ("Times 10{Enter}")
IfException
QRY: Key ("{Esc}")

Key ("Courier 12{Enter}")

End IfException

End Sub

This macro uses the AP= classic command to choose a font. In the Font dialog
box, it chooses Times 10. If the Times 10 font isn’t available, the error message
triggers the QRY IfException, which supplies the Esc keystroke to remove the
message from the screen, then chooses the Courier 12 font.

For an example of using NCM, see “Macro Structure.”

T1P When a macro changes options in a dialog box, use separate Key
statements for each option. That way, you can use IfException clauses to
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correct problems with each option (for example, if the macro chooses a font or
paragraph style that isn’t available in the document).

COMMENTS

You can enter comments in a macro file in several ways:

= Use REM at the beginning of a line. All text following the. REM on that line is
comment. The REM can be preceded by tabs and spaces.

= Use an apostrophe () at the end of a statement line. All text following the
apostrophe on that line is comment.

= Start a comment anywhere in the macro with a slash and an asterisk ( /*),
and end it anywhere with an asterisk and a slash ( */). This type of comment
can be as many lines long as you like.

MERGE PRINT COMMANDS Pull-down: ALT + U, P

Enters commands and variable information in order to print personalized form
letters and other documents.

Merge printing is the process of inserting information into a document while it's
being printed. You can use merge printing for form letters, mailing labels,
invoices, contracts, reports, and any other standard document that requires you
to “fill in the blanks.”

When you print a document with merge print commands, be sure that the print
option Interpret Merge Variables is selected (the default). If you want to print
the document with the variable names showing in the text, and ignore the
merge print commands, clear this option.

WORKING WITH MERGE PRINTING

To merge print, you need a master document that contains both the text of the
document and the instructions for inserting the merged information. The
merged information can come from a data file such as a mailing list, or from the
keyboard at print time, or you can specify it at the beginning of the document.
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This section gives general information on data files, variables, and master docu-
ments. For information about specific commands, see the sections on those
commands.

DATA FILES

A data file is a nondocument (ASCII) file that contains information that can

be inserted into a master document for merge printing. You can create data
files using MailList™ (on the Additional menu at the Opening screen) or using
WordStar in nondocument mode. You can also use data files from dBase,
Lotus 1-2-3, or Symphony, and you can use comma-delimited ASCII files from
any program that creates them.

A data file consists of a series of records. Each record consists of several fields,
or items of information. For example, a mailing list has one record for each
person, and each record has a field for the name, a field for the address, and
fields for city, state, and zip code.

To create a data file, open a nondocument file, and type your information.
Keep the following points in mind:

®  Make sure that the fields are in the same order in all records, and that all
records have the same number of fields.

®  Separate fields with commas or carriage returns. If a field contains a comma,
enclose the entire field in quotation marks.

= |f afield is empty (you have no information for it in this record), indicate the
blank field with a comma.

® You can enter blank spaces at the beginning and end of any fields; they are
ignored when you use the data file for merge printing. Do not use dot
commands in a data file.

CAUTION The rules above are very important. If you enter any records
incorrectly, you will get incorrect results when you print.

The following example shows a data file with three records. Each record has
seven fields: last name, first name, first address line, second address line, city,
state, and zip code. Note that in the first and second records, the blank second
address line is shown with a comma, and in the second record, the first name
field is enclosed in quotation marks because it contains commas.
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Long, Lynette, 702 Rosemund Place, , Sebastopol,CA, 95472
Praskin, "Alan, Laurie, & Elena",25 Oak St.,,Salem,MA,b 01976
Jaffe,Joe, 1120 25th Ave.,Suite 155,San Diego,CA, 90010

If a field contains both a comma and quotation marks, you can either double
the quotation marks or use apostrophes to enclose the field, as shown in these
examples:

‘Thomas "Bud" Nash, Jr.‘
"Thomas ""Bud"" Nash, Jr."

You can use another character, such as the asterisk (*), instead of the comma as
the data separator. Use WSCHANGE (DCEA) to change the default data
separator for all data files. In individual master documents, you can change the
data separator using the .df command. First create the data file using the data
separator character you want. Normally .df is followed by the filename. If the
file uses a different data separator than the default, follow the filename with a
comma and the data separator. For example, to use the / character as the data
separator for the data file MAILING.LST, use the command .df MAILING.LST, /.
The rules given above for commas apply to any data separator character.

VARIABLES

Variable data is information that changes from one copy of the document to
another. You assign a name to each variable, and use variable names in master
documents wherever you want to insert the variable data. When you print,
WordStar inserts the specific information for each copy of the document. The
information can come from a data file, from the keyboard at print time, or from
within the document.

To include a variable in a master document, at the location where you want to
insert the variable data, type the variable name with ampersands (&) before and
after it. For example, to insert the contents of the name field from your mailing
list, type &name&. You can put a variable within a paragraph or on a line by
itself.

Keep these points in mind when you type variable names:

= A variable name can contain up to 39 characters.
® You can use uppercase and lowercase letters interchangeably, and you can

put a space between the name and the ampersands. For example,
&address&, &ADDRess&, and & address & are all the same to WordStar.
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= You can use any punctuation except commas, spaces, and ampersands. To
use two words in a variable name, use a hyphen (=) or underline character
(_) instead of a space, for example, &first-name&.

= A variable name must match exactly the corresponding name in the merge
print command at the top of the document. If WordStar finds no data for a
variable name (if there is no corresponding name in a .rv, .av, or .sv
command or if the name is misspelled in either place), the variable name is
printed with ampersands, as it appears on the screen.

= There are eight predefined variables for the current date, time, page, line,
filename, drive, directory, and path. Data for these variables is supplied by
WordStar when you print; you need to enter only the variable name. For
more information, see “Variable” in “Editing Screen Insert Menu.”

® You can include formatting information with a variable by inserting a slash
and the name of a format you've predefined. See “Variable Formatting” and
“Variable Number Formatting” in this section.

When you print a master document, if the data file contains no information for
a variable, WordStar doesn’t print anything in the document. For example, if
the document contains the text &name& &title&, and one person in the list
doesn’t have a title, WordStar prints just the name. However, if a variable is the
only text on a line, the line probably also contains a carriage return. In this
case, if there is no data for the variable, the printout includes a blank line. To
avoid leaving a blank line, use the /o option at the end of the variable name.
(This is the letter “0,” either uppercase or lowercase.) For /o to work, the vari-
able name must be alone on the line in the master document.

For example, it's common for some addresses in mailing lists to have more lines
than others. The /o option allows you to use an extra address line where
needed without having a blank line for shorter addresses. The example below
shows an address specified with variable names without the /o option, and how
it is printed for one mailing list record.

&full-name& Mary Burton
&addrl& 72 Live Oak Dr.
&addr2&

&city&, &state& &zip& Novato, CA 95390

The next example shows how the same record is printed using the /o option.
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&full-name& Mary Burton
&addrls 72 Live Oak Dr.
&addr2/o& Novato, CA 95390

&city&, &state& &zip&

MASTER DOCUMENTS

A master document contains text, variable names, and merge print commands.
It can be, for example, a form letter, a contract, or an invoice. You create a
master document as you do any document. Put the merge print commands to
define the data file (if you’re using one) and to define the variable names at the
beginning of the document, and use the variable names in the text wherever
you want to insert the data.

Note: If you use a data file created with MailList, don’t enter the merge print
commands in the master document. Just choose Insert=>File (or use ~KR)
and insert the MAILLIST.DOT file from your MailList directory (usually
WS\OPTIONS). This file includes the appropriate commands for using a
MailList data file. Check the .df command and change the data file name or
add a path to it if necessary.

A simple master document is shown below.

.op

.df address.dta

TV

first, last,mr-ms, addressl,address2,city, state, zip,class
&first& &last&

&addressl&

&address2/0&

&city&, &state& &zip&

Dear &mr-ms& &lastég,

Thank you very much for joining our summer series as a
&class&. We look forward to seeing you at our
performances this year. We will be sending you more
information soon.

Sincerely,

Lila Kaufman
Subscription Director
.pa
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The .op command omits the page number from the letter. The .df command
names the ADDRESS.DTA file as the data file to use. The .rv command gives
variable names for each of the fields in each record in that data file. The next
four lines use the variable names to insert each person’s name and address in
the letter.

IMPORTANT You mustend each master document with a page break,
which must include a carriage return, so that each copy of the document starts
printing on a new page.

If the first record in the data file is this:
Long, Lynette,Ms, 72 Heath Rd.,,Sebastopol,CA,95472,Patron
then the first letter printed using this master document would look like this:

Lynette Long
72 Heath Rd.
Sebastopol, CA 95472

Dear Ms Long,

Thank you very much for joining our summer series as a
Patron. We look forward to seeing you at our performances
this year. We will be sending you more information soon.

Sincerely,

Lila Kaufman
Subscription Director

Note: You can replace variables with up to 4,000 characters of data in each
master document.

PRINT TIME REFORMATTING

A master document includes variable names that are replaced by actual data
when the document is printed. The data may be different lengths in each copy
of the document, so the length of lines changes as data is inserted. WordStar
normally aligns each document at print time to format the text around the
data, using the margins and line spacing that are in effect at that point in the
document.
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The example below shows, first, text from a master document and then actual
printed text for one copy of the document. The data in the printed document is
longer than the variable names in the master document. WordStar reformatted
the text as it printed so it stayed within the margins.

This contract is entered into on the &day& day of &monthg,
&year&, between &partyl& and &party2&.

This contract is entered into on the twenty-seventh day of
September, 1988, between Roberta Kachinsky and Anna Marie
Casini.

TIP Reformatting may change page breaks. Use Layout—>Alignment and
Spacing=>Keep Lines Together on Page (or .cp) if you want to keep certain lines
of text together on the same page.

If you are printing data that may extend beyond the text margins, and you don’t
want those lines to wrap, you can type the .pf dot command in your text. The
command .pf on aligns every paragraph in the rest of the document, .pf off
turns print time reformatting off, and .pf dis (the default setting) aligns para-
graphs at WordStar’s discretion, meaning that WordStar reformats only the para-
graphs where data has been inserted in a variable, from the variable to the end
of the paragraph. (Alternately, you can use choose Layout=>Alignment and
Spacing=>Word Wrap, and turn off Word Wrap for that section of the file, or
use the .aw on/off dot command.)

DATA FILE Pull-down: ALT + U, P, D
Classic: DF

Gives the name of a data file to use for merge printing.
Follow these steps to specify the data file to use.
1 Choose Utilities=>Merge Print Commands=>Data File.

2 In the Merge Print Data File dialog box, specify the name of the data file.
Be sure to specify the path with the filename.

3 Press F10 or choose OK.
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WordStar inserts the .df dot command followed by the name of the data file,
for example, .df address.dta. You can get the same result by typing the dot
command.

If you use a data file created with MailList, don’t use the Data File command or
type the .df command in the master document. Instead, use Insert=>File (or
AKR) and insert the MAILLIST.DOT file from your MailList directory (usually
WS\OPTIONS). This file includes the appropriate commands for using a
MailList data file. Check the .df command and change the data file name or
add a path to it if necessary. (If you usually use the same data file, you can edit
MAILLIST.DOT if necessary so that it contains the correct filename and path.)

You can also use .df to tell WordStar that the data file uses a character other
than the comma as the data separator. Using another data separator may be
useful if your data contains many commas. For example, if the data file
STAR.DTA uses the asterisk (*) as the data separator, you would edit the

.df command to read

.df star.dta,*

You can use the change (or c) option to indicate that you need to change
disks while printing in order to access the data file. For example, type

.df b:wslist.dta change to say that the data file named WSLIST.DTA will be on
drive B, but it’s not there now. When you print, WordStar pauses printing and
asks you to change the disk before it reads the data file.

You can use dBASE, Lotus 1-2-3, Symphony, or Quattro files as data files.
For more information, see “Using Data Files from Other Programs” later in this
section.

INAME VARIABLES Pull-down: ALT + U, P, N

12-48

Classic: RV

Names the variable fields in a data file.
This command tells WordStar the variable names for the fields in your data file.

IMPORTANT The Data File (.df) and Name Variables (.rv) commands are
always used together in a master document, and Data File must come first.
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Follow these steps to name the variables:
1 Choose Utilities=>Merge Print Commands=>Name Variable.

2 In the Name Variables for Merge Printing dialog box, type the variable
names for all the fields in the data file, in the same order in which they
appear in each data file record. Even if data from a field is not used in a
form document, you must name the field. (You must also be sure that all
records in the data file have the same number of fields.)

3 Press F10 or choose OK.

WordStar inserts the .rv dot command followed by the variable names. You
can get the same result by typing the dot command.

The example below tells WordStar to read the data from the ADDRESS.DTA file
and use it to replace the name, address1, address2, city, state, and zip code
variables.

.df address.dta
.rv name,addressl,address2,city,state, zip

When you merge print, WordStar keeps putting data in copies of the form docu-
ment until all the data is read from the data file.

Note: If you use a data file created with MailList, don’t use Name Variable

or type the .rv command in the master document. Instead, use Insert->File

(or AKR) and insert the MAILLIST.DOT file from your MailList directory (usually
WS\OPTIONS). This file includes .rv commands that contain all the MailList
variable names in the correct order. For more information, see the “MailList”
section of the Companion Programs manual.

You can use more than one .rv command to refer to the same data file. For
example, the two .rv commands below have the same effect as the one in the
previous example.

.rv name, addressl, address?2
.rv city,state, zip
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IMPORTANT |Ifthe .rv command and the data file records don’t
correspond exactly, WordStar reads the wrong data. This happens because
WordStar counts the number of variable names in the .rv command and then
reads that many fields. Because fields can be separated either by commas or
carriage returns, WordStar reads fields from the next line (or record) if there
aren’t enough fields in the current line (or record).

If you want to use only the first few fields from each record, you can use the
* character. After the *, specify all the fields up to the last field you want to
include. For example, if each record in your data file contains 15 fields, but
you want to use only items from the first, second, and fifth fields, type

.rv* name1, name2, name3, name4, name5. When you print the file,
WordStar reads only the first five fields in each record, then goes to the next
line. (.rv* works with comma-delimited data files; it doesn’t work with data
files that use a hard return to separate each field.)

Note: If you use more than one .rv* command in a master document to read
several records, be sure to give each variable a different name. For example, if
you have a data file that lists the sales for each month, you could print a report
listing sales for the quarter by using a separate .rv¥ command for each month in
the quarter:

.rv* distAl,distBl,distCl

.rv* distA2,distB2,distC2
.rv* distA3,distB3,distC3

Pull-down: ALT + U , P, S

Classic: SV

Sets a variable name to a specific value.

This command allows you to include in a master document the data to replace
a variable. Itis useful in documents where a frequently-used word changes
from copy to copy of the document. Follow these steps:

1 Choose Utilities=>Merge Print Commands=>Set Variable.
2 In the Set Variables for Merge Printing dialog box, specify the variable

name(s) and the corresponding data. You can set up to five variables at a
time. (To set more variables, choose this command again.)
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3 Press F10 or choose OK.

WordStar inserts the .sv dot command followed by the variable name, an equal
sign, and the data. You can get the same result by typing the dot command.

For example, you might have a contract between two people, referred to in
the master contract as party1 and party2. Each time you print the contract,
you want to use new names. At the beginning of the document, enter two
Set Variable (.sv) commands. Each time you need a new contract, edit the
master document to enter the appropriate names. For one contract, the com-
mands might read

.sv partyl=Roberta Kachinsky
.sv party2=Anna Marie Casini

WordStar ignores any spaces after the comma or equal sign. If you want to
include leading or trailing spaces in data, enclose the variable in quotation
marks or apostrophes. In the example below, there are four blank spaces
before the name, so four spaces will be inserted at the beginning of the data.

.SV company=" Medcom, Inc."

SET VARIABLE TO MATH RESULT Pull-down: ALT + U, P,V
Classic: .MA

Sets the value for a variable to the result of a mathematical expression, which
can include values from other variables.

You can use this command to perform calculations while you are merge print-
ing. It lets you define a variable in terms of an expression that uses information
from other variables. For example, you could total the dollar amounts of a
customer’s monthly purchases and insert a different total for each customer.
Follow these steps:

1 Choose Utilities=>Merge Print Commands=>Set Variable to Math Result.

2 In the Set Variable to Math Result dialog box, specify the variable name.
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3 Type the expression to calculate. The expression is written like expressions
used with the onscreen calculator, except that you can use merge print
variables. The valid symbols are shown on the screen.

4 Press F10 or choose OK.

WordStar inserts the .ma dot command in the format .ma variable=expression.
You can get the same result by typing the dot command.

For example, the merge print variable that contains the total amount of a
customer’s purchases could be calculated during merge printing by using the
dot command shown below.

.ma total=&iteml&+&item2&+&item3&+&itemd&

Notice that the merge print variables to the right of the comma (or equal sign)
are surrounded by ampersands (&), while the variable to the left of the comma
(or equal sign) is not. This is because the ampersands mean “substitute the
data here.”

When you print, WordStar reads data for the variables item1, item2, item3, and
item4 from a data file, adds them, and inserts the total in the text as the data for
the total variable. You can then go on to use the total variable in another
expression. The example shown below adds sales tax to the total to get the
grand total.

.ma grandtotal=&total&*.0725+&total&

IMPORTANT When you use Set Variable to Math Result, you must be
sure that any variables you put in the expression are defined earlier in the file.
In the example above, the variables &item1&, &item2&, &item3&, and
&item4& are defined either in a data file (using Data File (.df) and Name
Variable (.rv)), or using Set Variable (.sv) or Ask for Variable (.av).
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ASK FOR VARIABLE Pull-down: ALT + U, P, A
Classic: AV

Stops printing and asks for a variable value each time the document is printed.

This command tells WordStar to pause during printing and ask you for the data
to use to replace a variable. Each time you print the file, you specify the data
and WordStar fills it in wherever the variable occurs in the file. It is useful for
documents such as contracts; for example, you can type a name once at the
beginning of printing, and it is inserted in all the appropriate places. Follow
these steps:

1 Choose Utilities=>Merge Print Commands=>Ask for Variable.

2 In the Ask for Variable dialog box, specify the variable name.

3 When you print a file with an Ask for Variable command, a prompt asks for
the data to insert. If you don’t type a prompt in the dialog box, the variable
name followed by a question mark is used. For example, if you type
amount for the variable name and don't type a prompt, when you print the
file, the prompt AMOUNT?is displayed.

If you want a different prompt, type it in the dialog box. For example, if you
type Enter the amount of the invoice, that prompt is displayed instead of
AMOUNT?

4 Press F10 or choose OK.

WordStar inserts the .av dot command followed by the prompt if you entered

one (enclosed in quotation marks and followed by a comma) and the variable

name. You can get the same results by typing the dot command. The example
below shows the .av command without a prompt:
.av name

The followihg example shows the .av dot command with a prompt:

.av "Type the full name of the client: ", name
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If you use quotation marks within the prompt, the prompt is enclosed in
apostrophes:

.av ‘Enter the "Schedule B" rate: ', rate

During background printing, when WordStar encounters the .av command,
it displays the Print wait message in the status line. To display the Printing
screen so that you can see the prompt and enter the data for the variable,
choose File=>Print or press P at the Opening screen or AKP while editing.

When using this command, keep these points in mind:

= A prompt and its answer cannot be more than one line long because the
cursor stops when it reaches the right edge of the screen. This limits the size
of answers, so if you want to leave room for longer answers, keep your
prompts short.

= For a long prompt, use the Display Message (.dm) command to display the
prompt message, then use the Ask for Variable command with no message or
a short message.

= When you type a prompt, it's best to leave one or more spaces after the last
word and before the closing quotation mark. That way, when you type the
data, it won't start in the next column after the prompt.

Pull-down: ALT + U, P, I
Classic: JIF

Enters a specific condition that must be true for WordStar to print the text
between this command and the End If command.

Conditional merge print commands in WordStar allow you to use the same
master document to produce letters that contain customized information,
depending on conditions you set. For instance, you can use one master docu-
ment and one data file to generate letters that contain one of four customized
paragraphs, depending on where the recipient lives. The three conditional
merge print commands are If, End If, and Else. They insert the dot commands
.if, .ei, and .el. For each If command, you must use a corresponding End If
command. For more information, see “Else,” “End If,” and “Using Conditional
Commands” in this section.




MERGE PRINT COMMANDS

WordStar determines if a condition is met by comparing one item with another.
The items can be variables (data items from a data file or defined in the file or at
print time) or constants (items that never change). For example, you can send
letters only to clients who purchased more than $1000 worth of merchandise,
or only to clients who live in Tennessee. Typically, one item is a variable and
the other is a constant, but you can use any combination.

WordStar can compare items to determine whether they are the same (for text)
or equal (for numbers), or if one comes before or after the other in alphabetical
or numerical order. You tell WordStar how to compare items by using one of
the following symbols, called operators.

ALPHABETICAL NUMERICAL

= is the same as #= isequal to

< comes before #> is greater than

> comes after #< s less than

<= comes before or is the same as  #>= s greater than or equal to
>= comes after or is the same as #<= s less than or equal to
<> is not the same as #<> is not equal to

Follow these steps to enter an If condition.
1 Choose Utilities=>Merge Print Commands=>If.

2 In the If dialog box, specify the two items and the operator for the condition.
Several examples are shown below these steps.

3 Press F10 or choose OK.
WordStar inserts the .if dot command followed by the condition to evaluate, in
the format .if item1 operator item2. You can get the same result by typing the

dot command.

A condition to be evaluated with the .if command is generally in this format:

.if iteml operator item2
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The following example compares a variable to a constant (the most common
type of comparison).

.if &class& = patron

In this example, the condition is met if the data item for the variable CLASS
is patron.

The operators that begin with the # symbol are used with numbers rather than
with words. It is possible for either number item being compared to contain
nonnumeric characters, but before WordStar proceeds with the comparison, it
removes all the nonnumeric characters except for the minus sign (-) and the
period ( .).

Numerically, the following items are equal because WordStar ignores all non-
numerals.

12.45
$12.45
abcld2.dcs45

If each of these three items is in the &amt& field, and you use the following dot
command, all three items meet the condition.

Lif &amté& #= 12.45

However, if you use the operator without the # symbol, only the first item
would meet the condition because numerals are considered to be alphabetic
characters that come before A. Generally, it is best to use the operators with
the # symbol when comparing numbers.

You can also compare one variable with another, as in the examples below.

.1if &VAR1& > &VAR2&
.if &VAR1l& #> &VAR2&

The condition in the first example is met if the data for VAR1 comes after the
data for VAR2 in alphabetical order. In the second example, the condition is
met if the number in VAR1 is greater than the number in VAR2.
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Normally, WordStar ignores any spaces that come between the operator and
the following item. The following commands are equivalent.

.if &class&=patron
Lif &class& = patron

For two items to be the same (=), they must have exactly the same characters
(differences in uppercase and lowercase are ignored). If you know that a data
item from a data file has spaces in front of the letters, you need to include the
leading spaces in the comparison. To include spaces, enclose both the variable
and the constant in quotation marks (or apostrophes). Thus, the condition
shown below will be met only if the data in &class& is patron preceded by
eight spaces.

.if "&class&" = " patron"
To use quotation marks in the constant along with leading spaces, enclose the
entire item in apostrophes. To use an apostrophe in the constant along with
leading spaces, enclose the entire item in quotation marks, as in the example
below.

.if "&class&" = " patron‘s"
You cannot have quotation marks, apostrophes, and leading spaces in the same
constant. If the constant has no leading spaces, you can use quotation marks

and apostrophes freely anywhere.

Words are compared in alphabetical order. The word “cat” comes before the
word “catalog” in alphabetical order, so the following conditions are true:

.1f cat < catalog
.if catalog > cat

In alphabetical order, numbers come before the letter A. For example, the
following condition is true:

.if 2 < apple
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You can also specify a variable name for just the first item, as in the example
below.

.1f &classé&

Notice that there is no operator. The condition is met if the data for &class& is
not zero and not blank.

When you use an If condition, the dot command is followed by the action to be
taken when the condition is true. If there is text after the dot command, that
text will be printed only if the condition is true. If there is another dot com-
mand after the .if command, the new dot command will be performed if the
condition is true. To indicate the end of the conditional text or commands, use
End If (.ei).

Pull-down: ALT + U, P, L
Classic: EL

Prints the text between this command and the End If only if the If condition is
not true.

When you choose Else, WordStar inserts the .el dot command in your text. You
can get the same result by typing the dot command.

For more information, see “Using Conditional Commands” in this section.

Pulldown: ALT + U, P, E
Classic: EI

Resumes regular printing after an If condition.
Each If condition you enter must have a corresponding End If command.

When you choose End If, WordStar inserts the .ei dot command in your text.
You can get the same result by typing the dot command.

For more information, see “If” and “Using Conditional Commands” in this
section.
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USING CONDITIONAL COMMANDS

You can use conditional commands for a variety of purposes. The following
sections give some guidelines.

WHAT COMES BETWEEN IF AND END IF?

Almost anything can come between an If (.iff command and its corresponding
End If (.ei). In the following example, a paragraph of text is printed in the letter
when the condition specified in the .if command is true.

.if &class& = sponsor

Thank you for joining our summer season as a Corporate
Sponsor. Your company name will be prominently listed on
our programs and brochures. We also hope that you’ll join
us for our special opening night reception with the actors
and director.

.ei

.if &class& = patron

Thank you for joining our summer season. As a Patron, you
are invited to attend our special opening night reception
with the actors and director.

.ei

If the addressee is a sponsor, the first paragraph will be printed in the docu-
ment. If the addressee is a patron, the second paragraph will be printed:

You can also insert text from other files; for example, a retailer could include
free delivery information only for customers within certain zip codes.

TIP You can keep conditional paragraphs you use often in their own files,
and easily insert them into different master documents.

USING ELSE CONDITIONS

The previous example uses two If commands to take advantage of two possible
conditions (that is, if the variable &class& is sponsor or if it's patron). You can
combine these two Ifs into one.

In other words, if the data for the variable &class& is benefactor, insert a para-

graph about benefactors’ privileges, or else insert the paragraph about the recep-
tion. The command for the “or else” is Else (.el).
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Notice that the meaning of this example is slightly different than the meaning of
the previous one. The second paragraph will be inserted if the variable is
anything other than benefactor, for example, if it’s subscriber or if the data is
missing.

.1f &class& = benefactor

Thank you for joining our summer season as a Benefactor.
Your name will be prominently listed on our programs and
brochures. We also hope that you’ll join us for our
special opening night reception with the actors and
director.

.el

Thank you for joining our summer season. We hope you will
attend our special opening night reception with the actors
and director.

.ei

NESTED .IF COMMANDS

You can use conditional merge print commands to have WordStar choose
among three or more alternatives by nesting the commands. For example, you
might want to have a special paragraph in your letters to Benefactors, a special
paragraph to Patrons, and a general paragraph to all the other subscribers on
your list. So your conditions are:

If the data for the variable &class& is benefactor, insert the file
BENEFACT.DOC; or else, if the data is patron, insert the file PATRON.DOC;
or else, insert the file SUBSCRIB.DOC.

The commands for these conditions are shown below.

.1f &class& = benefactor
.fi benefact.doc

.el

.if &class& = patron

.fi patron.doc

el

.fi subscrib.doc

.ei

.ei



MERGE PRINT COMMANDS

Every if command must have a corresponding .ei command. The .if command
may or may not have a corresponding .el command.

TIP When you type nested conditional commands, you may want to indent
each nested condition. Indenting can make it easier to work with nested Ifs.
However, if you indent, you must delete the indents before you print, because
all dot commands must begin in column 1. The example below shows how the
commands shown above appear with indenting. Note that each column begins
with the .if command and ends with the .ei command.

.1f &class& = benefactor
.fi benefact.doc
.el
.if &class& = patron
.fi patron.doc
.el
.fi subscrib.doc
.ei
.ei

The example below shows another way to use nested If commands. You want
to send a letter to everyone on your list who lives in St. Louis, Missouri, except
the people who live around the University of Missouri. Zip codes in St. Louis
range from 63101 to 63199, and the zip code for the university is 63121.

You would create a command file with the following conditional merge print
commands.

Lif &zip& #<= 63199
Lif &zip& #>= 63101
.1f &zip& #<> 63121
.fi letter.doc

.ei

.ei

.ei

The first .if command eliminates zip codes greater than 63199, and the second
eliminates codes less than 63101. The third .if eliminates the 63121 zip code.
Only zip codes that meet all three conditions generate letters. All others are
ignored.
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Go TO TOP OF DOCUMENT Pulldown: ALT + U, P, T

Classic: .GO T
Resumes printing at the beginning of the document.

When you choose Go to Top of Document, WordStar inserts the .go top dot

command in your document. You can get the same result by typing the dot
command.

When WordStar encounters this command while printing, it skips the rest of the
text in the file and goes to the beginning of the file before it resumes printing.
This can be useful with conditional commands when you want some of the text
in a document printed for certain people only.

For more information, see “Go to Bottom of Document.”

G0 TO BOTTOM OF DOCUMENT Pull-down: ALT + U, P, B
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Classic: .GO B

Resumes printing at the end of the document.

When you choose Go to Bottom of Document, WordStar inserts the .go bottom
dot command in your document. You can get the same result by typing the dot
command.

When WordStar encounters this command while printing, it skips to the end of
the file before it resumes printing. This can be useful with conditional com-
mands when you want some of the text in a document printed for certain
people only. In the following example, if the data for the variable &play& is
not Hamlet, the rest of the text in the current document is not printed in the cur-
rent letter, and WordStar skips to the bottom of the file before printing again.

.if &play& <> Hamlet
.go bottom
.ei

Note that when you use this command, it ends printing unless you are merge
printing using a data file. The .df and .rv commands cause WordStar to start
printing another copy of the document until all the data in the data file is used.
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CLEAR SCREEN WHILE PRINTING Pull-down: ALT + U, P, C
Classic: .CS

Clears the Printing screen during printing and (optionally) displays a message.

This command is useful for displaying a message that explains what’s going on
while you're printing. It clears the Printing screen of previous messages, then
displays a message if you included one. Follow these steps:

1 Choose Utilities=>Merge Print Commands=>Clear Screen While Printing.

2 Inthe Clear Screen While Printing dialog box, type the message to display
when the screen is cleared. If you don’t want a message, don’t type
anything.

3 Press F10 or choose OK.

WordStar inserts the .cs dot command into your file followed by the message if
there is one. You can get the same result by typing the dot command in the file.

You can use this command together with Display Message, described below,
which displays a message without clearing the screen. These two commands
allow you to

= Keep track of how much of a document has been printed

= Display the data that's being inserted into merge print variables

= Give reminders and instructions to the person doing the printing

For example, the command .cs Now printing letter to &name&. clears the
screen and displays the contents of the data for the &name& variable in each

letter printed. If your list is sorted alphabetically by name, it’s easy to see how
much of the list you've already printed.

IMPORTANT Ifyou are printing in the background, when WordStar
encounters a .cs command, the message Print Wait appears in the title bar. To
display the Printing screen, choose File=> Print, or use the P classic command at
the Opening screen or the ~KP classic command while editing.
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DISPLAY MESSAGE Pull-down: ALT + U, P, M
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Classic: DM

Displays a message at the Printing screen during printing.

This command is useful for displaying a message that explains what's going on
while you're printing. Follow these steps:

1 Choose Utilities=>Merge Print Commands=>Display Message.
2 In the Display Message dialog box, type the message to display.

3  Press F10 or choose OK.

WordStar inserts the .dm dot command into your file followed by the message.
You can get the same result by typing the dot command in the file.

You can use this command together with Clear Screen While Printing (.cs),
described above, and other merge print commands. These two commands
allow you to

= Keep track of how much of a document has been printed

= Display the data that’s being inserted into merge print variables

= Give reminders and instructions to the person doing the printing

For example, the following command in a form letter keeps you informed of
your progress printing the data file.

.dm The letter to &first& &last& is now being printed.

The following example shows how you can use this command in merge print-
ing when you have a long question or answer.

.cs Type the data for "union name" after the question mark.
.av "? ",union-name
.dm Thank you.
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During printing, when WordStar encounters the .cs command it clears the
screen and displays

Type the data for "union name" after the question mark.
vl

After you type the data and press Enter, it displays

Thank you.

IMPORTANT Remember that these messages are displayed on the
Printing screen, and not during background printing. To display the Printing
screen, choose File= Print, or use the P classic command at the Opening screen
or the "KP classic command while editing.

PRINT FILE N TIMES Pull-down: ALT + U, P, R
Classic: RP

Prints multiple copies of a file.

You can print more than one copy of a file in one printing session. In most
cases, the best way to print multiple copies is to use the Number of Copies
option in the Print dialog box.

The Print File n Times command is useful if you always want the file printed a

certain number of times, or if you want to print multiple copies of a file that is
nested or chained in another file. Start on the first line of the file and follow

these steps:
1 Choose Utilities=>Merge Print Commands=>Print File n Times.

2 In the Print File n Times dialog box, type the number of times you want to
print the file.

3 Press F10 or choose OK.

WordStar inserts the .rp dot command followed by the number of times to
print the file, for example, .rp 5. You can get the same result by typing the dot
command.
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Don't use this command in a master document that uses a data file. When you
use the .df and .rv commands to use a data file, WordStar automatically prints
copies for all the records in the file. If you want to print multiple copies of
each version of the document, use the Number of Copies option in the Print
dialog box.

ADVANCED MERGE PRINTING
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USING DATA FILES FROM OTHER PROGRAMS

You can use files from Lotus 1-2-3 (all versions previous to 3), Symphony,
Quattro, dBASE 11, dBASE IlI, dBASE Ill+, and dBASE IV as data files for merge
printing. For example, you can print reports from your current data, use one of
these programs as a mailing list manager, compile reference lists for footnotes
and bibliographies, or print invoices based on the data.

To specify a spreadsheet or database file, use Merge Print Commands=>Data File
or type .df filename in the master document as you would for any data file,
using the database or spreadsheet filename. WordStar treats the rows and cells
in a spreadsheet as records and fields, respectively.

Note: For WordStar to know that a file is a database or spreadsheet, the file
must have the usual extension for that type of file. For example, a dBASE file
must have the .DBF extension.

INSERTING A SPREADSHEET When you use a spreadsheet as a data file,
WordStar ordinarily uses the entire spreadsheet (or the spreadsheet in the
MAIN window for Symphony). You can specify a different range or window by
typing the information with the filename in the Data File command. For
example, the following command specifies the range H3 to T33 and

window 2: .df filename 4, h3...t33, 2. Use these rules:

® You can specify the range by using range names or cell numbers. If you use
cell numbers, you can type an asterisk to represent the last cell in the
worksheet; for example, A3..* specifies a range from A3 to the end of the
worksheet.

= If you want to specify just a window, type two commas before the window
number, for example, .df filename,,2.
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= If you specify a Symphony worksheet and don’t specify a window, WordStar
looks for the MAIN window. [f you've deleted or renamed this window, be
sure to specify a different window name.

= [f the data file is on a separate disk and you want WordStar to prompt
you to insert the disk at print time, use the change or ¢ option. Type
the c after the filename and before the range or window, for example,
.df filename c, h3..t33. Don’t type a comma before the c.

After the Data File command, use Merge Print Commands=>Name Variables,
or.rv. You can name the variables as for any data file, or you can use selected
columns, rows, or cells from the worksheet. To specify columns, type a dollar
sign ($) in front of each column letter; for example, to use only information
from columns C, J, and M, the command should read .rv $C,$),$M. If you're
using a column-major (vertically based) worksheet, specify the selected rows,
for example, .rv $1,$5,$7,$25. You can’t select both columns and rows in the
same command.

When specifying columns or rows, you can also specify a cell, for example,
.rv $C,$),$K,$T$33. This is useful if your worksheet contains a constant, such
as an hourly wage or a unit price, that you want to use in all the form letters.

Note: When you type the variable names in your master document, be sure to
include the dollar sign before the row and before the column, for example,
&$)& or &$T$33&.

When merge printing from a spreadsheet, WordStar goes to a new record after
each .rv command. If you use more than one .rv command to list all the vari-
able names in a record, use the plus sign (.rv+) to tell WordStar not to go to a
new record after that command:

.rv+ $A,$B,sC
.rv $D,SE

INSERTING A DATABASE If you specify a dBASE data file, when you use
Merge Print Commands=>Name Variables, or .rv, just type an asterisk (*) and
don’t type any variable names. The command should read .rv*. WordStar
automatically picks up all the dBASE names for the fields. Be sure the variables
in the text of the master document match the dBASE field names.
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T1P To quickly insert a list of the dBASE field names for reference, move the
cursor to column 1 and type .ig to create a comment line. Choose Insert=>File
or press KR, and type the name of the dBASE file followed by /f to insert only
the field names (for example, address.dbf/f).

dBAGSE Il Plus lets you create memo fields of unlimited length. You can name a
memo field as a variable and thus include a customized sentence or paragraph
in each letter at print time.

VARIABLE FORMATTING

Variable formatting allows you close control of the appearance of your form
documents, especially those that use merge print variables in tables or charts.

For variable formatting, you must first define formats for variables. Use

Merge Print Commands=>Set Variable, or .sv, to define each format as shown
below. You can then include any format with any variable in the master docu-
ment. After the variable name, but before the closing ampersand, type a

slash (/) and the format name. For example, if you define a format named 6 and
you want to use it with the name variable, type &name/6& when you enter the
variable in the master document.

You cannot use variable formatting and the /o option with the same variable.

The sample .sv command below defines the format named 6. You can either
type this command, or choose Set Variable and specify 6 for the variable name
and the 20 L’s for the data.

.sv 6=LLLLLLLLLLLLLLLLLLLL

After the .sv comes the format name (6), followed by either an equal sign or a
comma, then the format definition. You can use any digit or letter (except the
letter “0”) as a format name. WordStar does not distinguish between uppercase
and lowercase letters in format names.

The number of characters in a format definition sets the number of spaces in the
format. Each character in the definition represents one character space. In the
example above, the format is 20 spaces wide because there are 20 L’s. So the
total number of spaces and characters used to replace the variable in the form
document is 20.
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The first letter in a format definition sets how the data will be aligned within the
format. It is either L, R, or C. L means that data is to be inserted into the format
flush left. R means that data is to be inserted flush right. C means that data is to
be centered. Again, WordStar does not distinguish between uppercase and
lowercase letters. If the format definition does not begin with one of these char-
acters, WordStar assumes that the format is for numbers. See “Variable Number
Formatting” in this section.

If a data item is longer than the format, WordStar truncates the data item. If the
field is flush left or centered, WordStar truncates any data left over at the right
end of the data item. If the field is right aligned, WordStar truncates from the
left end of the data item.

If the first character is L, each L in the format definition will be replaced with
data or, if there is no data for the corresponding position, with a space. If the
first character is R or C, each R or C is replaced with data or space when you
print the file.

Any character (including a space) that is different from the first character ir the
field format definition is printed literally even if there is data for that position.
For example, if the format is LLXL and the data item is 1234, WordStar prints
12X4. The X is different from the L, so it is printed literally.

This process is called masking because characters in the format definition mask
out characters in the data item. The most common masking character is the
space. You can use spaces in a format definition to the left of the first L or R in
the definition. (Any other character used to mask can’t be the first character in
the format definition.) In order to include leading spaces in the format defini-
tion, you must enclose the definition in apostrophes or quotation marks. In the
example below, there are two spaces between the initial quotation mark and
the first L.

.sv 6=" LLLL"
If the data is 1234, the variable in the form document is replaced with:

(two spaces)34(two spaces)

12-69




EDITING SCREEN UTILITIES MENU

The leading spaces in the format definition mask out the first two characters of
the data item. The last two L’s in the format definition are replaced with spaces
because the field is six characters long and the data is only four characters long.

Masking works only with left- and right-aligned fields. When C is the first char-
acter in the definition, characters other than C are inserted into the data but do
not replace any characters in the data.

VARIABLE NUMBER FORMATTING

You can use variable formatting to control the appearance of numeric data
items that replace variables in your form documents. You can read the numeric
data from a data file or use Set Variable to Math Result, or .ma, to calculate
numbers during merge printing.

First, you must define formats for numeric variables. Use Merge Print Com-
mands=>Set Variable, or .sv, to define each format as shown below. You can
then include any format with any variable in the master document. After the
variable name, but before the closing ampersand, type a slash (/) and the for-
mat name. For example, if you define a format named 3 and you want to use it
with the amount variable, type &amount/3& when you enter the variable in the
master document.

The sample .sv command below defines the format named 3. You can either

type this command, or choose Set Variable and specify 3 for the variable name
and $$,$$$.99 for the data.

.sv 3=$$,$$$.99

After the .sv comes the format name (3), followed by either an equal sign or a
comma, then the format definition. You can use any digit or letter (except the
letter “0”) as a format name. WordStar does not distinguish between uppercase
and lowercase letters in format names.

The number of characters in a format definition sets the number of spaces in the
format. Each character in the definition represents one character space. In the
example above, the format is nine spaces wide because there are nine charac-
ters. So, the total number of spaces and characters used to replace the variable
in the form document will be nine.
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Numbers are always right aligned in their formats. Several different symbols are
used in number formats to specify what to do with any extra spaces at the left of
the format (for example, print zeros or print spaces) and where to put decimal
points and commas.

The chart below shows characters you can use in a number format and how

they work.

CHARACTER
9

DESCRIPTION

Substitutes a digit here. If there is no digit in the data item
for this position, substitutes a zero. For example, if you use
the format 99999.99, the data 74.97 prints as 00074.97.

Substitutes a digit here. If there is no digit in the data item
for this position, or if the digit is a leading zero, substitutes a
space. For example, if you use the format ZZ7Z77.77, the
data 74.97 prints as (three spaces)74.97.

Substitutes a digit here. If there is no digit in the data item
for this position, or if the digit is a leading zero, substitutes
an asterisk (or a zero after the decimal point). For example,
if you use the format ***** ** the data 74.97 prints as
**%74.97 and the data 74 prints as ***74.00.

Substitutes a digit here if the digit is not a leading zero;
otherwise, substitutes a space. Places a dollar sign to the
left of the first digit. For example, if you use the format
$$$$$.99, the data 74.97 prints as (two spaces)$74.97.
Note that in this example, you can only use numbers up to
9999.99. In other words, with the $, you must have one
more character in your number format than the largest
number you expect to have as data.

Substitutes a digit here if the digit is not a leading zero;
otherwise, substitutes a space. Places a minus sign directly
before the first digit if the number is negative. For example,
if you use the format -$$$$$.99, the data —-24.41 prints as
(two spaces)-$24.41. As with the $, be sure to leave
enough spaces in the format for the largest number you
expect to have plus the minus sign and the $ if you use it.
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CHARACTER DESCRIPTION

Puts the decimal point here. If the data has more decimal
places than the format, the data is truncated (the extra digits
are not printed). For example, if you use the format
9999.999, the data 4.7885 prints as 0004.788. If the data
does not include a decimal point, the whole number is
printed to the left of the decimal point. For example, with
the same format, the data 1111 prints as 1111.000.

; Puts a comma here. For example, if you use the format
99,999, the data 7497 prints as 07,497 and the data 74
prints as 00,074.

() Puts parentheses around a number if it is negative;
otherwise, substitutes spaces. The parentheses must be the
first and last characters in the format definition. For
example, if you use the format (****.99), the data —-74.97
prints as (two spaces)(74.97). As with the $ and —, be sure
to leave enough spaces in the format for the largest number
you expect to have plus the parentheses and the $ if you
also use it. For example, for the data 112345.67 to print
correctly as a dollar amount, the format must have six
characters within the parentheses before the decimal point.
The shortest format for this example is ($$$$$$.99).

The characters above are the only characters you can use in a number format.
If you use other characters, the results are unreliable.

If data is longer than the format specified for it (except for extra digits after the
decimal point), WordStar prints a series of question marks the width of the for-
mat in the form document.

REF ORMAT Pull-down: ALT + U , R
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Aligns text to the current margins and tabs.

WordStar aligns new text to the current margins and tabs, but it does not auto-
matically realign existing text after you change margins, tabs, or fonts unless
you edit that text. Use the Reformat commands to reformat existing text.
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REST OF DOCUMENT Pull-down: ALT + U, R, R
Classic: AQU

Reformats from the line that contains the cursor to the end of the document.

To reformat the rest of the document, move the cursor to the first line of text
that you want to reformat, then choose Utilities=>Reformat=>Rest of Document,
or use the AQU classic command.

WordStar reformats the rest of the document, showing the progress on the
screen. You can stop reformatting by pressing AU.

When you plan to reformat a document, you can mark certain sections of text,
such as tables or charts, that you do not want to align. Choose Layout=>Alignment
and Spacing and set Word Wrap to off, and then back to on after the section, or
use the .aw off/on dot command. For more information, see “Alignment and
Spacing” in “Editing Screen Layout Menu.”

PARAGRAPH Pull-down: ALT + U, R, P
Classic: "B

Reformats from the line that contains the cursor to the end of the paragraph.

To reformat a paragraph, move the cursor to the first line of text that you want
to reformat, then choose Ultilities=>Reformat=>Paragraph, or use the ~B classic
command.

REST OF NOTES Pull-down: ALT + U, R, N
Classic: "ONU

Reformats all notes from the cursor location to the end of the document.

This command reformats all the footnotes, endnotes, annotations, and
comments in the rest of the document. Start before the first note that you
want to reformat, then choose Utilities=> Reformat=>Rest of Notes, or use the
AONU classic command.

WordStar reformats the rest of the notes. You can stop reformatting by
pressing AU.
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REPEAT NEXT KEYSTROKE Pull-down: ALT + U, E
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Classic: AQQ

Continuously repeats a single-letter command or character.

To start a repeat operation, choose Utilities=>Repeat Next Keystroke, or use the
AQQ classic command, and then type the command or character to repeat. To
stop repeating, press any key.

You can use this command for a repetitive task such as scrolling screen by
screen to the end of the file (choose Repeat Next Keystroke and press C, or

press AQQAC).

Be sure to press the Ctrl key to repeat a command. For example, with this com-
mand, AC scrolls down screen by screen; C repeats the character C.

To vary the speed of the repetition, use the number keys at the top of the key-
board. Press 0 for the fastest repetition, 9 for the slowest, or a number between
0 and 9 for the speed you want. Press the number key after you press the com-
mand or character to repeat.



CHAPTER 13

EDITING SCREEN
HELP MENU

Use the commands on the Help menu to get onscreen help for WordStar
commands and options, and to change the way WordStar displays menus
and prompts.

Help F1
Change Help Level...

H ELP Pull-down: ALT + H, H
Classic: F1

Displays help.

You can get onscreen help for every WordStar command and for each option in
a dialog box.

Iif you are using pull-down menus, when you choose Help from the Help menu,

you get an overview of WordStar help. To get help for a specific command,
highlight it on the menu and press F1. To get help in a dialog box, press F1.
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If you are using classic menus, press F1 at the Opening Menu or at the editing
screen, and then press the command you want help with. To get help in a
dialog box, press F1.

CHAN GE HELP LEVEL Pull-down: ALT + H, C
Classic: F1 F1

Changes which menus and prompts are displayed.

The help level determines whether you see classic menus or pull-down menus,
and allows you to turn off the display of menus and confirmation prompts
altogether if you are using classic commands.

The classic menus take up one third of most screens, so turning them off by
changing from help level 3 to help level 2 allows you to see considerably more
of a document while you edit. Even when menus are not displayed, you can
still use the commands.
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Follow these steps to change the help level:

1 If you are using pull-down menus, choose Help=>Change Help Level. If you
are using classic menus, press F1 F1.

2 Choose the help level you want.

HELP

LEVEL DESCRIPTION

4 Pull-down menu names are displayed on the menu bar
at the top of the screen. To see a menu, hold down the
Alt key and press the first letter of the menu name. All
prompts are displayed. This is the default setting.

3 All classic menus and prompts are displayed.

2 The classic Edit Menu is not displayed, but prompts are

displayed. This gives a full-screen display of the document.
Other classic menus are displayed if you pause after
pressing the menu letter (MK, 2O, AP, AQ).
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HELP

LEVEL DESCRIPTION

1 No menus are displayed during editing unless you ask for
help. Dialog boxes asking you to confirm a response are
not used either.

0 Menus are not displayed unless you ask for help.

Confirmation dialog boxes are not displayed. You can
move, copy, and delete hidden blocks.

3 Press F10 or choose OK.
At help levels 2 and below, you can display the classic Edit Menu by pressing F1.

You can change the default help level at the WINSTALL Set Basic Editing
Defaults menu or using WSCHANGE (DBAA).
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FERROR MESSAGES

This appendix lists error messages that may appear on your screen as you work
with WordStar. Messages are listed alphabetically. Each explanation includes
a suggested solution for the problem. On the screen, most error messages
include a Continue button. Choosing Continue or pressing Esc clears the error
message from the screen but does not correct the error.

The words filename and macroname when underlined here are substitutes for
the actual name that WordStar displays in the message.

A filename is required.

Type a filename to continue with the command, or press Esc to cancel.

A word is too long to fit within the margins.
A word in the paragraph you just aligned is too long to fit between the margins.
Unless you hyphenate the word, it will print past the right margin.

Arithmetic error.

Something in your AQM or .ma expression produced an invalid result, for
example, division by zero, the square root of a negative number, or a non-
numeric variable.

Background printing is turned off.

Either background printing is turned off in WSCHANGE or your computer has
insufficient memory. Finish editing the file you're in, and then print the file
from the Opening screen.
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Can’t change the file you are now editing.

Finish editing and close the file you're currently working in before you try to
protect it, rename it, or copy over it.

Can’t change file. Disk may be write protected.

Copy the file to a disk or directory that is not write protected. If the file is on a
floppy disk, remove the write-protect tab. Then try again.

Can’t change windows. You must save or abandon the current note window to
return to editing the main file.

You must save or abandon the current note window to return to editing the first
file.

Can’t check spelling. Possible reasons:
* Wrong version of dictionary
* No personal dictionary
* Not enough memory for personal dictionary

Make sure you're using the dictionary that came with this version of WordStar.
If you're using a personal dictionary, make sure there is enough memory set
aside for it in WSCHANGE. Check your CONFIG.SYS file to make sure it con-
tains a FILES=30 statement (add it if it's not there). [f it does, you might try
increasing it to FILES=40. If you use WordStar to change CONFIG.SYS, be sure
to open it as a nondocument file. If you change your CONFIG.SYS file, remem-
ber to reboot your computer afterward.

Can’t create footnotes or annoftations in columns. Note converted to endnote.
Footnotes and annotations are converted to endnotes when your text has more
than one column.

Can’t create subdirectory.

The name of the subdirectory you're trying to create may already be used as a
filename or a subdirectory name. Use a different subdirectory name.

Can’t create temporary or output file.

WordStar can’t create the temporary or print-to-disk file. Make sure there is
enough room on your disk. Then check your CONFIG.SYS file to make sure it
contains a FILES=30 statement (add it if it's not there). If it does, you might try
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increasing it to FILES=40. If you use WordStar to change CONFIG.SYS, be sure
to open it as a nondocument file. If you change your CONFIG.SYS file, remem-
ber to reboot your computer afterward.

Can’t delete a protected file.

Try the Protect/Unprotect command on the Opening screen File Menu or use
the Classic command C. Also, delete any copies of the file that have the exten-
sion .$A$, .$B$, or .$G$. You can't delete a file in a protected directory. To
delete a file on a protected floppy disk, remove the write-protect tab from the
disk.

Can’t delete the file you're printing.

You tried to delete a file that is printing in the background or printing to disk.
Wait until WordStar is finished printing this file, and then delete it.

Can’t delete filename. Disk may be write protected, or file may be protected.
Retry or skip this file?

The disk or directory that contains the file might be write protected. If the file is
on a floppy disk, remove the write-protect tab.

This error can occur when you’re deleting many files at once and one of the
files is protected.

To try again to delete this file, select Retry or type R. To move to the next file,
select Skip or type S.

Can’t display graphic image.

Preview cannot display a graphic image in this file for one of three reasons. It
may be too large or complex to be converted for display, in which case it will
probably be printed properly. It may not be a valid .PIX file, in which case it
cannot be printed by WordStar without conversion. Or it may be a text mode
.PIX file (a screen capture of a text screen), which can be printed but not
displayed.

Can’t edit temporary files ($ in file extension).

You cannot edit the temporary files that WordStar uses while editing. These file
extensions include .$A$, .$B$, .$G$, .$H$, .$AW, $BW, and so on. If you
want to edit the file, and you're sure that your edit won’t create problems,
rename the file or copy it to a new file before you edit.
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Can’t evaluate that expression. Check it for correctness.
WordStar can’t interpret the math expression as it’s entered. Correct the expres-
sion and try it again.

Can’t execute command. Your computer may not have enough memory.
The operating system is unable to run a DOS command because not enough
memory is available. Exit WordStar before running the command.

Can'’t find filename.
Make sure the WordStar program files are in the WordStar (usually WS) direc-
tory. If they’re in a different directory, use WSCHANGE to change the path to
your WordStar files.

Can’t find COMMAND.COM. Check the boot (system) disk.

WordStar can’t find the DOS program COMMAND.COM to run your DOS com-
mand. WordStar looks on the drive from which you first booted your system
and on the default drive. You can change the default drive with WSCHANGE.
Can’t find file on disk.
Be sure you typed the filename correctly. Include the path if the file isn’t on the
current drive or directory.
Can’t find macro macroname.

The macro that is running has called a nonexistent macro.

Can’t find that file. Create a new one?

You typed a new filename. If you want to create a new file, choose OK. If you
want to edit an existing file, choose Cancel, and type the correct filename. If
the file is on a different drive or directory, type the drive letter or directory path
before typing the filename.

Can’t find the file filename.

Make sure the WordStar program files are in the WordStar (usually WS) direc-
tory. If they are in a different directory, use WSCHANGE to change the path to
your WordStar files.
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Can’t insert a password-protected worksheet.

You tried to insert a spreadsheet program worksheet that is password-protected.
You must remove the protection before you can insert the worksheet.

Can’t insert a compressed worksheet.

You tried to insert a spreadsheet program worksheet that has been compressed.
WordStar does not accept compressed worksheets.

Can’t load GRFPIX.EXE.

You can’t display graphics because WordStar can’t load the GRFPIX.EXE pro-
gram. Make sure there is enough memory available. Check your CONFIG.SYS
file to be sure it contains a FILES=30 statement (add it if it's not there). If it
does, you might try increasing it to FILES=40. If you use WordStar to change
CONFIG.SYS, be sure to open it as a nondocument file. If you change your
CONFIG.SYS file, remember to reboot your computer afterward.

Can’t load Inset. Possible reasons:
* Not enough memory
* IN.SET not found
* SETUP.COM not found
* Inset not installed

Be sure Inset is installed on your computer and that you’ve run the Inset Setup
program. Make sure there is enough memory on your computer. Check your
CONFIG.SYS file to be sure it contains a FILES=30 statement (add it if it's not
there). If it does, you might try increasing it to FILES=40. If you use WordStar
to change CONFIG.SYS, be sure to open it as a nondocument file. If you
change your CONFIG.SYS file, remember to reboot your computer afterward.

Can’t move to undefined marker.
Use K, followed by a number from 0 to 9, to set the marker before trying to
move to it. You can also choose the Edit—Set Marker command.
Can’t open a window while background printing is in progress and Inset is
loaded. You can open a window when printing is complete.

There’s not enough memory to open a window because background printing is
active and Inset is loaded. When printing is complete, try again to open a
window.
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Can't print. PDF or driver files not found.
Make sure the printer description file (PDF) and the necessary driver overlay
files (DRIVERN.OVR) are in the WordStar directory.

Can’t print. Prologue file not found.
WordStar can’t find the PostScript initialization file WSPROL.PS. Be sure the
printer description file (PDF) for your PostScript printer and the necessary
drivers are in the WordStar directory.

Can’t rename a protected file.
The file you are trying to rename, or the directory it’s in, is protected. Before
you can rename a protected file, unprotect it. Then try again.

Can’t rename file.
There are two possible reasons for this message:

® You specified a drive letter for a new file that is different from the drive
where the original file is located. If you want the file on another drive, copy
it to that drive.

® The operating system won’t let WordStar rename the file. The name you
chose is probably already being used by a directory, a hidden file, or another
system file. Choose a different filename.
Can’t run macros in second copy of WordStar.
When a second copy of WordStar is loaded using Run DOS Command, macros
do not function in the second copy.
Can’t save file until printing is finished.

You tried to save a file that is currently being used by background printing (for
merge printing or printing to disk, for example). Wait until WordStar is finished
printing this file, and then save it.

Can’t sort long line.

A line of text selected to sort is longer than 4000 characters. Shorten the long
line and try the sort again.




ERROR MESSAGES

Can'’t store results. Disk full or filetype conflict.

WordStar can’t create the index (.IDX) or table of contents (.TOC) file because
your disk is full or your file uses the extension .IDX or .TOC. Create room on
your disk by moving or deleting files, or rename the current file with a different
extension.

Can’t update dictionary. Disk may be full, protected, not in drive, or does not
exist.

WordStar is unable to add the word you requested to the personal dictionary
(PERSONAL.DCT). You can delete words to make room or increase memory
for the dictionary in WSCHANGE. Also, make sure that PERSONAL.DCT hasn’t
been opened in WordStar in document mode. If it has, reopen it as a WordStar
nondocument and save it.

Change the extension for the original text file.
The default file extension for a table of contents is .TOC. Change the file exten-
sion to .TOC.

Converted file must have .PIX extension.

When you insert a graphic file, it must have the .PIX filename extension. Check
that the filename is specified correctly and try again. Also, it’s possible that the
Inset graphic file, which normally has the .PIX extension, has been renamed.
Cursor is not on a note.
The note command you are using requires that the cursor be on the note. Move
the cursor to the note and try again.
Disk full error.

Your disk is full. You need to make space on your disk by deleting files or
moving them to other disks. If you were creating fax files, the fax files may be
incomplete.

Disk I/O error.

DOS has encountered an input/output error. Try the DOS CHKDSK command
to see if you can repair the error, or refer to your DOS manual.
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Duplicate file prefix.

The first five characters of a fax filename must be unique. Check the fax direc-
tory to see if there are files with the same five-character prefix. Choose a fax
filename with a unique name or delete existing fax files that are no longer
needed.

Either the personal or the exceptions dictionary is full. Increase the memory for
the dictionaries or open a window on the personal dictionary or the exceptions
dictionary and remove some words.

You can increase the memory for the dictionaries in WSCHANGE or delete
some words in the dictionary being used.
End of block is at or before start of block.

The beginning block marker must precede the end block marker in your text.
In column block mode, the beginning block marker must also be to the left of
the end block marker.

End of block is not below and to right of start of block.

The block markers do not mark a valid column. Set the beginning block marker
in the upper-left corner and the ending marker in the lower-right corner of the
column block.

Enter new name for macro.

When you rename an existing macro, the New Macro Name option cannot be
blank. Type the new name for the macro and continue.

Expression is too complex.

Your math expression is too complicated for WordStar to handle. Rewrite it in
several smaller expressions.

File access denied by DOS. Check subdirectory and device names.

DOS is preventing you from opening a file because the file has the same name
as a subdirectory or DOS device. Rename the file and try again.
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File creation error.

WordStar cannot create a file. It might be because a disk is full, a root directory
is full, or a disk is write-protected. Check the CONFIG.SYS file to make sure it
contains a FILES=30 statement (add it if it's not there). If it does, you might try
increasing it to FILES=40. If you use WordStar to change CONFIG.SYS, be sure
to open it as a nondocument file. If you change your CONFIG.SYS file, remem-
ber to reboot your computer afterward.

File error. The disk may be full, or there was a disk write error, or CONFIG.SYS
file lacks the line FILES=20 (for DOS version 2.x) or FILES=30 (for DOS version
3.0 and above).

If necessary, delete files to make room. You may want to copy one or more
files to another disk before deleting them. Check your CONFIG.SYS file to
make sure it contains a FILES=30 statement (add it if it's not there). If it does,
you might try increasing it to FILES=40. If you use WordStar to change
CONFIG.SYS, be sure to open it as a nondocument file. If you change your
CONFIG.SYS file, remember to reboot your computer afterward.

File is currently in use.
The file you’re trying to edit is being used for printing to an output file. Wait for
printing to finish and try again.

File write error.

You cannot write to the specified file. The disk might be full, write protected,
or damaged.

If you're using WordStar in a local area network (LAN) environment, check that
you’ve specified a valid drive and directory for fax files and Preview work files
in WSCHANGE.

Function argument error in macro.
A macro function argument is missing, too long, or of the wrong data type. Edit
the macro.

Global replacement word list is full.

To clear the buffer, stop the spelling check (noting how far you got) and save
the file. Then reopen the file, move to the spot where you left off, and begin
the spelling check there.
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Help messages are not available. Either WordStar was unable to find the
WSHELP.OVR file, or you have used WSCHANGE to turn help off and make
WordStar memory-resident.

Make sure the WSHELP.OVR file is on your disk. Also make sure help is turned
on in WSCHANGE.

Hidden block. Press ~KH and try again.

You're trying to copy, move, or delete text that contains hidden block markers.
Press AKH or choose View=»Block Highlighting to make the markers reappear,
and then try again.

Hyphenation disabled or not enough memory.

Either hyphenation is turned off in WSCHANGE or there’s not enough memory
available on your computer. Check your CONFIG.SYS file to make sure it con-
tains a FILES=30 statement (add it if it's not there). If it does, you might try
changing it to FILES=40. If you use WordStar to change CONFIG.SYS, be sure
to open it as a nondocument file. If you change your CONFIG.SYS file, remem-
ber to reboot your computer afterward.

Ignore word list is full.

To clear the buffer, stop the spelling check (noting how far you got) and save
the file. Then reopen the file, move to the spot where you left off, and begin
the spelling check there.

Insufficient memory for background printing.

Wait until you finish editing, and then print the file from the Opening screen.

Invalid expression.

A value requires a length in columns, inches, points, or centimeters. Reenter
the information.

Invalid macro file.

The macro file has been damaged and it needs to be recompiled. To recompile
a macro, choose Utilities—Macros->Edit/Create, or press AMD. When you save
the macro, it is recompiled. Then try running it again.
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Invalid or missing external graphics driver program.

You requested that WordStar load an external graphics driver to interface
Preview with your monitor. The graphics drivers are files with a .WGD exten-
sion and are specified in the CRT.TYPE= line in FONTID.CTL. The name was
typed incorrectly, the driver file can’t be found, or the driver is incorrect for
your monitor.

Use WordStar to edit FONTID.CTL as a nondocument file to correct the
CRT.TYPE= line. If you're not using an external graphics driver, select the num-
ber for your monitor from the list of drivers in the FONTID.CTL file. If it still
doesn’t work, try reinstalling FONTID.CTL. For more information about the
FONTID.CTL file, see the Installing and Customizing booklet.

Left margin is greater than right margin.
Set the margins of your document so that the left margin is to the left of the right
margin.

Macro interrupted by user.

The macro that was running was interrupted when you pressed Esc or ABreak.

Macro is write protected.

You can’t edit the macro because it’s write-protected. If the file is protected,
unprotect it by choosing File—»Protect/Unprotect, or press AKC. If the directory
is protected, copy the macro to a disk or directory that is not write protected. If
the macro is on a floppy disk, remove the write-protect tab.

Macro not found.

Check the names and hot keys of existing macros in the list in the Play Macro
dialog box to be sure you’ve specified the correct macro name or pressed the
correct hot key for the macro you want to run.

Macro stack overflow.

There are too many PlayMacro commands or Call subroutines without Returns
in the macro that is running. Edit the macro and run it again. If it's a long
macro, try breaking it into two shorter macros.
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Macro stopped. Unable to execute specified command in this context.

Macro playback stops when the specified function cannot be executed at the
time it’s invoked. For example, the help level cannot be set in Preview. Edit
the macro to eliminate the error.

Mismatched parentheses.

The number of opening parentheses does not match the number of closing
parentheses. Check your expression and correct it.

Must have graphics display to run Preview.

Your monitor may not support graphics. It's also possible that the graphics
driver program is invalid or missing. Make sure the CRT.TYPE= line in the
FONTID.CTL file correctly specifies the type of monitor you have. For more
information about the FONTID.CTL file, see the Installing and Customizing
booklet.

New file already exists.

You’re trying to create a file that already exists. Choose File=»Open and type a
new filename.

No block defined yet or doing copy/move in wrong window.

Define both the beginning and end of the block before you copy it, move it, or
write it to disk. Also, be sure you're in the target window before you copy or
move a block between windows.

No disk in drive or not a valid DOS drive.

DOS can't find the disk drive you specified. For more information, see your
DOS manual.

No fonts defined in the FONTID.CTL file.

Check the FONTID.CTL file for font entries (screen font files have a .WSF
extension). Font entries are usually found at the end of the FONTID.CTL file,
and each entry begins with two numbers and an equal sign, for example,

01=, 02=. There should be at least one font entry in FONTID.CTL. If the file’s
empty, use COPYWS to copy the file again using the original WordStar disks.
For more information, see the Installing and Customizing booklet.
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No numbers in the block to add or subtract.

Before you use block math, be sure to mark the block correctly. You can’t use
block math if there are no numbers in the block you’ve marked.

No second window or not enough memory.

No second window is open. You may not have enough available memory to
open the window.

Not a valid directory path.

The path you entered is misspelled, incomplete, or doesn’t exist on the
specified drive. Enter the correct path.

Not a valid fax filename.

Be sure the fax filename is typed correctly. A fax filename starts with five char-
acters, followed by three numbers that represent the page number at which the
fax will begin. The file extension is always .PCX. Make sure the first five char-
acters are unique for each fax filename.

Not a valid filename.

Type the filename correctly. Include a drive letter or directory path if the file is
not on the current drive or directory. A filename can have up to eight charac-
ters and an optional three-character extension. Type a period between the
name and the extension. Don't use spaces between characters. For more infor-
mation about filenames, see the Reference manual.

Not a valid worksheet range.

The range you specified in the spreadsheet program worksheet doesn’t exist.
Check the worksheet and reenter the range.

Not a valid worksheet window.

The window you specified in the spreadsheet program worksheet doesn’t exist.
Check the worksheet and reenter the window information.

Not enough memory to continue.

Your computer has enough available memory to start WordStar, but not enough
to create necessary buffers and to load printer information. If you have memory-
resident programs running, exit them before you start WordStar again.
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Not enough memory to print.

WordStar loads either the default printer description file (PDF) or the one you
named at the Printer name prompt. Either the PDF is not valid or there is not
enough memory available to hold both the PDF and the driver overlay file.

Make sure you specify a valid printer name and that the PDF is on your disk.

Be sure the path in WSCHANGE is set correctly, and check for the necessary
driver overlay file. If you're trying to print while editing a document, try closing
the document and printing from the Opening screen. To check WordStar
memory usage, choose File=»Status or press ? at the Opening screen. If you are
running a memory-resident program with WordStar, exit WordStar, and exit the
other program before you start WordStar again.

Not enough memory to run program.

Your computer has enough available memory to start WordStar, but not enough
to create necessary buffers or to run Preview. Additional memory may be
required to display a graphic image. Press any key and Preview continues
without displaying all graphics. To obtain more memory, you may need to exit
WordStar. If you have other memory-resident programs running, exit them
before you start WordStar again.

Not in the directory.

The printer, font, range, window, or color you specified is not available.
Choose one that is listed in the directory on the screen.

Please type a valid macro name.

You must specify an existing macro name.

Save your work before printing this file.

When using background printing for the file you are currently editing, WordStar
prints the version of the file that you most recently saved. The latest changes to
this file have not been saved. To save the changes choose File=»Save, or

press AKS. Then print the file.

Second window is in use, or there is insufficient memory to edit note.

Either you are trying to create a note when you have two windows open, or
there is not enough memory to create the note. You may need to exit
WordStar, remove memory-resident programs, and start WordStar again. For in-
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formation about changing the amount of memory used by WordStar, see the In-
stalling and Customizing booklet.

Spelling checker disabled or not enough memory.

Either the spelling checker is turned off in WSCHANGE or there’s not enough
available memory. You may need to exit WordStar, remove memory-resident
programs, and start WordStar again. For information about changing the
amount of memory used by WordStar, see the Installing and Customizing
booklet.

Start past end of document.

When you entered the range of pages for a fax file creation, the first page num-
ber in the range was beyond the end of the document. These pages and any
subsequent requests for pages will not be included in the fax file. You can
choose the View option in the fax dialog box (or Preview) to determine the
correct range of pages. Remember to specify physical page numbers, not
renumbered ones. Then try again.

That drive is not on the list of legal drives.

Type a legal drive letter. You can add drives to the list of legal drives in
WINSTALL or WSCHANGE. When typing a filename, be sure to follow the
drive letter with a colon.

That drive is write protected.

Copy the file to a drive or disk that is not write protected, or remove write
protection from the drive (with a floppy disk, remove the write-protection tab).

That file is being edited. Temporary files with the same name exist. You can
look at the file but you can’t change it. (You can only look at a portion of large
files.) Look at the protected file?

The current directory contains one or more files with the same name as the one
you specified, but with the extension .$A$, .$B$, or .$G$.

This condition occurs primarily on LAN systems. Another user may be working
with the file you want to edit, or may be editing another file with the same
name but a different extension. (The temporary files for the two files would
have identical filenames.) The temporary file(s) could be left over from a pre-
vious editing session that was aborted by a system failure.
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Select OK to view the protected file. If you want to edit the file, wait until the
other person is done. If no one else is editing the file, check for the temporary
files and erase them. If this condition occurred because two files have the same
name but have different extensions, change one of the filenames or move one
of the files to a different directory.

That file is not a column (line lengths vary). You can:
* Insert the entire file.
* Insert the file up to the point where it starts to vary.
* Insert the file up to the point where it starts to vary and highlight it (for easy
deletion). Which option (1/2/3)?

When you use column block mode, WordStar assumes that a file you import is
a file with text in columns, that is, that all lines are the same length. To con-
tinue, choose one of the three options.

The block is too large to be restored later. Delete anyway?

The block of text is so large that you won'’t be able to restore it using the Undo
command. Erase the text only if you are sure you won't want to restore it. You
can change the size of the unerase buffer in WSCHANGE.

Thesaurus disabled or not enough memory.

Either the thesaurus is turned off in WSCHANGE or there’s not enough memory
available on your disk. You may need to exit WordStar, remove memory-
resident programs, and restart WordStar.

Too much space between columns, or too many columns.

You can have up to 8 columns in a WordStar document. Be sure the total
amount of space between the columns is not greater than the right margin. Ifit
is, either reset the margins or change the gutter values. Then try again.

Unable to check spelling while background printing is in progress and Inset is
loaded. Restart spelling check after printing is finished.

There’s not enough memory to check spelling and print at the same time. Wait
until printing is complete before you restart spelling check.
Up to 32 tabs will be saved.

You've set more tab settings than WordStar can save. Clear some of the tab
settings.
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User cancelled fax creation.

You pressed the Esc key during the fax file creation and the fax file is incom-
plete. Delete the fax file and try creating it again, or use the SHOWPCX.EXE
program to view the contents of the file before transmitting it.

Wrong version filename.
This file is from a previous release of WordStar. If you have files from a pre-
vious release that you no longer use, erase the old program files.

You must use the Inset that comes with WordStar.

You're using a version of Inset that did not come with your WordStar program.
You must install the version of Inset that is included with WordStar.




APPENDIX B

AScIT CONVERSION
CHARTS

This appendix consists of three charts. The first chart lists decimal, hexadecimal, mnemonic,
control code, and ASCII characters for characters 0-31. The second chart lists the characters
32-255 for code page 437. The third chart lists the characters 32-255 for code page 850.

DEC

000
001
002
003
004
005
006
007
008
009
010
011
012
013
014
015

HEX

00
01
02
03
04
05
06
07
08
09
0A
0B
0C
0D
0E
OF

MNEM

NUL
SOH
STX
ETX
EOT
ENQ
ACK
BEL
BS
HT
LF
VT
FF
CR
S0
SI

CTRL
@
~A
"B
w6
~D
AE
AF
"G
AH
AL
AJ
8K
AL
M
AN
~0

CHAR

t&roo@ode» *e €0

DEC

016
017
018
019
020
021
022
023
024
025
026
027
028
029
030
031

HEX

10
11
12
13
14
15
16
17
18
19
1A
1B
1C
1D
1E
1F

MNEM

PLE
DC1
DC2
DC3
DC4
NAK
SYN
ETB
CAN
EM
SUB
ESC
FS
GS
RS
us

CTRL
~p
~Q
AR
AS
AT
AU
Ay
W
Ax
AY
rZ
i
A\
~

A

CHAR

AP LT Tl e @AY

Key: Dec = Decimal Hex = Hexadecimal Mnem = Mnemonic Ctrl = Control code Char = ASCII character
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CODE PAGE 437

DEC

032
033
034
035
036
037
038
039
040
041
042
043
044
045
046
047
048
049
050
051
052
053
054
055
056
057
058
059
060
061
062
063
064
065
066
067
068

HEX

20
21
22
23
24
25
26
27
28
29
2A
2B
2G
2D
2E
ZF
30
31
32
33
34
35
36
37
38
39
3A
3B
3C
3D
3E
3F
40
41
42
43
44

CHAR

SR 3R 4 SR

& e e

OO NP WD = O
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DEC

069
070
071
072
073
074
075
076
077
078
079
080
081
082
083
084
085
086
087
088
089
090
091
092
093
094
095
096
097
098
099
100
101
102
103
104
105

HEX

45
46
47
48
49
4A
4B
4C
4D
4E
4F
50
51
52
53
54
55
56
57
58
59
5A
5B
5C
5D
5E
5F
60
61
62
63
64
65
66
67
68
69

CHAR

S I N<X<X=E<CHWLWXXxOVWVWO=Z=rXGHIIo™mTMm

.

- T QA —Hh o QA 0O T w

DEC

106
107
108
109
110
111
112
113
114
115
116
114
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142

HEX

6A
68
6C
6D
6E
6F
70
vl
72
73
74
7ES
76
7%
78
79
7A
7B
76
7D
7E
il
80
81
82
83
84
85
86
87
88
89
8A
8B
8C
8D
8E

CHAR
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DEC

143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180

HEX

8F
90
91
92
93
94
95
96
97
98
99
9A
9B
9C
9D
9E
9F
A0
Al
A2
A3
A4
A5
A6
A7
A8
A9
AA
AB
AC
AD
AE
AF
BO
B1
B2
B3
B4

0
I
>
=

© IO KD e IO SO OOt O PR D

J7 e

DEC

181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218

HEX

B5
B6
B7
B8
B9
BA
BB
BC
BD
BE
BF
Co
C1
C2
C3
C4
C5
Cé
C7
C8
€9
CA
CB
cC
CD
CE
CF
DO
D1
D2
D3
D4
D5
D6
D7
D8
D9
DA

CHAR

==

=

il

Y.

Lo — )

F=-+ | —4 + =

I= =

“H=F=3 m o+~ =3 4

-

DEC

219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255

CODE PAGE 437

HEX

DB
DC
DD
DE
DF
EO
E1
E2
E3
E4
ES
E6
E7
E8
E9
EA
EB
EC
ED
EE
EF
FO
F1
F2
F3
F4
F5
F6
F7
F8
F9
FA
FB
FC
FD
FE
FF

CHAR
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CODE PAGE 850

DEC

032
033
034
035
036
037
038
039
040
041
042
043
044
045
046
047
048
049
050
051
052
053
054
055
056
057
058
059
060
061
062
063
064
065
066
067
068

HEX

20
21
22
23
24
25
26
27
28
29
2A
28
2¢
2D
2F
2F
30
31
32
33
34
35
36
37
38
39
3A
38
3C
3D
3E
3F
40
41
42
43
44

CHAR

e O 0O NOOT P WMN O N -
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DEC

069
070
071
072
073
074
075
076
077
078
079
080
081
082
083
084
085
086
087
088
089
090
091
092
093
094
095
096
097
098
099
100
101
102
103
104
105

HEX

45
46
47
48
49
4A
4B
4C
4D
4E
4F
50
51
52
53
54
55
56
57
58
59
5A
5B
5C
5D
5E
5F
60
61
62
63
64
65
66
67
68
69

CHAR

S, MmN < X Es<sC—WMxooxOo Vo= rr ARG TITommm
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DEC
106
107
108
109
110
i g
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142

HEX

6A
6B
6C
6D
6E
6F
70
71
72
73
74
75
76
77
78
79
7A
7B
1C
7D
7E
WE
80
81
82
83
84
85
86
87
88
89
8A
8B
8C
8D
8E

CHAR
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~
Qv

o~ = = D D D D) Qe Qo Ay Dy Sk S



DEC

143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180

HEX

8F
90
91
92
93
94
95
96
97
98
99
9A
98
9C
9D
9E
9F
A0
Al
A2
A3
A4
A5
A6
A7
A8
A9
AA
AB
AC
AD
AE
AF
BO
B1
B2
B3
B4

0
I
>
=
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® o
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DEC

181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218

HEX

B5
B6
B7
B8
B9
BA
BB
BC
BD
BE
BF
co
C1
C2
C3
C4
C5
Cé
c7
C8
C9
CA
CB
cC
cb
CE
CF
DO
D1
D2
D3
D4
D5
D6
D7
D8
D9
DA

0
e
>
~

=== @ B > P

==

FPo—+ | =4 -~ &K e

=
==

===l |

e
S

S - mememe B O
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DEC

219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255

CODE PAGE 850

HEX

DB
DC
DD
DE
DF
EO
El
E2
E3
E4
E5
E6
E7
E8
E9
EA
EB
EC
ED
EE
EF
FO
F1
F2
F3
F4
F5
F6
F7
F8
F9
FA
FB
FC
FD
FE
FF

CHAR
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APPENDIX C

Macro
KEYSTROKES

This appendix describes the keystroke conventions used for the WordStar macro
system, and provides a table of all the keystrokes that the macro system recog-
nizes. For more information about macros, see “Macros” in “Utilities Menu.”

THE KEY( ) FUNCTION

The Key( ) macro function provides keystrokes to the application. The argument
of Key( ) is a keystroke string. For example, “Good Morning!{Enter}” is a valid
keystroke string, and to have it typed into WordStar you’d include the statement
KEY(“Good Morning!{Enter}”) in a macro. For guidelines for entering keystrokes
in the Key( ) function, see “The Macro Language” in “Macros” in “Editing Screen
Utilities Menu.”

TYPES OF KEYSTROKES

A keystroke is defined as the act of either pressing a single key or pressing a
number of keys at the same time. Keystrokes generate codes that are inter-
preted in one of two ways:



MACRO KEYSTROKES

= A keystroke can be an alphanumeric character, a punctuation mark, or
symbol such as A, ;, or . These are all called characters.

= A keystroke can be a command to perform an action such as delete a
character, move the cursor up one line, or start a new line. These
keystrokes are called application defined keystrokes.

The Key() function provides both types of keystrokes. The first type of
keystroke is represented in the keystroke string by simply entering the charac-
ter. The second type of keystroke is represented by a description as shown in
the table. Generally, the keystroke description is the same as the one that
appears on the key cap on the US keyboard. It is usually enclosed in braces
({}). (To enter an actual { or }, you double the character, for example, { { .)

A keyboard may contain more than one key that has the same general mean-
ing. To differentiate between keys with similar meanings, the following con-
ventions are used:

= Characters and descriptions enclosed in square brackets represent keys on
the numeric key pad, for example, [Enter]. Some of these keys are only
available on enhanced keyboards.

= Descriptions enclosed in parentheses represent the cursor and edit pad keys
on enhanced keyboards, for example, (UP) and (Del).

Combining these conventions leads to keystroke descriptions like {Enter},
{[Enter]}, and {(UP)}.

SHIFTED KEY DESCRIPTIONS

Keyboards have three types of keys that can be used with other keys, the Shift
key, the Control key (Ctrl), and the Alt key. Some non-US keyboards also have
a fourth key, the right Alt key (AltGr), which is used to generate additional
alphanumeric symbols. These keys are represented in macros enclosed in
braces with the accompanying key, for example, {Ctrl C}, {Alt A}, and {Shift F1}.

For alphabetic characters, punctuation marks, and other symbols, don’t indi-
cate the Shift key required to generate the keystroke; just enter the character as
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you normally would. For example, {Shift a} does not produce A. This is also
true for the AltGr shift key, which is used to generate characters, not instruc-
tions. For example, on a German keyboard, don’t represent / as {AltGr [3}.

I(EYSTROKES IN RECORDED MACROS

When a recorded macro is translated into a macro source file, keystrokes from
enhanced keyboards are translated into the equivalent keystrokes from unen-
hanced keyboards. For example, {(UP)} becomes {UP}. The same is true for
numbers and symbols on the numeric keypad; for example, {[1]} becomes 1.

If a specific keystroke is required, you can edit the macro and enter the
extended or numeric keypad description. When the macro is compiled, the
indicated scan code and character combination are used.

Note: When you execute a macro, it provides keystrokes to WordStar in the
same general way that the BIOS keyboard i/o service does. WordStar often per-
forms additional processing on a keystroke prior to acting on it. For example,

if you press AKAQ while recording (without taking your finger off of the control
key before pressing QQ), the macro file shows {CTRL KHCTRL Q}. During
playback, the WordStar editor takes the same action as if the source file con-
tained {CTRL K}Q.

I(EYSTROKES NOT IN THE TABLE

The table in this appendix shows the standard keystrokes based on the US key-
board in code page 437. Other keyboards and code pages can produce dif-
ferent keystroke codes. When a recorded macro is translated into a macro
source file, all recognizable codes are translated into US keyboard equivalents.
These equivalents may be particular keys or extended characters.

To enter a specific keystroke not in the table, enter it in {xxx,yyy} format,
where xxx is the high byte and yyy is the low byte of the decimal value of
the code.
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Any unrecognized keystroke code is translated into this same format when a
recording is translated into source code.

THE WORDSTAR MACRO US KEYSTROKE TABLE

The following table shows the valid keystrokes for WordStar macros.

The first column of the table shows the character or description associated
with each keystroke.

The second column shows the hexadecimal value of the code returned by
BIOS Interrupt 16H for each keystroke. This is called the keystroke code.
The high byte is usually called the scan code, and the low byte is usually
called the ASCII code. For text and punctuation keystrokes, the ASCII code
(low byte) is the number associated with the character.

The third column shows the decimal values of the high and low byte of the
keystroke code.

The fourth column indicates if the particular keystroke is available only on
an enhanced keyboard. It also shows keystrokes that are specific to
WordStar.

The last part of the table includes all the extended characters (those with
decimal codes 1 to 31 and 128 to 255). The characters shown in the table are
those displayed on the screen for the IBM symbol set for code page 437. (If
you're using a different code page, different characters are displayed on the
screen. The characters that are printed depend on the symbol set for the font
you use for printing.) You can enter extended characters in several ways. For
more information, see “Extended Character” in “Insert Menu.”



KEYSTROKE
DESCRIPTION

{BACKTAB}
{BKSP}
{DEL}
{(DEL)}
{DOWN}
{(DOWN)}
{END}
{(END)}
{ENTER}
{[ENTER]}
{ESC}
{HOME}
{(HOME)}
{INSERT}
{(INSERT)}
{LEFT}
{(LEFT)}
{PGDN}
{(PGDN)}
{PGUP}
{(PGUP)}
{RIGHT}
{(RIGHT)}
{TAB}
{(shy
{urP}
{cup)}
space

[*1}

OF
OF
53
53
50
50
4F
4F
1c
EO
01
47
47
52
52
4B
4B
51
51
49
49
4D
4D
OF
4c
48
48
39
02
28
04
05
06
08
28
0A
0B
09
37

00
08
00
EO
00
EO
00
EO
0D
0D
1B
00
EO
00
EO
00
EO
00
EO
00
EO
00
EO
09
00
00
EO
20
21
22
23
24
25
26
27
28
29
2A
2A

THE WORDSTAR MACRO US KEYSTROKE TABLE

015
014
083
083
080
080
079
079
028
224
001
071
071
082
082
075
075
081
081
073
073
077
077
015
076
072
072
057
002
040
004
005
006
008
040
010
011
009
055

000
008
000
224
000
224
000
224
013
013
027
000
224
000
224
000
224
000
224
000
224
000
224
009
000
000
224
032
033
034
035
036
037
038
039
040
041
042
042

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

keyboard
keyboard
keyboard

keyboard

keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard

keyboard
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KEYSTROKE
DESCRIPTION HEX ECIMAL NOTE
+ 0D 2B 013 043
{[+1} 4E 2B 078 043
, 33 2C 051 044
- 0C 2D 012 045
{-1 4A 2D 074 045
. 34 2E 052 046
{[.]1} 53 2E 083 046
/ 35 2F 053 047
{[/1} E0 2F 224 047 Enhanced keyboard
: 27 3A 039 058
: 27 3B 039 059
< 33 3C 051 060
= 0D 3D 013 061
> 34 3E 052 062
? 35 3F 053 063
@ 03 40 003 064
[ 1A 5B 026 091
\ 2B 5C 043 092
] 1B 5D 027 093
A 07 5E 007 094
_ 0C 5F 012 095
‘ 29 60 041 096
{ 1A 7B 026 123
| 2B 7C 043 124
} 1B 7D 027 125
~ 29 7E 041 126
n/a 00 7F 000 127
0 0B 30 011 048
{[01} 52 30 082 048
1 02 31 002 049
{[11} 4F 31 079 049
2 03 32 003 050
{[2]1} 50 32 080 050
3 04 33 004 051
{31} 51 33 081 051
4 05 34 005 052
{[41} 4B 34 075 052
5 06 35 006 053
4C 35




KEYSTROKE
DESCRIPTION

6
{[61}
7
{71}
8
{81}
9
{[91}

D AOO0O T N<XE<C—HULVOXVO VOZIMNCrXANoLAITOGTMMOO®>

07
4D
08
47
09
48
0A
49
1E
30
2E
20
12
21
22
23
17
24
25
26
32
31
18
19
10
13
1F
14
16
2F
11
2D
15
2C
1E
30
2E
20
12

HEX

36
36
37
37
38
38
39
39
41
42
43
44
45
46
47
48
49
4A
4B
4c
4D
4E
4F
50
51
52
53
54
55
56
57
58
59
5A
61
62
63
64
65

DECIMAL

007
077
008
071
009
072
010
073
030
048
046
032
018
033
034
035
023
036
037
038
050
049
024
025
016
019
031
020
022
047
017
045
021
044
030
048
046
032
018

054
054
055
055
056
056
057
057
065
066
067
068
069
070
071
072
073
074
075
076
077
078
079
080
081
082
083
084
085
086
087
088
089
090
097
098
099
100
101

THE WORDSTAR MACRO US KEYSTROKE TABLE
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KEYSTROKE

DESCRIPTION HEX

K X E < C ctn 35S0 T O S 3 — X = TTAQ —h

N

{CTRL+BKSP}
{CTRL+BREAK}
{CTRL+DEL}
{CTRL+(DEL)}
{CTRL+DOWN}
{CTRL+(DOWN)}
{CTRL+END}
{CTRL+(END)}
{CTRL+ENTER}
{CTRL+[ENTER]}
{CTRL+HOME}
{CTRL+(HOME)}
{CTRL+INSERT}
{CTRL+(INSERT)}
{CTRL+LEFT}
{CTRL+(LEFT)}
{CTRL+PGDN}
{CTRL+(PGDN)}

21
22
23
17
24
25
26
32
31
18
19
10
13
1F
14
16
2F
11
2D
15
2C
OE
00
93
93
91
91
75
75
1C
EO
77
77
92
92
73
73
76
76

66
67
68
69
6A
68
6C
6D
6E
6F
70
71
72
73
74
75
76
77
78
79
7A
7F
00
00
EO
00
EO
00
EO
0A
0A
00
EO
00
EO
00
EO
00
EO

033
034
035
023
036
037
038
050
049
024
025
016
019
031
020
022
047
017
045
021
044
014
000
147
147
145
145
117
117
028
224
119
119
146
146
115
115
118
118

102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
127
000
000
224
000
224
000
224
010
010
000
224
000
224
000
224
000
224

NOTE

Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced

Enhanced

Enhanced

keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard

keyboard



KEYSTROKE
DESCRIPTION

{CTRL+PGUP}
{CTRL+(PGUP)}
{CTRL+PRTSC}
{CTRL+RIGHT}
{CTRL+(RIGHT)}
{CTRL+TAB}
{CTRL+UP}
{CTRL+(UP)}
{CTRL+"}
{CTRL+[*]}
{CTRL+[+]1}
{CTRL+,}
{CTRL+-}
{CTRL+[-1}
{CTRL+.}
{CTRL+/}
{CTRL+[/]1}
{CTRL+;}
{CTRL+[}
{CTRL+\}
{CTRL+]}
{CTRL+*}
{CTRL+0}
{CTRL+1}
{CTRL+2}
{CTRL+3}
{CTRL+4}
{CTRL+5}
{CTRL+[5]1}
{CTRL+6}
{CTRL+7}
{CTRL+8}
{CTRL+9}
{CTRL+A}
{CTRL+B}
{CTRL+C}
{CTRL+D}
{CTRL+E}
{CTRL+F}

HEX

84
84
72
74
74
94
8D
8D
C1
96
90
C3
0C
8E
C4
C5
95
c2
1A
28
1B
co
CD
Cé
03
C7
C8
C9
8F
07
CA
cB
cC
1E
30
2E
20
12
21

00
EO
00
00
EO
00
00
EO
00
00
00
00
1F
00
00
00
00
00
18
1C
1D
00
00
00
00
00
00
00
00
1E
00
00
00
01
02
03
04
05
06

D

132
132
114
116
116
148
141
141
193
150
144
195
012
142
196
197
149
194
026
043
027
192
205
198
003
199
200
201
143
007
202
203
204
030
048
046
032
018
033

AL

000
224
000
000
224
000
000
224
000
000
000
000
031
000
000
000
000
000
027
028
029
000
000
000
000
000
000
000
000
030
000
000
000
001
002
003
004
005
006

NOTE

Enhanced

Enhanced
Enhanced
Enhanced
Enhanced
WordStar
Enhanced
Enhanced
WordStar

Enhanced
WordStar
WordStar
Enhanced
WordStar

WordStar
WordStar
WordStar

WordStar
WordStar
WordStar
Enhanced

WordStar
WordStar
WordStar

keyboard

keyboard
keyboard
keyboard
keyboard
keystroke
keyboard
keyboard
keystroke

keyboard
keystroke
keystroke
keyboard
keystroke

keystroke
keystroke
keystroke

keystroke
keystroke
keystroke
keyboard

keystroke
keystroke
keystroke
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KEYSTROKE
D P N HEX CIMAL NOTE
{CTRL+G} 22 07 034 007
{CTRL+H} 23 08 035 008
{CTRL+I} 17 09 023 009
{CTRL+J} 24 0A 036 010
{CTRL+K} 25 0B 037 011
{CTRL+L} 26 0C 038 012
{CTRL+M} 32 0D 050 013
{CTRL+N} 31 OE 049 014
{CTRL+0} 18 OF 024 015
{CTRL+P} 19 10 025 016
{CTRL+Q} 10 11 016 017
{CTRL+R} 13 12 019 018
{CTRL+S} 1F 13 031 019
{CTRL+T} 14 14 020 020
{CTRL+U} 16 15 022 021
{CTRL+V} 2F 16 047 022
{CTRL+W} 11 17 017 023
{CTRL+X} 2D 18 045 024
{CTRL+Y} 15 19 021 025
{CTRL+Z} 2C 1A 044 026
{ALT+BKSP} 0E 00 014 000 Enhanced keyboard
{ALT+(DEL)} A3 00 163 000 Enhanced keyboard
{ALT+(DOWN)} A0 00 160 000 Enhanced keyboard
{ALT+(END)} 9F 00 159 000 Enhanced keyboard
{ALT+ENTER} 1C 00 028 000 Enhanced keyboard
{ALT+[ENTER]} A6 00 166 000 Enhanced keyboard
{ALT+ESC} 01 00 001 000 Enhanced keyboard
{ALT+(HOME)} 97 00 151 000 Enhanced keyboard
{ALT+(INSERT)} A2 00 162 000 Enhanced keyboard
{ALT+(LEFT)} 98 00 155 000 Enhanced keyboard
{ALT+(PGDN)} Al 00 161 000 Enhanced keyboard
{ALT+(PGUP)} 99 00 153 000 Enhanced keyboard
{ALT+(RIGHT)} 9D 00 157 000 Enhanced keyboard
{ALT+TAB} A5 00 165 000 Enhanced keyboard
{ALT+(UP)} 98 00 152 000 Enhanced keyboard
{ALT+"} 28 00 040 000 Enhanced keyboard
{ALT+[*]} 37 00 055 000 Enhanced keyboard
{ALT+[+]} 4E 00 078 000 Enhanced keyboard
{ALT+,} 33 00 051 000 Enhanced keyboard
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KEYSTROKE

DESCRIPTION HEX DECIMAL NOTE

{ALT+-} 82 00 130 000

{ALT+[-1} 4A 00 074 000 Enhanced keyboard
{ALT+.} 34 00 052 000 Enhanced keyboard
{ALT+/} 35 00 053 000 Enhanced keyboard
{ALT+[/1} A4 00 164 000 Enhanced keyboard
{ALT+;} 27 00 039 000 Enhanced keyboard
{ALT+=} 83 00 131 000

{ALT+[} 1A 00 026 000 Enhanced keyboard
{ALT+\} 2B 00 043 000 Enhanced keyboard
{ALT+]} 1B 00 027 000 Enhanced keyboard
{ALT+} 29 00 041 000 Enhanced keyboard
{ALT+0} 81 00 129 000

{ALT+1} 78 00 120 000

{ALT+2} 79 00 121 000

{ALT+3} 7A 00 122 000

{ALT+4} 78 00 123 000

{ALT+5} 7C 00 124 000

{ALT+6} 7D 00 125 000

{ALT+7} 7E 00 126 000

{ALT+8} 7F 00 127 000

{ALT+9} 80 00 128 000

{ALT+A} 1E 00 030 000

{ALT+B} 30 00 048 000

{ALT+C} 2E 00 046 000

{ALT+D} 20 00 032 000

{ALT+E} 12 00 018 000

{ALT+F} 21 00 033 000

{ALT+G} 22 00 034 000

{ALT+H} 23 00 035 000

{ALT+I} 17 00 023 000

{ALT+J} 24 00 036 000

{ALT+K} 25 00 037 000

{ALT+L} 26 00 038 000

{ALT+M} 32 00 050 000

{ALT+N} 31 00 049 000

{ALT+0} 18 00 024 000

{ALT+P} 19 00 025 000

{ALT+Q} 10 00 016 000

{ALT+R} 13 00 019 000
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KEYSTROKE

DESCRIPTION HEX
{ALT+S} 1F 00
{ALT+T} 14 00
{ALT+U} 16 00
{ALT+V} 2F 00
{ALT+W} 11 00
{ALT+X} 2D 00
{ALT+Y} 15 00
{ALT+Z} 2C 00
{F1} 3B 00
{F2} 3C 00
{F3} 3D 00
{F4} 3E 00
{F5} 3F 00
{F6} 40 00
{F7} 41 00
{F8} 42 00
{F9} 43 00
{F10} 44 00
{F11} 85 00
{F12} 86 00
{SHIFT+F1} 54 00
{SHIFT+F2} 55 00
{SHIFT+F3} 56 00
{SHIFT+F4} 57 00
{SHIFT+F5} 58 00
{SHIFT+F6} 59 00
{SHIFT+F7} 5A 00
{SHIFT+F8} 5B 00
{SHIFT+F9} 5C 00
{SHIFT+F10} 5D 00
{SHIFT+F11} 87 00
{SHIFT+F12} 88 00
{CTRL+F1} 5E 00
{CTRL+F2} 5F 00
{CTRL+F3} 60 00
{CTRL+F4} 61 00
{CTRL+F5} 62 00
{CTRL+F6} 63 00
{CTRL+F7} 64 00

031
020
022
047
017
045
021
044
059
060
061
062
063
064
065
066
067
068
133
134
084
085
086
087
088
089
090
091
092
093
135
136
094
095
096
097
098
099
100

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

NOTE

Enhanced keyboard
Enhanced keyboard

Enhanced keyboard
Enhanced keyboard
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DESCRIPTION HEX
{CTRL+F8} 65 00
{CTRL+F9} 66 00
{CTRL+F10} 67 00
{CTRL+F11} 89 00
{CTRL+F12} 8A 00
{ALT+F1} 68 00
{ALT+F2} 69 00
{ALT+F3} 6A 00
{ALT+F4} 68 00
{ALT+F5} 6C 00
{ALT+F6} 6D 00
[ALT+F7} 6E 00
{ALT+F8} 6F 00
{ALT+F9} 70 00
{ALT+F10} 71 00
{ALT+F11} 88 00
{ALT+F12} 8C 00
EXTENDED CHARACTERS
CHARACTER HEX
© 00 01
® 00 02
v 00 03
. 00 04
& 00 05
'S 00 06
. 00 07
a 00 08
o) 00 09
O] 00 0A
3 00 OB
? 00 0C
d 00 0D
3 00 OE
* 00 OF
> 00 10
< 00 11
: 00 12
1] 00 13
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101
102
103
137
138
104
105
106
107
108
109
110
111
112
113
139
140

DEC

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

001
002
003
004
005
006
007
008
009
010
011
012
013
014
015
016
017
018
019

Enhanced keyboard
Enhanced keyboard

Enhanced keyboard
Enhanced keyboard
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00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

HEX

14
15
16
17
18
19
1A
1B
1C
1D
1E
1F
80
81
82
83
84
85
86
87
88
89
8A
8B
8C
8D
8E
8F
90
91
92
93
94
95
96
97
98
99
9A

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

DECIMAL

020
021
022
023
024
025

026
027
028
029
030
031
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154

NOTE



g

° 21O = Ok Y K h S

¢
-
A

00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

HEX

98
9C
9D
9E
9F
A0
Al
A2
A3
A4
A5
A6
A7
A8
A9
AA
AB
AC
AD
AE
AF
BO
B1
B2
B3
B4
B5
B6
B7
B8
B9
BA
BB
BC
BD
BE
BF
co
C1
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DECIMAL

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193

NOTE
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HEX

00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

C2
C3
C4
C5
Cé6
c7
c8
c9
CA
CB
cc
CD
CE
CF
DO
D1
D2
D3
D4
D5
D6
D7
D8
D9
DA
DB
DC
DD
DE
DF
EO
El
E2
E3
E4
ES
E6
E7
E8

DECIMAL

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232

NOTE
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00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

E9
EA
EB
EC
ED
EE
EF
FO
F1
F2
F3
F4
F5
F6
F7
F8
F9
FA
FB
FC
FD
FE
FF
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000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255



APPENDIX D

FuNcTION KEYS
AND OTHER
MACROS

You can use the function keys, which are usually labeled F1, F2, F3, and so on,
to execute the most frequently used WordStar commands with a single
keystroke.

Each function key is set to issue four different commands, depending on
whether you use the function key by itself or while holding down one of these
keys: Shift, Ctrl, or Alt.

The commands issued by the function keys are preprogrammed macros created
with the WordStar macro commands. You can change the function key assign-
ments by choosing Utilities=>Macros and then Record, Edit/Create, or Rename,
or using the classic command AMR, AMD, or *ME. For information about
working with macros, see “Macros” in “Ultilities.”

All the function key assignments are shown in the following table.
In addition to the function keys, several other preprogrammed macros are sup-

plied with WordStar. These keys are also listed in the table. Several other
macros that are not included in the table are also preprogrammed as examples.



FUNCTION KEYS AND OTHER MACROS

FUNCTION
KEY

(F1)

F1
Shift+F1
Ctrl+F1
Alt+F1

(F2)

F2
Shift+F2
Ctrl+F2
Alt+F2

(F3)

F3
Shift+F3
Ctrl+F3
Alt+F3

F4
Shift+F4
Ctrl+F4
Alt+F4

()

F5

Shift+F5

Ctrl+F5
Alt+F5

F6
Shift+F6
Ctrl+F6
Alt+F6

F7

Shift+F7
Ctrl+F7
Alt+F7

CLASSIC
COMMAND

F1
AOD
AQF
l

AU
AOC
AQA

APS
~AQRMQL
AL

r

APB
AQN
AQI

AY

AKY
AQS.LMAN
L

AT

AKH
AQS.RMAN
J

ABI\QP

AKV
AQS.PM6.
.

PULL-DOWN COMMAND
OR FUNCTION

Help =>Help (this key cannot be reprogrammed)

View=>Command Tags
Edit=Find
Inserts box-drawing character

Edit=Undo

Layout=>Center Line
Edit=>Find and Replace
Inserts box-drawing character

Style=>Underline
Utilities=>Spelling Check Global
Edit=>Next Find

Inserts box-drawing character

Style=>Bold

Utilities=>Spelling Check Other—>Word
Edit=>Go to Page

Inserts box-drawing character

Edit=>Delete=>Line
Edit=>Delete=>Block

Inserts .Im command on its own line
Inserts box-drawing character

Edit=>Delete=>Word

View=>Block Highlighting

Inserts .rm command on its own line
Inserts box-drawing character

Utilities—>Reformat=>Paragraph, then

Edit =>Go to Other=>Previous Position
Edit=>Move=>Block
Inserts .pm6 command and a carriage return
Inserts box-drawing character




FUNCTION
KEY

F8

Shift+F8
Ctrl+F8
Alt+F8

F9
Shift+F9
Ctrl+F9
Alt+F9

F10

Shift+F10
Ctrl+F10
Alt+F10

Alt+0
Alt+1
Alt+D
Alt+M
Alt+T
Alt+B
Alt+N

CLASSIC
COMMAND

AQSMOO

AKC
AQS.PA
L

AKS
AKB
AQS

AKD

AKK
AQD

AQOFS
AQP
n/a
n/a
n/a
n/a
n/a

FUNCTION KEYS AND OTHER MACROS

PULL-DOWN COMMAND
OR FUNCTION

Inserts the .rr command with current ruler line
settings above the current line

Edit=>Copy=>Block

Insert=>Page Break

Inserts box-drawing character

File=>Save

Edit=>Mark Block Beginning

Moves the cursor to beginning of the line
Inserts box-drawing character

File=>Save and Close

(this key cannot be reprogrammed)
Edit=>Mark Block End
Moves the cursor to the end of the line
Inserts box-drawing character

Style=>Select Paragraph Style
View=>Preview

Find next compiler error for editing macros
Enters a memo boilerplate

Enters a To Do list boilerplate

Bulleted List

Numbered list



SUBJECT INDEX

Note: This “Subject Index” is the first of two indexes in this manual. The second index (“Command
Index”) follows this index and contains Pull-down commands, Classic Opening and Editing Screen

commands, and dot commands.

1st Line Indent setting (paragraph style), 10-15
1st Line Indent setting (Ruler Line), 11-3
4x zoom option (Preview), 8-4

A

abandon changes to a file, 6-3 to 6-4
and exit WordStar, 6-17
abort. See cancel
accented characters. See extended character set
ACK (User acknowledgement required)
condition, 12-38, 12-39, 12-40
Add to Exceptions Dictionary option (Spelling
Check Other), 12-7, 12-9
Add to Personal Dictionary option (Spelling
Check), 12-3
Add to Personal Dictionary option (Spelling
Check Other), 12-5, 12-7,12-9, 12-10
addition. See math operations
Additional menu
MailList command, 4-1
Star Exchange command, 4-2
TelMerge command, 4-1
address lists. See MailList and merge printing
Adjust Window option (Preview), 8-4
Advanced Page Preview. See Preview
command (View menu)
alignment of text
Alignment and Spacing command (Layout
menu), 11-21to 11-26
automatic alignment, turn on/off, 7-25

alignment of text (continued)
center a line, 11-2
center multiple lines of text, 11-22
center vertically on a page, 11-28
Flush Left setting, 11-22
Flush Right setting, 11-22
grid for previewing alignment, 8-6
Justified setting, 11-22
and merge print variables, 12-69
and nondocuments, 2-5
in notes, 12-73
for paragraph styles, 10-16
Reformat commands, 12-72 to 12-73
and replacing text, 7-13
right align a header or footer, 11-16
right align text, 11-2, 11-22
Alignment setting
Alignment and Spacing command, 11-22
for paragraph styles, 10-16
ampersand (&) for variable data, in merge
printing, 12- 52
annotation
convert to another type of note, 7-21 to
7-22
edit, 7-19
insert in file, 9-25
reformat, 12-73
spelling check of, 12-9 to 12-11
Annotation command, 9-25
apostrophe (), for comments in macros, 12-41
ASC256.PDF, 2-5, 2-10

INDEX - 1




SUBJECT INDEX

ASCII codes
conversion charts, B-1 to B-5
See also extended character set
ASCII format, required for Windows Clipboard
contents, 7-7
ASCII.PDF, 2-5, 2-10
ASCII text files. See nondocument files
Ask for Variable command (Merge Print
Commands), 12-53 to 12-54
and background printing, 2-8, 6-7
Aspect option (Convert Graphic Options), 9-17
Auto Align command, 7-25
automatic leading, 11-25
Automatic scan option (Preview), 8-5
AutoRestore function (for macros), 12-36

B

background printing, 2-8, 6-7
and Clear Screen While Printing command,
12-63
and exiting WordStar, 2-22, 6-17
backup files (.BAK), and protected files, 2-19,
6-4 to 6-5
.BAK files. See backup files (.BAK)
beginning of block
goto, 7-17
marking of, 7-3 to 7-4
beginning of file, go to, 7-17
binding space, insert, 11-28
blank lines
in headers or footers, 11-16
omit merge printing of, 12-44 to 12-45
suppress printing of at top of page, 11-13
Block Highlighting command (View menu), 8-9
Block Math command (Utilities menu, Editing
Screen), 12-18 to 12-19
block operations
column block mode, 7-23 to 7-24
column replace mode, 7-24 to 7-25
convert case of block, 10-21 to 10-22

INDEX - 2

block operations (continued)
copy block between macros, 3-10
copy block between windows, 6-3, 7-6,
8-11
copy block from Windows Clipboard, 6-3,
7-6
copy block to another file, 7-7
copy block to Windows Clipboard, 7-7
copy block within a file, 7-6
Copy in ASCIl Format, 2-5, 7-7
count words or bytes in block, 12-20
delete block, 7-8
go to beginning/end of block, 7-17
highlighting, turn on/off, 8-9
mark beginning, 7-3 to 7-4
mark end, 7-5
mark previous block, 7-9
math command, 12-18 to 12-19
move block by unerasing, 7-2
move block from other window, 7-6
move block within file, 7-6
operations available, 7-4 to 7-5
sort a block of text, 12-19 to 12-20
Body Text paragraph style, 10-13
Bold command (Style menu), 10-2
See also Double Strike option
Bottom Margin setting (Page Layout), 11-11
box drawing. See extended character set
Brightness option (Convert Graphic Options),
9-18
bulleted lists, macro for, 12-31
Bypass This Time Only option (Spelling Check),
12-3
Bypass This Time Only option (Spelling Check
Other), 12-5, 12-7, 12-11

C

Calculator command (Utilities menu, Editing
Screen), 12-16to 12-18
Call command (in macros), 12-37



cancel
changes to a file, 6-3 to 6-4, 6-17
a command, 7-2 '
printing, 2-9, 6-8, 7-2
caret symbol (), in macros, 12-34
carriage returns
change hard returns to soft returns, 2-6
and Find/Find and Replace operations,
7-11,7-14
in nondocuments, 2-5
remove with Copy in ASCII Format option,
2-5,7-7
required at end of master documents, 12-46
cartridge fonts, 10-5 to 10-6
case conversion, 10-21 to 10-22
case sensitivity
and Find/Find and Replace operations,
7-10,7-13
in macros, 12-34
and same/equal operators, 12-57
and variables for merge printing, 12-43
centering text
Center Line command (Layout menu), 11-2
center multiple lines (Alignment setting),
11-22
vertically on a page, 11-28
centimeters
for leading, 11-25
in Page Layout dialog box, 11-10
in paragraph styles, 10-15
in Ruler Line dialog box, 11-3
chaining files together for printing, 9-14
ChainMacro command (in macros), 12-37
Change Drive/Directory command
File menu, Editing Screen, 6-15
File menu, Opening Screen, 2-19 to 2-20
Change Filename Display command (File
menu, Opening Screen), 2-20
Change Help Level command (Help menu,
Editing Screen), 13-2 to 13-3
Change Help Level command (Help menu,
Opening Screen), 5-2 to 5-3

SUBJECT INDEX

_

Change Printer command (File menu, Editing
Screen), 6-12 to 6-13
Change Window Size command (View menu),
8-11
chapters, place endnotes at end of chapters,
7-22
Character for Strikeout option, 10-23
check spelling. See Spelling Check commands
classic commands
displaying on pull-down menus, 1-6
function key equivalents for, D-1 to D-3
See also commands
Classic Commands on Pull-down Menus option
(Screen Settings), 8-13
classic menus
described, 1-5
display of, 5-2, 13-2
Clear Screen command, and background
printing, 2-8, 6-7
Clear Screen While Printing command (Merge
Print Commands), 12-63
Clipboard. See Microsoft Windows
Close command (File menu, Editing Screen),
6-3 to 6-4
CmdTags function (for macros), 12-36
Code Page 437
ASCII conversion chart, B-2 to B-3
See also US keystroke table
Code Page 850, ASCI! conversion chart, B-4 to
B-5
ColMode function (for macros), 12-36
colon (:) to separate statements in macro, 12-33
Color Processing option (Convert Graphic
Options), 9-18 to 9-19
Color/Shading command
for fonts, 10-11
for paragraph styles, 10-16
Colors option (Convert Graphic Options), 9-18
ColReplace function (for macros), 12-36
Column Block Mode command, 7-23 to 7-24
Column Break command (Insert menu), 9-2 to
9-3
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Column Replace Mode command, 7-24 to 7-25
Column Width setting (Column Layout), 11-6
Columns command (Layout menu), 11-5 to 11-7
combining files for printing, 9-13 to 9-15
command line options, 1-18
open nondocument file when starting
WordStar, 2-3
open specific file when starting WordStar,
2-3
run a macro when starting WordStar, 3-5,
12-22
command processor (DOS), access to run
multiple DOS commands, 2-21, 6-16
command tags
Command Tags command (View menu),
8-810 8-9
displaying, 1-11
commands
cancel or stop, 7-2
in document and nondocument files, 2-4
function key equivalents for, D-1 to D-3
menus and commands, 1-3 to 1-6
notations for in this manual, 1-2
repeat single-letter command, 12-74
See also classic commands; dot commands
Comment command, 9-22 to 9-23
comments
convert to another type of note, 7-21 to
7-22
edit, 7-19
insert in file, 9-22 to 9-23
in macros, 12-31, 12-41
reformat, 12-73
spelling check of, 12-9 to 12-11
comparison operators, for merge printing, 12-55
conditional commands, for merge printing,
12-54 to 12-58, 12-59 to 12-61
Continuous Underline option, 10-22 to 10-23
continuously repeat single-letter command or
character, 12-74
Contrast option (Convert Graphic Options), 9-18

INDEX - 4

control characters
and Find/Find and Replace operations,
7-11,7-14
in macros, 12-34
See also classic commands; commands
conventional memory usage
display of, 2-21, 6-16
See also memory
Conversion Options option (Convert Graphic),
9-16
Convert at Print command, 7-21 to 7-22
Convert Case command (Style menu), 10-21 to
10-22
Convert Note command, 7-21
Converted Filename option (Convert Graphic),
9-16
converting files
documents to fax (.PCX) fgrmat, 2-13 to
2-16,6-9 to 6-12, 8-5 to 8-6
documents to nondocuments, 2-5
fax files to graphics (.PIX) files, 9-19 to 9-20
graphics files, 9-16 to 9-19
nondocuments to documents, 2-6
Star Exchange command, 4-2
copies, number of copies to print, 2-7, 6-6,
12-65 to 12-66
Copy command
Edit menu, 7-6 to 7-7
File menu, Editing Screen, 6-13
File menu, Opening Screen, 2-17
Macro, 3-11, 12-28
Copy in ASCIl Format, 2-5, 7-7
copy operations
block of text between macros, 3-10
blocks of text, 6-3, 7-6 to 7-7, 8-11
columns of text, 7-23 to 7-25
file, 2-17, 6-13
macros, 3-11, 12-28
style to style library, 10-19
Copy Style to Library option (paragraph style),
10-19




count words or bytes in block, 12-20
Cross-reference option (Thesaurus), 12-14
cross-references in indexes, 9-28
.CRT files
and fax files, 2-16, 6-12
and Preview, 8-6 to 8-7
current date or time. See date variable; time
variable
Current Directory command, 9-3 to 9-4
Current Drive command, 9-3 to 9-4
Current Filename command, 9-3 to 9-4
Current Path command, 9-3 to 9-4
Current Time command, 9-3 to 9-4
cursor indicator, in nondocuments and
documents, 2-4
cursor movement, 1-13 to 1-15
See also Go to commands; scrolling
Custom Printer Code command (Insert menu),
9-10to 9-11
adding custom printer codes to a PDF, 9-34
to 9-35
Change Printer Codes command, 9-32 to
9-34

D

Data File command (Merge Print Commands),
12-47 t0 12-48
database files
insert for merge printing, 12-67 to 12-68
insert in document, 9-12 to 9-13
Date variable, 9-3, 9-5
dBASE files
insert for merge printing, 12-67 to 12-68
insert in document, 9-12 to 9-13
“dead keys” for extended character set, 9-7
decimal tabs, 11-3to 11-4
Define Highlighted Word option (Thesaurus),
12-14
Define Paragraph Style command (Style menu),
10-14to 10-18
DELCRT utility, 2-16, 6-12, 8-7

SUBJECT INDEX

Delete command
Edit menu, 7-8 to 7-9
File menu, Editing Screen, 6-14
File menu, Opening Screen, 2-17 to 2-18
Macro, 3-12, 12-29
delete operations
block, 7-8
columns of text, 7-23 to 7-25
commands for, 7-8 to 7-9
file, 2-17 to 2-18, 6-14
line, 7-8
macros, 3-12, 12-29
Preview files, 2-16, 6-12, 8-7
screen fonts, 2-16, 6-12
style from style library, 10-20
undelete (restore) text, 7-2 to 7-3
word, 7-8
Delete Style from Library command (Manage
Paragraph Styles), 10-20
dialog boxes
change function of Enter key in dialog
boxes, 1-13, 7-25
described, 1-12 to 1-13
options for in macros, 12-35
dictionaries for spelling, 12-11 to 12-12
See also exceptions dictionary; personal
dictionary
Diffuse process type, 9-18
directories and subdirectories
change logged directory, 2-19 to 2-20, 6-15
for macro files, 3-7, 12-23
for .PCX fax files, 2-13, 6-9, 8-5
Directory variable, 9-4, 9-6
disk space
and fax files, 2-16, 6-12
insufficient disk space for saving file, 6-5
and Preview files, 8-7
display
classic commands, 1-6, 5-2, 13-2
classic menus, 5-2, 13-2
command tags, turn on/off, 8-8 to 8-9
dot commands, 8-12

INDEX - 5




SUBJECT INDEX

display (continued)
file list, extensions excluded from list, 2-2
grid in Preview, 8-6
memory usage, 2-21, 6-16
a message during merge printing, 12-64 to
12-65
screen elements, selection of, 8-12 to 8-13
display formatted pages. See Preview command
(View menu)
Display Message command (Merge Print
Commands), 12-64 to 12-65
Dither process type, 9-18
division. See math operation
document files
compared to nondocument files, 2-4 to 2-5
converting documents to nondocuments, 2-5
converting nondocuments to documents, 2-6
inserting, 9-11 t0 9-12
open for editing, 2-2 to 2-3
open nondocument and document at same
time, 6-3
document styles. See under paragraph styles
DOS, run a DOS command, 2-20 to 2-21, 6-15
to 6-16
DOS text files. See nondocument files
dot commands
described, 1-6
display of, 8-12
HideDots function (for macros), 12-36
in nondocuments and documents, 2-4
print rather than execute dot commands,
2-8, 6-7
Dot Commands option (Screen Settings), 8-12
Dot Leader to Tab command, 9-30
dot matrix printers
and subscript roll, 10-9
and superscript roll, 10-10
double-spaced text
Line Spacing setting for Alignment and
Spacing, 11-22 to 11-23
Line Spacing setting for paragraph styles,
10-16

Double Strike command, 10-10 to 10-11

See also Bold command (Style menu)
drive, change logged drive, 2-19 to 2-20, 6-15
Drive variable, 9-4, 9-6

E

edge smoothing for graphics, 9-18
Edit/Create command (Macro), 3-9 to 3-10,
12-26 to 12-27
Edit menu
Copy command, 7-6 to 7-7
Delete command, 7-8 to 7-9
Edit Note command, 7-19
Editing Settings command, 7-23 to 7-25
Find and Replace command, 7-12 to 7-14
Find command, 7-9 to 7-11
Go to Character command, 7-15
Go to Marker command, 7-16
Go to Other command, 7-16 to 7-18
Go to Page command, 2-5, 7-15 to 7-16
illustrated, 7-1
Mark Block Beginning command, 7-3 to 7-4
Mark Block End command, 7-5
Mark Previous Block command, 7-9
Move command, 7-5 to 7-6
Next Find command, 7-15
Note Options command, 7-20 to 7-22
Set Marker command, 7-18 to 7-19
Undo command, 7-2 to 7-3
Edit Note command (Edit menu), 7-19
Editing Screen, 1-7 to 1-11
Editing Settings command (Edit menu), 7-23 to
7-25
Else command (Merge Print Commands),
12-58
See also conditional commands
EMS. See expanded memory usage
End If command (Merge Print Commands),
12-58
See also conditional commands




end of block
goto, 7-17
marking of, 7-5
end of file, go to, 7-17
endnote
convert to another type of note, 7-21 to
7-22
edit, 7-19
insert in file, 9-24
location of, 7-22
numbering of, 7-20 to 7-21
reformat, 12-73
spelling check of, 12-9 to 12-11
Endnote command, 9-24
Endnote Location command, 7-22
Enter Correction option (Spelling Check), 12-3
Enter Correction option (Spelling Check Other),
12-5,12-7,12-10
Enter key, change function of in dialog boxes,
1-13, 7-25
Enter Word into Text option (Spelling Check
Other), 12-9
envelopes, and Print from Keyboard command,
2-11t0 2-13
equal sign (=), for soft hyphen display, 11-24
erase operations. See delete operations
error messages, A-1to A-17
errors in macros, 3-10
Esc Cancel option (Spelling Check), 12-3
Esc Cancel option (Spelling Check Other), 12-5,
12-7,12-9,12-11
even offset. See page offset
even pages
footer for, 11-17to 11-18
header for, 11-14 to 11-15
select for printing, 2-7, 6-7
exceptions dictionary
Add to Exceptions Dictionary option
(Spelling Check Other), 12-7,12-9
described, 12-12
exclusion list, for index creation, 3-2 to 3-3

SUBJECT INDEX

execute a macro. See Play command; Single
Step command
exit
Preview, 8-6
SHOWPCX utility, 2-15
WordStar, 2-22, 6-17
Exit WordStar command
File menu, Editing Screen, 6-17
File menu, Opening Screen, 2-22
expanded memory usage
display of, 2-21, 6-16
See also memory
exponential operations
onscreen calculator for, 12-16 to 12-18
See also math operations
Extended Character command (Insert menu),
9-6 t0 9-10
extended character set
ASCII conversion charts, B-1 to B-5
box and line drawing, 9-8 to 9-10
and converting documents to
nondocuments, 2-5
“dead keys” for, 9-7
insert an extended character command, 9-6
to 9-7
international characters, 9-7 to 9-8
and kerning, 11-23
in macros, 12-35

F

Fax command
File menu, Editing Screen, 6-9 to 6-12
File menu, Opening Screen, 2-13 to 2-16
tips about fax files, 2-16, 6-11 to 6-12

fax file formats supported, 9-19 to 9-20

Fax Files for Entire Document option (Preview),

8-5

Fax Files for Range option (Preview), 8-6

FAX. PDF, 2-16, 6-11

fields and data files, 12-42 to 12-43
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File at Print Time command (Insert menu), 9-13
to 9-15
File command (Insert menu), 9-11 to 9-13
file conversion. See converting files
File menu, Editing Screen
Change Drive/Directory command, 6-15
Change Printer command, 6-12 to 6-13
Close command, 6-3 to 6-4
Copy command, 6-13
Delete command, 6-14
Exit WordStar command, 6-17
Fax command, 6-9 to 6-12
illustrated, 6-1
Open/Switch command, 6-2 to 6-3
Print command, 6-5 to 6-8
Rename command, 6-14
Run DOS command, 6-15 to 6-16
Save and Close command, 6-5
Save As command, 6-4
Save command, 6-4
Status command, 6-16 to 6-17
File menu, Opening Screen
Change Drive/Directory command, 2-19 to
2-20
Change Files Displayed command, 2-20
Copy command, 2-17
Delete command, 2-17 to 2-18
Exit WordStar command, 2-22
Fax command, 2-13 to 2-16
illustrated, 2-1
New command, 2-2
Open Document command, 2-2 to 2-3
Open Nondocument command, 2-3 to 2-4
Print command, 2-6 to 2-9
Print from Keyboard command, 2-11 to
2-13
Protect/Unprotect command, 2-18 to 2-19
Rename command, 2-18
Run DOS Command, 2-20 to 2-21
Status command, 2-21 to 2-22
Filename variable, 9-4, 9-6
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filenames
characters allowed in, 2-2
for fax files, 2-14, 6-9
variable for, 9-4, 9-6
files
abandon changes to a file, 6-3 to 6-4, 6-17
copy a file, 2-17, 6-13
delete afile, 2-17 to 2-18, 6-14
displayed list of, changing, 2-20
open specific file when starting WordStar,
2-3
opening, 2-2 to 2-4
print to disk file, 2-9 to 2-11
printing, 2-6 to 2-9
protect/unprotect, 2-18 to 2-19
rename a file, 2-18, 6-14
save and close, 6-5
save and resume editing, 6-4
save under a new name, 6-4
See also document files; nondocument files
Find and Replace command (Edit menu), 7-12
to 7-14
macro for, 12-40
Find command (Edit menu), 7-9 to 7-11
1st Line Indent setting (paragraph style), 10-15
1st Line Indent setting (Ruler Line), 11-3
fixed-size fonts, 10-6
flag column, characters displayed in, 1-10 to
1-11
Flag Column option (Screen Settings), 8-12
floppy disk drives, and changing logged drive
caution, 2-20, 6-15
Font command (Style menu), 10-4 to 10-7
Font setting (paragraph style), 10-15
fonts for printing
cartridge fonts, 10-5 to 10-6
and fax files, 2-16, 6-11
fixed-size fonts, 10-6
go to font tag, 7-17
in header or footer, 11-16
internal fonts, 10-5 to 10-6




fonts for printing (continued)
macro for choosing a font, 12-40
nonproportional fonts, 10-6 to 10-7
in a paragraph style, 10-15
proportional fonts, 10-6 to 10-7
scalable fonts, 10-6
select a font, 10-4 to 10-5
soft fonts, 10-5 to 10-6
See also screen fonts
Footer Margin setting (Page Layout), 11-11
Footer option, 11-17to 11-18
footnote
and columns of text, 11-7
convert to another type of note, 7-21 to
7-22
edit, 7-19
insert in file, 9-23 to 9-24
numbering of, 7-20 to 7-21
reformat, 12-73
spelling check of, 12-9 to 12-11
Footnote command, 9-23 to 9-24
foreign characters. See extended character set
form feeds, and printing, 2-7, 6-7
form letters. See merge printing
formatting functions
and converting documents to
nondocuments, 2-5
include in disk file for printing, 2-9 to 2-10
and nondocuments, 2-4
forms, and Print from Keyboard command, 2-11
to 2-13
4x zoom option (Preview), 8-4
full speed printing, 2-8, 6-8
function keys, 1-17
for commands, D-1 to D-3

G

Global Replacement option (Spelling Check),
12-3,12-5

Global Replacement option (Spelling Check
Other), 12-10
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.Gn§$ files, 8-6, 8-7
Go to Bottom of Document command (Merge
Print Commands), 12-62
Go to Character command (Edit menu), 7-15
Go To command (Preview), 8-3
Go to Marker command (Edit menu), 7-16
Go to Other command (Edit menu), 7-16 to 7-18
Go to Page command (Edit menu), 7-15 to 7-16
and nondocuments, 2-5
Go to Top of Document command (Merge Print
Commands), 12-62
GoTo command (in macros), 12-38
Graphic command (Insert menu), 9-15 to 9-22
graphic files
formats supported, 9-15
inserting, 9-15 to 9-22
placement tips, 9-21
and Preview, 8-6, 8-7, 8-8
printing of, 9-22
gray levels in an image, and Screen Frequency
option, 9-18
gray shading
with the Color/Shading option, 10-11
with the Color/Shading setting for
paragraph style, 10-16
Grid display On/Off option (Preview), 8-6

H

Halftone process type, 9-18
Hanging Indent paragraph styles, 10-13
hard carriage returns
change to soft returns, 2-6
and Find/Find and Replace operations,
7-11,7-14
See also carriage returns
Header/Footers command (Layout menu),
11-14t0 11-18
Header Margin setting (Page Layout), 11-11
Header option, 11-14 to 11-17
Heading paragraph style, 10-13
Height option (Convert Graphic Options), 9-17
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help levels, and menus, 1-3
Help menu, Editing Screen
Change Help Level command, 13-2 to 13-3
Help command, 13-1 to 13-2
Help menu, Opening Screen
Change Help Level command, 5-2 to 5-3
Help command, 5-1 to 5-2
HideDots function (for macros), 12-36
high resolution, for fax files, 2-15, 6-10
highlighting for block, turn on/off, 8-9
hot keys for macros, 3-6, 12-22 to 12-23
hyphenation
Hyphenation setting, 11-24 to 11-25
Optional Hyphen command, 11-27 to
11-28
See also soft hyphens

.IDX file extension, 3-2
If command (Merge Print Commands), 12-54 to
12-58
See also conditional commands
IfException clause (in macros), 12-38 to 12-41
Ignore Background option (Convert Graphic
Options), 9-18
Ignore/Check New Word option (Spelling
Check Other), 12-9
Ignore/Check Next Word option (Spelling
Check), 12-3, 12-5, 12-7
Ignore/Check Next Word option (Spelling
Check Other), 12-10
indent
1st Line Indent setting (paragraph style),
10-15
1st Line Indent setting (Ruler Line), 11-3
Index command (Utilities menu, Opening
Screen), 3-1 to 3-3
index creation, 3-2 to 3-3
index entry
cross-references format, 9-28
edit, 7-19
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index entry (continued)
generate the index, 3-1 to 3-2
mark text for an entry, 9-29 to 9-30
type an entry, 9-28 to 9-29
Index Entry command, 9-28 to 9-29
Index/TOC Entry command (Insert menu), 9-26
to 9-30
Insert function (for macros), 12-36
Insert menu
Change Printer Codes command, 9-32 to
9-35
Column Break command, 9-2 to 9-3
Custom Printer Code command, 9-10 to
9-11
Extended Character command, 9-6 to 9-10
File at Print Time command, 9-13 to 9-15
File command, 9-11 to 9-13
Graphic command, 9-15 to 9-22
illustrated, 9-1
Index/TOC Entry command, 9-26 to 9-30
Note command, 9-22 to 9-25
Other Value command, 9-3 to 9-4
Page Break command, 9-2
Par. Outline Number command, 9-30 to
9-32
Today’s Date Value command, 9-3
Variable command, 9-5 to 9-6
Inset, 9-21, 12-15t0 12-16
Inset command (Utilities menu, Editing Screen),
12-15t0 12-16
insufficient disk space for saving file, 6-5
integer functions
onscreen calculator for, 12-16to 12-18
See also math operations
internal fonts, 10-5 to 10-6
international characters. See extended
character set
international dictionaries, 12-12
international thesaureses, 12-14
Interpret Merge Variables option, for printing,
2-8,6-7
Italic command (Style menu), 10-2 to 10-3




J

“jaggy” smoothing for graphics, 9-18
justification. See alignment of text

K

Keep Line Together in Column command,
11-29t0 11-30

Keep Line Together on Page command, 11-29

Keep Words Together on Line command, 11-28

Kerning setting, 11-23

Key() function for macros, 12-34 to 12-35, C-1

keyboard, Print from Keyboard command, 2-11
to 2-12

KEYBOARD.MRG file, 2-11, 2-12 to 2-13

keystroke, repeat, 12-74

keystrokes in macros. See under macro
language

L

landscape orientation, 11-12
Language Change command (Utilities menu,
Editing Screen), 12-15
laser printers, form feeds for printing, 2-7, 6-7
Last Math as Dollar option, 9-3 to 9-4
Last Math Expression option, 9-3 to 9-4
Last Math Result option, 9-3 to 9-4
Layout menu
Alignment and Spacing command, 11-21 to
11-26
Center Line command, 11-2
Columns command, 11-5to 11-7
Header/Footers command, 11-14to 11-18
illustrated, 11-1
Line Numbering command, 11-20 to 11-21
Page command, 11-8 to 11-13
Page Numbering command, 11-18to 11-19
Right Align Line command, 11-2
Ruler Line command, 11-2to 11-5
Special Effects command, 11-26 to 11-30
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leader dots for table of contents, 9-30
Leading (Line Height) setting
Alignment and Spacing, 11-25 to 11-26
and line numbering, 11-21
for paragraph styles, 10-15
leave. See exit
Left Margin setting
and columns of text, 11-7
for paragraph styles, 10-15
in the Ruler Line, 11-3
legal dictionaries, 12-12
library styles. See paragraph styles
line drawing. See extended character set
line height. See Leading (Line Height) setting
Line Numbering command (Layout menu),
11-20to 11-21
line of text, delete, 7-8
Line Spacing setting
Alignment and Spacing, 11-22 to 11-23
in paragraph styles, 10-16
and sort block operations, 12-20
Line variable, 9-5
lines, keeping together, 11-29 to 11-30
locate. See Find entries
logarithms
onscreen calculator for, 12-16 to 12-18
See also math operations
Lotus 1-2-3 files
insert for merge printing, 12-66 to 12-67
insert in document, 9-12t0 9-13
low resolution, for fax files, 2-15, 6-10
lowercase, convert text to, 10-21 to 10-22

M

macro language
colon (:) to separate statements, 12-33
commands available, 12-37 to 12-38
comments in, 12-31, 12-41
DEF subclause, 12-39
description of, 12-30
exception conditions, 12-38 to 12-40
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macro language (continued)
functions available, 12-35 to 12-36
IfException clause, 12-38 to 12-41
Key() function, 12-34 to 12-35, C-1
keystrokes,

for code pages other than code page

437,C-3to C-4
defined and described, C-1 to C-2
in recorded macros, C-3
shifted keys, C-2
US keystroke table, C-4 to C-17
MAIN subroutine, 12-33
samples of macros,
bulleted lists, 12-31
choose a font, 12-40
find and replace operation, 12-40
Good morning!, 12-37
structure of a macro, 12-30 to 12-33
subroutines, 12-33
syntax for keys and key combinations,
12-34 to 12-35
Macros command (Utilities menu, Editing
Screen), 12-21 to 12-41
description of, 12-21 to 12-23
errors in macros, 12-27
hot keys for, 12-22 to 12-23
Macros command (Utilities menu, Opening
Screen), 3-4 to 3-12
description of, 3-4 to 3-5
errors in macros, 3-10
hot keys for, 3-6
mailing labels. See merge printing
MailList and merge printing, 12-42, 12-45,
12-48
MailList command (Additional menu), 4-1
Manage Paragraph Styles command (Style
menu), 10-19 to 10-21
manually feeding paper to printer, pause
printing between pages, 2-7, 6-7
Manuscript paragraph style, 10-13
margin settings
change with ruler line, 11-2to 11-5
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margin settings (continued)
changing in the Layout menu, 11-8 to 11-11
and columns of text, 11-7
illustrated, 11-9
in paragraph styles, 10-15, 10-16
Mark Block Beginning command (Edit menu),
7-3to 7-4
Mark Block End command (Edit menu), 7-5
Mark Previous Block command (Edit menu), 7-9
Mark Text for Index command, 9-29 to 9-30
marker
go to specific marker, 7-16
setting of, 7-18 to 7-19
masking, for merge print formatting, 12-69 to
12-70
master documents, for merge printing, 12-45 to
12-46
math operations
Calculator command, 12-16 to 12-18
insert values, 9-4
Last Math as Dollar option, 9-3 to 9-4
Last Math Expression option, 9-3 to 9-4
Last Math Result option, 9-3 to 9-4
Set Variable to Math Result command
(Merge Printing), 12-51 to 12-52
measurement units
Alignment and Spacing dialog box, 11-25
to11-26
Page Layout dialog box, 11-10
paragraph styles, 10-15
Ruler Line dialog box, 11-3
medical dictionaries, 12-12
memory
display usage on Status screen, 2-21, 6-16
and fax file creation, 2-16, 6-12
and Preview, 8-7
printing graphic files, 9-22
and running DOS commands, 2-21, 6-16
and size of erased text in buffer, 7-2 to 7-3
and viewing large fonts, 2-16
and Windows Clipboard, 7-7




memory-resident programs, caution against
running from within WordStar, 2-21,
6-16
menu bar, 1-8
menus
change type of, 5-2 to 5-3, 13-2 to 13-3
described, 1-3 to 1-6
in document and nondocument files, 2-4
See also specific menus by name
Merge Print Commands (Utilities menu, Editing
Screen), 12-41to 12-72
merge printing
ampersand (&) for substitute data, 12-52
Ask for Variable command, 12-53 to 12-54
blank lines, omit printing of, 12-44 to 12-45
centered variables, 12-69
Clear Screen While Printing command,
12-63
comparison operators, 12-55
conditional commands, 12-54 to 12-58,
12-59 to 12-61
constants, syntax rules for, 12-57
Data File command, 12-47 to 12-48
data files, 12-42 to 12-43
database files, use as data file, 12-67 to 12-
68
described, 12-41 to 12-42
Display Message command, 12-64 to 12-65
Else command, 12-58, 12-59 to 12-60
End If command, 12-58
fields and data files, 12-42 to 12-43
formatting of numeric variables, 12-70 to
12-72
formatting of variables, 12-68 to 12-70
Go to Bottom of Document command,
12-62
Go to Top of Document command, 12-62
If command, 12-54 to 12-58
Interpret Merge Variables command for
printing, 2-8, 6-7
left alignment of variable, 12-69
masking, 12-69 to 12-70
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merge printing (continued)
master documents, 12-45 to 12-46
message display while printing, 12-64 to
12-65
Name Variables command, 12-48 to 12-50
nested .if commands, 12-60 to 12-61
operators, 12-55
pause for input, 12-53 to 12-54
Print File n Times command, 12-65 to
12-66
print time commands, 12-62 to 12-66
records and data files, 12-42 to 12-43
reformatting at print time, 12-46 to 12-47
right alignment of variable, 12-69
separator for fields, 12-43
Set Variable commands, 12-50 to 12-52
spreadsheet, insert as data file, 12-66 to 12-
67
variables, rules for, 12-43 to 12-4
variables with ampersand (&), 12-525
messages, error, A-1 to A-17
Microsoft Windows
Clipboard contents must be in ASCII
format, 7-7
copy block from Clipboard, 7-6
copy block to Clipboard, 7-7
See also windows
mouse
conventions for use in WordStar, 1-15 to
1-17
and dialog boxes, 1-12 to 1-13
displaying command tags, 1-11
mark beginning of block, 7-3 to 7-4
not recorded in macros, 3-8, 12-25
shortcuts, 1-17
and the status line, 1-10
Move command (Edit menu), 7-5 to 7-6
move operations
block of text, 6-3, 7-5 to 7-6, 8-11
block of text by unerasing, 7-2
column of text, 7-23 to 7-25
in the same file, 7-6
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move operations (continued)
from a window, 7-6
See also cursor movement; Go to entries
multiple copies, number to print, 2-7, 6-6,
12-65 to 12-66
Multiple pages option (Preview), 8-4
multiplication. See math operations

N

Name Variables command (Merge Print
Commands), 12-48 to 12-50
negative numbers, for block math, 12-19
nested .if commands, for merge printing, 12-60
to 12-61
nesting files for printing, 9-14 to 9-15
New command (File menu, Opening Screen),
2-2
Next Find command (Edit menu), 7-15
No cursor movement (NCM) condition, 12-39
nondocument files
compared to document files, 2-4 to 2-5
converting documents to nondocuments,
2-5
converting nondocuments to documents,
2-6
as default file format, 2-2
open nondocument and document at same
time, 6-3
open nondocument file when starting
WordStar, 2-3
print using Print Unformatted Text
command, 2-3 to 2-4
nonprinted comments. See comments
nonproportional fonts, 10-6 to 10-7
Note command (Insert menu), 9-22 to 9-25
Note Options command (Edit menu), 7-20 to
7-22
notes
copy to Windows Clipboard, 7-7
edit a note, 7-19
go to note, 7-17
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notes (continued)
options for, 7-20 to 7-22
spelling check of, 12-9 to 12-11
number formats, for merge print variables,
12-70to 12-72
Number of Columns setting (Column Layout),
11-6
number of copies to print, 2-7, 6-6
numbering
of lines, 11-20 to 11-21
of notes, 7-20 to 7-21
of pages, 11-18t0 11-19
of paragraphs, 9-30 to 9-32
See also page numbers
Numbering Style setting (Line Numbering),
11-20

o)

odd offset. See page offset
odd pages
footer for, 11-17 to 11-18
header for, 11-14to 11-15
select for printing, 2-7, 6-7
On/Off/Inherit Options setting (paragraph style),
10-16
onscreen help, 1-7
See also Help menu
Open Document command (File menu,
Opening Screen), 2-2 to 2-3
Open Nondocument command (File menu,
Opening Screen), 2-3 to 2-4
Open/Switch command (File menu, Editing
Screen), 6-2 to 6-3
Open/Switch Window command (View menu),
8-9t0 8-11
operators, for merge printing, 12-55
Optional Hyphen command, 11-27 to 11-28
Options command (Preview), 8-5 to 8-6
Options option (Convert Graphic), 9-17
Orientation setting (Page Layout), 11-11 to
11-12



Other command (Style menu), 10-7 to 10-11
Other Value command (Insert menu), 9-3 to 9-4
outline numbers for paragraphs, 9-30 to 9-32
overprinting

Overprint Character command, 11-26 to

11-27
Overprint Line command, 11-27
Strikeout command, 10-7 to 10-8

P

Page Break command (Insert menu), 9-2
required at end of master documents, 12-46
Page command (Layout menu), 11-8 to 11-13
Page Length setting (Page Layout), 11-12 to
11-13
page margins. See margin settings
Page Numbering command (Layout menu),
11-18to 11-19
page numbers
for fax files, 2-14, 6-10, 8-6
go to specific page, 7-15 to 7-16
in header or footer, 11-15to 11-16
omit, 11-19
“physical” page numbers, 2-14, 8-6
position on line, 11-19
print a selected range of, 2-7, 6-6
print only odd or even page, 2-7, 6-7
restart numbering of, 11-19
suppress printing of, 11-19
page offset, 11-10to 11-11
and line numbering, 11-21
Page Preview. See Preview command (View
menu)
Page variable, 9-5
Paper Bin setting (Page Layout), 11-13
paper length (page length), 11-12to 11-13
Par. Outline Number command (Insert menu),
9-30 to 9-32
paragraph alignment. See alignment of text
Paragraph Indent paragraph style, 10-13
paragraph numbering, 9-30 to 9-32
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Paragraph Outline Numbering Style option
(Paragraph Outline Number), 9-31
paragraph styles
copy style to library, 10-19
default editing settings, change, 10-18
define a style, 10-14 to 10-17
delete a style, 10-20
document style described, 10-17 to 10-18
go to paragraph style tag, 7-17
predefined styles, 10-12 to 10-13
rename a document style, 10-21
rename a library style, 10-20
return to previous style, 10-13
save new style in library, 10-16
select a style, 10-12
Path variable, 9-4, 9-6
pause a macro, 3-8, 12-25
Pause Between Pages command, 2-7, 6-7
Pause Print command, and background
printing, 2-8, 6-7
pause printing temporarily, 2-9, 6-8
PauseForlnput function (for macros), 12-35
PauseForKey function (for macros), 12-36
.PCX file format, 2-13 to 2-16, 6-9 to 6-12, 8-5
PDFs. See printer definition files (PDFs)
personal dictionary
Add to Personal Dictionary option (Spelling
Check), 12-3
Add to Personal Dictionary option (Spelling
Check Other), 12-5, 12-7, 12-9,
12-10
described, 12-11 to 12-12
“physical” page numbers, 2-14
.PIX files, 9-16, 9-21
and Preview, 8-7, 8-8
Play command (Macro), 3-7, 12-24
PlayMacro command (in macros), 12-37
points
for leading, 11-25
in Page Layout dialog box, 11-10
in paragraph styles, 10-15
in Ruler Line dialog box, 11-3
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portrait orientation, 11-12
ports, redirect printer output to another port,
2-7,6-6
Position on Line setting (page numbers), 11-19
precedence of operations, for calculator, 12-17
Preview command (View menu), 8-2 to 8-8
and incorrect display of headers/footers,
11-17
Print command
File menu, Editing Screen, 6-5 to 6-8
File menu, Opening Screen, 2-6 to 2-9
Print File n Times command (Merge Print
Commands), 12- 65 to 12-66
Print from Keyboard command (File menu,
Opening Screen), 2-11 to 2-13
Print Line Numbers setting (Line Numbering),
11-20
Print Page Numbers setting, 11-19
print to disk file, 2-9 to 2-11
Print Unformatted Text command, 2-8, 6-7
and nondocument files, 2-3 to 2-4
Print Wait message, 2-8, 6-7
printer
change printer, 6-12 to 6-13
redirect printer output to another port, 2-7,
6-6
Printer Code option (Custom Printer Code), 9-11
See also Custom Printer Code command
printer definition files (PDFs)
adding custom printer codes to, 9-34 to
9-35
change for printing, 6-12 to 6-13
for printing to disk, 2-9 to 2-11
See also individual PDFs by name
printing
cancel, 2-9, 6-8, 7-2
chained files, 9-14
convert notes to another type at print time,
7-21 10 7-22
envelopes, 2-11 to 2-13
insert another file when printing current
file, 9-13 to 9-15
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printing (continued)
multiple copies of one file, 2-7, 6-6
multiple files at one time, 9-14 to 9-15, 12-
55to 12-56
nested files, 9-14 to 9-15
pause printing, 2-7, 2-9, 6-7, 6-8
speed of printing, 2-8, 6-8
See also background printing
Printing screen, 2-8 to 2-9, 6-8
Process Type option (Convert Graphic
Options), 9-18
ProFinder, hot keys and Preview, 8-8
proportional fonts, 10-6 to 10-7
in headers or footers, 11-16
Protect/Unprotect command (File menu,
Opening Screen), 2-18 to 2-19
PRVIEW PDF, 2-10
pull-down menus
described, 1-3 to 1-4
display of, 5-2, 13-2
display of classic commands on, 1-6

Q

QRY (User clarification required) condition,
12-38, 12-39, 12-40
Quattro files
insert for merge printing, 12-66 to 12-67
insert in document, 9-12 to 9-13
question mark (?). See wildcard character
quit. See exit
Quotation paragraph style, 10-13

R

read-only files. See Protect/Unprotect
command (File menu, Opening Screen)
Record command (Macro), 3-8 to 3-9, 12-24 to
12-25
records and data files, 12-42 to 12-43
redirect printer output, 2-7, 6-6
print to disk file, 2-9 to 2-11



redline text. See Strikeout option
Reformat command (Utilities menu, Editing
Screen), 12-72to 12-73
and nondocuments, 2-5
reformatting text, automatically (Auto Align
command), 7-25
REM for comments in macros, 12-31, 12-41
Rename command
File menu, Editing Screen, 6-14
File menu, Opening Screen, 2-18
Macro, 3-12, 12-29
Rename Document Style command (paragraph
style), 10-20
Rename Library Style command (paragraph
style), 10-20
rename operations
afile, 2-18, 6-14
a macro, 3-12, 12-29
for paragraph styles, 10-20, 10-21
Repeat Next Keystroke command (Utilities
menu, Editing Screen), 12-74
replace. See Find and Replace command (Edit
menu)
resolution, for fax files, 2-15, 6-10
Resolution option (Convert Graphic Options),
9-18
Rest of Document command (Spelling Check
Other), 12-4t0 12-6
Rest of Notes command (Spelling Check Other),
12-9to 12-11
restoring erased text, 7-2 to 7-3
Return command (in macros), 12-38
Return key. See Enter key
Return to Editing command (Preview), 8-6
Return to Previous Style command (Style
menu), 10-13
Return to Previous Word option (Thesaurus),
12-14
Reverse B/W option (Convert Graphic Options),
9-17t0 9-18
Right Align Line command (Layout menu), 11-2
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right alignment. See under alignment of text
Right Margin setting (paragraph style), 10-16
Right Margin setting (Ruler Line), 11-3
Right Page Margin setting (Column Layout), 11-6
roll

for subscripts, 10-8 to 10-9

for superscripts, 10-10
Rotation option (Convert Graphic Options), 9-17
ruler line

described, 1-9

predefined ruler lines, 11-5

Ruler Line command (Layout menu), 11-2

to11-5

Ruler Line option (Screen Settings), 8-13
ruler units

in Page Layout dialog box, 11-10

in paragraph styles, 10-15

in Ruler Line dialog box, 11-3
Run DOS Command

File menu, Editing Screen, 6-15 to 6-16

File menu, Opening Screen, 2-20 to 2-21
run macro. See Play command; Single Step

command

S

Save and Close command (File menu, Editing
Screen), 6-5
Save As command (File menu, Editing Screen),
6-4
Save command (File menu, Editing Screen), 6-4
scalable fonts, 10-6
and kerning, 11-23
for subscripts, 10-9
for superscripts, 10-10
Scan range option (Preview), 8-5
scientific notation
for block math, 12-19
for the calculator, 12-17 to 12-18
Screen Display option (Custom Printer Code),
9-11

INDEX - 17




SUBJECT INDEX

screen fonts
delete with DELCRT utility, 2-16, 6-12, 8-7
and fax files, 2-16, 6-12
and Preview files, 8-7 to 8-8
See also fonts for printing
Screen Frequency option (Convert Graphic
Options), 9-18
Screen Settings command (View menu), 8-12 to
8-13
Scroll Bar option (Screen Settings), 8-13
scroll bar (vertical), 1-10
scrolling
commands for, 1-15
continuously up/down, 7-18
with a mouse, 1-16
See also cursor movement
search. See Find entries
Select Paragraph Style command (Style menu),
10-12t0 10-13
sentence, convert case of, 10-21 to 10-22
serial number, display of, 2-22, 6-16
Set Marker command (Edit menu), 7-18 to 7-19
Set Page Number setting, 11-19
Set Variable command (Merge Print
Commands), 12-50 to 12-51
Set Variable to Math Result command (Merge
Print Commands), 12-51 to 12-52
SetHelpLevel function (for macros), 12-36
Settings command (Style menu), 10-22 to 10-23
sheet feeders
choose bin to use, 11-13
form feeds for printing, 2-7, 6-7
shell out to DOS, 2-20 to 2-21, 6-15 to 6-16
shorthand macros. See macro entries
show. See display
SHOWPCX utility, 2-15
single-spaced text
Line Spacing setting in Alignment and
Spacing, 11-22 to 11-23
Line Spacing setting in paragraph styles,
10-16
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Single Step command (Macro), 3-10to 3-11,
12-27 to 12-28
SingleStep function (for macros), 12-36
size adjustment, of windows, 6-3, 8-11
slash and asterisk (/*), for comments in macros,
12-41
Smoothness option (Convert Graphic Options),
9-18
soft fonts, 10-5 to 10-6
soft hyphens
and Find/Find and Replace operations,
7-11,7-14
and hyphenation of words, 11-24 to 11-25
Optional Hyphen command for, 11-27 to
11-28
See also hyphenation
soft returns
change hard returns to, 2-6
See also carriage returns
Soft Space Dots option (Screen Settings), 8-12
Sort Block command (Utilities menu, Editing
Screen), 12-19 to 12-20
Space Between Columns setting (Column
Layout), 11-6
spaces, underline between words, 10-22 to
10-23
Spacing setting (Line Numbering), 11-20
Special Effects command (Layout menu), 11-26
to11-30
speed of printing, 2-8, 6-8
Spelling Check Global command (Utilities
menu, Editing Screen), 12-2 to 12-3
Spelling Check Other command (Utilities
menu, Editing Screen), 12-4 to 12-12
spreadsheet files
insert for merge printing, 12-66 to 12-67
insert in document, 9-12 to 9-13
square root
onscreen calculator for, 12-16 to 12-18
See also math operations
Star Exchange command (Additional menu), 4-2



start
Inset, 12-15to 12-16
WordStar, 1-2
Starting Number for Note command, 7-20 to
7-21
Starting Number option (Paragraph Outline
Number), 9-31
status
of printing, 2-9
Status screen for WordStar, 2-21, 6-16
Status command
File menu, Editing Screen, 6-16 to 6-17
File menu, Opening Screen, 2-21 to 2-22
status line, described, 1-10
Status Line option (Screen Settings), 8-13
Stop command (in macros), 12-37
stop list (exclusion list), for index creation, 3-2
to 3-3
Strikeout command, 10-7 to 10-8
define character for, 10-23
style bar, 1-8 to 1-9
Style Bar option (Screen Settings), 8-13
Style menu
Bold command, 10-2
Convert Case command, 10-21 to 10-22
Define Paragraph Style command, 10-14 to
10-18
Font command, 10-4 to 10-7
illustrated, 10-1
Italic command, 10-2 to 10-3
Manage Paragraph Styles command, 10-19
to 10-21
Other command, 10-7 to 10-11
Return to Previous Style command, 10-13
Select Paragraph Style command, 10-12 to
10-13
Settings command, 10-22 to 10-23
Underline command, 10-3 to 10-4
Style setting (paragraph style), 10-15
subdirectories. See directories and
subdirectories
subroutines. See macro language
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Subscript command, 10-8 to 10-9
subtraction. See math operations
Super High resolution, for fax files, 2-15, 6-10
Superscript command, 10-9 to 10-10
Suppress Blank Lines at Top of Page setting
(Page Layout), 11-13
switch between windows, 6-2 to 6-3
symbols
for columns, 11-7
in flag column, 1-10to 1-11
in ruler line, 1-9
for soft hyphen, 11-24 to 11-25
Symphony files
insert for merge printing, 12-66 to 12-67
insert in document, 9-12 to 9-13
synonym display. See Thesaurus command
(Utilities menu, Editing Screen)
syntax errors in macros, 3-10

T

Tab Stops setting (Ruler Line), 11-3to 11-4
table of contents

creating, 3-3 to 3-4

insert entry for, 9-26 to 9-28

leader dots for, 9-30
tabs

converted to spaces with Copy in ASCII

Format, 2-5, 7-7

decimal tabs, 11-3to 11-4

in nondocuments, 2-4, 2-5

in paragraph styles, 10-15

set tab stops, 11-3 to 11-4
Tabs setting (paragraph style), 10-15
TelMerge command (Additional menu), 4-1
template files, for printing from keyboard, 2-11,

2-12t0 2-13
Thesaurus command (Utilities menu, Editing
Screen), 12-13 to 12-14

Thumbnail display option (Preview), 8-4
Time variable, 9-4, 9-5
title bar, 1-8
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Title paragraph style, 10-13
TOC command (Utilities menu, Opening
Screen), 3-3 to 3-4
TOC Entry command, 9-26 to 9-28
.TOC file extension, 3-4
Today’s Date Value command (Insert menu),
9-3
Top Margin setting (Page Layout), 11-11
TOPIX.SET file, 9-19, 9-20
trigonometric functions
onscreen calculator for, 12-16 to 12-18
See also math operations
TSRs. See memory-resident programs
2x zoom option (Preview), 8-4
Type New Word option (Thesaurus), 12-14
Type Word command (Spelling Check Other),
12-8to 12-9
typewriter, use printer as, 2-11 to 2-12

U

underlining
continuous underline, 10-22 to 10-23
double underlining tip, 10-8
Underline command (Style menu), 10-3 to
10-4
Undo command (Edit menu), 7-2 to 7-3
unerase text (restore), 7-2 to 7-3
unformatted text, print dot commands, 2-8, 6-7
unprinted comments. See comments
unprotect a file, 2-18 to 2-19
Update Style Library setting (paragraph style),
10-16
uppercase, convert text to, 10-21 to 10-22
US keystroke table, C-4 to C-17
Use Compound Numbers option (Paragraph
Outline Number), 9-32
Use Form Feeds command, 2-7, 6-7
Use Line Numbering setting, 11-20
User acknowledgement required (ACK)
condition, 12-38, 12-39, 12-40
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User clarification required (QRY) condition,
12-38, 12-39, 12-40
Utilities menu, Editing Screen
Block Math command, 12-18 to 12-19
Calculator command, 12-16 to 12-18
illustrated, 12-1
Inset command, 12-15 to 12-16
Language Change command, 12-15
Macros command, 12-21 to 12-41
Merge Print Commands, 12-41 to 12-72
Reformat command, 2-5, 12-72 to 12-73
Repeat Next Keystroke command, 12-74
Sort Block command, 12-19 to 12-20
Spelling Check Global command, 12-2 to
12-3
Spelling Check Other command, 12-4 to
12-12
Thesaurus command, 12-13 to 12-14
Word/Character Count command, 12-20
Utilities menu, Opening Screen
Index command, 3-1 to 3-3
Macros command, 3-4 to 3-12
TOC command, 3-3 to 3-4

\'

Variable command (Insert menu), 9-5 to 9-6
variables for merge printing. See merge printing
vertical scroll bar, 1-10
Vertically Center Text on Page command, 11-28
View command (Preview), 8-3 to 8-4
and fax files, 2-15, 2-16, 6-10 to 6-11
View menu
Block Highlighting, 8-9
Change Window Size command, 8-11
Command Tags command, 8-8 to 8-9
illustrated, 8-1
Open/Switch Window command, 8-9 to
8-11
Preview command, 8-2 to 8-8
Screen Settings command, 8-12 to 8-13



w

Width of Character(s) option (Custom Printer
Code), 9-11
Width option (Convert Graphic Options), 9-17
wildcard character, and Find/Find and Replace
operations, 7-10to 7-11, 7-13, 7-14
windows
copy block between windows, 6-3, 7-6,
8-11
move block from another window, 7-6
open or switch between, 6-2 to 6-3, 8-9 to
8-11
size adjustment, 6-3, 8-11
See also Microsoft Windows
Word/Character Count command (Utilities
menu, Editing Screen), 12-20
Word command (Spelling Check Other), 12-6
to 12-7
Word Wrap command, and the Auto Align
command, 7-25
Word Wrap setting, 11-24
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WordStar
exit, 2-22, 6-17
starting, 1-2
version and serial number display, 2-22, 6-16
See also command line options
WordStar Release 4, create a file compatible
with, 2-11
worksheet files
insert for merge printing, 12-66 to 12-67
insert in document, 9-12 to 9-13
WS4 PDF, 2-11
WSG files, 8-7
WSINDEX.XCL file, 3-2 to 3-3
\WSM file extension, 3-7, 12-23

X

XTRACT PDF, 2-10 to 2-11

yA

zoom, Preview pages, 8-3 to 8-4
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Pull-down Commands

Alt+0 (select paragraph style), 10-12

Alt+1 (preview), 8-5, 8-6

Alt+2 (exit preview), 8-6

Alt+A,M (MailList), 4-1

Alt+A,S (Star Exchange), 4-2

Alt+A, T (TelMerge), 4-2

Alt+E,B (mark beginning of block), 7-3 to 7-5

Alt+E,C (copy block of text), 7-6 to 7-7

Alt+E,D (delete text), 7-8 to 7-9

Alt+E,E (mark end of block), 7-5

Alt+E,F (find text), 7-9 to 7-11

Alt+E,G (go to next occurrence of specified
character), 7-15

Alt+E,| (change editing settings), 7-23

Alt+E |, A (auto align text), 7-25

Alt+E,1,C (column block mode on/off), 7-23 to
7-24

Alt+E,1,D (change function of Enter key), 7-25

Alt+E,|,R (column replace on/off), 7-24 to 7-25

Alt+E,K (mark previous block), 7-9

Alt+E,M (go to marker), 7-16

Alt+E,N (view or edit note/index entry), 7-19

Alt+E,O (go to other location), 7-16 to 7-18

Alt+E,P (go to page/line number), 7-15to 7-16

Alt+E,R (find and replace text), 7-12 to 7-14

Alt+E,S (insert place marker), 7-18 to 7-19

Alt+E, T (set options for notes), 7-20

Alt+E, T,C (convert note), 7-21

Alt+E,T,E (print endnote at specific location),
7-22

Alt+E, T,P (convert note at print time), 7-21 to
7-22

Alt+E,T,S (change starting number for notes),
7-20to 7-21

Alt+E,U (undo), 7-2 to 7-3

Alt+E,V (move block of text), 7-5 to 7-6
Alt+E, X (next find/replace), 7-15
Alt+F,A (save as), 6-4
Alt+F,C
close file, 6-3 to 6-4
protect/unprotect file, 2-18 to 2-19
Alt+F,D (open document file), 2-2 to 2-3
Alt+F,E (rename file), 2-18, 6-14
Alt+F,F (create fax file), 2-13 to 2-16, 6-9 to
6-12
Alt+F, H
change files displayed, 2-20
select/display/change printer, 6-12 to 6-13
Alt+F,K (print from keyboard), 2-11 to 2-13
Alt+F,L (save file, go to Opening screen), 6-5
Alt+F,N (open nondocument file), 2-3 to 2-6
Alt+F,O (copy file), 2-17, 6-13
Alt+F,P
print file, 2-6 to 2-11
save current file and print, 6-5 to 6-8
Alt+F,R (run DOS command), 2-20 to 2-21,
6-15t0 6-16
Alt+F,S (save file and resume editing), 6-4
Alt+F,T (delete file), 2-17 to 2-18, 6-14
Alt+F,U (display Status screen), 2-21 to 2-22,
6-16t0 6-17
Alt+F,V (change logged drive/directory), 2-19 to
2-20, 6-15
Alt+F,W
open new file, 2-2
open/switch between windows, 6-2 to 6-3
Alt+F,X
close file without saving, exit WordStar,
6-17
exit WordStar, 2-22
Alt+H,C (change Help level), 5-2 to 5-3
Alt+H,H (Help), 5-1 to 5-2
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Alt+Hyphen(-), (pause/end pause macro), 3-8,
12-25,12-35

Alt+1,A (insert other value), 9-3 to 9-4

Alt+1,C (column break), 9-2 to 9-3

Alt+1,E (insert extended character), 9-6 to 9-10

Alt+,F (insert file into document), 9-11 to 9-13

Alt+1,G (insert graphic), 9-15 to 9-22

Alt+1,H (change printer codes), 9-32 to 9-35

Alt+l,1 (display index/table of contents menu),
9-26

Alt+1,1,D (insert dot leaders), 9-30

Alt+1,1,1 (create index entry), 9-28 to 9-29

Alt+1,1,M (mark index entry), 9-29 to 9-30

Alt+1,1,T (table of contents entry), 9-26 to 9-28

Alt+1,L (insert file at print time), 9-13 to 9-15

Alt+1,N (insert comment/note), 9-22

Alt+1,N,A (insert annotation), 9-25

Alt+1,N,C (insert nonprinting comment), 9-22 to
9-23

Alt+I,N,E (insert endnote), 9-24

Alt+1,N,F (insert footnote), 9-23 to 9-24

Alt+1,0 (paragraph numbering), 9-30 to 9-32

Alt+1,P (page break), 9-2

Alt+1,T (insert current date), 9-3

Alt+l,U (insert custom printer code), 9-10 to
9-11

Alt+1,V (insert variable), 9-5 to 9-6

Alt+L,A (alignment and spacing), 11-21 to 11-26

Alt+L,C (center text), 11-2

Alt+L,E (display special effects menu), 11-26

Alt+L,E,C (overprint character), 11-26 to 11-27

Alt+L,E,H (soft hyphen), 11-27 to 11-28

Alt+L,E K (binding space), 11-28

Alt+L,E,L (overprint line), 11-27

Alt+L,E,O (conditional column break), 11-29 to
11-30

Alt+L,E,P (conditional page break), 11-29

Alt+L,E,V (center text vertically), 11-28

Alt+L,H,F (footer), 11-17to 11-18

Alt+L,H,H (header), 11-14to 11-17

Alt+L,! (right align line), 11-2

Alt+L,L (line numbering), 11-20 to 11-21
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Alt+L,N (page numbering), 11-18 to 11-19

Alt+L,0O (newspaper-style columns), 11-5 to
11-7

Alt+L,P (page layout for printing), 11-8 to 11-13

Alt+L,R (ruler line), 11-2t0 11-5

Alt+S,B (bold), 10-2

Alt+S,C (display Convert Case menu), 10-21 to
10-22

Alt+S,D (create/edit paragraph style), 10-14 to
10-18

Alt+S,E (display continuous underline/strikeout
menu), 10-22 to 10-23

Alt+S,F (choose font), 10-4 to 10-7

Alt+S, [ (italic), 10-2 to 10-3

Alt+S,M (display paragraph style menu), 10-19

Alt+5,M,C (copy paragraph style), 10-19

Alt+5,M,D (delete paragraph style), 10-20

Alt+S,M,E (rename library paragraph style),
10-21

Alt+5,M,R (rename document paragraph style),
10-20

Alt+S,0 (other style menu), 10-7

Alt+S,0,B (subscript), 10-8 to 10-9

Alt+S,0,C (print in color), 10-11

Alt+S,0,D (double strike), 10-10 to 10-11

Alt+S,0,P (superscript), 10-9 to 10-10

Alt+S,0,S (strikeout text), 10-7 to 10-8

Alt+S,R (revert to previous paragraph style),
10-13

Alt+S,S (select paragraph style), 10-12 to 10-13

Alt+S,U (underline), 10-3 to 10-4

Alt+U,B (block math), 12-18 to 12-19

Alt+U,C (onscreen calculator), 12-16 to 12-18

Alt+U,E (repeat a keystroke ), 12-74

Alt+U,| (create index from Opening Screen),
3-1to03-3

Alt+U, | (start Inset), 12-15to 12-16

Alt+U K (sort block), 12-19 to 12-20

Alt+U,L (specify language), 12-15

Alt+U,M (display macro menu), 3-4 to 3-7,
12-21 to 12-23

Alt+U,M,C (copy macro), 3-11, 12-28




Alt+U,M,D (delete macro), 3-12, 12-29

Alt+U,M,E (edit/create macro), 3-9 to 3-10,
12-26 to 12-27

Alt+U,M,N (rename macro), 3-12, 12-29

Alt+U,M,P (play macro), 3-7, 12-24

Alt+U,M,R (record macro), 3-8 to 3-9, 12-24 to
12-25

Alt+U,M,S (play macro/single step), 3-10 to
3-11,12-27 to 12-28

Alt+U,O (spell check other), 12-4

Alt+U,O,N (spell check notes), 12-9 to 12-13

Alt+U,O,R (spell check rest of document), 12-4
to 12-6

Alt+U,O,T (spell check word not in document),
12-8 to 12-9

Alt+U,O,W (spell check a word), 12-6 to 12-7

Alt+U,P (merge print commands), 12-41 to
12-47

Alt+U,P,A (ask for variable), 12-53 to 12-54

Alt+U,P,B (go to end of file and resume
printing), 12-62

Alt+U,P,C (clear screen for messages while
printing), 12-63

Alt+U,P,D (data file), 12-47 to 12-48

Alt+U,P,E (end IF condition), 12-58

Alt+U,P,| (begin IF condition), 12-54 to 12-58

Alt+U,P,L (ELSE condition), 12-58

Alt+U,P,M (display message while printing),
12-64 to 12-65

Alt+U,P,N (name variables), 12-48 to 12-50

Alt+U,P,R (repeat printing), 12-65 to 12-66

Alt+U,P,S (set variable), 12-50 to 12-51

Alt+U,P,T (go to beginning of file and resume
printing), 12-62

Alt+U,P,V (variable to math result), 12-51 to
12-52

Alt+U,R (reformat menu), 12-72

Alt+U,R,N (reformat notes), 12-73

Alt+U,R,P (align rest of paragraph), 12-73

Alt+U,R,R (align rest of document), 12-73

Alt+U,S (spell check global), 12-2 to 12-4
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Alt+U, T (create table of contents), 3-3 to 3-4

Alt+U,T (thesaurus), 12-13 to 12-14

Alt+U,W (word/byte count of block or file),
12-20

Alt+V,B (display/hide block/place markers), 8-9

Alt+V,C (display/hide command tags), 8-8 to 8-9

Alt+V,0 (open/switch between windows), 8-9
to 8-11

Alt+V,P (preview), 8-2

Alt+V,P,E (exit preview), 8-6 to 8-8

Alt+V,P,G (preview specific page), 8-3

Alt+V,P,O (preview options), 8-5 to 8-6

Alt+V,P,V (preview from different perspectives),
8-3 to 8-4

Alt+V,S (screen settings display), 8-12 to 8-13

Alt+V,W (size window), 8-11

Classic Opening Screen Commands

? (display Status screen), 2-21 to 2-22
\ (create fax files), 2-13 to 2-16
AM (MailList), 4-1
AS (Star Exchange), 4-2
AT (TelMerge), 4-2
B (print from background), 2-8, 2-9
C
continue printing, 2-9
protect/unprotect file, 2-18 to 2-19
D (open document file), 2-2 to 2-3
E (rename file), 2-18
F
change files displayed, 2-20
print full speed, 2-9
| (create index), 3-1 to 3-3
K (print from keyboard), 2-11 to 2-13
L (change logged drive/directory), 2-19 to 2-20
M (display macro menu), 3-4 to 3-7
MD (edit/create macro), 3-5, 3-7, 3-9 to 3-10
ME (rename macro), 3-11, 3-12
MO (copy macro), 3-11
MP (play macro), 3-5, 3-7
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MR
create macro, 3-4 to 3-5
record macro, 3-8 to 3-9
MS (play macro/single step), 3-5, 3-10 to 3-11
MY (delete macro), 3-12
N (open nondocument file), 2-3 to 2-6
O (copy file), 2-17
P
display Print screen, 2-8
pause printing, 2-9
print file, 2-6 to 2-11
PB (print from background), 2-9, 6-8
PC (continue printing), 2-9, 6-8
PF (print full speed), 2-9, 6-8
R (run DOS command), 2-20 to 2-21
S (open new file), 2-2
T (create table of contents), 3-3 to 3-4, 9-28
X (exit WordStar), 2-22
Y (delete file), 2-17 to 2-18

Classic Editing Screen Commands

A~ (enlarge window), 6-3, 8-11
"G
auto-indent (nondocument mode), 2-4
change hard carriage returns to soft returns
(document mode), 2-6
AA (move left one word), 1-14
AB (align rest of paragraph), 2-5, 7-25, 11-23,
12-73
ABreak (stop macro), 3-5, 3-7, 3-11, 12-22,
12-28
AC
move to next screen, 1-15
scroll down a screen, 8-4, 12-74
AD (move right one character), 1-14
AE (move up one line), 1-14
AEnd (move to end of file), 8-4
AF (move right one word), 1-14
AG (delete character at cursor), 7-2, 7-9
AH (delete previous character), 7-2, 7-9
AHome (move to beginning of file), 8-4
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AK (save setting and close dialog box), 1-13

AK" (convert block to uppercase), 10-21

AK’ (convert block to lowercase), 10-21

AK. (convert block to sentence case), 10-21

AK< (unmark block), 8-9

AK? (word/byte count of block or file), 12-20

AK] (copy block from Clipboard), 7-6

AK\ (create fax files), 6-9 to 6-12

AK] (copy block to Clipboard), 7-7

AK 0-9 (set place marker), 7-18

AKA (copy block between windows), 6-3, 7-6

AKB (mark beginning of block), 7-3 to 7-5,
12-18,12-19

AKC (copy block), 7-6

AKD (save file, go to Opening screen), 3-10,
6-5,7-19, 9-22,9-23,9-24, 9-25, 12-27

AKE (rename file), 6-14

AKF (run DOS command), 6-15 to 6-16

AKG (move block between windows), 6-3, 7-6

AKH (display/hide block/place markers), 8-9

AKI (column replace on/off), 7-24 to 7-25

K] (delete file), 6-14

AKK (mark end of block), 7-5, 12-18, 12-19

AKL (change logged drive/directory), 6-15

AKM (block math), 9-4, 12-18 to 12-19

AKN (column block mode on/off), 7-23 to 7-24,
12-18, 12-19

AKO (copy file), 6-13

AKP (print file while editing), 2-8, 6-5 to 6-8,
12-54,12-63, 12-65

AKQ (quit file and abandon changes), 2-3,
2-19, 6-3

AKQX (close file without saving, exit WordStar),
6-17

AKR (insert file into document), 7-24, 9-9, 9-11
to 9-13, 12-45

AKS (save file and resume editing), 3-10, 6-4 to
6-8, 6-5, 12-26

AKT (save and name a file), 6-4

AKU (mark previous block), 7-9

AKV (move block), 7-6

AKW (write block to file), 2-10, 7-7



AKY (delete block), 7-8

AKZ (sort block), 7-24, 12-19 to 12-20

AL (repeat previous find/replace), 7-11, 7-14,
7-15

AM (display macro menu), 12-21 to 12-23

AM! (insert current time), 9-4

AM# (insert last math expression), 9-4, 12-17

AMS$ (insert last math result as dollar), 9-4,
12-17,12-18

AM* (insert current filename), 9-4

AM. (insert current directory name), 9-4

AM: (insert current drive letter), 9-4

AM= (insert last math result), 9-4, 12-17, 12-18

AM\ (insert current path), 9-4

AM@ (insert current date), 9-3

AMD (edit/create macro), 12-21, 12-23, 12-25,
12-26 to 12-27

AME (rename macro), 12-23, 12-28, 12-29

AMO (copy macro), 12-28

AMP (play macro), 12-22, 12-23, 12-24

AMR (record macro), 12-21, 12-23, 12-24 to
12-25

AMS (play macro/single step), 12-22, 12-27 to
12-28

AMY (delete macro), 12-29

AQOJ (change function of Enter key), 7-25

AO# (page numbering), 11-18to 11-19

AQ? (display Status screen), 6-16 to 6-17

AQ] (right-align line), 11-2, 11-16

AOA (auto align text), 7-25

AOB (editing screen settings), 1-6 to 1-7, 8-9,
8-121t0 8-13

AQOC (center text), 11-2

AOD (command tags display), 1-6, 1-11, 8-8 to
8-9,8-12,12-36

AQE (soft hyphen), 11-25, 11-27 to 11-28

AQF (display paragraph style menu), 10-19

AQFD (create/edit paragraph style), 10-14 to
10-18,10-18

AOFE (rename document paragraph style),
10-21
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AOFO (copy paragraph style), 10-17, 10-18,
10-19

AQOFP (revert to previous paragraph style),
10-13,12-33

AOFR (rename library paragraph style), 10-20

AOFS (select paragraph style), 10-12 to 10-13,
10-17,12-32

AOFY (delete paragraph style), 10-20

AQI (set tab width/nondocument mode), 2-4

AOK (open/switch between windows), 3-10,
6-2t0 6-3,8-9to 8-11, 12-27

AQOL (ruler line,) 1-9,11-2t0 11-5

AOM (size window), 6-3, 8-11

AONA (create annotation), 9-25

AONC (enter nonprinting comment), 9-22 to
9-23

AOND (view or edit note/index entry), 7-19,
9-22,9-23, 9-24, 9-25, 9-29

AONE (insert endnote), 9-24

AONF (insert footnote), 9-23 to 9-24

AONG (find note), 7-17

AONI (create index entry), 9-28

AONL (spell check notes), 12-9 to 12-13

AONU (realign notes), 12-73

AONV (convert note), 7-21

AQOO (copy current ruler line), 11-5

AOP (preview), 6-10, 8-2 to 8-8, 9-21, 10-7,
11-7,11-17,11-20, 11-26

AOPE (exit preview), 8-6 to 8-8

AOPG (preview specific page), 8-3

AOPO (preview options), 8-5 to 8-6

AQPV (preview from different perspectives), 8-3
to 8-4

AQS (line spacing), 11-2, 11-21 to 11-26, 12-35

AQU (newspaper-style columns), 11-5to 11-7

AQV (center text vertically), 11-28

AQY (page layout for printing), 11-8 to 11-13

AQZ (paragraph numbering), 9-30 to 9-32

AP, (overprint line), 11-27

AP! (custom printer code), 9-10

INDEX - 27




COMMAND INDEX

AP& (start Inset from within WordStar), 12-15 to
12-16

AP* (insert graphic), 9-15 to 9-22
AP— (color/shading), 10-11
AP. (insert dot leaders), 9-30
AP= (choose font), 6-13, 10-4 to 10-7, 12-40
AP? (select printer), 6-12 to 6-13
APO (insert extended character), 9-6 to 9-10
APB (bold), 10-2
APD (double strike), 10-10
APE (custom printer code), 9-10, 9-33, 9-34
APF (custom printer code), 9-10, 9-34
APG (custom printer code), 9-10, 9-34
APgDn

preview next page, 8-4

scroll down a line, 1-15
APgUp

preview previous page, 8-4

scroll up a line, 1-15
APH (overprint character), 9-7, 11-26
APK (mark index entry), 9-29 to 9-30
APL (form feed), 2-12
APO (binding space), 11-28
APQ (custom printer code), 9-10, 9-33, 9-34
APR (custom printer code), 9-10, 9-33, 9-34
APS (underline), 10-3 to 10-4, 10-22
APT (superscript), 10-9 to 10-10
APV (subscript), 10-8 to 10-9
APW (custom printer code), 9-10, 9-33, 9-34
APX (strikeout text), 10-7 to 10-8, 10-23
APY (italics), 10-2 to 10-3
Q< (move to next style tag), 7-17
AQ= (find next font tag), 7-17
AQ 0-9 (move to marker), 7-16, 7-18
AQA (find and replace text), 7-12 to 7-14, 12-40
AQB (move to beginning of block), 7-17
AQC (move to end of document), 1-14, 7-17
AQDel (delete line left of cursor), 7-8, 12-33
AQE (move to beginning of screen), 1-14
AQF (find text), 7-9 to 7-11
QG (go to next occurrence of specified

character), 7-15
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QI (go to page/line number), 2-5, 7-15 to 7-16

AQ)J (thesaurus), 12-13 to 12-14

AQK (move to end of block), 7-17

AQL (spell check rest of document), 12-4 to
12-6

AQM (onscreen calculator), 9-4, 12-16to 12-18

AQN (spell check a word), 12-6 to 12-7, 12-12

AQO (spell check word not in document), 12-8
to12-9,12-12

AQP (go to previous position), 7-17

AQQ (repeat next command), 12-74

AQR (move to beginning of document), 1-14,
7-17

AQRAQL (spell check global), 12-2 to 12-4

AQS (move to beginning of line), 11-16

AQT (delete to specific character), 7-8

AQU (align rest of document), 2-5 to 2-6. 6-13,
7-25,10-5,10-12, 11-23, 12-73

AQV (go to most recent find/replace or block),
7-17

AQW (scroll continuously up, one line at a
time), 7-18

AQX (move to end of screen), 1-14

QY (delete line right of cursor), 7-8

AQZ (scroll continuously down, one line at a
time), 7-18

AR (move to previous screen), 1-15

AS (move left one character), 1-14

AT (delete word), 7-8

AU (undo), 7-2 to 7-3, 9-10

AW (scroll up a line), 1-15

AX (move down one line), 1-14, 8-4

AY (delete line), 7-8

AZ (scroll down a line), 1-15

Dot Commands

.. (enter unprinted comment), 9-23

.av (ask for variable), 2-12, 12-44, 12-52, 12-53
to 12-54

.aw (auto align), 7-25, 9-9, 9-13, 11-24, 12-47,
12-73



.bn (sheet feeder bin number), 11-13

.cb (column break), 9-2 to 9-3, 11-7

.cc (conditional column break), 11-7, 11-29 to
11-30

.co (newspaper-style columns), 2-12, 11-6, 11-7

.cp (conditional page break), 11-29

.cs (clear screen for messages while printing),
12-63

.cv (convert note at print time), 7-21

.df (data file), 9-15, 12-43, 12-45, 12-46, 12-47
to 12-48, 12-52, 12-62, 12-66, 12-67

.dm (display message while printing), 12-54,
12-64 to 12-65

.e# (endnote starting value), 7-21, 9-24

.ei (End If condition), 12-54, 12-58, 12-59,
12-61

.el (Else condition), 12-54, 12-58, 12-59, 12-61

f# (footnote starting value), 7-21, 9-24

f1...5 (footer commands), 11-15

fi (insert file at print time), 9-13 to 9-15

.fm (footer margin), 11-10

fo (footer), 11-17to 11-18

.o b (go to end of document/resume printing),
12-62

.g0 t (go to beginning of document/resume
printing), 12-62

.he (header), 11-14t0 11-17

.hm (header margin), 11-10, 11-16

.hy (auto-hyphenation), 11-24, 11-28

.if (begin IF condition), 12-54 to 12-58, 12-59,
12-60 to 12-61

.ig (enter unprinted comment), 9-23, 12-68

.ix (create index entry), 9-29

.kr (kerning), 11-23

# (line numbering), 11-20to 11-21

.la (specify language), 12-14, 12-15

.Ih (line height), 11-23, 11-25

.Im (left margin), 11-4

COMMAND INDEX

Is (line spacing), 11-23

.ma (math), 12-51 to 12-52, 12-70

.mb (bottom margin), 11-7, 11-10

.mt (top margin), 11-7, 11-10, 11-16

.0j (justification), 11-22

.op (omit page numbering), 11-19, 12-46
.p# (paragraph numbering), 9-32

.pa (page break), 2-12, 9-2

.pc (print page number at specific location),

11-12,11-19

.pe (print endnote at specific location), 7-22,

9-24

.pf (print time reformatting), 12-47

.pg (turn page numbering back on), 11-19
.pl (page length), 2-10, 11-12

.pm (paragraph margin), 11-4

.pn (specify/restart page number), 11-19
.poe (even page offset), 11-10

.poo (odd page offset), 11-10

.pr or= (landscape/portrait mode), 11-12
.rm (right margin), 9-13, 11-4, 11-6, 11-12
.rp (repeat printing), 2-7, 6-6, 12-65 to 12-66
.rr (ruler line), 11-4to 11-5

.rv (name variable), 12-44, 12-46, 12-48 to

12-50, 12-52,12-62, 12-66, 12-67

.sb (suppress blank lines at top of page), 11-13
.sr (set roll for sub/superscripts), 10-8 to 10-10
.sv (set variable), 12-44, 12-50 to 12-51, 12-52,

12-68,12-70

.th (tab setting), 11-4
.tc (table of contents entry), 3-4, 9-26 to 9-28
.ul (underline spaces between words), 10-4,

10-22to 10-23

.xe (custom printer code), 9-33

.xq (custom printer code), 9-33

.Xr (custom printer code), 9-33

XW (custom printer code), 9-33

.xx (redefine strikeout character), 10-8, 10-23
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